Screwed up badly when trying to install... :(

Discussion in 'Tomato Firmware' started by brickshitter, Aug 23, 2014.

  1. brickshitter

    brickshitter Network Newbie Member

    I have a WRT54gl, v. 1.1. I tried to change firmware a while ago (so I don't recall exactly at what point I screwed up), but ever since then I only get the following screen .

    Is all lost? Can I revert to normal settings?
  2. JoeDirte

    JoeDirte Networkin' Nut Member

  3. brickshitter

    brickshitter Network Newbie Member

    I tried the 30-30-30 thing, to no avail. The link suggests that in my case (DMZ light LED not lightning up) then "simply clearing the NVRAM should solve the problem." but I have no idea how to do so.
  4. gfunkdave

    gfunkdave LI Guru Member

    We need more information. Which firmware were you attempting to upgrade from/to? If you were trying to go straight from the Linksys firmware to Tomato, that was your problem. You need to first switch to the DD-WRT firmware that is designed to switch from Linksys's firmware, then upgrade to Tomato from there.

    First, read this:

    If you don't need a JTAG reset (which involves a specialized cable and opening the router - really, you might as well get a new one at that point), then go to and click Router Database. Type in "wrt54gl" and click on the WRT54GL result.

    Download one of the "Mini-Build required for initial flashing" options depending on if you are flashing via a TFTP program or the web.

    Once the new firmware is flashed, log on to the router and flash Tomato via the web interface. Be sure to check the box to erase NVRAM after flashing.

    An Asus RT-N10P can be had new for about $15, and the RT-N12 is about $30.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice