Semi bricked wrt54gv4?

Discussion in 'Cisco/Linksys Wireless Routers' started by SmDFrylock, Sep 29, 2007.

  1. SmDFrylock

    SmDFrylock LI Guru Member

    recently got hold of a wrt54g v4 (CDFA) from a friend of mine, and I wanted to replace the stock firmware (4.20.7) with the VPN version of DD-WRT v23 VPN.

    Following the instructions, I reset to factory defaults, and loaded the v23 mini build, which appeared to flash ok. I then reset the defaults in the v23 mini build and then tried to flash to v23 VPN. afterwards the router failed to reboot. Luckily Boot_wait was on so I tftp'd mini back onto the router no problem and tried again. same results.

    At this point, v23 micro and mini and v24 micro work with no problems. I got standard to boot once, but failed to reboot after I reset the defaults. No other v24 RC3 works on the router and results in having to do the pin 16 short out trick on the board in order to get the router to ping again. No official firmware seems to boot either. I've tried 4.20.6 all the way to 4.21.1 with the router failing to boot with all firmwares except for 4.30.5, which boots once and fails after a default reset. I've also tried the 30 second reset button methods and typing command in SSH to try to reset the defaults and NVRAM with the same results as above.

    The only thing I can think of is that there's something in the NVRAM or flash that is corrupted, or even faulty ram, but I'm not sure. One thing I'm noticing is it appears that the router will not boot any firmware above 2.5MB, including official linksys builds. It makes me believe that the other 1.5mb is either bad or filled with something that is not erasing, and the only thing I can think of at this point would be to completely erase the flash and hope the bootloader will take a new image.

    is there any way to do that outside of a jtag?
  2. smapdi

    smapdi Network Guru Member

    I'm having the same issue as you with an spare WRT-54G v2. It won't boot with any firmware greater than ~3mb. Did you ever find a fix for your issue?
  3. SmDFrylock

    SmDFrylock LI Guru Member

    Nope. Still looking.

    I've got this post on three forums now and still no response on any of them. Either no one knows how to fix it, it's so easy to fix no one wants to waste their time to just answer it or they just figure it's such a stupid question thats been asked so many times that we need to do more digging in some mythical FAQ somewhere.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice