setting DNS thru DHCP

Discussion in 'Other Linksys Equipment' started by dpassent, Feb 2, 2005.

  1. dpassent

    dpassent Network Guru Member

    I tried to search the forum but didn't find any aswers. Here's the problem. I have WAG54G v1.2 with 1.02.7 firmware. My ADSL provider for the reasons that are beyond my human perception decided to DROP automaticly setting up DNS server while establishing ppp session. It means that my router gets IP, gets default gateway, but it doesnt get DNS servers. Not a big deal, cause i know IP of those DNS servers. There is one problem and I think this is big feature lack of WAG54G. I am not able to set the DNS configuration into WAG's DHCP server configuration. It means, that I need to walk over to every single computer in my LAN and set it up manually. But I have several notebooks that are set to DHCP to work at my home and at my work. It's very inconvinient to configure DNS settings every time. Is there any solution for it? Is there any kind of configuration thru telnet commands or something. DHCP server in WAG is not reach in options. Range of IP addresses pool and lease time is not enough for serious configurations.

    Any help would be much appreciated

  2. dpassent

    dpassent Network Guru Member

  3. dpassent

    dpassent Network Guru Member

    well... did a bit of research and i found out the solution.
    1. setup bridge connection with custom IP config.
    2. put DNS servers in that config
    3. save all
    4. change connection type to PPPoA
    5. set it up
    6. if your ISP doesnt assing you DNS automaticly, settings from previous steps (bridge) are applied to DHCP server in WAG.

    so i am happy puppy now :)

  4. HiSpeed

    HiSpeed Network Guru Member


    That's very interesting and I'd like to know :
    1. Are there many ISP doing this ? Which is yours ?
    2. Only "RFC 1483 Brigded" works or "RFC 1483 Routed" works also ?
  5. dpassent

    dpassent Network Guru Member

    ad 1. dunno really. my ISP was giving away preconfigured ADSL routers with one RJ45 port that had DNS servers preconfigured. I switched this router for linksys and spotted they dont assing DNS servers with PPP session
    ad 2. didnt really tested other than bridged. it worked, i jumped the ship without further testing :)

  6. robocop2002

    robocop2002 Guest


    I did it using "RFC 1483 Routed" to set DNS, then save and go back to PPPoA, set all the rest and save again.
    Works fine for me.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice