Setup 2 WRT54g

Discussion in 'Cisco/Linksys Wireless Routers' started by pkincade, Aug 10, 2004.

  1. pkincade

    pkincade Network Guru Member

    I have two routers and am trying to setup one as WDA access point.
    I have set both with Satori 4.

    Router 1 ver 1.1
    dhcp enabled ip
    wds set with mac addresses of router 2
    disable firewall/loopback
    hookedup through cable internet

    router 2 ver 2
    dhcp disabled ip
    wds set with mac address of router 1
    disable firewall and loopback

    works fine as wired access point
    Once unplugged and try to connect to router 2, never gets internet access and cant ping other router.

    What am I leaving off?
  2. Couledouce

    Couledouce Network Guru Member

    Very soon I'm be doing the same as you, my new WRT should arrive tomorrow...

    Have you tried the last steps of the Sveasoft documentation for WDS:
    "However, you may need to reboot each router. Now telnet or ssh into each router (assuming you have enabled those features) and type "brctl addif br0 wds0.2" (or if it is not the first wds link then replace wds0.2 with wds0.x, where x means the wds interface + 1).
    If you did not enable telnet or ssh, go to the admin --> management interface, hit run and in the popup windows type the above command."
  3. pkincade

    pkincade Network Guru Member

    I just tried to run those commands.

    sh: brctl: not found

    I dont guess that helped any :cry:
  4. pkincade

    pkincade Network Guru Member

    Anyone have any suggestions? I need some help here.
  5. Couledouce

    Couledouce Network Guru Member

    So now after a couple of weeks of telling people to read the documentation:
    I have got my second WRT54G and I'm trying to connect it up.

    And I can't get it working...

    I'm too tired now so I'm going to leave it to another night when I will spell out the instructions and maybe somebody can tell use were the problem is.
  6. Couledouce

    Couledouce Network Guru Member

    How do you enter commands from admin --> management

    When entering "brctl addif br0 wds0.2" by the admin --> management page I also get the error:
    sh: brctl: not found

    Does an option else where have to be enabled?
    Is there a pre-fix command to type?
  7. Couledouce

    Couledouce Network Guru Member

    Well I got it working and documented my setup in this post:

    The only difference I can see with your setup (I'm actually using a v1.1 and v2 like you) maybe the loopback disabled in the "Administration/Management" menu.

    Otherwise like me you may have entered the wrong MAC address?

    I would still like to find out how to correctly enter the "brctl addif br0 wds0.2" command.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice