Shibby on RT-N16 DHCP conflict?

Discussion in 'Tomato Firmware' started by _wb_, Dec 13, 2012.

  1. _wb_

    _wb_ Networkin' Nut Member

    I have installed Shibby version on a RT-N16. I am running it as a gateway.
    Modem WAN - WAN Tomato -
    Tomato LAN 1-4 ports connect to Aiport Express to serve wifi,VOIP ATA,8-port SWITCH

    I run Tomato for QoS and DNS. This is my gateway to the Internet.
    I run a separate machine to lease DHCP addresses and it is connected to the switch now.

    In this scenario, any machines connected to tomato or the switch do not get any IP address. If I connect the DHCP server machine to Tomato LAN port then it provides IP addresses to anything connected to it except for anything connected to the switch.
    Any ideas what the problem is here? It might be something simple but I can't get my head around it.
  2. koitsu

    koitsu Network Guru Member

    I can think of a couple reasons this might be happening, but you need to provide all the configuration details you've applied to the RT-N16. For example are you using VLANs? If so I can see that being the problem.

    Are all your machines configured for the same network (i.e.

    Alternate possibilities include that your 8-port switch is actually examining and filtering layer 3 traffic to some degree, i.e. it has "some smarts" that might do things like drop/ignore packets destined to the broadcast address, or that the issue relates to ARP (layer 2 traffic) since layer 2 traffic on switches (not hubs) is segregated.

    Unless you can put the DHCP server on one of the RT-N16 LAN ports, my recommendation to you would be to use the built-in DHCP server in TomatoUSB. Is there some reason you can't use it? If there is some DHCP feature/setting that your DHCP server provides that TomatoUSB's DHCP server (called dnsmasq) doesn't possibly I can explain to you how to enable/configure that feature.
  3. _wb_

    _wb_ Networkin' Nut Member

    I am not using VLANs but I have a separate guest wifi network running on Tomato for my friends that come visit my house.
    The DHCP server running on a separate machine is also running dnsmasq. I wanted to try something different and ran into this issue. I see many arp requests on the switch but no replies. I assume the switch is dropping them before it reaches the destination.
    I believe the swith is doing something funny here but I am not sure what kind of setting that would be on a managed netgear switch. Any tips would be appreciated.
    I guess I should just make it run on Tomato, but this seems that the switch is doing things that affect my network performance.
  4. gfunkdave

    gfunkdave LI Guru Member

    Why not just use a VLAN version of Tomato and have the RT-N-16 be the access point for both networks? It would be a simpler setup.

    It sounds like your switch is set to filter multicast and possibly other traffic.
  5. koitsu

    koitsu Network Guru Member

    Multicast has absolutely nothing to do with this problem. I think gfunkdave might have meant broadcast traffic, i.e. traffic destined to the broadcast address of your network.

    You just now disclosed that it's an 8-port managed switch (this is the first I've heard of one BTW -- smallest managed switch I've heard of is 16-port). Wish I had known that before. I have quite a bit of experience with managed switches, but only HP ProCurve and Cisco.

    With some managed switches, you can define a port that's classified as an "uplink" port, sometimes called a "default" port. Occasionally this is convoluted by use of VLANs (on the switch itself -- do not confuse this with Tomato's VLANs or 802.1Q tagging). You want to make sure that that port is the one with the LAN cable that goes to the RT-N16.

    If there's nothing like this configurable in the switch, then it may be a security feature -- sometimes things like "port security" and other features end up dropping layer 2 traffic they consider "harmful" in some ways. Disable features like this and see if things improve.

    If nothing helps, then hands down my recommendation (and I strongly suggest you do this anyway!) is to contact Netgear. Explain the problem concisely and give them a diagram of your network topology (physical wiring). Don't bother talking about the wifi or VoIP parts -- they have no relevance. Just stick to the issue and keep it simple. Push hard on tier 1 support will probably try to dance around the issue with things like "try power-cycling the switch" or other nonsense (although running the latest firmware I would agree with). Ask to get in contact with a tier 2 support individual or actual engineer. If you can't, consider another product, or consider a non-managed switch.
  6. Monk E. Boy

    Monk E. Boy Network Guru Member

    Are the two DHCP servers on the same LAN segment?

    Some (all?) Airport Expresses have a SINGLE ethernet port for both "WAN" and "LAN". With your setup you cannot use this kind of AP because the bizarre logic by which it works (DHCP server on WAN is a number of hops away and therefore won't respond to the DHCP request before the AE) since your DHCP servers are both 0 hops away from each other.

    If you have a dumb ethernet switch you can subtitute for the managed switch, just temporarily, you could rule out whether the managed switch is the source of the problem. 8-port 10/100 switches can be had for as little as $15 now.
  7. _wb_

    _wb_ Networkin' Nut Member

    Well, I enabled the DHCP server on Tomato only and everything is back to normal. I did have the other machine running DHCP for network and a wifi running on Tomato with DHCP for network I still have not tried to reenable the wifi. I could setup an uplink port on the switch but then I would probably need to use VLANs.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice