Slow speeds for only one computer

Discussion in 'Tomato Firmware' started by mikeymike88, Dec 10, 2013.

  1. mikeymike88

    mikeymike88 Reformed Router Member

    Hi Guys,

    I know this is my first post, but I've been researching on here for a while. I have an E2500 that I recently flashed with Shibby v1.28. Everything was working great on the 5Ghz network, but the 2.4Ghz network was unbearably slow. I was only getting speeds of 1mbps on all devices connected to the 2.4Ghz network with my Comcast plan of 25mbps. After doing some research, I found this thread here:

    I applied these settings and my speed increased to what it should be. Now the only problem is that on one device (Asus laptop), the speed is still very very slow. I am only able to get 3mbps consistently. The speed never increases. On the device list of the router, this device is only showing a Tx/Rx rate of 6/65. I am not sure why this is only happening on this one device. Also, shouldn't the quality for all connected devices be higher than they are? The devices are all within 20 feet of the router. Do you guys have any ideas? Thank you in advance!

  2. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Those are very good "quality" numbers.

    Did that Asus client behave any differently with stock router firmware?
  3. mikeymike88

    mikeymike88 Reformed Router Member

    Yes the Asus client worked perfectly on the stock firmware. The only other settings I have changed so far on the wireless settings are the Transmit Power to 0 (default) and the 802.11n Preamble to Green Field on the 2.4Ghz network. No QOS or bandwidth limiting changes so far
  4. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    I'm assuming you're already using 20MHz channel width, correct?

    Green field preamble is just as it sounds: best to use when there are no neighboring b or g devices. Even then, the benefits are modest. There may even be performance issues if there are neighboring networks using g or b devices. Suggest the default preamble until you've finished troubleshooting.

    The Asus client, what type of device and wireless card? Firmware/software updated or recently changed? It may be a specific driver or setting compatibility issue. There are many other possibilities as well, such as client not actively transmitting when you're looking at the client list. Is throughput a problem, or just the numbers on the devices list?
  5. mikeymike88

    mikeymike88 Reformed Router Member

    Yes, set to 20Mhz channel width. I'll try turning setting the preamble to default and see if it makes a difference.

    On the Asus client, the throughput is the problem. I am able to achieve my maximum bandwidth on all other devices besides this one. I am not sure of the model number of the device (it's my roommates laptop) but the wireless drivers were already at the latest version. I can get you that specific info later when I get off work. Could firmware/drivers be causing this even though it worked great on the stock firmware? That leads me to believe that it must be a setting with the router, but I may be wrong. Anything other settings I can change on the router to troubleshoot?
  6. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Could be a setting issue, but there are specific router-client hardware and driver combinations that behave in unexpected ways. Some Intel drivers, for example. Sometimes when clients negotiate a slow transmission speed but have good reception speed it can be an issue with client transmission power or possibly power saving features.
  7. mikeymike88

    mikeymike88 Reformed Router Member

    Actually, I think changing the preamble fixed it! Seems like I'm getting the full speeds now. I'll let you know if something changes, but this looks promising. Thank you!
    Marcel Tunks likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice