Slow wireless speeds

Discussion in 'Tomato Firmware' started by turuncuoglu, Nov 25, 2010.

  1. turuncuoglu

    turuncuoglu Networkin' Nut Member

    I have an Asus RT N16 with tomato. I am very satisfy with the router except my wireless speed sucks. After the reboot it is pretty fast but it drops to 2mbps pretty fast. A reboot solves the problem but I do not understand why this is happening. I have optware installed with two module enabled.

    PU Load (1 / 5 / 15 mins) 0.01 / 0.16 / 0.23
    Total / Free Memory 123.99 MB / 85.43 MB (68.90%)
    Total / Free Swap 250.98 MB / 250.98 MB (100.00%)

    I have no idea what is going on but I would really appreciated any help.

  2. wouter

    wouter Addicted to LI Member

    A long ongoing similar topic is discussed for DD-WRT:
    I was hoping that Tomato would not show that behaviour...but IT DID last Sunday!
    For family sake (to keep the Internet going on full speed), I reverted the WRT54GL back to stock firmware for now again.

    Briefly the situation here is as follows:
    Cable internet with a Docsis 2 modem, the WAN port/Inernet connection type must be set to DHCP in the router.
    The router is a WRT54GL 1.1.
    There are usually 4 wireless client PC's: three with a WMP54G and one with a WPC54G adapter.
    For the WMP54G adapters I have installed the latest Ralink RT61 driver (no difference regarding the wireless rate problem compared to the stock Linksys driver, although even the latest Linksys driver is dated very old).
    Wireless is set to G-Only, with WPA2 Personal and AES.
    The choosen channel seems to not interfer with neighbors.

    Stockfirmware (currently loaded 4.30.13 build 16) does not show the wireless rate drop (and stay low) behaviour.
    Tarifa 35b seems to be ok too with respect to wireless rate.

    Various DD-WRT firmware versions (the problem seems to be introduced with some DD-WRT pre-SP2 version, I have not tried the latest recommended 14929 though, older DD-WRT SP1 versions seems to be ok with respect to wireless rate) and now also Tomato build 52 does show the wireless rate drop issue.
    The wireless rate problem suddenly appears (I assume there will be some kind of trigger, which I have not found yet), it results in the router going down to a low wireless rate of 1 or 2 Mbps, the clients may still show 54 Mbps in the Windows taskbar icon. The actual wireless network speed (thus Internet speed) really decreases for the whole wireless network.

    The problem may be triggered by a client.
    The solution is to either reboot the router or reboot one of the clients (I have had the luck to run into situations that reboot of one client did NOT solve the problem, and rebooting the next client DID solve the problem (and have seen different clients that needed a reboot, so it is not isolated to one problem client), I even found that a "repair" of the wireless network adapter may fix the problem (so, reconnect the client to the router seems to do the trick..I only have no clue yet how to figure out which clients is the culprit).

    Maybe the above helps to get at least a good description of the problem I have seen and ways to solve it, and more important it hopefully leads to a real solution.
  3. wouter

    wouter Addicted to LI Member

    It seems we are alone out here with this problem ;-)
  4. Toastman

    Toastman Super Moderator Staff Member Member

    Seems like the clients are failing to negotiate a high link speed, and are reverting to mode "B". It would seem to me to be a compatibility issue on those clients, but I have no answer for you. I think you should ignore most of the assumptions made in that DD-WRT forum - I just looked at it and had to take some pain-killers after reading the first couple of pages, I had to stop before I choked :biggrin:
  5. TexasFlood

    TexasFlood Network Guru Member

    How did you choose the channel you're using? I assume you're tried others with no difference?

    In the old days you could tweak settings like Beacon Interval, Fragmentation Threshold, RTS Threshold, but not sure if this is applicable with the RT-N16.

    The only time I saw a situation vaguely similar here it was with an old client card which I no longer use. If It was a client software issue in my case. With the original software it would start fine and fall to the lowest speed just as you describe. It allowed me to select the connect rate which worked fairly well. Eventually I switched to some other client software I found on the Internet for the same chipset which resolved the problem.

    This is my experience for what it's worth and may have nothing to do with your situation.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice