[SOLVED]another WAG354G that doesn't upgrade anymore

Discussion in 'Other Linksys Equipment' started by icest0rm, Mar 28, 2006.

  1. icest0rm

    icest0rm Network Guru Member


    I don't know why I did, but I did...

    I downgrade to one 1.01.03 because just seen on the linksys beta site, thought that maybe would had some differences from the 1.01.05...

    but now my router doesn't get anynore 1.01.05, everytime it says "upgrade succesful" but still holds 1.01.03...

    I've tried also TFTP as suggested somewhere and by Linksys but also this shows succesful upgrade but the router still shows 1.01.03...

    anyone found a solution?
    should I really go for a replacement as suggested by Linksys?
  2. nic_gix

    nic_gix Guest

    After the upgrade in 1.01.05 and return back in 1.01.03 I had lost also the possibility of doing again upgrade but finally I accomplished with the following way:

    1) I downloaded the latest firmware (ftp://ftp.linksys.com/international/firmware/WAG354G-EU_AnnexA_EU_1_01_05.zip) and tftp (ftp://ftp.linksys.com/pub/network/tftp.exe) from linksys

    2) I ran the tftp and I put default ip ( and the default password (admin) and I selected file firmware that I had downloaded (Wag354g-EU_AnnexA_EU_1_01_05.bin)

    3) I reset the router pressing the button for 30" and as soon as the power LED became RED, I pressed immediately “upgrade†in tftp!

    ... it appeared to complete immediately (as then that it did not work) but the power led blinking enough hour green mark that it made finally upgrade, and thus and it became finally!
  3. icest0rm

    icest0rm Network Guru Member

    you should be assumed by Linksys!
    that made the trick! :cheer:

    how did u discover that way? none of the 4 linksys technicians I discussed with suggested this way! :rockon:

    thank you m8 :thumbup:
  4. ginna

    ginna Guest

    Dear all, please help me with the firmware downgrade... I had firmware ver. 1.01.05 and I had to change provider but with that version it is locked to work with forthnet. How can I downgrade the firmware and unlock my rooter? (I am talking about WAG354G-EU rooter...)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice