[Solved] Not Able to Connect to Printer via WiFi (Mac OSX)

Discussion in 'Tomato Firmware' started by fiwiman, Feb 5, 2018.

  1. fiwiman

    fiwiman Network Newbie Member

    I'm encountering a somewhat odd behavior with my WiFi clients on my LAN subnet ( WiFi clients aren't able to connect to my printer on this subnet (yet can ping the printer from the command line). Instead the printer utility times out. Wired clients on the same subnet are fine.

    Wifi (Mac OS X) IP:
    Printer IP:

    I'm running an ASUS Asus RT-N16 router with tomato only for a AP. Maybe it's something there, really not sure.
    (Tomato Firmware 1.28.0000 MIPSR2-140 K26 USB AIO)

    I have some firewall custom stuff, but this is for my other Virtual Wireless (VLAN) networks.
    iptables -t filter -I INPUT 1 -p tcp -i br1 -m multiport --dports 22,80,443 -j DROP
    iptables -t filter -I INPUT 1 -p tcp -i br2 -m multiport --dports 22,80,443 -j DROP
    I've attached my topology diagram.

    I've captured some output from pfSense:

    [2.4.2-RELEASE][admin@pfsense.lan]/root: tcpdump -i vmx0 host
    12:39:47.902133 IP > 0 SRV (QM)? Brother DCP-L2540DW series._ipp._tcp.local. (60)
    12:39:48.295153 IP > 0 [2q] SRV (QM)? Brother DCP-L2540DW series._pdl-datastream._tcp.local. TXT (QM)? Brother DCP-L2540DW series._pdl-datastream._tcp.local. (77)
    From what I gather these are bonjour requests...

    Any thoughts on what can be happening here?

    EDIT: I tried to enable "Enable Udpxy" & "Wireless Multicast Forwarding", still doesn't work.

    Attached Files:

    Last edited: Feb 5, 2018
  2. eibgrad

    eibgrad Network Guru Member

    Does the printer at least show up as an available resource on those wireless clients having problems (thanks to network discovery), even though they might not be able to connect to it?

    What happens if use the *same* wireless device that's having problems, but instead use a wired connection?
  3. fiwiman

    fiwiman Network Newbie Member

    The same device (laptop) when wired works, wireless does not. It's definitely the AP that causing this.
  4. eibgrad

    eibgrad Network Guru Member

    But what about my first question? When using wireless, I'm interested in whether at least network discovery works, but you just can't connect to it? Particularly because you say ping works, suggesting it might be an issue at the protocol level.
  5. fiwiman

    fiwiman Network Newbie Member

    How would I know if network discovery works on the Mac? If I bring up the "Print & Scan" preference setting I do see "Idle" beneath the printer - would that suggest network discovery is working?

    Again, thanks for your help.

    Attached Files:

  6. eibgrad

    eibgrad Network Guru Member

    I'm not a Mac user, so I'm at a bit of a disadvantage here. But I assume the Mac is similar to the Windows in this respect.

    When I'm using Windows, I can go to Explorer, select the Network option, and the network window is auto-populated w/ all sorts of devices on the network (printers, servers, shares, whatever). All those devices are being "discovered" thanks to the network discovery protocol. Each device sends its connection information (e.g., IP address) to the client.

    Something similar happens if I go to the Add Printer applet. By default, it searches the network for printers using the same thing, network discovery. What it finds get listed as a possible printer for you to configure.

    That's what I'm trying to determine. Are you seeing the printer show up under such circumstance? For all I know, the printer you already have defined was when configured when it was a wired client. But what if you deleted that printer and started over? Would it offer the same printer again (suggesting that network discovery is working)? If it doesn't, then that suggests network discovery is NOT working.

    I'm just trying to pin down exactly where it breaks.
  7. fiwiman

    fiwiman Network Newbie Member

    My first thought, when it didn't work, was to remove the printer and try to add it. On one of my macbooks, when I removed the printer from the "Print" preference pane it didn't re-populate automatically, in fact I wasn't able to get the printer software installation wizard to find it on my network thus I couldn't complete driver installation.

    This would suggest the something is impeding network discovery from happening and given the fact that others have had issues with bonjour, I'm more inclined to think that the AP is culprit.

    Oh, it happens on two macbooks exactly the same way.

    Some have said to revert back to 132, but that seems a little old. Also, I'm not entirely sure I completely wiped the nvram when I put shibby on the router (not sure that would have an effect or not). Perhaps I'll try again to reflash and clear the nvram again.
    Last edited: Feb 6, 2018
  8. eibgrad

    eibgrad Network Guru Member

    It is only the printer you can't talk to? Are there other wired devices on the 192.168.3.x network having similar problems, say a server share?

    It almost sounds as if the printer and wireless client are not on the same ethernet segment. Network discovery won't cross ethernet segments/boundaries. And given the complexity of your network layout, perhaps it doesn't correctly reflect the actual layout. It looks ok, but as I said, that's just what you *believe* it to be. Could it be incorrect?
  9. fiwiman

    fiwiman Network Newbie Member

    It should reflect reality...I don't have an issue from a wireless client to a server share on the 192.168.3.x network, tested and it works fine. It's all very odd...
  10. eibgrad

    eibgrad Network Guru Member

    Could it be a firewall that's causing a problem? I'm thinking one of the differences between the wired and wireless config on that client is the MAC address. Any kind of filtering on the printer based on MAC address? Not very common, but just trying to think outside the box.

    Otherwise I'm stumped at the moment.
  11. fiwiman

    fiwiman Network Newbie Member

    I don't think it's a firewall issue. I haven't got any rules on my LAN that would filter based on MAC. From what I remember, this was working with Asus RT-N66U until I removed it and put in its place an older RT-N16 for some other reason.

    Yeah I don't understand it. Threads like the following probably point to the router in some way:


    I do however, appreciate the help. Thanks.
  12. eibgrad

    eibgrad Network Guru Member

    Here's an idea. I know sometimes ppl take a shortcut when configuring the router as an AP. They just assign it a LAN ip, disable its DHCP server, and connect it LAN to LAN.

    But I have seen rare cases where that wasn't enough. It required disabling the WAN, perhaps even disabling routing on the AP. Otherwise it just didn't work properly.

    And make sure you reset that router to defaults too before converting it to an AP. If you don't, you can leave artifacts that screw up the new config. Go the extra mile and make sure the AP is in a super clean state, then reconfigure for AP mode.
  13. eibgrad

    eibgrad Network Guru Member

  14. fiwiman

    fiwiman Network Newbie Member

    Ok, it works now - the nightmare is hopefully over.

    I switched from RT to RT-N version of shibby as from what I understood, the RT N16 is the only model that works with both. As to what the cause was, dunno, but this thread lead me down the right path:


    Thanks for the help @eibgrad
  15. friedgreen

    friedgreen Networkin' Nut Member

    Glad to see you found my old post on the Airplay problem with v140 shibby.
    I've since tried v140 with multiple Mac print servers unsuccessfully.
    The zeroconf/airplay/bonjour packets do not pass the bridge from wireless to hardwired connections.
    Since it seems mips is dead now and arm is the only cpu being worked on I'll need to upgrade to mips soon if no developers pick up the ball (hint hint).
    eibgrad likes this.
  16. Monk E. Boy

    Monk E. Boy Network Guru Member

    Whoa, I completely missed that his was using Bonjour. I've given up on Bonjour, not because of Tomato (don't even use it at home anymore), but because Bonjour is always breaking. For a technology intended to making things simple, it certainly introduces a hell of a lot of problems.

    I setup fixed DHCP leases for printers, then add them on clients using their DNS names. No Bonjour involved, just a straight DNS to IP lookup and then it sends data over port 9100, IPP, or LPD. Honestly it's a lot simpler arrangement and far less prone to breaking so long as you maintain adequate documentation on your network/router setup.

    For file sharing I do the same kind of thing, fixed DHCP lease, defined DNS name, connect to server using the DNS name, and voila, everything works without any quirky always breaking component sitting in the middle to trip you up.
  17. friedgreen

    friedgreen Networkin' Nut Member

    There is a free application called 'handyprint' can eliminate the apple bonjour print servers and allow direct mapping to the printers from any IOS, android, or windows client.
    Bonjour print server I was working with was also making public printer advertisements over insecure means and was patched after being alerted after hacks were published. Linux as well is using bonjour under the name Avahi and it has issues as well, usually removed forcefully.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice