[Solved] Odd Entware/snmp issue

Discussion in 'Tomato Firmware' started by paped, Jun 17, 2014.

  1. paped

    paped LI Guru Member

    I am wondering if anyone has a fix for this issue as I have been searching but cannot find a similar problem.

    I have a Asus RT-N16 router running Shibby Tomato build 120 (K26 USB-VPN), with Entware installed on to a small USB stick connected to the routers USB port.

    Basically I have always run MRTG/Routers2.cgi and used the inbuilt snmp client which used to assign references from port 1 to 13 for my interfaces and I had the MRTG conf file set-up to suit and I could reboot the router without any issues.

    However when the inbuilt snmp client was removed a few versions ago I moved to Entware which picked up the same 1 to 13 ports and everything worked fine initially.

    The issue is that if the power drops or I cold reboot the interfaces seem to increase, I end up with interface 1-19 shown and I lose stats for my PPP0 and TUN21 interfaces as they move from interface 12 and 13 to 18 and 19 so do not match my MRTG configuration. Effectively snmp adds another 6 interfaces from 12 to 17 and I have no idea what these are as there are no descriptions on the snmp output?

    I have found a easy fix for this, as if I warm reboot from the GUI, snmp goes back to normal with just interface 1 -13 shown again and MRTG is working again for the PPP0/TUN21 interface. So it seems to be something to do with a difference between booting from a power cycle/off compared to a warm reboot????

    Is there any way to fix the interface mapping manually in snmp, I think Cisco routers have a file that you can use but not sure if something like this would work or exists for Tomato?

    Alternatively, has anyone else had this issue and knows of a fix?

    Thanks in advance for any help,

  2. paped

    paped LI Guru Member

    Solved by doing the following not sure if all steps are needed or which fixed it but....

    1) Reinstalled entware/snmpd on the router
    2) Changed my mrtg conf file to use the interface name rather than id i.e. /ppp0:community_string instead of 12:community_string
    3) Setup a restart command to the snmpd init.d script in the firewall script. So on connection/reconnection snmpd is restarted

    Been stable over a week now and through a number of reboots.

    Hope this may help someone else.
    Last edited: Jul 17, 2014
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice