SPA942; Lost access to Admin Webinterface

Discussion in 'Other Linksys Equipment' started by digicom, Mar 26, 2008.

  1. digicom

    digicom Guest

    I upgraded the fw of my SPA942 from 5.1.15a to 5.2.5 a couple of weeks ago. In the beginning it was working as it should, but I probably made some mistake when configuring the line 4 SIP settings (mistyped the outbound proxy or ...) and after booting I lost access to the Admin Webinterface. Since then I have been stuck with the CheckingDNS message on screen ( it is not registering even on any of the three ten working accounts). Basic WUI works ok. Looks like I did not activate accidentally any admin password , because the SPA is not even asking any at this time. Just giving the 403 error - not required authorization or equivalent... when trying to access the admin side of the web-interface.

    I have tried to analyze the unit with an old sw for the spa-3000 called Hottub and with that I can extract out all the user side parameters, nothing from the admin side. The program obviously requires proper http access to the admin side. I do have a copy of all the original (correct) settings in a hottub-file-form though, but for the moment no way to admin access to the device. I also have the correct spa.cfg file (xml) of the unit (previous fw)

    Is there a hard reset procedure or equivalent? The menu reset (14) does not work. Apparently not without these missing admin rights.

    Is it possible to log into the phone by telnet/SSH in order to switch back on the Admin Webinterface?. I tried to reflash it back to 5.1.15a by tftp, but it does not work either without these webadmin rights.

    Has anyone else noticed that the 942 does not work well with Firefox? I think my problem is at least partly due to this fact. I understood this unfortunately too late. Firefox accesses well the User interface, but gets stuck or very slow immediately one tries to access the Admin Menu. IE seems to work OK.

    Any ideas how to regain control of the phone? :confused:
  2. Toxic

    Toxic Administrator Staff Member

    you will need to reset to factory defaults afaik. from the 942 buttons press "setup" then press 14.

    hope this helps. I just got my 942 yesterday, it seems to be pretty amazing!
  3. John Glimberg

    John Glimberg Network Newbie Member

    I have exakt the same problem. Did you find a solution back in 2008 ?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice