Speed and Stability Problems with 1.28.7633.3

Discussion in 'Tomato Firmware' started by Arghtastic, Jun 25, 2012.

  1. Arghtastic

    Arghtastic Networkin' Nut Member

    Tomato Firmware v1.28.7633 .3-Toastman-IPT-ND ND VPN
    - Linux kernel and Broadcom Wireless Driver updates
    - Support for additional router models, dual-band and Wireless-N mode.

    The above is my version info. I did an upgrade from (can't remember) an earlier version of Toastman (same features) and now my wireless speed and stability is horrible. I've reviewed and tweaked my settings 3 or 4 times now and it hasn't helped. I've looked at the frame burst, WMM, and other obvious settings.

    Any tips would be appreciated.

    PS. Hardware is 2xWRT54GLv1.1s with WDS setup.
  2. Mercjoe

    Mercjoe Network Guru Member

    The stupid but obligitory questions:

    The old versions you had worked just fine in the WDS?

    Did you do a complete NVRAM reset and rebuild the settings from scratch?

    Have you used something like inSSIDer and made sure you do not have someone on the same channel as your WDS?

    Also, Do you have the VPN versions flashed to BOTH routers? The reason I ask is that the VPN version take up a lot of space and add complexity to the code. The little 'blue box that could' is getting a little long in the tooth and it does not take much as it used to to overload one. I would put the minimum feature version on the end of the WDS. There are less things to confuse the issue by doing that.
  3. Arghtastic

    Arghtastic Networkin' Nut Member

    Thanks Mercjoe. . .yes, the old version (maybe a year) worked fine. I've done a Survey and picked the channel that no one is on. Yes, I am using VPN version on both. I had done so for a matter of simplicity. I see your point on using the non-VPN version--would you recommend I do that on the "end" closest to the modem or the end farthest away?

    I did not clear the NVRAM--which was probably a bit stupid, but my QoS rules took a while and I wanted minimum fuss. I will try again with a clear if I can't get it. I did change the cable between the cable modem and the main router--it helped. It was a bit long and a bit old and seemed to be a bit flaky.

    Now, my speed is reported as low 20 megabits (supposed to have 30--direct connect laptop gets just over that.) and upload is in the 4.5 megabit range (supposed to be 5.)

    Still would appreciate any other tuning suggestions.. . . and thanks in Advance!
  4. Mercjoe

    Mercjoe Network Guru Member

    If you do not use the VPN functionality, then I would recommend not using it at all. With a newer router that has more RAM and CPU, then flashing a larger firmware is ok. On the little WRT's, go with what you use and keep it as small and simple as possible.

    If you use VPN, then you want it on the main router as that is the one that should be handling all your network functions (DHCP, QOS, security, etc). The remote router should just be a connection endpoint/AP. Basically a dumb switch with a radio. The standard firmware should suffice.

    Questions: You have afterburner set to ON correct? Are you set to G only? Or do you have the wireless mode set to AUTO?

    As for getting the QOS rules and outer setting over to the new flash; There is a nifty trick on the later builds that makes it a BREEZE to transfer settings.

    See: http://www.linksysinfo.org/index.ph...orial-and-discussion.28349/page-9#post-138676

    I keep a text output file on backup that I can use to reset a fresh flash in a matter of minutes.

    Changing the cable from the modem to the router should not effect a flaky wireless link. It is possible that you were seeing network dropout as a wireless dropout? Just asking as sometimes one can seem like the other.
  5. Arghtastic

    Arghtastic Networkin' Nut Member

    I have been trying to get the VPN functionality to work with a secure gateway, but am not currently using it--want to.

    I will try the switch to a less intelligent mode on the remote one and lower the firmware. I do have afterburner on and G only (now.) thank you for all the advice.

  6. Arghtastic

    Arghtastic Networkin' Nut Member

    So. . . .I tried the other modes and nothing worked even though the routers linked. This lead me to do a 30/30/30 reset on the extension WRT54GL. After that it came back with a different MAC address (can you tell me if this should be. I thought these were physically set and not virtual.) and now works fine.
  7. Arghtastic

    Arghtastic Networkin' Nut Member

    00:90:4C:5F:00:2A was the MAC address in question--which disappeared after moving the device (unplug/re-plug.) WDS would not function without wl0_hwaddr being set to 00:90:4C:5F:00:2A instead of the real MAC.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice