Speed Issues with E3000 switch

Discussion in 'Networking Issues' started by Mad Ed, Mar 22, 2011.

  1. Mad Ed

    Mad Ed Networkin' Nut Member

    Dear all,

    I don't want to give up the fight for a fast LAN at home and I hope you can help.

    I own an E3000 and a NAS as well as a Gigabit laptop. When I transfer files from or to the NAS the speed reaches 2-3MB/sec (Terracopy). Sometimes it drops to 512Kb/sec. Not funny.

    I have tried a direct connection, which is fast!! I also tried an old switch, which Is only 100 LAN, but reaches 8-10 MB/sec. Interestingly as soon as I connect the E3000 to the switch as well, the speed drops to 2-3 MB again.

    All cables are fine. So I have to consider the E3000 to be the problem. Can this be a setup issue?

    Thanks all for help!!

  2. Toxic

    Toxic Administrator Staff Member

    does the e3000 support jumbo frames? is it enabled? try disabling it.
  3. Mad Ed

    Mad Ed Networkin' Nut Member

    Had a look. Jumbo Frames not enabled. I am using TOMATOUSB RAF from Victek by the way. However, I have already tested the lated firmware from Linksys as well as the DD-WRT and the orig TOMATOUSB as well. All have the same issue.
  4. occamsrazor

    occamsrazor Network Guru Member

    Has anyone ever tested to see if jumbo frames actually works on the E3000? I'm curious...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice