Speed test 25Mbps w/o Router, 14Mbps w/Router!

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by 92GTA, Jul 24, 2010.

  1. 92GTA

    92GTA LI Guru Member

    I have a Cisco WRVS4400N v.1.1 using Firmware v1.1.08. I have Brighthouse for my cable internet provider here in Bakersfield CA. I use NO Brighthouse software or Cisco/Linksys software. It's just Windows 7 x64 retail with driver files for all devices and NO software.

    I was paying for 15Mbps and always testing between 14-15Mbps. All was well. Last week I upgraded to 25Mbps but I couldn't get test results over 14Mbps. I called and they verified my account settings were correct and that my modem supported it.

    I went home and decided to do some speed tests bypassing my router. Without my router using just my cable modem, I ran 5 back-to-back speed tests and got between 23-25Mbps. Then I put my router back in the equation and did 5 more back-to-back speed tests at the exact same site right after. I can't get a speed test result over 15Mbps to save my life!

    WTF is wrong with the router? lol. Any suggestions on what the heck to try?

    Thanks! Alex
  2. Toxic

    Toxic Administrator Staff Member

    Can you confirm dont have IPS enabled on the WRVS4400N ? when you test the WRVS4400N how are you connected to the router? via ethernet or wireless?
  3. 92GTA

    92GTA LI Guru Member

    IPS is enabled and I'm connected hardwired.

    Can IPS be the cause? Is it safe to disable it?
  4. Toxic

    Toxic Administrator Staff Member

    IPS will slow down bandwidth since it has to inspect every packet of data and scan it for malicious content.

    have you updated to the latest IPS signature? what IPS sig are you running at present?

    what firmware version does your router have?
  5. 92GTA

    92GTA LI Guru Member

    No I've never updated my IPS signature. I'm running v1.33. The router is firmware v1.1.08.

    Where do I find IPS signature updates?

    EDIT: Found it, version 1.42. I'll update it now.

    EDIT 2: Speed tests with the new update are even worse, I only get about 10-11Mbps. When I turn IPS off I actually can get up to 23-24MBps! But is this something I want to have off?
  6. Toxic

    Toxic Administrator Staff Member

    The vast majority of router do not have IPS. IPS is a nice feature but it is at cost to bandwidth unless you have a router in excess of the price of a WRVS4400N ;)

    you could try updating to v1.1.13 firmware as well and see if there is any difference.
  7. 92GTA

    92GTA LI Guru Member

    Thanks. I tried the newer firmware a year ago and had wireless issues. Perhaps I'll just leave IPS turned off.

  8. Toxic

    Toxic Administrator Staff Member

    for information only

    Changes from v1.1.03 to 1.1.13

    • Resolved an issue that caused the Quick VPN client to fail to reconnect to the router after disconnecting a VPN session.
    • Resolved an issue in Dual-Stack Mode feature that caused the router to not work properly if IPv6 mode was enabled.
    • Resolved an issue in the Administration -> Management tab that caused the router WebGUI to not be able to remove router usernames.
    • Resolved an issue in the Web GUI that allowed a user to enter and save an invalid character string in the Syslog Server field.
    • Resolved an issue in the Web GUI that allowed a user to save an invalid LAN IP address.
    • Resolved an issue that allowed an invalid IP address to be saved in the Static IP Mapping tab of the Web GUI.
    • Resolved an unclear statement in the popup message after enabling remote management.
    • Resolved a typo in the popup message that occurred when a user created the same username to access the router.
    • Updated the TrendMicro server certificate for URL, Access, and email security.
    • Resolved an issue on the WebGUI Firewall page that causes the check boxes to become grayed out after clicking the "Disable All Rules" button.
    • Resolved an issue that causes the Wireless AP to become unresponsive after changing Wireless MAC Control from "Prevent" to "Allow.â€
    • Resolved an issue on the WebGUI Firewall page. If *any* IP-based ACL rules are present, then any Forbidden Domains or Keywords present in the Internet Access Policy are not applied.
    • Resolved an issue on the Administration-> Log page that causes the "View Outgoing Table" and "View Incoming Table" buttons to remain grayed out and inaccessible after log settings are saved.
    • Resolved an issue in the Switch QoS Settings page that causes you to be unable to save the CoS settings.
    • Resolved an issue in the WLAN driver that caused connectivity issues with older WLAN adapters. It is recommended that customers update the WLAN client adapter driver version to the latest from the manufacturers website.
    • Resolved an issue on the Firewall -> Basic Settings page. When customers enabled Block Java, Cookies, ActiveX, or Access to Proxy HTTP Server, websites would open slowly.
    • Resolved an issue in Dynamic DNS resolution that causes the VPN tunnel to fail to connect to the new WAN IP if the WAN IP changed.
    • Resolved an issue in IPS that causes FTP throughput to become very slow when transferring large quantities of smaller files.
    • Updated IPS signature support for version 1.40.
    • Resolved an issue in the WebGUI that causes the advanced parameters section of the VPN page to not save the settings.
    • Resolved an issue that causes the WebGUI to become inaccessible when being accessed across a QuickVPN tunnel established by a Vista PC.
    • Resolved an issue in the VLAN code that causes the switch ports to be unresponsive until a system power cycle is performed.
    • Updated PPPoE and L2TP username and password fields to support special characters.
    • Updated the pop-up message for the password field when users enter more than 22 characters.
    • Updated the setting for "Management via WLAN" to be disabled by default.
    • Resolved an issue in the WebGUI to show the accurate amount of VPN tunnels available and in use.
    • Resolved an issue in the WebGUI formatting that causes the Remote Management page to become unviewable when the user is using Firefox to view the router WebGUI remotely.
    • Resolved an interoperability issue between the WRVS4400N and the WET200.
    • Resolved an issue in the VPN subsystem that causes the NetBIOS Broadcast to fail across a VPN tunnel.
    • Resolved an issue that causes the System UP time shown in the SNMP Browser to not match the System Up time in the WebGUI.
    • Resolved an issue that causes the DHCP Server on a VLAN-based subnet to not assign the statically configured DNS Server to the DHCP Clients.
    • Resolved an issue that causes Port Forwarded packets to fail to go through the HardwareNAT table when IPS is disabled.
    • Resolved an issue when a user applies https (SSL) to do remote management, the packet with SSL port 443 does not get forwarded to the LAN through port forwarding.
    • Resolved an issue in the LAN subnet pulldown menu. Removed the subnet.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice