Spent 15 hours trying to get WDS to work

Discussion in 'Sveasoft Firmware' started by olanin, Aug 20, 2004.

  1. olanin

    olanin Network Guru Member

    DSL -> WRT54G -> Channel 5 -> WRT54G

    I spent about 15 hours so far and cant get it to work. I tried the latest free satori and Alchemy-pre5.2.2 v2.09.1.8sv to no avail. To make it easier, im not using security or mac filtering.

    I cant describe all the things I tried, so far everything and every guide I could find.

    To test I have the main wrt54g at one end of the room and the other at the other end of the room. After a reboot or whatever i'll pull out the nic card and reinsert, that way i'll get the second non-wired wrt54g. I can ping it, but not the internet or main wrt54g. If I unplug the second non-wired wrt54g, i'll get the first wrt54g, can ping it and get on the internet.

    I dont really know how anyone can help, unless theres a better guide or info. I spent plenty of time searching here and sveasoft (but not a member at sveasoft so I cant post there).

    Basic settings

    dsl modem:
    1st wired wrt54g: gateway
    2nd non-wired wrt54g: gateway (tried) x.x.10.1 & x.x.10.2

    same ssid: justinnet for both and channel 5

    no security or mac filtering

    Tired under WDS both LAN and P2P. The mac would be the other wrt54g, same subnet ( and the others ip address. Lazy WDS disabled (but did try it enabled).

    I also tried having the second as a AP and Client, but neither did anything.

    Im ready to pay someone to help. BTW, in the future I would like to add another wrt54g as another wireless ap like this second one im trying to set up and one or two as a wired. I want to get this working first.
  2. DeployedOne

    DeployedOne Network Guru Member

  3. Edge

    Edge Network Guru Member

    When setting up WDS, make sure you are using the WIRELESS MAC address of both routers.

    You can find out what your WIRELESS MAC address is by going to the STATUS page, then clicking WIRELESS. The wireless mac is usually 2 digits higher than your LAN MAC address (ie. xxxxxxxAC vs xxxxxxxAE).

    Give that a try.
  4. olanin

    olanin Network Guru Member

    Is there more then one mac address per wrt54g? I was using the one on the bottom. If so that might be my problem.

    Besides that I tried everything. I printed out all the WDS-related info on sveasoft's site and plan on looking over it all this weekend.
  5. DeployedOne

    DeployedOne Network Guru Member

    Yes there is more than one MAC address for the WRT.

    If you follow the link I have above for the seavasoft thread on WDS you will see that is says not to use the one on the bottom of the WRT and how to find the correct MAC you should be using.

    That is your problem...

    Keep plug'n and you'll get it!
  6. Edge

    Edge Network Guru Member

    Yes - each router has 2 MAC addresses. One for LAN and one for the WIRELESS.

    f you go to the STATUS page, it will automatically sho you the LAN MAC ADDRESS. DO NOT USE THIS ONE. Instead, click on WIRELESS (at the top of the status page) and use the WIRELESS MAC.

    Good luck.
  7. olanin

    olanin Network Guru Member

    Thanks. I'll give it a try this weekend.
  8. pkitester

    pkitester Network Guru Member


    Just because inaccurate data bugs me... :)

    There are three MAC addresses.

    1) WAN
    2) LAN
    3) Wireless

    To set up WDS you definately need to use the Wireless MAC, or your could experiment with the Lazy WDS, which should do no authentication of the MAC.
  9. olanin

    olanin Network Guru Member

    Still no luck. Spendt about 5 hours today. I checked the mac address under status -> wireless plus its the same as listed in netstumbler. Here are my settings and more basic info. Sorry about the load time, but notice anything?

    dsl modem ( -> {wired} WRT54G @ (gateway -> {wireless channel 3} -> WRT54G @ (gateway next room with good signal -> wireless client @ (gateway

    Currently using Satori-4.0 v2.07.1.7sv but tired Reformed_B8_Alchemy_5_2_2.bin with no luck.

    Still having the same problem. If im connected to the wired wrt54g, I can ping it and get on internet, but cant ping wireless wrt54g. If im in the next room and connected to the wireless wrt54g I can ping it, but not the wired wrt54g or the internet. But the others mac is listed on the status page of the others. How do I test? With a TC1100 and Linksys cardbus wpc54g v1.2 @ gateway and subnet Strange part, if I connect the second wrt54g to a wire, it seems to work (unless I tested wrong).
  10. olanin

    olanin Network Guru Member

    main config. the is the dsl modem (westell 2200 no dhcp)



    WDS config page. Each has the others wireless mac address. Same as in the status -> wireless and also in netstumbler

    Its getting the others WDS signal??

    General wired status screen

  11. DeployedOne

    DeployedOne Network Guru Member

    Here is a few things I see right of the bat...

    1. Disable the WAN port on the second router (Basic -> Internet Setup).

    2. Address both router's LAN (Basic -> Network Setup) with addresses outside of the 192.168.10.X range and use say & (and use as the gateway on the second router)

    3. Setup DHCP on the first router.

    4. Disable Lazy WDS.

    5. Make sure you are getting the MAC addresses for WDS from the Status -> Wireless page of each router.

    This will help. I would also use different SSID's but keep the channel the same.

    After you do this it really should work. If you ever wire both to test connectivity through your second router to the internet... wire one LAN port on #2 to a LAN port on #1 and associate your client computer to the #2's SSID

    So it should be wired like this:

    router #1

    -WAN port to DSL modem

    -LAN ports to wired clients and/or other AP's that are on the same LAN

    router #2

    - WAN port disabled (because #1 is handling access to the internet)

    -LAN ports to wired clients and/or to #1 router LAN port (if not connected via WDS)

    I hope this helps!!!
  12. olanin

    olanin Network Guru Member

    I got it to work!!!

    Well first I reload my Reformed_B8_Alchemy_5_2_2.bin firmware insted of the satori, then did a factory reset on both. Entered in what you said and it worked!

    After that I changed both ssid to just one, enabled WEP and mac filtering. And so far so good. I only tried it out in my room (12:15am lol) but during the day I plan to fully test it outside. Im sure it'll all work fine.

    Thanks for the help!
  13. DeployedOne

    DeployedOne Network Guru Member

    Good job!

    Glad to hear you got it working.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice