SRW224P Switch - I'm locked out... Help, advice...

Discussion in 'Networking Issues' started by justinmann, Apr 22, 2006.

  1. justinmann

    justinmann LI Guru Member

    This is my first post, so hello all!

    I recently purchased an SRW224P switch and when I changed the admin password, the switch kicked me out (as expected), but then wouldn't let me back in. It's one of those situations where I'm 99% certain that I typed the password in correctly, and I've tried all sorts of mistyped variants, but to no avail. Additionally, I'd set up an additional username and password and it won't let me in under that one either. I've tried getting back in through the web interface (which is where I configured this) and then in through the console interface (thinking maybe something else was wrong) but it refuses to let me in either way.

    There appears to be no reset switch on the switch, and no instructions on what to do if this happens. Any input would be greatly appreciated...

  2. tnttrx

    tnttrx Guest

    Similar problem here:

    I have SRW2024 and while I was trying to upload new firmware file (I've failed because my http server that should provide firmware file was down at that moment) power went off.
    After few moments power restored and switch seemed to work as usual - "system" led was lit and port leds with cables attached were lit too. It even recognizes if 100Mbps or 1Gbps device is attached to the port (green and orange leds).
    But... Switch does NOT forward any packages. I can connect computers on any port on the switch and can't ping each other. I even can't ping switch itself (default address is
    I haven't got any cable to connect via console port, so I've used some standard serial calbe I've found and there's no way to get some answer on the console: HyperTerminal doesn't show any kind of activity (I've followed instructions found on Linksys site about HyperTerminal configuration).

    I know that there's no external "reset to the factory defaults" switch, but is there any other way to reset this Linksys? Any way to make boot ROM not boot existing firmware but to load factory default or something similar?

  3. justinmann

    justinmann LI Guru Member

    Thought I would update all on the status of this saga... I finally got wise, and contacted Linksys support through their chat function (which works much better than email or the phone) and they suggested I send the switch back to newegg, even though technically newegg isn't supposed to take back linksys products at all. So I got Newegg on their chat thing, and they said they would take it back. W00t!

    So, when I got the new switch, I discovered why the old switch wouldn't let me back in. Turns out the password setup field on the switch is only 8 characters long, while the password input field for login is inifinite. I was not watching the asterisks appear when I put in the password the first time. Of course, Linksys support should have realized this and suggested that I truncate the password to eight characters, but I suppose they'd rather eat a switch. I did write tech support and let them know. Eight characters? How secure is that?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice