Stability issues with Thibor 15b1

Discussion in 'HyperWRT Firmware' started by qBot, May 7, 2006.

  1. qBot

    qBot Network Guru Member

    I'm having stability issues with this firmware. I upgraded this morning to version 15b1. Since this i've had problems streaming large files off of a computer. A couple of seconds in to the process the Wireless connection drops. I immiediately switched back to the stock 4.20.8 firmware and now everything is fine. Funnily enough I had this problem with an old version of the stock firmware too. It would have been pre 4.xx . The only out of the ordinary features that I was using on Thibor, was QoS for Skype (Highest) and HTTP (Medium), Static DHCP and a few blocked web pages.

    I did have Thibor 15 installed last night and it didn't seem to have problems but i'm not too sure if I was transferring large files.

    Any ideas anyone?

    Edit: I'm also using 128 bit WPA2 encryption. But i used that on both firmwares with the same key.
  2. Toxic

    Toxic Administrator Staff Member

    had you used a hard reset the router after the upgrade?

    what wireless settings are you using?

    beacon interval, Fragmentation Threshold, RTS Threshold, Frame Burst?
  3. Thibor

    Thibor Super Moderator Staff Member Member

    i've re-instated the overclock, it will be in 15b2
  4. qBot

    qBot Network Guru Member

    After the upgrade I went I used the "clear nvram factory defaults" option in the firmware so that shouldn't be a problem.

    @Thibor Thanks for the response. Just out of curiousity, how do you know that is the problem? Did you see it before.
  5. Acid-drop

    Acid-drop Network Guru Member

    are you sure keeping the overclock is really a good idea ?
    I doubt it can be a solution to any problem
  6. Thibor

    Thibor Super Moderator Staff Member Member

    it is the solution for the gv2.2 installed by Linksys. i don't like it either. i have made it a choice for releases in the future. you can choose to overclock by setting cpu_overdrive=1 if you have the type of cpu that requires it.
  7. beach-hobo

    beach-hobo LI Guru Member

    I have a gv2.2 and am new to custom firmware on routers. Can someone give me an example how to add the "cpu_overdrive=1" command in HyperWRT b2 when it becomes available ???
  8. slamcat

    slamcat Network Guru Member

    You'll have to telnet or sshd into the router, and at the command prompt, issue the following commands:

    nvram set cpu_overdrive="1"

    To make sure the setting stays on router reboot, issue this right after it:

    nvram commit

    And that should do it.

    Assuming that variable is an nvram setting.
  9. qBot

    qBot Network Guru Member

    Are there any consequences to doing that. Could it cause damage to my router?
  10. slamcat

    slamcat Network Guru Member

    Most likely not. The Linksys stock firmware through the firmware updates used that setting as a dirty fix to a large file transfer problem over the LAN, although they didn't set a variable called cpu_overdrive, it was more like a currently existing variable clkfreq, IIRC.

    Keep in mind though that uploading any third party firmware voids your warranty anyway (although as long as you flashed back to Linksys stock firmware I'm sure they'd be none the wiser).
  11. qBot

    qBot Network Guru Member

    Well, I set the "cpu_override" flag and it seems to have solved it. The most annoying though is that I was talking to Linksys technical support months back when I had this problem first. They kept blaming my belkin wireless cards and telling me to mess around with driver settings. If they fixed the bug by overriding the cpu then the tech guys should have known about it and stopped me from wasting so much time on it.

    @Thibor Great firmware and great tech support.
  12. Thibor

    Thibor Super Moderator Staff Member Member

    wow, that's surprising news.
    i instigated the cpu_override variable, and i haven't released the firmware with the fix in it, but hey; whatever works for you :)
    (i think you'll find that it isn't quite as fixed as you think it is)
  13. qBot

    qBot Network Guru Member

    Ya, your right. The streaming seemed fine but when I tried transfering a file it dropped again. I read the above post to mean that the feature was always in the firmware but it just had to be activated with that cpu_override flag. My bad.
  14. qBot

    qBot Network Guru Member

    Ok, well this problem was definitely fixed with the b3 release. Just one question though. When I do a backup of my config in the Administrative page will it save how I the CPU in over drive or will I have to explicitly set it each time I restore my config.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice