Static IP Adress instead of DHCP

Discussion in 'HyperWRT Firmware' started by ganymed, May 24, 2006.

  1. ganymed

    ganymed LI Guru Member


    i'm having big trouble with the DHCP Server of the Linksys WRT54GL and HyperWRT. Can someone eplain step-by-step how to setup a static IP Adress on router and PC instead of DHCP?

    Thanks in advance.
  2. prowler1968

    prowler1968 Network Guru Member

    A) What firmware does your router use - Stock Linksys or Hyperwrt? What version?

    B) I have not seen any issues mentioned recently that the firmware has any problems with the DHCP server.

    C) What operating system are you running?

    D) Did you upgrade the firmware at any point? Perhaps the memory of the router needs to be completely cleared, either with the reset button on the back (hold down 30 secs.) or in the router Administration Tab.

    E) Where exactly is the problem - the router getting an ip address from you ISP or your computer getting an IP address from the Router?
  3. ganymed

    ganymed LI Guru Member

    A) HyperWRT, newest version (Thibor 15c?)

    B) It seems to be a specific problem of my PC

    C) Win XP Prof.

    D) I upgraded the Firmware to HyperWRT as soon as i received the router. I tried several resets and cleared the NVRAM, but nothing seems to help.

    E) The router is not getting an IP address (only the autoconfig There seems to be something wrong with the DHCP Server or my TCP/IP connection. I searched with google, asked on another forum, but still have this issue.

    DHCP with my PDA or Laptop works fine, i only have problems with my PC.

    Any help is appreciated, also regarding the "old" thread subject.

    Sorry for my bad english ;)
  4. prowler1968

    prowler1968 Network Guru Member

    It seems as if you have a problem with your router communicating with your modem. Since you have tried the resets/clear NVRAM, that would rule out a firmware issue UNLESS your ISP has an odd protocol.

    Log into your router (default of and on the setup/basic setup tab, verify that your setting matches the type of ISP that you have. There have been other discussions that, many times, it may be a faulty cable/dsl modem that causes this type of problem. It could also be your ethernet cable itself is worn causing this type of problem.

    I would try a different ethernet cable, verify the ISP type (If you ISP provides you with a static IP address and you have Hyperwrt set up as DHCP, then it cannot get an IP address). Also, try to hook your computer directly to the modem and see if you can get your computer to obtain its IP address. Another thing that may be happening is that you modem is linked to the MAC address of the previous device attached directly to the modem (example - your old router or your network card if you were connected directly). In this case, you could go into the setup tab of Hyperwrt and clone the MAC address of the previous device.

    Failing any of these options, I would try to swap out the modem with your ISP.
  5. mstombs

    mstombs Network Guru Member

    I read this as the PC not getting an IP address from the router.

    This can be due to firewalls on the PC etc, but you can define a static IP on the PC in the TCP/IP settings (which should be set to auto for DHCP).

    By default the router uses addresses above for DHCP, lower address can be define on the PC ie, subnet mask

    The gateway and DNS server addresses can both be the router (assuming Hyperwrt Thibor default
  6. ganymed

    ganymed LI Guru Member

    I still don't understand where i should type in the IP on the router's configuration menu.
  7. prowler1968

    prowler1968 Network Guru Member

    If your ISP requires you to enter your own IP address, you select on the Basic Setup Tab of the router configuration "Static IP" and enter the configuration from your ISP.

    If you are wanting to assign an IP address to a particular device on your network, you will go to the Static DHCP tab on the router configuration and enter the MAC address of the network card in your PC and then enter the IP address that you want to ALWAYS be assigned to that particular device.

    As MSTOMBS said previously - You could have a firewall blocking your request to get an IP address from the router if your other devices are able to get their IP address from the router. Another issue - If you are connecting wirelessly, you will not be able to get an IP address if your security settings on the Client PC do not match the router's configuration.

    Out of the box, Windows XP should not have any issues connecting to the router provided that the device drivers are all correctly functioning in the Operating System.
  8. ganymed

    ganymed LI Guru Member

    I did exactly what you wrote, but the router still doesn't work. I made some screenshots for another forum where i posted this strange problem, maybe you can help me to fix it or see the cause:

    ipconfig /all of my PC that doesn't connect to the internet:

    ipconfig /all of mylaptop that connects to the internet (same WLAN/router!!):

    Networkdiag of my PC:

  9. myersw

    myersw Network Guru Member

    First screen shot indicates that the xp pc did not get a IP address. XP will give out a IP address in the indicated range when no IP address is configured on the pc or did not get a IP address from DHCP. Review your IP config settings and try turning use DHCP on, remove any static entries you have tried and see if you get an IP address then. Should. If not need to determine why not before trying to get fancy with a static lease.
  10. ganymed

    ganymed LI Guru Member

    I really tried everything to get DHCP running, but it didn't helped.
  11. swinn

    swinn Network Guru Member

    Verify that the DHCP service in Windows XP is set to Automatic and is currently running.
  12. ganymed

    ganymed LI Guru Member

    It is of course.
  13. prowler1968

    prowler1968 Network Guru Member

    I see that you have a DLink DWL-122.

    I have had problems with those. I had one that worked for about 3 months and died (The computer could recognize the DLINK, but could not find the router - I think the receiver/transmitter died.)

    I got a replacement from DLink that died in less that 1 week.

    The third has been working for about 1 month. I got a Linksys to replace it.

    Try swapping that for your laptop's wireless USB adapter and try the Prism one in your non-working machine to see if that would make the machine connect to the internet.
  14. ganymed

    ganymed LI Guru Member

    i bought a new wlan network card and it didn't solve my problem.
  15. Somebodympc

    Somebodympc Network Guru Member

    Are you using WEP? This happened to me because I used WEP, the moment I used WPA I had no issues with DHCP.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice