Stats, MRTG and SNMP

Discussion in 'Tomato Firmware' started by paped, Nov 12, 2007.

  1. paped

    paped LI Guru Member

    I am wondering if any body can help I need to setup a graph that is external to the tomato WRT54GL V1.1 router which shows my bandwidth usage so I naturally thought MRTG would be the way to go I have it setup on one of my PC's already from when I used to use DDWRT. I found the Howto on the forum and installed it but to no avail it just won't work I have tried various conf files as per the howto, not used notepad, rebiuld the router from scratch I have the correct entries coming up in syslog so SNMPD appears to be working. However everything I try just gets a not responding error it is as if something is blocking port 161 ps I have no firewalls running except the Tomato one which I have tried port forward on but nothing. The annoying thing is that I tried the exact set-up on a V2.2 54g router that got fried by lightening, only the WAN and one switch port works but MRTG works so I am baffled has anybody got any ideas how to get this going on a GL?
    The other option is to use the internal graph but is there anyway of showing this without having to log in to the router?
    I must admit I am not aware of a wish list but if anyone reads this is there any chance of get snmp added in to the firmware proper? As this would make Tomato 110% perfect!!!!!

    Thanks in advance for any help....
  2. paped

    paped LI Guru Member

    Finally get snmp working on my GL so to help anybody else having problems with this here is what I did....

    Download the files from this website -
    Once in the download page which is linked from the above page click the snmpd link and the file should begin to download, do a save link as on the conf file and name it snmpd.conf
    Put both these file in the same directory on the CIFS share

    Then follow the howto done by bokh -
    using the snmpd and conf file you have just downloaded (and tailor the file paths for your installation) and it works.

    Not sure what the difference is between the files but this also seems to get round the snmpwalk issue as I can do a full walk on the router without snmp locking up which appears to have been a problem in the past.

    Hope this may help somebody....
  3. paped

    paped LI Guru Member

    OK can anybody please help as this is beginning to get annoying... I have managed to get the snmpd working as explained above but every few hours it just dies on me and the only way I can restart it is to reboot the router. There is nothing in the syslog to explain way it dies it just stops responding to MRTG and when I log in and do the top or ps commends on ssh it is just not there anymore????
  4. bogderpirat

    bogderpirat Network Guru Member

    ssh to your box, run the snmpd executable in there and leave your terminal open. as soon as the snmpd dies, check whether the terminal says anything about snmpd dying.

    all of however this sounds a bit like your wrt is slightly damaged, maybe faulty ram, an overheated cpu or something of the sort. are there any other things that work anomalously?
  5. paped

    paped LI Guru Member

    I have already done this but retried it today as a double check, from the MRTG graph the service dies just after 3pm today (started again at 9am so lasted 6 hours) in the SSH terminal the is nothing shown error wise and rechecked using the "top" and "ps" commands and snmpd has just disappeared again. Checked syslog and again no errors shown even though snmpd was started with the -s syslog switch... so i am a bit stumped on this one?

    Everything else seems to work fine on the router in fact other than this snmpd problem it has been 100% stable and has often gone well over 2 months between reboots and most of these have been due to upgrades rebooting the system rather than there being a problem that forced it.
  6. bokh

    bokh Network Guru Member

    What is your MRTG probing for on the WRT54 (like bandwith-usage, uptime, memory, etc.)? Don't sent a complete config, just the description.
  7. paped

    paped LI Guru Member

    All I am probing for is the bandwidth on 2 interfaces PPP0 and Vlan1, MRTG during the snmpwalk did pick up all the other network interfaces such as BR0, Vlan0 etc but all others are commented out in the MRTG config file so not being probed for... So any ideas of what could be wrong would be appreciated as there seems to be no rhyme or reason for it. As to test the router I have put DDWRT back on with my old backed up config from last year for a day and a half and snmp worked for the whole time without a hitch???? I am now back on tomato with SNMPD + the conf file on CIFS2 and the problem is back again.... also tried it of CIFS1 but it seems to have the same problem.

    Thanks for any help or ideas given....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice