strange network problem :wallbang:

Discussion in 'Networking Issues' started by argh, Jan 21, 2006.

  1. argh

    argh Network Guru Member

    Hi. I have the strangest problem.

    My network looks like this:

    dlink 624+ 
    dhcp server
      | (
      | (
    linux router
    subnet mail and
    dhcp server
     | (
     |                                                                        (wireless)
     | (                                       (
     | ( in use))                |---Computer 1
    Wrt54gl --------------(wireless)------------------|
     | (no dhcp)                                                   |
     |                                                                   |
    Sat tuner(                Wap54G(
                      ------------------------------------- switch
                      |                                                   |
                      |                                                   |
             nslu2(                  computer2(
    All firmware original linksys. Wap is V2.0 with 2.08 eu firmware.

    My strange problem is if i try to ping the nslu from the computer1 or sat-tuner it takes a very long time before i get a response(approx 15 sec). Enough to samba to timeout. But if i ping computer2 from the same computers it responses quick.

    If i ping slug from computer2 it responses quick.

    I can ping anything from slug or computer2 without a delay.

    I can accsess web-interfase of wap54g from computer2 without any problem. But not from wireless side.(sometimes i can if i restart the wap)

    I run the wap in ap mode wit.h wep encryption.
    I would post pictures of my setup i i had an internet server :\ (damn isp)

    Also transfer rate seems slow. Streaming music is cutting at times.

    Can anybody help me to solve this problem? :(
  2. AtillaThePun

    AtillaThePun Network Guru Member

    I can't tell what your NSLU2 is connected to from your diagram.

    Have you checked the ARP cache on Computer 1 to see if the MAC address for the NSLU2 matches the actual? Have you done a trace route from Computer 1 and Computer 2 to the NSLU2 to see what the different route or hold up could be?
  3. argh

    argh Network Guru Member

    Hi. Thanx for the reply. the slug is connected to the switch. I have updatet the diagram.

    This is real weard. Somtimes i can ping. Somtimes not. Somtimes tracert gives reply. sometimes not.

    Tracert from computer1 to slug:
    try 1:
    Tracing route to []
    over a maximum of 30 hops:
      1     1 ms     1 ms     1 ms []
    Trace complete.
    try 2:
    Tracing route to []
    over a maximum of 30 hops:
      1     *        *        *     Request timed out.
      2     *        *        *     Request timed out.
      3     *        *        *     Request timed out.
      4     *        *        *     Request timed out.
      5     *     ^C
    Traceroute from linux-router to slug.
     1:  gatekeeper-if1 (                           1.765ms pmtu 1500
     1: (                         3.357ms reached
         Resume: pmtu 1500 hops 1 back 1
    From computer2 to slug.
    Tracing route to []
    over a maximum of 30 hops:
      1    <1 ms    <1 ms    <1 ms []
    Trace complete.
    When i checked the arp cache i noticed that all my computers is not present in this table.
    Yep. the mac adresses matches.

    it seems to loose awarness that the computer is there at times.

    also i can tracert from computer1 to slug but not from slug to computer1. but if i traceroute from slug to sat-tuner or linux-router i get reply at once.

    Sometimes cannot ping the wap from computer1.

    i think the wap54 or wrt54 is the holdup.
    My wap54g is set up as a ap-client with wep encryption on channel 11. static ip

    my wrt54gl i set up with this settings.
    Wan port static ip
    lan port static ip
    dhcp server disabled
    ddns disabled
    mac adress clone disabled
    advanced routing off( i had it sat to router with rip enabled but it did not do any changes.)
    uPnp disabled
  4. AtillaThePun

    AtillaThePun Network Guru Member

    When the trace route from computer 1 responds what does THAT look like. Since the connectivity is intermittent it's almost certainly not your settings. I believe you said you'd changed out the Cat5 cables?

    This pretty much narrows it down to 3 things. Either

    1. the NIC in Computer1 is going bad. (Or possibly the TCP/IP stack)
    2. The WAP54G is going bad. I'm not familliar with this device, does it have multiple ports? Maybe the port Computer1 is plugged into is getting flakey.
    3. The switch is going bad (bad port w/ intermittent connectivity)

    If Computer2 can reliably reach the Internet then you can rule out anything to do with the WAP54G (with the possible exception of a bad port, see #2 above).

    When Computer1 can't ping/tracert does it have a valid IP (i.e. one on your network, not one assigned randomly by Windows)?
  5. argh

    argh Network Guru Member

    Wap54g is a accsess-point. Purly 1 ethernet to wireless.

    i can tracert computer1 from computer2.

    i cannot tracert computer1 from slug. tried to change cable. no difference.

    tried to remove switch. no difference.

    now i have tried to move the wap so it is ~3meters from the wrt. and have plugged the nslu directly into the wap. Same problems.

    I have problems with downloading big files to computer 2 from computer1 or internet.

    I think my settings must be wrong somewhere. Or i need some other firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice