Strange Problem

Discussion in 'Networking Issues' started by cheezitman2002, Nov 29, 2005.

  1. Hi. For some time now, I've been having problems with my WRT54GS V4. I have 2 computers, one wired, and one wireless, and sometimes an Xbox, which is wired, hooked up to it, but every several days, one of my computers, the one wired to the Router, stops working. Sort of. I can't access any web pages, access my router's config page, or sign on to AOL Instant Messenger. The strange thing is, though, that I can use Bitorrent. And I get incredible speeds doing so. Everything else on the computer stops working, though. When I try to load anything in either Firefox or IE, I get a "The page you were looking for could not be found" after 30 seconds of trying to connect. The light on my router stays on, and the activity light on my modem keeps blinking, and it tells me I'm connected, but running a ping command times out no matter what I do. I've been able to get around this by turning off the computer, unplugging the router, turning off the modem, disconnecting the modem and router from each other, powering them on, reconnecting them, and powering my computer on again, but it's sort of a pain, and lasts for a week at the most. During the time when my wired computer is down, my Xbox, which is also wired, works perfectly, as does my wireless computer. I've tried everything I can think of, but nothing seems to work. Thanks.
  2. riyehn

    riyehn Guest

    I'm experiencing similar problems with my WRT54G V3, though I unfortunately haven't found any permanent solution. All of my network activity stops working about once a day, except for BitTorrent traffic, despite all of the lights indicating that things should be working. For me, though, it tends to affect the entire network, not just my own (wirelessly connected) computer.

    Not sure if this will help you or not, but in my own experience all I have to do is restart the router itself, then wait about a minute and things work again without rebooting my PC. Maybe your problem is different, but that seems to work (albeit temporarily) for me.
  3. jgutz20

    jgutz20 Network Guru Member

    i've had issues like this when i was using azureus, i dont know if it was just that program or bit torrent as a whole. you could limit the upload speed of the bit torrent client. all these incoming IP addresses is probably overloading the router
  4. compuworm

    compuworm Network Guru Member

    Yes, Strange

    OK, I have a wrt54gs v2 and it works great. I have two computers and two xboxs hooked up one of each is wireless and the other hardwired. But, I simply don't have any problems. I do use static IPs for all and I have the latest firmware installed on the router, HyperWRT WRT54GS_4.70.6-201105 (Thibor). Maybe just maybe you need to change or reinstall your firmware. Have u tried this.
  5. NateHoy

    NateHoy Network Guru Member

    This is normal in the stock firmware. The stock Linksys firmware maintains connections for a very long time (5 days) and eventually the router simply cannot create any new connections, and "dies" (all the established connections run OK, but new ones cannot be created).

    HyperWRT Tofu and Thibor both have a fix for this right in their firmware. For other firmware, put this in your startup script (it disconnects idle connections after 1/2 hour instead of 5 days).

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    The key number is the "1800", which is 1/2 hour. If you see connections to SSL pages, etc, dropping prematurely, then try upping that number and experimenting. BUT, I connect to a corporate VPN using my WRT54G, and I've enjoyed a solid week of VPN connectivity with nary a problem using this script, in addition to an all-around rock solid router, using BitTorrent, VPN, *and* a Vonage VoIP phone adapter.

    Unfortunately, the stock Linksys firmware, in addition to having the 5-day problem, ALSO does not allow startup scripts...

    Here is a more complete/thorough startup script in case you want to play with even more settings:

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    Caveat emptor. Works for me, though, and this is a VERY common BitTorrent fix.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice