Stuck att green blinking ready/status

Discussion in 'Cisco/Linksys Network Storage Devices' started by Woppe, May 5, 2007.

  1. Woppe

    Woppe LI Guru Member

    I was running my NSLU2 just fine with unslung 6.8, when it suddenly stopped responding. I had to pull the plug to shut it down (pushing the power button on the front didn't have any effect).
    Now it won't boot anymore - it stucks at the green blinking ready/status-led. I cannot ping it, nor access it through the web interface or connect to it using SSH.

    Do you have any idea what I should do to make it work again?
  2. z80_fr

    z80_fr Guest

    the same for me... but get it work few minutes

    I got my NLSU2 last friday, setup the IP to fixed IP using the LINKSYS tool. Connected an old 20GB 2,5" HDD, formated the HDD using the NLSU2 web interface. And then upgraded to UNSLUG 6.8.

    Everything was running pecfectly. I did let the slug powered ON. after trying to get TELNET connection to work (I've used the TELNET enable web page)
    But TELNET connection only allow me to enter username and password then prompt some text that say something like "unslug running from flash minimum services" blabla bla.... then cosd the TELNET connection by itself.

    I decided to browse the web for more informations about that. During this time the slug was still runnnig and powered ON.
    But when I looked again at the slug after browsing for 1 hour or so, the staus LED was blinking. With the same behavior than you.

    I have tryed to remove and restore power, no success. Then removed power and HDD and then power back on same result. Decide to search the WEB on NLSU2-linux to find a solution for restoring original firmware. But after a while the STATUS stop blinking after the slug made a small "beep".

    Then I've tryed to connect the slug using the original LINKSYS configuration software, and it worked, I've setup again the IP because it had been changed back to original !!!
    I was happy to get connection again. Unfortunately the slug stop working again but without blinking the STATUS LED! no web, no TELNET, no thing.
    Even the power OFF / ON and try to gain acces using original configuration tool fail.

    The slug is powered OFF since Tuesday afternoon and I've tryed to power it again.
    Any sugestion and/or help welcome.
  3. harrylow

    harrylow Guest


    Did you find a solution to the blinking green light .

    I just purchased the NSLU2 took it out of the box, pluged it in and got the blinking green light, when i ran the wizard couldn't even detect the device. (ethernet light is solid)

    Brand new machine out of the box and it doesn't even work ???:confused:

    Oh also resetting does nothing as well, hold down the reset button until the beep and then back to the blinking lights.

  4. Problem with IP

    I had exactly the same situation ... but now it works.

    I noticed (I have connected the device to the computer using a separate swich with no router and it wrked) that the NSLU2 tried to get an IP address on my router (Linksys WRT54G) which has DHCP turned on but somehow it got stuck. The logs showed that they are in a constant loop of asking for an IP address and getting one. So, I have turned OFF the DHCP feature on the router for a while and reseted both devices (with resetting the IP address n NSLU2 with 2 seconds reset) - it worked. After more than 5 minutes the NSLU2 stopped blinking beeped for a while, then beeped twice and started functioning an expected (using the defauld address of 77). I run the setup, set al the parameters manualy and was able to turn the DHCP featuer back ON (but I have added a static lease just in case).

    Now it all works!
  5. Woppe

    Woppe LI Guru Member

    I sent my NSLU2 to linksys, and they replaced it with a new one.
  6. havermoutpap

    havermoutpap LI Guru Member

    I had a similar, but maybe different issue. No boot, but repeated blinking status led and disk access every few seconds. The problem was a faulty power supply. These Chinese pieces of engineering are really great. Replace them when in doubt.
  7. Thanks, your info pointed me in the right direction. The green Ethernet LED on my new NSLU2 never stopped blinking when I connected it to my router (Buffalo WHR-G54S running DD-WRT).

    Turns out the NSLU2 didn't like the DHCP IP my router gave it, so I manually assigned it the IP it expects out of the box ( - like in the manual). I hit 'apply settings' in my router and the NSLU2's LED went solid. It's now fully functional, no DHCP disabling or even NSLU2 unplugging/resetting necessary!

    Quick version if your 'Ethernet' LED won't stop blinking: In your router configuration, assign this static IP address - - to your new NSLU2.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice