Stumped with port forwarding after upgrade

Discussion in 'Tomato Firmware' started by jsheeler, Feb 12, 2008.

  1. jsheeler

    jsheeler LI Guru Member

    I have been a faithful Tomato user since 1.07(I think that was the first I used). I have never had a problem at all with it. I made the upgrade to the latest 1.15 the way I always have.
    -hold reset for 30
    -flash new firmware
    -hold reset for 30

    Everything looked like the flash was successful.
    Now the crazy part.
    I cannot for the life of me get port forwarding to work!! I have tried everything that I can think of. Clear NVRAM...reflashing. I can switch firmwares to DD-WRT for example and get my port forwarding working within a minute or 2. Reflash any version of Tomato and they will not work.

    What am I overlooking??

  2. FRiC

    FRiC LI Guru Member

    Was the port forwarding rule added correctly? (i.e. you pressed "Add" and not "Save"?) Is the rule enabled? (Not doubting you, just sanity checking.) :)
  3. jsheeler

    jsheeler LI Guru Member

    I am pretty sure I added the rules correctly. I think I have add/deleted rules over 100 times to no avail.

    don't worry, I need the sanity check!!


  4. jsheeler

    jsheeler LI Guru Member

    Well, unfortunately I am stuck with DD-WRT for now. I have tried every version from 1.11 to 1.15 without being able to forward ports.

  5. j.m.

    j.m. Network Guru Member

    Are you pressing the "Save" button after you add the rules?
  6. jsheeler

    jsheeler LI Guru Member

    I sure am
  7. j.m.

    j.m. Network Guru Member

    Well, I'm sure you are missing something, but it is hard to tell just what that is without seeing your configuration. Are you double NAT'ed by any chance? I.e., is your broadband modem also a router (esp. common in DSL modems)? Is the LAN IP of your router when flashed with DD-WRT different than with Tomato? How are you testing the efficacy of your port forwarding efforts?
  8. jsheeler

    jsheeler LI Guru Member

    I agree that I am probably missing something, but I really cannot seem to find out what it is. I have never had a problem switching versions ot Tomato or even trying different distros b4.

    nope. cable modem

    it is the same. - router ip - static ip of pc

    I have an app called Local Port Scanner. I have also tried some of the many web based port scanner/checker. Lastly my webserver, ftp server and RDP connection are all inaccessible from outside the LAN.


  9. jsheeler

    jsheeler LI Guru Member

    Have been messing around some more with Tomato. Get this...

    UPNP works. successfully opens a port using it.

    If I use the exact same settings, for the same app and turn UPNP off in Tomato the damn port is closed!!

    I am really stumped here

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice