successfully debricked a WAP54G

Discussion in 'Other Linksys Equipment' started by hedpe, Jun 10, 2005.

  1. hedpe

    hedpe Network Guru Member

    Hey all,

    In the course of my research, I needed to make custom firmware for my WAP54G to take sensor data. Well, of course I bricked it on the first try. So i looked around and found solutions for a bricked WRT54G. I looked at the WAP54G motherboard... where is the flash chip!?

    Well, after I unscrewed the whole thing, it was underneath the motherboard.

    So i took a windows computer, connected it directly to the WAP54G, and gave it a specific ip address of "" with subnet "" and the rest of the fields blank. I then did "ping -t" so i could see when i brought it back up from ping responses.

    I tried the first method by placing a wire between pins 15 and 16 to short them... it didn't work. So I tried taking a wire, taping it to the metal washer/bolt of one of wireless antenae's on the WAP54G, and touching the other end of the wire to pin 16, and powering it on. This worked! I started getting pings from it!

    So then i "tftp -i afirmware.trx", i got successfully transfered, the green light came back on the router, i did a soft reset by holding the reset button for like 10 seconds, and then bam! I could get into the web interface again :)

    Hope this helps people in the future!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice