Sudden disconnecting ethernet on WAG54G - UK

Discussion in 'Other Linksys Equipment' started by waxsteel, Jul 5, 2005.

  1. waxsteel

    waxsteel Network Guru Member

    My WAG54G - UK router/modem has started to act up!

    I get good wireless connection but the ethernet is screwed up - I get constant "cable disconnected" then "network available" messages popping up now (though it reported network speeds between 10 mbs & 100mbs for the few seconds it was up - I have 10 baseT!!!).

    I have reduced the network cards settings from Autosense to 10mbs full duplex & it works fine now, BUT my xbox - which doesnt have that kind of control over its network - is dead to the router - no lights at all. I have tested the xbox elsewhere & it is not at fault. Its like the autosensing has gone on the router.

    Any suggestions for how to set an xbox to 10 base T and not autosensing???

    I have tried the router on other pcs & they all do this disconnect cycle until I set their network cards to 10baset full duplex.

    I've hit hard reset a few times and updated firmware to 1.02.1 but have run out of ideas - any suggestions anyone??
  2. TazUk

    TazUk Network Guru Member

    Have you tried different cables?
  3. waxsteel

    waxsteel Network Guru Member

    Oh yes & tried those cables on other machines & they work. I took the router into work where it exhibited the same disconnect / connect issue with their cables too, until I set the work machines network card to 10base t (half or full duplex) - then it stayed connected & worked fine.

    Seems to me that the auto-negotiation, auto- sense or whatever is broken on the WAG54g-uk now.

    I am borrowing a single speed 10baseT hub to see if it recognises the xbox plugged through that, otherwise I think I'll need a new router. Don't think I'll be able to use it for anything that isnt/cant be set only to 10baseT

    Do you think its worth raising the issue with Linksys under warranty??- I've bought the router in Feb 2004
  4. TazUk

    TazUk Network Guru Member

    It's worth a try :)
  5. waxsteel

    waxsteel Network Guru Member

    Well I tried connecting the xbox to an old single speed 10baseT hub & then plugged that into the router - started working fine - just goes to show you shouldn't throw these old things away.

    Saves me having to get a new router modem anyway, until something else goes wrong. I'm going to plug the adsl line through a surge protector just in case as well - I already had the powersupplies to all my equipment surge protected.
  6. jasonoliver

    jasonoliver Guest

    I have exactly the same problem. It was all working fine in XP then I got the netwrok card disconnected messages and had to set the card to 10 mbps. I've tried new cables, firmware updates for my bios, nic and router and also updated all fo the Windows drivers but nothing works. Does anyone esle have any ideas?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice