System Crashing While Downloading; Indicates WUSBGXP.sys

Discussion in 'Other Linksys Equipment' started by Zadillo, Jul 2, 2005.

  1. Zadillo

    Zadillo Network Guru Member

    Hi all,

    I've been experiencing a problem where my system will completely crash seemingly at random. The one pattern has been that it will often happen while downloading something for an extended period (i.e. most recently I've been trying to download the 1.2 gig installer for the Auto Assault beta, using FTP). If I just leave my PC doing nothing it is fine, but it will likely crash like this and report a system error while it is downloading for an extensive period of time.

    I turned off "automatic restart" so I could see exactly what the error was.

    This time, when it crashed, it showed me a dark blue diagnostic screen explaining that an error had occurred.

    The error it reported was:


    For Technical Info, it said:

    STOP: 0x000000D1 (0x3199E43B, 0x00000002, 0x00000000, 0xB8117D98)

    WUSBGXP.sys - Address B8117D98 base at B80EE000, DateStamp 4069f4da).


    So, this seems to indicate some problem with the driver. I am using a Wireless-G USB Adaptor from LinkSys. Honestly, I'm not exactly sure which hardware version it is. Is there a surefire way to tell? The CD at least says ver 2.0, but I wasn't sure if that was the hardware version of the setup wizard version. The model number just says WUSB54G.

    The driver I have installed right now is, which is for the v2 hardware, and the latest I saw on the site.


    I guess my question is, is there any way to find out what this problem might be, and how to resolve it. I would be happy to get a newer LinkSys adaptor, either USB or PCI, if that would help.

    If anyone has any suggestions or ideas, I would really appreciate it.


  2. jagboy

    jagboy Network Guru Member

    did you try to google the error.

    see if rolling back the driver will help.
    try to install the adapter on another comp. and see if you get the error.

    i dont think that getting a new usb54g will help. my gut is telling me it is a software problem.
  3. Zadillo

    Zadillo Network Guru Member

    I tried googline the error but only came up with a handful of results..... other people reporting problems, but didn't see any concrete answers or explanations.

    I'm not sure what I should roll the driver back to. I am running with the only driver available for the WUSB54G, and I never had another driver for it.

  4. Zadillo

    Zadillo Network Guru Member

    One thing I'm going to try...... I am using it with the onboard USB from my motherboard (an MSI K8T Neo2 FISR). I also have a third party PCI card which has USB 2.0 on it, and I will try and see if that makes a difference.
  5. DBClark

    DBClark Guest

    I am having the very same problem and have tried several things, to try and solve to no avail.

    Anyone that comes up with a solution to this one...please post it!
  6. KoP

    KoP Network Guru Member

    Exactly the same problem. I'm 100% sure that the problem is the WUSB54G, but I can't get it out. It seems to be another problem from linksys that it will never be resolve. First, the WAG54G V1, now this. :thumbdown:

    I try the V4 drivers, but the WLAN MONITOR ain't working correctly, so I'm using the V2.

    How do I know which version of WUSB54G I bought?
  7. icest0rm

    icest0rm Network Guru Member

    well don't mix up different drivers for different hw versions....
  8. Zadillo

    Zadillo Network Guru Member

    For what it's worth, my system has been pretty stable. It does seem like as long as I use the v2 drivers, and have it plugged into the right USB port, everything is stable. I haven't had any crashes in a while.
  9. KoP

    KoP Network Guru Member

    The drivers V1 and V2 works properly, but the V4 still have issues that we all know. The question here is how do we know which version o WUSB54G do we have, and how do we know.

    As far as I know, al the drivers works fine with my WUSB54G, so I supossed that those drivers are for all WUSB54G.

    I just write an email to the linksys support, to see if they can help me with this.
  10. KoP

    KoP Network Guru Member

    The only way you have to see the version of your WUSB54G is going to device manager, into your network adapter, and see the version number of driver that is installed. meens WUSB54G V1.
  11. icest0rm

    icest0rm Network Guru Member

    nope....behind the it's bottom...
    I've written:

    Model no.: WUSB54G ver. 4

    I don't think all driver will suit all version...AFAIK version 4 mount a Ralink chip which uses different drivers...

    anyway, ver.4 drivers works ok for me as I posted in the other issues with Wireless Monitor...
  12. KoP

    KoP Network Guru Member I know.

    If you check in the packages there are the drivers for V1 V2 and V4 (subfolder "drivers") the WUSB54G works properly, not the WLAN MONITOR.
  13. icest0rm

    icest0rm Network Guru Member

    why you are still saying that WLAN MONITOR it's not working?
    Mine it's working...I've the icon in the task bar and all working ok with latest package...
  14. KoP

    KoP Network Guru Member

    I read a lot of info about this, and it seems that the older VIA chipsets (KT266, KT333 and KT400) have problems with WLAN cards based on certain particular chipsets.
    The problem is not connected to any certain WLAN provider.

    The problem might also be in the VIA VT8235 chip that most if not all of the problem motherboards have mounted.

    There are other older chipsets that I have heard have the same problems. some old BX chipsets behave the same way.
    But these seem to all have been fixed after the WLAN card recieves a non shared IRQ.

    With this information we can conclude that VIA is the problem here.

    Since we don't have the option to download a generic driver, only those from linksys, I will buy a USB 2.0 4-port PCI card with chipset ALI. Is the cheapest way, I hope, to forget this anoying issue.

    Before this, I will give it a try to that "non shared IRQ" information, reserving all in my BIOS, and then plugging in the WUSB54G...
  15. icest0rm

    icest0rm Network Guru Member

    why not?
  16. KoP

    KoP Network Guru Member

    Correct me if I'm wrong, but the WUSB54g V1 has the netchip 2280 + prism PCI chip, and the V2 has the newer prism54 dongles, and the V4 has the ralink-based devices (you have this can find generic drivers for this, I think there are somewhere, see their website.)

    I'm just tired of googling all over the net, without finding generic drivers for the V1, which I have.

    There are different chipset for different adapters:

    prism-based USB devices WUSB54Gv1
    netchip 2280 + prism PCI chip
    A few months ago, all 802.11g wifi dongles were prism54-based, and covered by the development that happens here. Those were based on the following combo :

    a netchip 2280, configured as a USB <-> PCI bridge
    a PCI prism chip : ISL3877, ISL3880, ISL3890, ISL3890 (fullmac-capable), ISL3886 (only softmac capable)
    Although some of those PCI chips are fullmac-capable, it appears that the firmware loaded into all instances of this combo are softmac firmwares (that additionally include some code to interact with the net2280)

    The communication protocol of those devices includes many idiosyncrasies meant to take care of the net2280.

    newer prism54 dongles WUSB54Gv2
    Those devices got rid of the net2280 with a new generation of chips directly integrating the usb communication part (ISL3887, as the XH8196 driver seems to indicate).

    They have a different firmware and the communication protocol is somewhat different (the core communication protocol is the same, though). Basically, the protocol is simpler, less verbose.

    Basic support for them is lagging behind only by a little bit, due to my not having one. If you can spare one, please send it over ! If you can test and improve the support yourself, that's even better :)

    ralink-based devices WUSB54Gv4
    You're in luck here, because ralink seems to cooperate, and an USB driver is in the works.

    atheros (madwifi) devices Netgear Adapters
    It seems they are coming (see netgear's website ; you bet i'll get one !) I only know the wg111t and wg111u.

    All I could find are proyects to make open drivers, all of them for Linux, but nothing for XP or 2000.

    If you know anything, please let us know.
  17. icest0rm

    icest0rm Network Guru Member

    sorry thought u had v4 for which downloadable drivers from ralink are alreayd available and newer than linksys ones
  18. KoP

    KoP Network Guru Member

    Did you fix the problem connecting the WUSB54G Adapter to a PCI card with USB ports, or you are still having those freezes in XP?
  19. vwtoys

    vwtoys Network Guru Member

    same thing...

    I have the same problem. My system will blue screen with some dump info and reboots right away. This happens when it's downloading through some P2P live tv sites with heavy traffic. Sometimes it would crash with a large size download as well. The adapter runs pretty warm on the plastic case. (I can imagine how hot the chip is to make the non conducting plastic warm to the touch).

    I think the adapter is not capable of handling large amounts of data download/upload. Otherwise it's stable for day-to-day surfing. And the range of this adapter is amazing.
  20. KoP

    KoP Network Guru Member

    Finnaly I just sell it, now I'll buy the EDIMAX EW-7128g PCI card with Ralink RT2500 chipset. F**k Linksys and their WUSB54G Ver.1.
  21. icest0rm

    icest0rm Network Guru Member

    Re: same thing...

    same problem solved upgrading drivers as I wrote.
  22. vwtoys

    vwtoys Network Guru Member

    Re: same thing...

    Update: I was having the same problem with the new PC that I just built. The adapter was attached to a powered USB hub (running the latest driver from linksys). It crashes with large file downloads at high speeds. I finally decided to connect it on the back of the case (the ports straight off of the mobo) and it's doing OK running BT. I'll test it some more when I get home. But if this is the case. Maybe the WUSB54G doesn't like too many obstructions to the USB controller. Or is it trying to suck out more power during high speed downloads? I don't know. But maybe moving it to other ports would be worth trying.
  23. icest0rm

    icest0rm Network Guru Member

    i did try that solution with no results, only upgrading drivers did the trick
  24. vwtoys

    vwtoys Network Guru Member

    What I was trying to say was, even with the new driver, the adapter experiences problems when connecting to certain USB ports. In my case it was a powered hub. I have now been running bt on it for about 18 hours straight and still I have not seen one bsod. With the hub in the way, it lasts about 2-3 minutes before crashing hard. So if anyone experiences similar issues with the latest driver, please try different USB ports.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice