Teaman - cstat issue - Tomato-Teaman-ND-1.28.0025

Discussion in 'Tomato Firmware' started by ripmyundies, Jun 19, 2012.

  1. ripmyundies

    ripmyundies Serious Server Member

    Hi all, I have a Linksys WRT54G, have been running stock Tomato 1.28 for long time - works well
    needed IP brand width monitoring so installed;
    Tomato Firmware v1.28.0025 Teaman-SDHC-VLAN-PPTPD ND USB VPN

    Works ok, however the when I go into IP Traffic, and Monthly (or weekly) I get a message:
    The cstats program is not responding or is busy. Try reloading after a few seconds.

    I have tried CIFS (it writes a file ok) and also tried restarting and clicking "Create new file" in admin section.
    also tried saving in VRAM but I get the exact same message.

    Any clues?!
  2. teaman

    teaman LI Guru Member

    Just tried it here on an old WRT54G v2, using a CIFS mount for storage: worked just fine. Please do make sure you have checked the "Create new file" checkbox when/if/after changing the "Save History Location" parameter on the IPTraffic/Admin page (that is, before hitting the 'Save' button).
  3. ripmyundies

    ripmyundies Serious Server Member

    Hi there, and thank you. I did get it working, not sure why but it took a few attempts/create new file, try again....but going now. Also noticed the it needed to have the Netbios filled out in CIFS setup to talk to share on my QNAP NAS (even with UNC, L/Pass all entered).

    One of the clients said it consumed 16GB overnight which is wrong as it's just a tablet (and I checked my ISP log) so I reset file again and will let you know if it persists.

    Thank you again, please take an OBE from petty cash
  4. rhester72

    rhester72 Network Guru Member

    I'm having the same issue with Toastman's build (storing cstats to a USB hard drive), but when I check "create new file" and then save, no file is created. rstats is configured exactly the same way, but works as expected. There's also no cstats binary that I can find, but never having used this feature before, I'm not sure if there's supposed to be. =)

    I do see this in the log:

    Jul 11 18:28:35 cerberus user.debug init[1]: starting cstats (new datafile).

  5. XeoNoX

    XeoNoX Serious Server Member

    i know this is a old thread but it comes up high on google searches … when searching for The cstats program is not responding or is busy. Try reloading after a few seconds

    What it means is that it's not saving. In the saving destination, do you see the file that it created?

    If not, go under Administration -> Bandwidth monitoring. Click the box "Create new file" and then apply. This will force it to create a new file.

    i have mine saving to my usb drive attached to the router…so i chose "custom path" and listed the path to my usb drive: "/tmp/mnt/sda2/"

    you can see if its saving and if it created a new file by using telnet to login to the the router and then use the commands "cd" and "ls" to navigate and list the directories.
    or from the tomato GUI u can navigate TOOLS > SYSTEM COMMANDS > "Execute System Commands" and check from there. example:

    cd /tmp/mnt/sda2/

    this navigates and lists contents of my usb stick

    NOTE: each usb device attached to router as storage is named find out what yours is named just go to your tomato gui in your browser and navigate to USB & NAS> USB SUPPORT> Attached Devices > it should list the devices connected there. remember to Format USB drive with FAT32
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice