Tenda W1800R 5G LED Light

Discussion in 'Tomato Firmware' started by xiaobb, Apr 17, 2014.

  1. xiaobb

    xiaobb Network Guru Member

    Can someone help me fix the W1800r 5G led problem? I am using Shibby's firmware 117. The 5G LED won't turn off when I disable the 5G.
    I looked around and tried several commands like 'gpio enable', 'wl -i eth1 leddc 1', 'wl -i eth2 leddc 1'.
    None of them seems to turn off the 5G LED on the router.

    Please give me some suggestions.

  2. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

  3. xiaobb

    xiaobb Network Guru Member

    Thanks for the reply, I tried 'led 5g off', but the 5g led is still on.
    I looked the led.c and there is a line for the w1800r
    static int w1800r[] = { 255, -13, 255, 255, 255, 255, 255, -12, -5};
    Could it be the parameter is not set correctly? I am not a programmer so I don't know how those numbers work.

  4. xiaobb

    xiaobb Network Guru Member

    I did more digging on this 5g led, I found that 'gpio disable 5' actually turn off the 5g led for a second. Same as 'led 5g off'. Basically it just blink the 5g led.
    Then I saw a process blink_5g, and if I kill this process, the the above led command turn off the led. Which is great.

    Can some one explain to me what this blink_5g does?
    Better yet, can Shibby or Vic fix this led problem for me?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice