TFTP "Error 3" when trying to unbrick my WRT54G v2

Discussion in 'Cisco/Linksys Wireless Routers' started by vibe666, Oct 18, 2005.

  1. vibe666

    vibe666 Network Guru Member

    Okay, I'm getting there (or I thought I was) with my bricked WRT54G v2.

    Initially, I got nothing. No ping, no nothing at all, except a green rapidly blinking power light.

    I tried shorting pins 15-16 on the flash chip, but no good, but eventually, earthing pin 16 got me a ping response, which was a major victory for me, or so I thought.

    I tried the linksys firmware upgrade util, which said it worked, but it still wouldn't respond afterwards, beyond the ping.

    so i dug around here till i found enough info about how to use TFTP to upload a new firmware, and went and googled myself a little TFTP app, and stuck that and the firmware in the root of C for convenience.

    this is what I did:

    tftp -i -t1 put HyperWRT_2.1b1_G.bin

    and repeated that every second for about 10 seconds after I powered up the router.

    most of the time, I got this:
    which I'm guessing is that it's just not able to connect, for whatever reason, but at one point in the boot cycle I was getting this (I tried this a few times, but it was always the same).
    So I look up error code 3 and it's something to do with a lack of space on the destination. huh.

    so where do I go from there? is there a way to empty the destination or to tell tftp to overwrite what's in there when it uploads the .bin file?

    thanks in advance for any help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice