tftp server ON tomato

Discussion in 'Tomato Firmware' started by kameleon, Dec 2, 2007.

  1. kameleon

    kameleon LI Guru Member

    I am having a little bit of a problem. I am doing some stuff with mythtv and the mvpmc project. The mvp box has to do a tftp boot. I am running a WRT54GS with tomato 1.07 (yes I have not upgraded in a bit ;) ) and it is my DHCP host and all. I have a tftp server running on the port I need (16869) on my mythtv box and it is open according to nmap. But I cannot get the router to pass the traffic to that box. I have tried the dhcp-option=66,<ip-of-tftp-server>, dhcp-boot=boot-file,<ip-of-tftp-server>, and just about anything else I can find online.

    Is there a way to run my tftp server ON the tomato powered router? I think that would solve alot of my issues. Thanks in advance.
  2. PeterT

    PeterT Network Guru Member

    Have you tried

    --dhcp-boot=<filename>,[<servername>[,<server address>]]

    ie both the name AND address of the tftp server ?

    Also, DNSMASQ CAN act as a TFTP server; however, in the Tomato build that option is not enabled.
  3. kameleon

    kameleon LI Guru Member

    Yes I tried that also. Like I said it COULD be that the tftp server on my ubuntu box is messing up but nmap shows that the port is open|filtered just like all the other services on there. Thanks for the help.

    also as a side note, some of the settings I have to back out of the router otherwise I get error 502 on every site I visit. Unless I use an IP address I can't get to anything. That is until I remove the setting from the dnsmaq.conf file.
  4. this works for me:

    filename is 'pxelinux.0', twice ',' and the ip of the tftp server.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice