That old ADSL2MUE cookie

Discussion in 'Other Linksys Equipment' started by Lapitude, Apr 15, 2008.

  1. Lapitude

    Lapitude Addicted to LI Member

    Yes it's failed with a red power LED! I have a green ethernet light but nothing else. Tried the PCtool and finally got in after many attempts. Downloaded the kernel and FS succesfully it appeared. After rebooting nothing had changed. What was worse, I could not get back in using PCtool and started using the toolinit script which said it had connected with the modem, but still could not communicate using PCtool or telnet and I've tried a lot of times. Suppose it's time for the serial cable....does anyone think it will help or should I give up while I still have hair? I don't like giving up
    Stumped of Fleet
  2. mstombs

    mstombs Network Guru Member


    Green Ethernet light probably means the bootloader is OK, but something corrupt causing the Linux OS to fail to boot.

    If it went wrong due to a botched firmware upgrade, then it should be possible to revive. If a random failure probably a hardware fault, and could be anything!

    Its worth trying another 5V power supply, and/or monitoring the 3.3V rail - conveniently available on the serial console connector.

    The Linksys 5V 1A PSU is poorly regulated typically outputs 7-9V open circuit, and a tiny 3.3V regulator gets very hot. I have repaired one where this regulator failed - couldn't output more than 0.5A, the 3.3V rails drops to 2.5V and the router stuck in a reboot loop.

    With 4Mb flash/ 16MB ram the ADSL2MUE has been great for me to get into Linux and embedded devices, and my repaired router (with working JTAG connector and serial console cable) still working fine...
  3. Lapitude

    Lapitude Addicted to LI Member

    mstombs the man

    Hi thanks so much for replying, it was a failure with no messing with firmware. Confirm 3.3v on the serial pins. I used the 5v from the ATX PSU in the PC so well regulated. What I find hard to understand is the toolinit script response that I was connected but no ip assignment on PCtool since - think it must be a chip failure, any ideas oh Guru? :) keep up the good work!
  4. mstombs

    mstombs Network Guru Member

    A serial console connection may tell you what is happening, but its best to get that working before a problem - my last Nokia DKU-5 cost 1p + 2.50 postage - and they can also be used with Fonera/WRT54GL etc.

    It can be hard to catch the bootloader without a serial console, if its stuck in a reboot loop the bootloader may only be available for a couple of seconds in every 20. A hub or switch between PC and modem can help, plus use a static IP address in right range.

    If the environment area is trashed the bootloader IP may resort to the windows apipa 169.254.x.y range
  5. Lapitude

    Lapitude Addicted to LI Member

    Thank you for your reply. Ok you persuaded me I ordered a DKU-5 for £2.50 on you know who, while I was on I saw an MUE and got it for £6.50!
    I digress from the thread but what would you recommend as the "best " FW for an MUE with a WRT54G (at present configured as a simply AP - all I can get to work as I am LLU pppoa). It apparently has 4.22 on at present
  6. mstombs

    mstombs Network Guru Member

    Hope the new 2MUE isn't in same state as old one...

    Re firmware - I am biased - I use Routertech 2.5+ in pppoa half-bridge mode (UK LLU), using the built-in script I created! What firmware do you have on the wrt54G? (Because if 3rd party can add a firewall script which means you can completely turn off the iptables netfilter firewall in the modem).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice