"the wireless router is not in rescue mode" ?? asus rt-n66u help

Discussion in 'Tomato Firmware' started by flatlinerz, Jul 24, 2013.

  1. flatlinerz

    flatlinerz Reformed Router Member

    hey guys

    I just got a asus rt-n66u and tried to install tomato to it for the first time, after holding down the reset button and plugin the power cable for RT-N66U and go into firmware restoration utility and upload Tomato after couple of seconds I get "the wireless router is not in rescue mode"
    anybody know what I am doing wrong?
  2. RMerlin

    RMerlin Network Guru Member

    What I usually do is I click on the Upload button first, and only after that I turn the router on while pressing reset. That way, as soon it enters recovery mode, the upload will begin.
  3. Monk E. Boy

    Monk E. Boy Network Guru Member

    With the router disconnected, press and hold the restore button. Connect power, and continue holding the restore button until the power light starts slowly flashing on and off. It's now in recovery mode.

    Next connect an Ethernet cable from your system to one of the router's LAN ports. On your system's Ethernet interface, you can either configure it for DHCP and wait a bit so it gets a self-assigned IP address (169.254.###.###), or you can assign to it. If you do the latter, you should be able to open up a web browser and visit the recovery mode website at From it you can erase the NVRAM and upload a firmware, though I prefer the utility because it forces you to wait until the firmware is flashed and working.

    I've had mixed issues with getting various versions of the recovery utility working. Some work best with a self-assigned address. Others work if you manually assign an IP address. Some others just plain don't seem to work at all. So, basically, you can try both methods, and if it still doesn't work, then you can try visiting ASUS's support site and grab a newer-ish version of the utility.

    I say newer-ish because someone mentioned that new versions won't let you flash third party firmware. The version I have complains that the firmware isn't geniune, but still lets you upload it to flash. Worst case, while you're there, download the latest ASUS firmware. That way if your tool won't let you upload Tomato, you can flash the new ASUS firmware onto it, then flash to Tomato from its website.

    Note that I mentioned the "reset NVRAM" button on the recovery mode website. Sometimes when switching between different firmwares w/o using the recovery utility I had to go back into recovery mode and use that button for the new firmware to boot successfully.
  4. flatlinerz

    flatlinerz Reformed Router Member

    guys now I get this error saying "IP invalid"

    this is driving me insane! dunno what I am doing wrong I follow the instructions above to a tee
  5. shibby20

    shibby20 Network Guru Member

    set static ip on you PC`s network card:

    gateway and dns are not needed.
  6. Monk E. Boy

    Monk E. Boy Network Guru Member

    If all else fails, try holding the WPS button instead of the restore button. Depending on the model ASUS sometimes wires up reset/WPS backwards (basically two buttons, button 1 & button 2, button 1 is normally reset button 2 is normally wps, but in some models button 1 is wps and button 2 is reset, except nobody told the CFE which still treats button 1 as reset).

    The most important thing is to be patient and give it time. Windows Vista/Vista.1 (Win7) loves to waste time trying to determine if a connection can route traffic to the internet before letting applications talk on it.
  7. RMerlin

    RMerlin Network Guru Member

    Also disable any wireless interface to ensure that you only have one single interface working (the one wired to the router).
  8. havdaddy

    havdaddy Reformed Router Member

    I'm having similar issues but only from trying to upgrade my firmware, not put tomato on it. My router acts like it's in recovery mode (power light slow blinks) but even after disabling my wireless, setting the static IP and subnet and even the gateway (tried it both ways) the adapter never manages to connect to the router (tried multiple cables just to make sure) and the rescue utility says the router is not in recovery mode. I get network activity on the connection but minimal RX. Only about 20 to 60 bytes during some point of trying to connect. I've tried going directly to the recovery mode page but that just times out. I've tried every LAN port on the router (even tried the WAN port just for kicks) but nothing. Computer says it's an unidentified network and never gets internet connectivity via the connection nor does it allow any communication that I can see to the router. I tried using the WPS button vice the reset button and even tried both simultaneously. No joy. Any other advice? Asus isn't open yet and I need help.
  9. Toastman

    Toastman Super Moderator Staff Member Member

  10. redsandvb

    redsandvb Network Guru Member

    I had the same thing happen to me trying to put Tomato on a new RT-N66U. After putting the router into recovery mode I had to do the following before it would load Tomato:

  11. Nicko

    Nicko Network Newbie Member

    I also had a lot of problems trying to get it to recognize stuff. My solution in the end was to put the ethernet cable in one of the middle lan ports, but I think the most important part was to restart the Rescue.exe file after any other failure. Then it worked.
  12. Siff

    Siff Serious Server Member

    I had the same issue as the OP. I tried 10+ times with the restoration utility and in all cases I was getting the message that the router is not in rescue mode. I tried with the WEB interface as well and nothing seemed to work until I left the router since I had to go out. When I came back Tomato was up and running! :)

    So, if the firmware loads and you are getting the message after the "verification" is completed, probably the just needs some extra time to finish flashing the firmware. The 2 RT-N66Us (revision B1) I flashed with Tomato (and the original Asus firmware) needed more than 25 min. before they started responding to ping.

    Hope this helps.
  13. RMerlin

    RMerlin Network Guru Member

    The RT-N66U uses fairly slow flash (at least compared to the newer Asus routers), so 25-45 mins is fairly common when flashing through Recovery mode.
  14. Siff

    Siff Serious Server Member

    ^^^ I guess that you have flashed a whole bunch of Asus routers so far :)! I have flashed 7 total and only 2 of them are Asus, so waiting more than 5 min. after uploading the firmware wasn't something I expected :). If you add the error message, you'll see that one can very easily get the impression that there is something wrong with the firmware upload, while the only thing I had to do was to wait!
  15. schnappi

    schnappi Networkin' Nut Member

    Want to second what siff said.

    Wait for the "wireless" lights to come on the RT-N66U after flashing with the asus firmware restoration utility and getting the "fail message." Tomato did flash correctly and the wireless "lights" will come on.
  16. JustinChase

    JustinChase Networkin' Nut Member

    I've spent the last 2 hours trying to flash this darn router, with no luck.

    I just keep getting 'not in recovery mode'. the power light comes on for 3 seconds, then goes off for 3 seconds, over and over. i assume this is "show blinking" that indicates recovery mode.

    I've tried different versions of firmware, all act the same.


    I'm unable to ping, and I cannot open the web GUI at either.

    i have my wired IP4 settings set for an IP of, subnet of, I don't have a gateway set.

    I've managed to load a Merlin version of DD-RT, and another version of DD-RT, both using the 'stock' GUI firmware upgrade system.


    I've tried wiping NVRAM, but still no love for me.

    I'm out of ideas on what to try.
  17. JoeDirte

    JoeDirte Networkin' Nut Member

    Hopefully that subnet was just a typo. It should be
    Try a different Ethernet cable? Make sure it's plugged into a LAN port on the Asus - not the WAN.
  18. Monk E. Boy

    Monk E. Boy Network Guru Member

    If you're using Windows 7 or, god forbid, 8, you have to wait a couple minutes after plugging in a cable for the $&*#(@&*$(#@ idiotic internet connection tester to finish wasting time before it'll let you use the interface. If you reboot the router or put the router into recovery mode, the clock starts over at 0. If the router was forwarding packets and letting you connect to the internet, the test would go by faster, but obviously in recovery mode the router isn't fully functional so you have to wait for Microsoft's folly.

    Recovery mode isn't affected by the firmware on the device, since it lives in the CFE, which loads before the firmware. Think of it as a bootloader. If you have any kind of "internet security" software on your system, try disabling or uninstalling it, as that can also muck up your ability to make connections. Worst case you could try a LiveUSB/LiveCD version of Linux to get into a more vanilla environment.

    Essentially what that error means is that the recovery utility your system was unable to connect to the router. If there is software on your system that's preventing the recovery utility from establishing a connection, then you need to get rid of or disable that software.
    Last edited: Nov 7, 2014
  19. JustinChase

    JustinChase Networkin' Nut Member

    yeah, typo, whoops.

    I changed ethernet cable, and tried all LAN ports, still no luck.

    Then, I remembered the cardinal rule of computers. If sh*t don't work, reboot the computer.

    After rebooting the laptop, I verified I could ping the router, good. I put into recovery, checked ping, still good (progress for me). I then tried the to upload the firmware; success!!!

    I can't believe I had to reboot the laptop, but that seems to have been the secret.

    Now, if I could just figure out why my speedtest is only 16meg, and my service is 60meg. I was getting 50-55 meg pretty consistently with my measly e3000 router with toastman firmware, so I really thought this router would get me my full speed. If I plug directly into the modem, I get 65-70 meg.

    several hours fighting the router to lose another 40% of my download speed is not the "happy ending" i hoped for.
  20. mstombs

    mstombs Network Guru Member

    What firmware now on N66? I get 100Mbps through mine, and 70Mbps when connected wireless to an E3000 which in turn connected to the N66 via 100Mbps cable. Both currently on Shibby firmware (probably not latest...).
  21. JustinChase

    JustinChase Networkin' Nut Member

    I just installed tomato-K26USB-1.28.RT-N5x-MIPSR2-123-AIO-64K

    I also did a NVRAM clear from within the firmware before any further setup/customizing.


    I just tested again on speedtest.net and got very weird results.

    First test started off strong, then jumped to almost 150MB/sec and finished at nearly 130

    the next one was over 80, with 2 big dips down to about 20 during the test

    the next one was 135

    the next one was 48

    the last one was 70

    I guess it's more an indication of speednet not being reliable than a problem with my router.

    considering 2 results were more than double my 60MB speed, I'm guessing speedtest just isn't very reliable any more.
  22. Monk E. Boy

    Monk E. Boy Network Guru Member

    It could indicate a problem with Charter Communications. Try another ISP.

    Weirdly I can sometimes get a faster/more reliable test using a source a few hundred miles away in another major city hosted by a different ISP than the one in the major city right next door that's hosted by my ISP.

    To my knowledge, the servers aren't run by speedtest.net, they're run by the various ISPs and speedtest just points you at their server.

    Glad to hear you got the firmware figured out. Just last night I had a problem sharing media on my home network, tried flipping everything off and on and reset settings up the wazoo, no dice. I noticed some zombie processes, so I rebooted the system serving the media to clear them out, and like magic the systems that weren't seeing that system started working.
  23. baldrickturnip

    baldrickturnip LI Guru Member

    Don't know if people are still having problems with the recovery mode etc

    I was having issues with finding and connecting to the ac66u

    what I had to do was the normal manual set of IP and then remove the LAN cable and set the router in rescue mode via the holding of the reset while turing on the power and getting the slow LED flashing

    then I disabled the LAN port on my computer , and re enabled and plugged in the LAN cable again to the router.

    if I did not disable/enable I was not getting any result.
    lb2101 likes this.
  24. plrichard

    plrichard Network Newbie Member


    Your response was just what I needed to get the tomato firmware flashed on RT-N53. Had to disable port, enable port and plug in LAN cable. Thanks
  25. OliverB

    OliverB New Member Member

    Thanks baldrickturnip, your solution worked. I wrote a small step by step instruction with all the steps that what I have done in order to make it work. The steps are a compilation for all the above posts so thank you all for your help and input. Some steps might be optional but it's better to be safe than sorry.

    Already sent an e-mail to Asus regarding this but I thought posting it here as well.

    If you have the Asus router in Recovery Mode and Wireless Router Firmware Restoration Utility gives "The wireless router is not in rescue mode" after it tries to find the ASUS router for a couple of seconds, try the following steps:

    • Set IP and Network Mask as instructed (192.168.1.x/
    • Disable Windows Firewall
    • Disable other adapters in Network Connections, except LAN (ETHERNET)
    • Reboot Windows
    • Remove the cable from the router's LAN port (if cable is connected). You can keep it in the computer
    • Place router in recovery mode by pressing Reset and powering it up. Keep holding reset until the Power LED slowly blinks.
    • Disable LAN network on Computer
    • Re-Enable LAN Network on Computer
    • Plug the cable in one of the LAN in the router not (not WAN!)
    • In Firmware Restoration select the firmware you want installed.
    • Now when pressing Upload in the Firmware Restoration app it should successfully upload your new firmware version.
    • Re-enable other adapters and Windows Firewall
    lb2101, Haldi4803 and edmore like this.
  26. Monk E. Boy

    Monk E. Boy Network Guru Member

    Technically you should use port 1 on the router, on most newer ASUS units the other ports will not respond when the router is in recovery mode.

    I honestly have no idea what this disable/enable nonsense is, perhaps it's something introduced in Windows 8/8.1/10. If so it would be yet another reason NOT to use Windows 8/8.1/10. Only if enough people smack their hand for misbehaving will they listen, like they did after Vista.
  27. edmore

    edmore New Member Member

    I have an Asus RT N56U Router that would not reset and I was about to give up. I thought it was bricked. However, as a last resort, I strictly followed OliverB's instructions and I managed to reset the router on first attempt and install OpenWRT. Many thanks for that.
  28. Haldi4803

    Haldi4803 Reformed Router Member

    Indeed. My N53 was stuck and nothing worked.
    Tried a whole lot of stuff but all failed, followed OliverB's instruction down to the line and used LAN Port nr1 then the rescue utility worked :)
    Firmware successfully flashed, now the 5ghz lamp is glowing.
    Now I just need patience then I can flash tomato over the original firmware :)
  29. Shashvat

    Shashvat New Member Member

    Turning off WiFi, setting IP to, changing port to no 2, solved Invalid IP address problem for me.
  30. Gunn317

    Gunn317 New Member Member

    So I was having the same issues as you mentioned with the "The wireless router is not in rescue mode" and I couldn't get the mini-CFE web server page to load in a browser. I knew the router was in recovery mode as the power button light was slowly flashing.

    OliverB's instructions worked for me too(!)...but only the first time I had to perform the recovery mode firmware update. Strange. I followed the exact instructions, and the mini-CFE web browser page came up as soon as I typed into my Chrome browser. I then uploaded the T Mobile firmware downgrade file and it worked great.

    But when it came time to do it again to upload the ASUS 3626 firmware, it wouldn't work. Back to the same problems. I tried to follow everything to a T, but no luck.

    I then found a forum post at snbforums "T-Mobile Cellspot" thread, page 11. And in there was a little tip about using the Incognito or Private mode of the web browser. Something about it not working with the existing cache). So I set router in recovery mode and simply fired up Chrome, then created a new Incognito tab, typed in and BOOM! The mini-CFE web server page loaded and I was able to upload the ASUS firmware successfully!

    Now to put my desired Merlin or AdvancedTomato on here....whew. I have another TM AC-1900 router to do the same steps on. We'll see if Incognito mode works instead of OliverB's steps instead...
    FPSguy likes this.
  31. Sean B.

    Sean B. Network Guru Member

    In Chrome if you: Click on the 3 vertical dots in the upper right corner, select "more tools", then select "clear browsing data" which will bring up a scroll box showing the types of data to be cleared, "Cached images and files" and "Cookies and other site data" need to be checked, then click the "Clear browsing data" button, should allow the standard Chrome tab to function with your recovery mode again.
  32. FPSguy

    FPSguy New Member Member

    Thank you Gunn317!!! Nothing was working for me until I tried Incognito mode in Chrome. I'm not sure why Chrome would not pick up the mini-CFE web page without this, but it works in Incognito mode. Thanks!
  33. jamesey

    jamesey New Member Member

    omggggg thank you so so so much.

    3 hours of hell. was literally one try away from taking the router to the salvation army and buying another one.

    just so its clear, the fix that worked for me was the one where you disable your stupid network adapter, unplug the ethernet, re-enable the network adapter, plug in the ethernet, magic.

    (or here is the whole routine copy pasted from above, thank you soooo much everyone)

    • Set IP and Network Mask as instructed (192.168.1.x/
    • Disable Windows Firewall
    • Disable other adapters in Network Connections, except LAN (ETHERNET)
    • Reboot Windows
    • Remove the cable from the router's LAN port (if cable is connected). You can keep it in the computer
    • Place router in recovery mode by pressing Reset and powering it up. Keep holding reset until the Power LED slowly blinks.
    • Disable LAN network on Computer
    • Re-Enable LAN Network on Computer
    • Plug the cable in one of the LAN in the router not (not WAN!)
    • In Firmware Restoration select the firmware you want installed.
    • Now when pressing Upload in the Firmware Restoration app it should successfully upload your new firmware version.
    • Re-enable other adapters and Windows Firewall
  34. lb2101

    lb2101 New Member Member

    Thanks OliverB - easy to follow instructions which worked perfectly. I was having all the above problems until I came across this post. If you follow the steps exactly, for some reason Windows cooperates.
  35. chrcoluk

    chrcoluk Networkin' Nut Member

    guys an update from me here.

    First thank you to everyone involved especially oliver.

    NT16 unbricked.

    However the full process is not required.

    I was intrigued that everyone reported success but it didnt make sense, with some of the steps.

    The shorter process which works.

    With lan cable unplugged from router reboot into rescue mode (Slow blinking power led).
    Disable windows firewall
    In device manager disable all network devices other than the one used to connect to the device.
    Connect the cable into LAN port on router I used port 1.
    Click upload in recovery tool and it should work.

    So much shorter process, it seems bizarrely having multiple network devices on a system somehow breaks the process.

    How did my device brick?

    I had already successfully installed a firmware, was a 3.x ddwrt firmware. I simply saved a setting and the power led went out along with connectivity to the device. Given such a simple thing bricked it I will be trying openwrt instead (need the gui VLAN features). DDWRT seems to be in a permanently testing state, and is constant threads on their forum asking for the "least broken" build.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice