Thibor 15C lock up problem

Discussion in 'HyperWRT Firmware' started by prowler1968, May 18, 2006.

  1. prowler1968

    prowler1968 Network Guru Member

    I have just came across an issue that has never been an issue with the Thibor firmware I've used in the past.

    I have a GS 3.0 Router with Thibor 15C. I received a couple of messages trying to access different web sites where I was unable to connect to the site. I then tried the router address and connected to the configuration page. I checked the status and the router had only been up for 2 days.

    I thought perhaps my internet connections was down, but I tried to access a web site again and could not access the site. When I tried the router again, I could not get into the setup page. I tried to ping a web address (not an IP address) of my local cable modem ISP, and got no response repeatedly.

    I had to power my router down and then back up. Everything is functioning fine now. I cleared the NVRAM before the upgrade from 14 to 15 and then cleared the NVRAM after (don't recall the first build that I tried). I then did the 15b1, b2, b3 and then 15C. I DID NOT clear the NVRAM between different 15 build versions.

    No Peer to Peer networking or other high volume usage on the router that I know of that would cause this. Has anyone else been having a lock-up problem with this firmware?
  2. pharma

    pharma Network Guru Member

    You should clear NVRAM to absolutely determine whether this is an issue or not. It is possible some of the variables from earlier 15 builds contained bad or corrupt data which you're not "clearing out" -- especially in your case since you seem to be the only one with this issue ..

    Clearing out NVRAM is a good procedure since it makes it much easier for the developer to troubleshoot, regardless whether or not they are sub-builds within the same version number. An extra 5 - 10 minutes for setup isn't going to kill you.

    Sometimes when there are websites you can't reach it's related to your MTU setting -- sometimes too high. The below link might help, if not they have an extensions FAQ section:

  3. Thibor

    Thibor Super Moderator Staff Member Member

    i've not heard of my firmware locking up from ANY version yet. i will keep my eyes and ears open, but i have not rebooted any of my GS's since flashing with 15c last week and they are still up without issue.
  4. prowler1968

    prowler1968 Network Guru Member

    Yes, after my post, I did go ahead and Clear NVRAM, re-flash 15C, and clear nvram again. I then manually keyed my configuration back in.

    There was another post about losing the connection with the cable/modem, but I was unable to reach the router by its IP address. A totally different problem than the Linksys losing communications with the modem.

    Now that I have re-loaded 15C and reconfigured the firmware, I'll continue to see how the firmware works. I have never had lockup problems and have only had issues with certain functions not working correctly while Thibor updated the earlier builds.

    I'll update should I have any further issues to report, although I expect that this will be the cure as it does seem to be common that problems resolve themselves when the NVRAM is cleared of any old "garbage" information.
  5. tempralflux

    tempralflux Network Guru Member

    the only thing i`ve notice about 15c so far is when i reboot using the GUI or button on the back i lose internet connection to get it back i have to disable QOS and then enable again works fine after that did all the usual NVRAM clear and stuff this is on a GS v1.1 with upgrade my v4 GS to see if i get the same problem, firmware still rocks tho
  6. adam217

    adam217 Network Guru Member

    I was the one posted in the other thread about the router losing the net connect and that the only fix I could make work was to clear/reset router and re-enter all my settings. After reading this thread I'm glad to hear I'm not the only one with this issue, is does seem to be related to the QoS, as tempralflux stated, I tried disabling the QoS and then rebooting router, it functions again. I had it happen to me for what I would guess to be the fourth time, last one was right before coming here to see if there was any response to my question, only to find this thread.

    Thibor, has anything significant changed in QoS besides the addition of application profiles between 15b2 and 15c? I think I skipped 15b3. As I stated in the other thread, this is the first release that has had this issue.

    P.S. Upon re-enabling QoS and rebooting the router it makes the internet cease to function again, disabling QoS and rebooting makes it function again.
  7. Thibor

    Thibor Super Moderator Staff Member Member

    the backend of the QoS system is the same as 14, only the front-end code has changed. i have QoS enabled here and my internet connection is working, so if i can't reproduce it; i can't fix it. the changes between 15b2 which worked for you, and 15c which didn't is:

    * Fixed Access Restrictions screwing with ipaddr and macaddr blocking.
    * Added bf1942, battlefield2, CounterStrike, CS:Source and MSN File Transfers to Applications list in QoS.asp.
    * Made menu lists grey in QoS.asp
    * Made text boxes in DMZ.asp larger.


    * Fixed DDNS....yet again, pptp fix broke it.
    * integrated changes to DMZ.asp I've been working on.


    * Fixed Zoneedit.
    * Fixed PPTP not giving correct IP to DDNS.
    * Fixed WOL.
    * Fixed Logging bug.
    * Fixed Large file transfer issue for Gv2.2 type. enter "nvram set cpu_overdrive=1;nvram_commit" in the command page, or via Telnet/SSH.
    * Fixed rtsp_conntrack.

    taken directly from my site. as you can see, there are NO changes to qos functionality there, so whatever has changed for you would seem to be local.
  8. adam217

    adam217 Network Guru Member

    I have no idea how this thing works, does the QoS use some form of a temporary folder/cache that could be getting full or corrupted? I really don't know what else I could say or do to help, but seeing as it happened to somebody else its would likely not be something specific to me or my setup. Is there any way I could provide you with anything, directory dump or copy of a configuration file, or anything that might help?

    If there is nothing that can be done, then so be it, I will happily go back to an older release, I had just hoped that getting my situation out there might induce others with similar issues to speak up and maybe find a common link. I had read the release notes, but just figured since it was narrowed down more to the QoS being or related to the cause that you may have done something small that did not warrant documentation.
  9. Thibor

    Thibor Super Moderator Staff Member Member

    i didn't do anything else to QoS. post the results of /tmp/.ipt, iptables -t mangle -nvL. i will need A LOT more detail from you if i'm to diagnose this for you. ie, internet connection type, are you connecting wirelessly? and a lot more besides.
  10. prowler1968

    prowler1968 Network Guru Member

    adam - I think that my problem was different than yours. I don't think that I lost the entire internet connection between router and modem, I could not even connect to the router at ip I simply think I had a router lock-up. I simply unplugged the power and powered it back on and I was up and running.

    I did, however, clear nvram, reflash, clear nvram, re-enter setup info. manually. I have never had a loss of internet connectivity or a router lock-up until today. I think I may have had some garbage in the routers' memory. I'll be watching, but after a full day, I have seen no slow downs or anything else that leads me to believe it was more that just coincidence. As has been stated in the forums many times, clearing the nvram does a lot of help for problems that cannot be reproduced.

    If my problem comes again, I'll re-post with information about it.
  11. tempralflux

    tempralflux Network Guru Member

    i entered in telnet "cat /tmp/.ipt" to get the results checked the contents with a working connection and 1 after reboot (no connection) the compared content are identical assuming i use the right command that is but can post the content. i have about 10 entries in QOS but when i remove all except 3 no need to diasble/enable QOS to get internet connection back after reboot. Please put me right if command i used above is wrong

    forgot to mention when internet connection is lost on computer can still use ping/traceroute with router diagnostics
  12. scorpy

    scorpy Network Guru Member

    This is similiar to one of the probs I had a wee while ago.Couldn't access the router GUI in FF and IE had to reboot the router.
    I also had a complete browser lockup,again in FF and IE,a couple of times.
    I had QoS enable too.
    Will be installing 15c again over the weekend after finding out that NTL was partially at fault with the internet connection problem I had.
  13. tempralflux

    tempralflux Network Guru Member

    found that when i reboot and lost connection to the net i used iptables -L and found only these entries Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    only until i disabled/enabled QOS that i got the tables back. which is why i lose connection so i need to find out why the tables won`t restore after a reboot.
  14. adam217

    adam217 Network Guru Member

    My router doesn't lose connection to the modem, it just doesn't allow anything out to the net. The router can still receive an IP/DNS from my modem, I can release/renew it, I can power cycle both of them, all will come up properly, modem will sync, and router will get a connection and lease from the modem, nothing come in and/or goes out to the web. This is only after it has randomly decided to act this way, it works perfectly with all options enable until then. Clearing everything and setting everything back up will have it working on its marry way again until such random occurrence.

    Thibor, most of the info your requesting can be found in the "thibor15c" thread on page three, my lengthy post has my setup page by page how I input everything. Done it quite a few times in the transition from 14 throughout out the 15's.

    Results of the commands you asked to be run: They were run via the "run command" interface.

    # /tmp/.ipt

    /tmp/ /tmp/ 2: /tmp/.ipt: Permission denied

    # iptables -t

    iptables v1.3.5: Unknown arg `-t'
    Try `iptables -h' or 'iptables --help' for more information.

    # mangle -nvL

    /tmp/ /tmp/ 2: mangle: not found

    I would have to guess that isn't the output you were looking for.

    These were run while it is working, QoS disabled, other people are using the connection at the moment so I cannot disable net access. Do I need to run these commands another way or do something entirely different? As stated before I am not familiar with Linux, I am very computer literate, but have always stayed on the DOS side of the fence.

    I will do anything I can to help, I did not intend for you to work me through this problem, you have already done more than I could have ever asked. If you choose to walk away from this I understand, I would, working on problems you cannot see, replicate nor have direct contact with is near impossible.

    Thank you all for your input.
  15. Thibor

    Thibor Super Moderator Staff Member Member

    "cat /tmp/.ipt"
    "iptables -t mangle -nvL"
    run them both with and without QoS activated
  16. tempralflux

    tempralflux Network Guru Member

    /tmp # cat /tmp/.ipt
    :OUTPUT ACCEPT [0:0]
    -I PREROUTING -i br0 -j MARK --set-mark 256
    :OUTPUT ACCEPT [0:0]
    -A PREROUTING -i vlan1 -d -j DROP
    -A PREROUTING -p icmp -d -j DNAT --to-destination
    -A PREROUTING -p tcp -m tcp -d --dport 44444:44444 -j DNAT --to-destination
    -A PREROUTING -p udp -m udp -d --dport 33333:33333 -j DNAT --to-destination
    -A PREROUTING -p tcp -m tcp -d --dport 54321:54321 -j DNAT --to-destination
    -A PREROUTING -p udp -m udp -d --dport 12345:12345 -j DNAT --to-destination
    -A PREROUTING -p tcp -m tcp -d --dport 5060:5061 -j DNAT --to-destination
    -A PREROUTING -p udp -m udp -d --dport 5060:5061 -j DNAT --to-destination
    -A PREROUTING -p udp -m udp -d --dport 16384:16482 -j DNAT --to-destination
    -A PREROUTING -d -j TRIGGER --trigger-type dnat
    -A POSTROUTING -o br0 -s -d -j MASQUERADE
    :INPUT ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    :logaccept - [0:0]
    :logdrop - [0:0]
    :logreject - [0:0]
    :trigger_out - [0:0]
    :lan2wan - [0:0]
    :grp_1 - [0:0]
    :advgrp_1 - [0:0]
    :grp_2 - [0:0]
    :advgrp_2 - [0:0]
    :grp_3 - [0:0]
    :advgrp_3 - [0:0]
    :grp_4 - [0:0]
    :advgrp_4 - [0:0]
    :grp_5 - [0:0]
    :advgrp_5 - [0:0]
    :grp_6 - [0:0]
    :advgrp_6 - [0:0]
    :grp_7 - [0:0]
    :advgrp_7 - [0:0]
    :grp_8 - [0:0]
    :advgrp_8 - [0:0]
    :grp_9 - [0:0]
    :advgrp_9 - [0:0]
    :grp_10 - [0:0]
    :advgrp_10 - [0:0]
    :grp_11 - [0:0]
    :advgrp_11 - [0:0]
    :grp_12 - [0:0]
    :advgrp_12 - [0:0]
    :grp_13 - [0:0]
    :advgrp_13 - [0:0]
    :grp_14 - [0:0]
    :advgrp_14 - [0:0]
    :grp_15 - [0:0]
    :advgrp_15 - [0:0]
    :grp_16 - [0:0]
    :advgrp_16 - [0:0]
    :grp_17 - [0:0]
    :advgrp_17 - [0:0]
    :grp_18 - [0:0]
    :advgrp_18 - [0:0]
    :grp_19 - [0:0]
    :advgrp_19 - [0:0]
    :grp_20 - [0:0]
    :advgrp_20 - [0:0]
    -A INPUT -m state --state INVALID -j DROP
    -A INPUT -i lo -m state --state NEW -j ACCEPT
    -A INPUT -i br0 -m state --state NEW -j ACCEPT
    -A INPUT -m psd -j logdrop
    -A INPUT -p icmp -j logdrop
    -A INPUT -p igmp -j logdrop
    -A INPUT -j logdrop
    -A FORWARD -i br0 -o br0 -j ACCEPT
    -A FORWARD -m state --state INVALID -j DROP
    -A FORWARD -p tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1461: -j TCPMSS --set-mss 1460
    -A FORWARD -i vlan1 -o br0 -j TRIGGER --trigger-type in
    -A FORWARD -i br0 -j trigger_out
    -A FORWARD -i br0 -j lan2wan
    -A FORWARD -p tcp -m tcp -d --dport 44444:44444 -j logaccept
    -A FORWARD -p udp -m udp -d --dport 33333:33333 -j logaccept
    -A FORWARD -p tcp -m tcp -d --dport 54321:54321 -j logaccept
    -A FORWARD -p udp -m udp -d --dport 12345:12345 -j logaccept
    -A FORWARD -p tcp -m tcp -d --dport 5060:5061 -j logaccept
    -A FORWARD -p udp -m udp -d --dport 5060:5061 -j logaccept
    -A FORWARD -p udp -m udp -d --dport 16384:16482 -j logaccept
    -A FORWARD -i br0 -m state --state NEW -j logaccept
    -A FORWARD -j logdrop
    -A lan2wan -j grp_1
    -A logaccept -m state --state NEW -j LOG --log-prefix "ACCEPT " --log-tcp-sequence --log-tcp-options --log-ip-options
    -A logaccept -j ACCEPT
    -A logdrop -m state --state NEW -j LOG --log-prefix "DROP " --log-tcp-sequence --log-tcp-options --log-ip-options
    -A logdrop -j DROP
    -A logreject -j LOG --log-prefix "WEBDROP " --log-tcp-sequence --log-tcp-options --log-ip-options
    -A logreject -p tcp -m tcp -j REJECT --reject-with tcp-reset

    /tmp # iptables -t mangle -nvL
    Chain PREROUTING (policy ACCEPT 10580 packets, 5489K bytes)
    pkts bytes target prot opt in out source destination
    6034 5252K MARK all -- br0 * MARK set 0x100

    Chain INPUT (policy ACCEPT 9850 packets, 1922K bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 2195K packets, 1535M bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 453 packets, 108K bytes)
    pkts bytes target prot opt in out source destination

    Chain POSTROUTING (policy ACCEPT 2255K packets, 1550M bytes)
    pkts bytes target prot opt in out source destination
    /tmp #
  17. tempralflux

    tempralflux Network Guru Member

    with firewall switched off reboot with QOS on Internet
    connection lost until QOS is disabled and then
    iptables are restored i`ve even toggled firewall
    on/off/on to see if iptables return nothing happens
    until QOS is toggled.


    sorry prowler1968 seemed to have hijacked your thread with a slightly different problem but hopefully working to a common goal
  18. tempralflux

    tempralflux Network Guru Member

    With thibor`s help found my reboot problem to be the counterstrike-source entry in QOS just removed it from list and now everything seems to be okay.

    thibor told me that the half-life pat works for cs:source so will use that instead

    once again many thanks thibor.
  19. Thibor

    Thibor Super Moderator Staff Member Member

    the bittorrent entry is fine, i use that one myself
  20. tempralflux

    tempralflux Network Guru Member

    sorry edited my post, yes don`t seem to have any problems with it so removed it from the post, didn`t want to confuse anybody into thinking it was part of problem.
  21. prowler1968

    prowler1968 Network Guru Member

    Read the whole discussion from the beginning - I did not hijack anyone's post - I started this thread. I only acknowledged reading a post in another thread that was similar, but my symptoms were different so I started a different thread. If anything, my thread has been hijacked.

    I do not use (at least at the moment), QOS, so my issue is apparently from a different source. I have re-flashed my router and cleared the NVRAM and set it back up manually re-entering the set up information. I only posted to see if this was an isolated issue or more widespread. Thibor has not seen any lock up problems as no other posters have had problems identical to mine.

    The QOS problems you and adam (and others) are having may have a common cause and if that can be found in my DIFFERENT problem with a common root cause, then by all means give some input. If you feel I have hijacked another thread, post into that thread and get the discussion back on track. As I said, my problem was different and, at this point, is no longer a problem.
  22. Thibor

    Thibor Super Moderator Staff Member Member

    you misunderstand mate, he was apologising for hijacking YOUR thread
  23. prowler1968

    prowler1968 Network Guru Member

    I thought that was apologies to adam for me hijacking his alternate thread - my bad!! Sorry guys, read between two non-existent lines!!! :cheerup:

    As long as we all benefit from EACH OTHERS input for any problems, we all get the reward of the best firmware for our routers.

    Thanks for setting me straight, Thibor.
  24. adam217

    adam217 Network Guru Member

    So it looks as though the CS:Source application profile did the trick over here for me as well, got rid of it and router started working with QoS enabled.

    Even though the answer my be over my head; Why did the CS:Source application profile cause this? Why did it take effect after some random amount of time? Will any of the other new profiles have the same effect?

    Thank you very much for figuring this out. I am relieved to find out that neither I nor my router is crazy.

    P.S. I'm sorry for the hijacking, I believe it was me that started it. I thought we had the same issues in common and I jumped at the idea of having more people to work with to find the answer.
  25. Thibor

    Thibor Super Moderator Staff Member Member

    it's easy enough, and i think you'll understand it. there is a typo; it was expecting to see conterstrike-source and couldn't find it, as it is coUnterstrike-source
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice