Thibor11 WRT54GS Firmware released

Discussion in 'HyperWRT Firmware' started by Toxic, Dec 17, 2005.

  1. Toxic

    Toxic Administrator Staff Member

    Thibor just sent me his latest firmware, which has now been renamed to coincide with Tofu's changes.

    grab it here:

    Thibor11 Firmware for WRT54GS

    Integrated Tofu's codebase(tofu11)
    Fixed Lazywds bug
    Changed the Name to Thibor11 to show compliance with Tofu's release
    integrated DNS choice changes(dnsmasq no longer DNS server)
    any bugs, please report in Linksysinfo or Hyperwrt forums
  2. Kitfox

    Kitfox Guest

    I'm new to installing third-party firmware. Anything specific I should know before doing it.
  3. lwf-

    lwf- Network Guru Member

    Good job Thibor, I will try flashing tomorrow.
  4. moh0815

    moh0815 Network Guru Member

    Uaahh - great! :thumbup:
    Could you put this info into the Announcements-section?

    thanks & regards,
  5. scotkb

    scotkb Network Guru Member

    Great stuff Thibor, thanks very much!
  6. mazilo

    mazilo Network Guru Member

    Me too. I have three WRT54GS v3 units. All of them have been flashed to the new Linksys v4.70.6 firmware. Do I need any speciall procedures to flash this third party firmware on my WRT54GS v3 units?

    While on the subject, can I also add asterisk or SiPATH after flashing this third party firmware?
  7. Thibor

    Thibor Super Moderator Staff Member Member

    you don't need any special procedures, just flash as normal and then factory reset the router afterwards. if you want SiPATH you may be better off with DD-WRT as it is included in the VOIP version
  8. kimz

    kimz Network Guru Member

    great, will try it too!!
  9. Rik

    Rik Network Guru Member

    Great work! Exept, it looks like WEP Security is'nt working well in this new version!?
  10. Thibor

    Thibor Super Moderator Staff Member Member

    you need to give me a little more detail than "not working well". can you elaborate so i can check it?
  11. lumpy2

    lumpy2 Guest

    hello, i have big problems with the download from this page...
    could anyone put the file on a public webspace oder send the firmware via mail to me ?
    big thx


    ... sorry for my english
  12. Rik

    Rik Network Guru Member

    Sorry Thibor. When I put the WEP Security on (128 bits 26 hex digits), not 1 of my 3 wireless pc's does work to (or through) the wrt54gs, so I went back to the version of Thibor, Nov. 20, 2005 and than WEP works ok again.
    Hope its enough for you to recover the problem.
    (WRT54GS v1.0)
  13. Thibor

    Thibor Super Moderator Staff Member Member

    which key index are they on? did you try resetting the router to defaults?
  14. Rik

    Rik Network Guru Member

    I use key-index no.3 (but all 4 are filled)
    And yes I always reboot before and after upgrading. (erase nvram; reboot)
    After this i'll did not used:Go to the "factory defaults" menu option and use it Could that be the problem?
    Of course I do'nt use restoring configuration if switching to new software.
    Else I will try it tomorrow again, than you hear from me Thibor!
  15. Thibor

    Thibor Super Moderator Staff Member Member

    i don't think i altered any of the code affecting WEP operation. I'll look through it tonight when i get back from work to see if i dropped any bollocks in there :)
  16. Rik

    Rik Network Guru Member

    I just try it one our ago, with the newest software and the same happens, with WEP on, as dicribed above. (Wireless computers can't pass the wrt54gs)
  17. Raere

    Raere Network Guru Member

    I installed it to switch from DD-WRT. Works great, I don't have any problems with it. Good job! :clap:
  18. tofu

    tofu Network Guru Member

    rik, could you try running "nvram forcewep0=0;nvram commit;reboot" and see if it works? Try also using index 1 for wep. I've experienced problems using others for some unknown reason. If not, you can undo this using "nvram unset forcewep0;nvram commit;reboot"
  19. Cortig

    Cortig Network Guru Member

    failed install

    Hi All,

    I can't figure out what I'm doing wrong, but no matter what I try, every time I flash the firmware from HyperWRT 2.1b1 I get a warning telling me that the process failed.

    I tried Hyperwrt_GS_Thibor-201105 and Hyperwrt_GS_Thibor-171205 and both failed on my WRT54GS v 2.1 (from the web interface). Is there something obvious I'm missing ??

    Should-I try flashing through tftp??
  20. kulprit

    kulprit Network Guru Member

    It always says to upgrade from the official linksys firmware Cortig. So reset to defaults, then upgrade to linksys official, the reset, upgrade to Thibor, then back to defaults and you are all good to go.
  21. Rik

    Rik Network Guru Member

    I did running "nvram forcewep etc." but my router become very unstable after doeing this. I have to give him a cold reset. Now using index key 1 for wep and all works very well! (keys 2, 3 and 4 does'nt work at all. Before this new software I always used key 3 and until now, no problems)
    Thanks for thinking with me!
    greetings Rik
  22. Cortig

    Cortig Network Guru Member

    Thanks a million kulprit. I had clearly missed that. Will do! :thumb:
  23. PaCkEtGrEmLiN

    PaCkEtGrEmLiN Network Guru Member

    I agree with Rik, as WEP ( 64 or 128bit ) with Keys 2,3 or 4 are not working correctly in this release. Only Key 1 on my GS 1.0 works. Using the Odyssey Client Manager it's interesting to note that I'm still able to connect to the AP when it is set to push Key 2,3 or 4 but the AP will not offer an IP.

    Oh forgot to add as I tested and found the following to be working as expected via ( AES or TKIP ) ... WPA / WPA2 / WPA2-Mixed Mode.

    Regards - PaCkEt
  24. Thibor

    Thibor Super Moderator Staff Member Member

    i'm working on the WEP problem now guys, bugfix release soon
  25. Rik

    Rik Network Guru Member

    Don't hurry for me Thibor! For the rest the software (as far as I can see) is working good! No problems at all with WEP key 1. Its only for myself that I didn't do something wrong.
  26. Thibor

    Thibor Super Moderator Staff Member Member

  27. Toxic

    Toxic Administrator Staff Member

    Bugfixed update is now in the downloads. sorry for the delay, one of my websites for hosting the files was offline to ftp uploads until this morning.

    Thibor11 updated Firmware
  28. Rik

    Rik Network Guru Member

    Great work Thibor! Everything works o.k. now.
  29. 3dogs

    3dogs Network Guru Member

    does it work with WRT54G?

    I've read that the G v1-4 and the GS are the same or almost the same physical unit so I assume that my G v4 can take Thibor firmware.

    Is that true?

    If so, why the GS in the name? Sorry if this has been covered. I just want to be sure.

    Anyway, thanks for the work.
  30. NateHoy

    NateHoy Network Guru Member

    Re: does it work with WRT54G?

    The WRT54G V4 and WRT54GS V4 are the same hardware. The WRT54GL is also the same. The difference is in the Linksys-provided firmware that enables SpeedBooster for the GS (or, more to the point, disables it for the G and GL). So, congratulations, load Thibor and you get a free SpeedBooster upgrade.
  31. purephase

    purephase Network Guru Member

    Everything appears to be fine with this release, thanks Thibor!

    Still seems a little unstable with Azureus, uPNP and QoS enabled. I've tried the startup scripts that are mentioned in a number of posts (even though, it looks like Thibor included most -- if not all -- of the "fixes" provided by the scripts in the base package).

    Here's a breakdown of the setup I'm using:
    1 Vonage router
    2 wired machines, one for P2P
    1 wireless machine

    Static IP's assigned to 1 wired machine and Vonage router. QoS settings apply HIGHEST priority to Vonage router and LOW to non-standard Bittorrent port. uPNP was enabled (I've disabled it to see if stability improves) for MSN Messenger on second wired workstation. Wireless settings are WPA2-PSK with AES specifically (very long PSK). Port range forward specified for Bittorrent on non-standard port.

    With this setup, everything works fine for a few hours but call quality starts to degrade and overall speed (browsing, d/l'ing etc.) degrades across all machines. Once the router is rebooted, everything is fine again for a few hours, and then.. etc.

    As I said, right now I've disabled QoS and uPNP to see if stability improves (I think it will). I don't think that this is the fault of the router/firmware, I think there is something that I'm missing during setup that would help.

    I have erased nvram settings and restored factory defaults (did it after prior to disabling uPNP and QoS). Any advice?
  32. groupdelay

    groupdelay Network Guru Member

    uPNP seems to have issues, as others have indicated. Windows Internet Gateway/Upnp Icon doesn't stay up when running this version. Works fine in the last version of Hyper-WRT and other 3rd party firmwares.
  33. pharma

    pharma Network Guru Member

    Re: does it work with WRT54G?

    To get any speedbooster benefit, you would need speedbooster clients (wireless speedbooster cards) for files transferred behind your network. This doesn't affect internet downloads, just files transferred between computers.


    I did not realize HyperWRT firmware was for Vonage routers, only for wrt54 (g) & (gs). If you are using a wrt54 router, try the forum at . A search of "QOS" will give a handful of related threads.

  34. MarkA

    MarkA Network Guru Member


    Thanks for the great firmware! I tried DD-WRT but my connection kept freezing up. I have great speed with this firmware. :)

  35. compuworm

    compuworm Network Guru Member

    Which Firmware to download

    Can someone help me out. I went to the download page for Thibor's
    Downloads and simply don't know which one to download for my router. I have a wrt54gs v2. Which one is better?
  36. iLLz

    iLLz Guest

    If the internet gateway icon doesn't stay running, you should powercycle your modem and router together to fix it. This will also help with uPnP.

    Simply, unplug the modem and router.
    Then wait a minute and plug modem back in, letting it completely cycle.
    Then plug the router back in and let it cycle.

    The internet icon should be running shortly after the cycling, just remember to do it in the right order. Sometimes i have found that a complete "network cycle" and rebooting the PC's may be in order.

    I am using Thibor11 + WOL iwthout any problems so far to answer the question of which firmware to use.

  37. Cortig

    Cortig Network Guru Member

    Weird.. I posted back but the message never showed up :cry:
    I tried that as well and I get the same warning. The WRT54GS is now running the official firmware and refuses to be flashed into Hyperwrt_GS_Thibor-171205.
    I downloaded Hyperwrt_GS_Thibor-120106 today. I'll give it a try.
    That's really weird :(
  38. Thibor

    Thibor Super Moderator Staff Member Member

    Thibor13d is now released and available in the usual places, ie from bcat, bagu and the download section here of course. you can also get it from my website at Changelog is also shown there
  39. WhiteCollar

    WhiteCollar Network Guru Member

    Hi Thibor - nice work!... if you have time, I have a couple questions regarding enabling Kai on the router.

    I have a WRT54GS v1.0 router. I flashed with your latest Hyperwrt_GS_Thibor13d.bin. Everything seemed to go ok... then i rebooted (cleared NVRAM, restore factory defaults).

    I visited your site and used the recommended startup-script for Kai. I saved the script & rebooted again.

    The problem is that when I go to, it just says "Your router is currently syncing with Kai...
    Please refresh this page in 2 mins." However, the router doesn't seemed to be syncing as there is no internet connectivity when I look at the lights.

    I have done some reading over
    here and if I use telnet to manually enter the commands, it seems to start kai - but i haven't seen any additional config. pages on the router to input user / pass, etc. I thought these would be under Administration->Management, but I don't see anything there about Kai.

    I think I'm missing something in the script perhaps... can anyone help? TIA!
  40. Thibor

    Thibor Super Moderator Staff Member Member

    when it says it's syncing with kai, it's actually downloading the kaid binary from teamxlink. if that doesn't work for any reason, it won't change page
  41. WhiteCollar

    WhiteCollar Network Guru Member

    I don't think that I'm actually retrieving the kaid binary file... there is no leds flashing, the page just seems to be sitting there.... i refresh & I get the same msg "Your router is currently syncing with Kai... Please refresh this page in 2 mins."

    However, I can reach the binaries here:
    alternative site

    Then I was looking at the script, and noticed when I type
    this in I do get to a page to enter username & password. I did so & rebooted, but it apparently didn't hold the settings.

    Do you know what I'm doing wrong? Maybe some ports aren't forwarded?

    If someone was setting kai up on the router the 1st time, do you normally just flash your firmware (reboot, etc), then enter the script you outlined? Should that open up the Kai feature in the Linksys Admin pages - are there any components required or is there anything else I overlooked?

    Other threads I read were suggesting using a pc or the xbox as a webserver to hold the kaid & kaid.conf files - is that necessary?
  42. Acid-drop

    Acid-drop Network Guru Member

    this message shouldnt be "Announcement" anymore I think :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice