Thibor12 and monitoring vlan1 bandwidth

Discussion in 'HyperWRT Firmware' started by Krip, Jan 21, 2006.

  1. Krip

    Krip Network Guru Member

    Hi Guys,

    I was wondering if there is any way to monitor bandwidth over the vlan1 port when running Thibor12 on a GS v1.1?

    My ISP has a monthly cap and so I want to monitor vlan1 only as this is the connection to my cablemodem. The majority of PC apps log bandwidth using the PC LAN port, but this is no good when you are on a network and don't want to include data used sharing files and streaming audio/video between computers.

    I know it can be done a couple of ways using DD-WRT, but i'd like to stick with Thibor as it flies! :)

  2. Thibor

    Thibor Super Moderator Staff Member Member

    have you tried using that wrtbwlog thing?
  3. Krip

    Krip Network Guru Member

    Hi Thibor,

    It didn't work last time I tried it, but I'll give it a whirl and let you know...

  4. Krip

    Krip Network Guru Member

    Ok tried WRTbwog again and it still wont start up...

    # ./
    Please wait... (~10s)
    syntax error

    The only reason I can think of is because it says, "It will not work with the default Linksys firmware, Sveasoft Satori or Hyperwrt, as these firmware versions do not include awk, which is required by WRTbwlog."

    Unfortunately there doesn't appear to be an error log anywhere to see exactly what's wrong.

  5. Thibor

    Thibor Super Moderator Staff Member Member

    the syntax error is due to the command formation, it seems that it is incompatible with Hyperwrt
    the original is:
    mhport=$(cat "./data/config"|grep "wrt_mhport"|cut -d '=' -f2)
    this gives a syntax error, but this...
    mhport=`cat data/config | grep "wrt_mhport" | cut -d '=' -f2 `
  6. Krip

    Krip Network Guru Member

    Thanks for taking a look, Thibor.

    I did try editing the file as you posted above, but this time it returned 2 syntax errors.

    I guess it's a no go?

  7. Thibor

    Thibor Super Moderator Staff Member Member

    there will be errors of a similar type throughout all the .sh files
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice