Thibor14 Released

Discussion in 'HyperWRT Firmware' started by GhaladReam, Feb 24, 2006.

  1. GhaladReam

    GhaladReam Network Guru Member

    Thanks a lot Thibor for another great release!

    A lot of the bugs that were causing me problems in 13d seem to be resolved!

    New firmware is posted on Thibor's main site:

    P.S. Just so everyone knows, I used to be an avid DD-WRT user, but have since switched to HyperWRT+Thibor because, well, IT'S BETTER!
  2. myersw

    myersw Network Guru Member

    GhaladReam, I agree. I to used to be a dd-wrt fan, that is until I found Hyperwrt+thibor. Always were fighting problems with dd-wrt. For me Hyperwrt just works.
    Thanks for a great job Thibor. Will download and install the 14 stuff this eve.
  3. callous

    callous Network Guru Member

    Previous DDWRT user here as well. But too soon to tell if I'll stay as I only installed Thibor last night..

    Good news is that it's been up for 12 hours without problems LOL

    Anyways what does:

    "Added lots of iptables matches/targets whilst maintaining stability " mean for changelog? Does it mean added compatibility for bittorrent programs???
  4. AeN0

    AeN0 Network Guru Member

    I just upgraded to thibor13d last week and now there is a new version :grin:.

    Between, I have a WRT54GS V4 with thibor13d, do I need "Thibor 14 (latest)" or "Thibor14 for the GSv4, Upgrades from stock firmware" ? It may be a stupid question but I just want to be sure !
  5. NateHoy

    NateHoy Network Guru Member

    AeN0 -

    I think the one for the GSv4, as the description implies, is specifically for upgrading from the stock firmware. I think you're fine just using the regular one.

    Or, to put it differently, I just upgraded in the middle of typing this from Thibor 13d -> Thibor 14 on my WRT54G V4 (identical hardware to your WRT54GS V4) and the new firmware loaded and is working fine. :thumb:

    LOVE the new options for P2P. The new firmware is doing great so far. Thanks, Thibor!!!! :rockon: :rockon: :rockon:
  6. purephase

    purephase Network Guru Member

    13d was good enough already, but with the few issues resolved in this release 14 is near-perfect.

    Thanks Thibor. Upgrade was as smooth as all the rest. This is the first time that my router rebooted since the upgrade to 13d. ;)
  7. swinn

    swinn Network Guru Member

  8. dragon67

    dragon67 Network Guru Member

    Thanks Thibor for another great released. Smooth upgrade. But I am not sure is a bug or just happned to me that the SSH not working. Keep prompting for password but not able to login. Any user's can confirm this? Appreciate.
  9. AeN0

    AeN0 Network Guru Member

    Thanks to all. I just upgraded to thibor14 with the regular thibor14.
  10. mmisnan

    mmisnan Network Guru Member

    Argghh.. no, 12 days w/o reboot and no problem with uTorrent and now I need to upgrade again .. but .. anyway ... :cheering: Thibor, you rock!
  11. Thibor

    Thibor Super Moderator Staff Member Member

    swinn: what planet are you on? :)
    once more for those that didn't get it the first half dozen times i've said it...the ONLY difference between the two versions is the codepattern. this ONLY affects flashing from "original linksys firmware" and using TFTP. cosmetically and functionally there are zero differences between the 2 versions. if you have the gsv4 version and want to upgrade, using the normal version is just fine(it will work). i haven't uploaded the v4 version to my website yet, i'm planning on doing it tonight.FYI, the version numbers at the top of the page are IDENTICAL between the 2 versions
  12. snwbdr

    snwbdr Network Guru Member

    Like the new QoS options in Thibor 14. Everything is running fine and fast. I get up to 300KB/s down on a good torrent with with the Thibor 14 firmware and Azureus 2.4. Never have to reboot(just when I flash firmware), no lost connections. Also like the new firewall options that were made with 13. Thanks Thibor :)
  13. luojs

    luojs Guest

    Looks like "http://x.x.x.x/SysInfo1.htm" page lost information about SpeedBooster.
  14. dirtyclyde

    dirtyclyde Network Guru Member

    WPA2+AES in WDS mode does not seem to work

    3 WRT54GS v2.1
    1 WRT54GS v1.1
    2 WRT54G v4.0

    All running AP-WDS with Thibor 14, I was running G-only WPA2+AES
    but WPA2+AES does not seem to work, changed to WPA+AES works OK

    Thibor 13a-d worked great with WPA2+AES format, thibor 14 no workee

    WRT54GSv2.1 -->WDS->WRT54GSv1.1->WDS->WRt54Gv4

    WRT54GSv2.1 -->WDS->WRT54GSv2.1->WDS->WRT54Gv4

    1 XBOX 360, 1 old XBOX,3 PCs & 1 Laptop
  15. snwbdr

    snwbdr Network Guru Member

    not sure but is this the info on speedbooster?
    get wl_gmode=6;
  16. Thibor

    Thibor Super Moderator Staff Member Member

    thibor13a-d worked using WPA2-AES??? i don't mean to doubt you but it's very unlikely as i haven't changed the wireless driver between those versions and the current one doesn't support it. you MAY have had WPA2-TKIP&AES working, that is wpa/wpa2 mix mode.
  17. dirtyclyde

    dirtyclyde Network Guru Member

    WPA2+AES on 14

    STA, WDS & WET Configurations

    I followed the chart about what was supported and I did use WPA2+AES not TKIP, and it did indeed work Thibor, the chart showed WRT-A (WPA2+AES) WDS WRT-B (WPA2+AES).

    I know because my WInXP showed WPA2 which works with my 511T wireless card as WPA2+AES, my WG121 will not work with WPA2 only WPA.

    I reloaded 13D on two WRTs they work WPA2+AES
    14 does not work.
  18. Thibor

    Thibor Super Moderator Staff Member Member

    i have made zero wireless changes, but just to be sure, i will go away and test what you have said
  19. Thibor

    Thibor Super Moderator Staff Member Member

    i've tested with settings as follows:
    router ip's and
    ssid=same on both
    macs of opposite side
    security=WPA2 Personal

    i started with wpa personal&aes and it worked just fine so then i moved over to wpa2 personal and it didn't work, i rebooted both routers and still it wouldn't associate. ssid broadcast was also enabled
  20. callous

    callous Network Guru Member

    Is there a flaw in the origanl 4.70 that is preventing WPA2+AES?
  21. Thibor

    Thibor Super Moderator Staff Member Member

    no, 13a-d also used 4.70
    the restriction is in the wireless driver and the nas binary
  22. bcat

    bcat Network Guru Member

    OK, Thibor 14 for the GS and GSv4 is mirrored here. Sources will be uploaded after Thibor packages them.

    @Thibor: Thanks for another great release, as usual!

    HyperWRT :rockon:
  23. Thibor

    Thibor Super Moderator Staff Member Member

    welcome matey :)
  24. callous

    callous Network Guru Member

    Thanks for the hard work by the way, Thibor!

    I love how I still retain the original firmware look with extra powerful features!
  25. swinn

    swinn Network Guru Member

    Ah sorry I didn't realize you could flash between the two versions without problems since they are using the different code patterns. I'll go back in my hole now.

  26. Fedorov

    Fedorov Network Guru Member

    Having only just got my WRT54GS v4 and going straight to Thibor 13d, do I need to reset to factory defaults before flashing?

    After flashing am I able to load my 13d config which I'd saved or do I have to enter everything back in manually?

    Many thanks again Thibor.

  27. Thibor

    Thibor Super Moderator Staff Member Member

    just flash to 14, you don't have to reset and you won't need to restore
  28. iamqwerty

    iamqwerty Network Guru Member

    Best firmware so far - when do you release the sourcecode?

    Thank you for all your hard work!
  29. Thibor

    Thibor Super Moderator Staff Member Member

    glad you like it qwerty, i've sent the sources to bcat and you can also get them from my website
  30. Kenny7

    Kenny7 Network Guru Member

    great firmware thibor!

    i have a 3km link and tried alchemy and dd-wrt. some things worked well, some did not... especially WPA wouldnt work for me more than some hours...

    now i got 2 wrt54GS v1.1 with WPA-AES running in WDS mode just fine so far!
    i've just donated 22euro = 15GBP

    just some questions:
    [fade:32cc7cc204]in site survey my other wrt wont get listed. i'm using "WDS only" on that bridge and not wds-ap as i did before with dd-wrt. is that the problem for site survey? imho i need a AP and scan as a client on the other wrt?[/fade:32cc7cc204] edit: wds+ap and it works! good to know

    the second question (haved already searched in the forums and didnt find a clear answer!)
    how to read those site-survey-rates 1,2,5.5,6,11,12,24,9,18,36,48,54 in blue and green.

    btw the 3km distance link didnt work with alchemy or earlier dd-wrt at all on my GS, only on the G v2 and v2.2 i got. a simple driver issue i guess with earlier linksys code...
    now running perfect with my 2 GS in device list my other wrt is listed with -81dbm and it was -87dbm and -90 noise before! now noise -97 yeah!

    i got a second wlan here with 5 wrt54g v2 and 2.2
    can i go for thibor or do i have to use tofu software? he's still at 13c but i might wait if thibor really wont work. speedbooster isnt needed its just for internet sharing and fast enough. just wpa would be nice and istn working rockstable for me atm!

    but there are some nice features from dd-wrt which i miss.
    cron-based auto-reboot (maybe i just wont need it with thibor?^^) and the status page which you can access without the router-PW.
    but i like the site survey page of thibor fw and also the router status page with statistics and especially the inet-uptime!

    well thanks for your work. if i can help you with some webspace just tell me. i got 400mb @100mbit/s 1und1 serverwith 10gb traffic
  31. Thibor

    Thibor Super Moderator Staff Member Member

    hey kenny. firstly thanks for the donation; it's very much appreciated. you can use mine on your g if you want to, but it's simpler to use tofu's else you will have to do the dd-wrt flash and then to mine.
    you can auto-reboot using the command line should you need to. with regard to site survey, the numbers are supported speeds, the blue numbers are for 11b and the green numbers are 11g
  32. Kenny7

    Kenny7 Network Guru Member

    well they all are flashed with dd-wrt atm. i just wanna know if i will encounter any errors because of that speedbooster enabled. will it force my G's to use it or will speedbooster just be disabled if it's not supported by all devices in that wlan?

    supported by this link? so if i can only reach 18mbit in G it will just tell me 1,2,9,12,18 in green? can i see the current speed of my wds-only link? dd-wrt told me 18mbit at the wireless status page if i have used autotransmission. i had to set fixed 18mbit to have a stable connection then.

    auto-reboot was needed by some of my friends. their wrt just f*cked up sometimes and i couldnt access it over wlan and they had to go to their roof and powercycle it... well daily reboots just prevented them from getting annoyed^^
  33. Fedorov

    Fedorov Network Guru Member

    Worked a treat, many thanks, running great! :)
  34. tuskan

    tuskan Network Guru Member

    seen ask problem solved with openwrt and coming with dd-wrt...
    do you have any plans of embedding this feature in hyperwrt?

    mean ask timing setting
  35. Thibor

    Thibor Super Moderator Staff Member Member

    @tuskan: huh?
    kenny: yes your other wrt isn't being seen by site survey because it's not in ap mode. wds mode is what's normally known as "Ad-Hoc" mode. your Gv2 will take my firmware.
  36. moh0815

    moh0815 Network Guru Member

    does it mean that in thibor14 'wpa2 personal-AES' generally doesn't work, or is this issue wds-related only?
    I'm still running thibor12 with 'wpa2 personal-AES' enabled in AP-mode - works fine, but will it also work in Thibor's v14?

  37. Thibor

    Thibor Super Moderator Staff Member Member

    wpa2-aes works just fine in ap mode. it's wds where wpa2 will not work due to a limitation in the wireless driver. don't worry moh, you're still secure
  38. 4char

    4char Network Guru Member

    Thanks for the great work!

    But I got a problem. The has the wildcard and MX options (I think these are new options in 14). but the change does not stick. It still unchecked if you check either Wildcard or MX and try to save the change. BTW, I'm using FireFox and WRT54GS v3.0
  39. Thibor

    Thibor Super Moderator Staff Member Member

    thanks, i know about it and have already fixed it.
  40. Saro2002

    Saro2002 Network Guru Member


    sorry for my bad english...

    I have a problem with the Thibor 14

    I use PPPoE with Connect on Demand : Max Idle Time 5 Min!

    My Problem is the Router disconnect every 5 mins and i fly out of my game/stream/download or other.

    the Thibor 13d has this Problem not and i can play one hour or longer.

    How i can Fix it? or is this a bug in the Release?

    Edit: My Router is a Linksys WRT54GS V4
  41. Thibor

    Thibor Super Moderator Staff Member Member

    i am using dial on demand and it doesn't disconnect for me. erase your nvram and restore default settings and then set it back up manually
  42. Saro2002

    Saro2002 Network Guru Member

    thx for the answer.

    I have restet to default settings, an to factory settings (NVRam clear)!

    I reflash to Thibor 13d it works perfectly, i flash to 14 the same problem again!

    Keep Alive : Redial Period 30 Sec.

    works perfectly and i have a stable Connection only the dial on demand disconnect me every 5 minutes.

    My flash way
    1. reset the Router to Factory defaults.
    2. flash the Firmware
    3. reset the Router ro Factory defaults.
    4. configuring the Router
  43. Thibor

    Thibor Super Moderator Staff Member Member

    seriously: there is NO issue with 14's dial on demand. i am using it myself. try changing your max idle time to 0
  44. Saro2002

    Saro2002 Network Guru Member

    With max idle time "0" i have a durable connection and no disconnects!

    Connection Uptime : 0 days, 00:09:45

    the statistics updatet very irregularly (5 mins then 1 min then 3 mins) is this normal?



    i have now connect with Keep on alive... it is very seriously

    Router Uptime: 0 days, 01:19:45
    Connection Uptime : 0 days, 09:01:58

    I have a connection uptime that is longer as the router uptime :eek:
  45. Thibor

    Thibor Super Moderator Staff Member Member

    something has happened with your time sync. the statistics update every 3 minutes(i think). i don't know what's going on with your uptime. if 13d was working fine for you, go back to it. i WILL find out what is going on with this release, many many people say it's good and a few say it's not. the changes between the 2 aren't major so it should be quite straightforward to backtrack and figure out what is wrong(i think maybe to do with IMQ or an iptables extension)
  46. Saro2002

    Saro2002 Network Guru Member

    Now i have the Thibor 13d and it works perfectly.

    Perhaps these data help during the problem identification:

    Firmware Version:v4.70.8, Hyperwrt 2.1b1 + Thibor13d , Feb  9 2006
    Boot Version:v3.6.4
    RF Status:enabled
    RF Firmware Version:v4.70.8, Hyperwrt 2.1b1 + Thibor13d
    RF Domain:ETSI (channel 1~14)
    RF Channel:6
    RF SSID:linksys
    -----Dynamic Information
    RF Mac Address:xx:xx:xx:xx:xx:xx
    LAN Mac Address:xx:xx:xx:xx:xx:xx
    WAN Mac Address:xx:xx:xx:xx:xx:xx
    Hardware Version:2.0
    Flash Type=Intel 28F320C3 2Mx16 BotB;
    CPU Clock=200;
    Write Mac Address=xx:xx:xx:xx:xx:xx;
    get wl_gmode=6;
    totalram=14761984, freeram=1982464, bufferram=1966080;
    Total IEs = 0
  47. Thibor

    Thibor Super Moderator Staff Member Member

    how could that help? that's just general information. thanks for trying anyway, it's a nice thought
  48. LiOn

    LiOn Network Guru Member

    Can I flash Thibor 14 od WRT54G V3.1 please? I'm currently using DD-WRT V23 latest Beta SP1. This is from Thibor's Web site:
  49. Thibor

    Thibor Super Moderator Staff Member Member

    if you do, it's on your own head. i will not support it
  50. Netman66

    Netman66 Network Guru Member

    SSID Ghost?

    I have to admit, this is one super-slick firmware! After struggling with a few of the alternates I have finally settled on Thibor's build. Plain and simple - and it works. :thumb:

    I do have one thing to contribute.

    I changed the Router Name and SSID (they are both the same) and enabled WPA2 Personal. Connecting from an XPSP2 laptop it shows TWO wireless networks !

    One is correctly labelled as the new name with full signal strength and WPA secured. The second (phantom) SSID is shown as linksys (the original name) with very low signal strength and also WPA enabled.

    Can anyone else confirm if they change the Router name and SSID to the same names (but not linksys) that they see the same "phantom"?

    I can post screenshots if required.

    Router is a 54GS v4 model. Reset before and after flash, plus unplugged it after configuring so it would reload clean.

    Other than this, I am preparing to load up a template created in Firewall Builder. Does anyone care to give a hardcore Windows Server MVP some pointers?? :cry:

    Thibor, in short order and when this is all ironed out, I will be contributing to your retirement fund! Keep up the amazing work.

  51. Pinion

    Pinion Network Guru Member

    I'm running a version 2 wrt54gs with the latest linksys firmware from I'd like to try Thibor's firmware, which one of these should I use?

    Thibor 14 (latest)

    Thibor14 for the GSv4, Upgrades from stock firmware

    From the title I assume that's only for a version 4 wrt54gs running official linksys firmware. However I'm not 100% sure. So which version should I install on my 2.0 wrt54gs? Thanks.
  52. purephase

    purephase Network Guru Member

    The v4 firmware is only to upgrade v4 routers from stock. Use Thibor14.
  53. purephase

    purephase Network Guru Member


    Do you live in an apartment building? It sounds like you're seeing another wireless access point in the area.
  54. Netman66

    Netman66 Network Guru Member

    No, I'm in a house on 3 acres. Closest place is about 200M away and not in line-of-sight.

    I also have a D-Link wireless router in the house that has SSID disabled - I don't see that one - which is expected.

    This "phantom" is definitely the same box I'm working on. I see 3 networks on the Status page - WAN, WLAN and LAN. If I expand any of them I see 4 interfaces - eth0, imq0, imq1 and vlan0.

    Is that expected? I know this is likely elementary for Linux people, but I'm just "broadening my horizons" and getting back into *nix so I'm very rusty (seized up, actually!).... :rofl:
  55. Netman66

    Netman66 Network Guru Member

    I just looked again at my "View Wireless Networks" applet and it's gone. Too weird...

    Well...I guess it's just the FW Builder advice that's needed now.

    I need some sleep! back in the A.M.
  56. callous

    callous Network Guru Member

    I couldnt find the documention for hyperwrt or Thibor,

    Which of the interfaces below isthe actual bandwidth I have used from my Internet Provider??

    LAN (rx/tx) : 1.17 M (10.02 K/s) 3.99 M (34.05 K/s)

    WLAN (rx/tx) : 0 (0.00 K/s) 0 (0.00 K/s)

    WAN (rx/tx) : 3.24 M (27.62 K/s) 1.32 M (11.23 K/s)

    eth0 (rx/tx) : 5.02 M (42.84 K/s) 5.37 M (45.79 K/s)

    imq0 (rx/tx) : 0 (0.00 K/s) 0 (0.00 K/s)

    imq1 (rx/tx) : 0 (0.00 K/s) 0 (0.00 K/s)

    vlan0 (rx/tx) : 1.24 M (10.58 K/s) 4.05 M (34.55 K/s

    Is it vlan0 or WAN??
  57. Thibor

    Thibor Super Moderator Staff Member Member

    WAN(Wide Area Network), is your internet connection
  58. spooky75

    spooky75 Network Guru Member

    Every time you change Wireless channel, "Frame Burst" setting changes to "Enable". Odd.
  59. phinn

    phinn Network Guru Member

    I'm now running this on my WRT54G v4. I used to run Tofu but as he says on his Tofu website Thibor should now be used in replacement:

    Note: All changes I have made up to G/GL 13c have been incorporated into the "Thibor" version. The code base for both "Thibor" and "tofu" versions are almost the same now (yes, it works for G), and Thibor has plans for an SL version as well, so I am no longer maintaining a duplicate "HyperWRT +tofu" firmware.
    You can upgrade from tofu 13 to Thibor's by just using upgrade page. For hardware without tofu 13, you can install tofu 13 or DD-WRT mini as a first step to upgrade your G/GL to Thibor's GS firmware.

    I'm guessing it'll be better maintained too.

    Anyway it works great on the G!
  60. Saro2002

    Saro2002 Network Guru Member

  61. Thibor

    Thibor Super Moderator Staff Member Member

  62. tuskan

    tuskan Network Guru Member


    that what i meant about ack timing setting.
    so - do you planning something about?
  63. Thibor

    Thibor Super Moderator Staff Member Member

    no, no plans
  64. Ruebe

    Ruebe Network Guru Member

    Router drops connection


    I tested Thibor 14 on my WRT54GS V.4 for about one week. In this time my router lost the WAN-Connection every 5 till 20 minutes.
    My settings were: PPPOE Connect on Demand: Max Idle Time 60 min.

    If I set to: Keep alive: Redial Period 30 sec. the router doesn't reconnect.....

    When I try the same with to original Firmware 1.05.2, I get no disconnects with the Connect on demand settings. But so I miss all the nice features of the thiborsoft....

    Btw.: I only use the wired ports. The wireless settings are disabled.
    Is there a trick to get it working, or is there a litte bug?

    Thanks !
  65. tuskan

    tuskan Network Guru Member

    can you please explain why? The feature really works.
    I've tasted it, but then flashed back 2 hyperwrt coz DD-wrt has buggy WAN port - hunging every several hours...
  66. ericjwill

    ericjwill Network Guru Member

    WRT54G v1.1

    Thibor 14 works great on my wrt54g v 1.1 hardware. Haven't bothered with afterburner since I have no afterburner capable clients, but otherwise it works great.
  67. Dawggy

    Dawggy Network Guru Member

    Great work once again Thibor!!!
    Got it running on my wrt54G v3 works flawlessly
  68. Thibor

    Thibor Super Moderator Staff Member Member

    tuskan: i'm sorry but i don't feel that i have to explain myself to you or for that matter to anybody else. if you feel strongly enough that the firmware you use HAS to have ack timing in, you have the right to take the sources and modify them to your own ends.
  69. Casey321

    Casey321 Network Guru Member

    Thank you Thibor for the great firmware!

    I flashed my WRT54G V3 with Thibor14 and it runs better that ever before. Best of all everything in your version is working for me, unlike some others.


    Casey . . .
  70. purephase

    purephase Network Guru Member

    Uptime : 11 days, 09:33:37

    This is great. The last reboot was for the upgrade to 14. Before that, the last reboot was for the update to 13d.

    No problems at all. QoS is working great for VOIP and the router is handling BitTorrent traffic just fine.

    Thanks Thibor.
  71. ymboc

    ymboc Network Guru Member

    Awesome stuff!

    However my dyndns options (Wildcard, mx) don't seem to keep and infact reset/disable the existing options (stored at as opposed to how it seemed to work in 13 where I think the firmware was sending 'nochg' for options not configurable via the firmware.

    Also what is the result of checking the 'mx' checkbox? Does it set the mx record to the routers wan ip/hostname? -- is there a way we can continue to refer to '3rd party' mail exchangers (ala parked domain).

    perhaps if there could be a method of selecting off/on/nochg ?

    Again awesome release but it's back to 13d for me (which is great too!)

    Edit/Woops: Found this issue already referenced in this thread
  72. squibtone

    squibtone Network Guru Member

    Is it me or has Thibors firmware turned my GS 1 into a hotrod? Seems like dd-wrt was clunky compared to this! My router seems to respond way faster than dd-wrt when configuring (internet access too), wireless connects faster , and WDS to my G with dd-wrt was flawlessly fast and easy...

    Got an XP VPN connection to a dd-wrt at work and that connection lit up without any problem....dd-wrt it was a gamble if I could connect or not.

    Thibor....really love how any changes made to the config are so super long reboots....

    I just may be a convert.... stuff... :clap: :cheer: :cheering: :thumb:
  73. netcdf

    netcdf Guest

    Max Idle Time

    I have the same problem how Saro2002. My WRT54GSv4 disconnects after the Max Idle Time even when its not idle. For Example when i enter 5, then it disconnects every 5 minutes.
  74. magnus33

    magnus33 Network Guru Member

  75. DigiH

    DigiH Network Guru Member

    Max Idle Time

    Unfortunately I have the same problem as Saro2002 and netcdf. Whatever I set as the max idle time, my WRT54G (v 3.1 - ok, I just read in this thread that 3.1 isn't officially supported, but everything else seems to work just fine fine, and the max idle time issue with Saro2002 and netcdf also seems to be happening on other hardware versions) reboots exactly after that time, no matter what I'm doing at the time i.e. getting cut off in the middle of a voip call, whcih shouldn't really count as being idle ;)

    Several reboots, nvram erases and virgin set ups didn't change anything. I wondered if it had to do anything with the Conntrack - Established State Timeout setting, but changes to it didn't make any difference either.
  76. penkert

    penkert Network Guru Member


    I recently upgraded from Tofu13c to Thibor14 on my three WRT54G units. I just love the stability and the feature set of this firmware. (The only thing missing for me would be a VPN server, but I understand that this is too far off the original Linksys release to go with the HyperWRT philosophy, and after all it's up to Thibor how he wishes to spend his time.)

    There is one feature in Tofu13c that I miss in Thibor14. I am running a 3-node WDS network with several computers wired to the WRTs. With Tofu13c I was able to wake up any wired computer in the network from any of the three WRTs. In Thibor14 WOL only works with machines wired directly to the WRT that is sending the WOL call. So the magic packet doesn't seem to be sent over the WDS connections. It is so much easier to use the primary router to send WOL calls since the WOL list automatically gets populated with static DHCP entries----another feature I love BTW. Is it possible to have WOL calls sent across WDS connections again?

    And one more thing. Thibor has said several times in this thread that WDS and WPA2-AES (only) is not supposed to work. It is working for me unless there is a bug in the firmware that leads to my inputs being ignored. Here's my setup on all three WRTs:

    Basic Wireless Settings:
    - WDS ("Access Point + WDS" works just as well)
    - G-Only (I haven't tried any other mode here)
    - SSID Broadcast enabled
    - WDS mode "Link with the following" ...

    Wireless Security:
    - WPA2 Personal
    - AES (not TKIP+AES)

    The rest is pretty much standard. I have also had trouble getting this setup to work in the past and I found that this is a reliable way of doing it (in this order):

    1. Set up wireless security to WPA Personal (not WPA2 Personal) AES using the same key that the WPA2 connection is supposed to be using in the end.
    2. Set up Basic Wireless Settings to "WDS" or "Access Point + WDS", "G-only" (don't know if anything else works since I don't need it), an SSID and WLAN channel of your liking, and use the WDS mode feature "Link with the following" with the wireless MACs of the other WRTs.
    3. Get your WDS network running with these settings.
    4. On all routers change "WPA Personal" to "WPA2 Personal" and leave the rest untouched (well besides hitting the Save Settings button, of course, LOL).

    For me the network has always come right back up then, and (as long as Access Point + WDS is used on at least one router) Windows shows that it is infact a WPA2 network. And again, the WPA algorithm in the firmware setup is shown as "AES", not "TKIP+AES".

    Thibor if there's anything you'd like me to test I'll be happy to assist you. (However, due to a change of internet providers I'm going to have a two-to-three-week downtime starting this Friday and I might not be able to check this thread during that time.)

    Take care,
  77. Thibor

    Thibor Super Moderator Staff Member Member

    on your router wds+ap, give me the contents of /tmp/nas.lan.conf
  78. penkert

    penkert Network Guru Member

    I'm sorry, but I'm new to this. I assume I have to telnet into the box and then what?
  79. Thibor

    Thibor Super Moderator Staff Member Member

    telnet into your box, then type "cat /tmp/nas.lan.conf"
    copy what it returns here. do the same for your other boxes too if you wouldn't mind.
  80. penkert

    penkert Network Guru Member

    OK, I edited out my WPA2 key----the rest is a 1:1 copy:

    Box 1 (WDS+AP, running DHCP):

    nas -P /tmp/ -l br0 -H 34954
    -i eth1 -A -m 128 -k [my-WPA2-Key] -s P-Link -w 4 -g 3600

    Box 2 (WDS only):

    nas -P /tmp/ -l br0 -H 34954
    -i eth1 -m 128 -k [my-WPA2-Key] -s P-Link -w 4

    Box 3 (WDS only):

    nas -P /tmp/ -l br0 -H 34954
    -i eth1 -m 128 -k [my-WPA2-Key] -s P-Link -w 4
  81. Thibor

    Thibor Super Moderator Staff Member Member

    shit; according to that your are using WPA-PSK2 AES, and you say it's working over wds?
  82. dirtyclyde

    dirtyclyde Network Guru Member


    I have six WRT54GS & WRT54G running WPA2/AES in the WDS mode on Thibor 14, but you must start off WPA/AES set all of them up in the WDS mode, once you get them to work change it to WPA2/AES. I think the WDS links are running WPA/PSK/AES and the Wireless is WPA2 only PSK2, reason I say this is I have a shitless WG121 that will only work WPA, also have a WG511T which will run WPA2 or WPA (PSKor PSK2).

    Once the WRTs are up and running WPA2 the WG121 will not connect, but the WG511T on the Laptop connects MS Zero and Netgears App. in WPA2 mode. So the WDS links appears to run in

    Thibor 14 WRT54GS v2.1 2 WDS Links WPA2/AES

    BusyBox v1.01 (2006.01.29-22:09+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    # cd /tmp
    # cat *nas*
    nas -P /tmp/ -l br0 -H 34954
    -i eth1 -A -m 128 -k XxxxxxxxxxX -s RADIUS-8 -w 4 -g 3600

    -m 128 = PSK2
    -w 4 = AES


    The Wireless side is running WPA2/PSK2/AES. NAS is set up to PSK2 (-m 128).

    Usage: nas [options]
    -l LAN interface name
    -i Wireless interface name
    -k WPA share-key
    -m 2 - WPA
    4 - PSK
    32 - 802.1X
    64 - WPA2
    66 - WPA WPA2
    128 - PSK2
    132 - PSK PSK2
    -g WPA GTK rotation interval
    -h RADIUS server IP address
    -r RADIUS secret
    -p RADIUS server authentication UDP port
    -s SSID
    -w 1 - WEP
    2 - TKIP
    4 - AES
    6 - AES+TKIP
    -P nas pid file
    -I WEP key index
    -K WEP share key
    -H UDP port on which to listen to requests
    -t ??????
    DD-WRT V23 3-25-06 mini has to be set up WPA2 Pre-Shared-Mixed
    mode and works WDS. will not work WPA2 Shared Key Only, has to be WPA2 Shared Key Mixed.

    DD-WRT v23 03-25-06 your choice are WPA Shared Key Only, WPA2 Shared Key Only, WPA2 Shared Key Mixed.


    2 WRT54GSv2.1 WDS WPA2/AES Thibor14 (xbox 360)
    1 WRT54GSv1.1 WDS WPA2/AES (mixed) dd-wrtv23-032806 mini (AMD64)
    2 WRt54Gv4.0 WDS WPA2/AES Thibor14 (xbox)
    1 WRT54Gv4.0 WDS WPA2/AES (mixed) dd-wrtv23-032806 mini (VAX780)
  83. Thibor

    Thibor Super Moderator Staff Member Member

    -m 128 is WPA2-PSK only, that's why i asked for the nas command. -m 132 is WPA2/WPA mix. wds is working wpa2-ONLY with aes. cool, that's the first confirmed case i've seen of WDS working with WPA2.
    for info, wpa2-psk aes is wpa2 only, wpa2-psk aes+tkip=wpa2/wpa mix mode(-m 132, -w 6)
  84. penkert

    penkert Network Guru Member

    Yeah, as I said, it's working like a charm, and it's good to know that it is really WPA2-PSK AES internally and not some kind of misconfiguration. It's strange that we have to use that intermediate WPA1 configuration but that seems to do the trick and dirtyclyde just confirmed it. :)
  85. Thibor

    Thibor Super Moderator Staff Member Member

    yep, i have psk2-aes working here with 5 GS's and 2 WRTSL54GS's
    all in WDS. when i have time i will investigate and see if there's a way to avoid having to establish psk1 connectivity first.
  86. penkert

    penkert Network Guru Member

    Great, thanks Thibor! :rockon:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice