Thibor15b1 WRT54G and GS Firmware released

Discussion in 'HyperWRT Firmware' started by Toxic, May 4, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    Updated to 4.71.1 codebase
    Added Progressive QoS page
    Integrated Layer7 support to the web interface
    Fixed Numerous Web Interface bugs
    Upgraded Iptables to version 1.3.5
    Upgraded Dropbear to version 0.48.1
    Upgraded Busybox to version 1.1.2
    Updated Log.asp
    Added Rupans Dropbear patch and grcore's services.c patch
    Fixed Dial On Deman Bug(ipp2p was the cause)
    Updated Redirect Help page
    Added PPPoE Service Type
    Added PPTP DHCP option

    The DDNS options have reverted to the Original 2 in the Stock Sources. as i get time i will put Zone-edit back but the format for ddns has changed quite a lot.

    check out our downloads or
  2. AmyGrrl

    AmyGrrl Network Guru Member

    Does the KaiStation script work with this release... I couldn't get it to work with Thibor14 and still doesn't seem to work with Thibor15... Is KaiStation gone for good?
  3. Toxic

    Toxic Administrator Staff Member

    if you really want kaistation to work then use a firmware that the script works with.
  4. AmyGrrl

    AmyGrrl Network Guru Member

    I thought it did work with this firmware... if not... then why would the needed script be posted on the firmware's homepage?
  5. the_sly_dog

    the_sly_dog Network Guru Member



    have to setup paypal account :)

    thank u guys for the hard work

    think u have earned afew drinks down the pub lol :drinking:

    and i cant forget to say thanks for all the help from eveyone that helped sort out few probs ,, :cheering: rules best site on the INTERNET :rockon:
  6. silsila

    silsila Network Guru Member

    Kaistation not working isn't anything do do with thibor's firmware. Teamxlink seem to have stopped hosting the binaries.

    Use this startup script:

    cd /tmp
    echo "#!/bin/sh" > startkaid
    echo "cd /tmp" >> startkaid
    echo "if [ ! -s gokaid ]; then" >> startkaid
    echo "wget \"\" -O gokaid" >> startkaid
    echo "wget \"\"" >> startkaid
    echo "sleep 1;chmod +x gokaid;fi" >> startkaid
    echo "./gokaid -d" >> startkaid
    chmod +x startkaid
    echo "*/2 * * * * root /tmp/startkaid" > cron.d/check_kaid
    touch crontab

    Enter your user name and password in XBMC not
    Thanks to perkomat.
  7. AmyGrrl

    AmyGrrl Network Guru Member

    That's all I wanted to know... I suspected that Teamxlink wasn't hosting the needed files anymore.... still can't get that script working ethier.... when I used to use the actually KaiStation I use to have to telnet to the router and start kai manually... is thier a command to start kai via telnet using this script
  8. Mag1c1an

    Mag1c1an LI Guru Member

    Kai Script!

    Okay, ive upgraded to the firmware and its great.

    However, as stated the script for kai at doesnt seem to be working properly.

    Instead of the negative attitude, how about a link to a script that does work.

  9. silsila

    silsila Network Guru Member

    I've tested the script I posted and it is working. The telnet command I think was "nvram set kai_enabled=1" but i've not needed it.
    I have used the script and just entered my details in xbox media center and it logged into kai no problem. Try rebooting the router after the script is saved and also disable then restart kai in xbmc if you are using this.
  10. lwf-

    lwf- Network Guru Member

    Good job, thank you very much. I will go flash my GS1.1 right away.
  11. NateHoy

    NateHoy Network Guru Member

    I posted this on, but I'll repeat it here, too.

    Thibor 14 -> Thibor 15 should be treated as a brand new firmware, not an upgrade.

    In other words, after the flash is complete, you should do a "Clear NVRAM Factory Reset" by going to the Administration page, Factory Reset, and taking the "Clear NVRAM" option for factory reset.

    Then, when you are done, rekey your settings into the router. Do not attempt to restore a saved configuration from Thibor 14 or any other firmware.

    Thibor has made some sweeping changes in this release, and I wouldn't recommend trying to keep settings between the two. Just for giggles while I was testing it, I tried skipping the NVRAM reset, and had a few minor problems that went away as soon as I cleared NVRAM and rekeyed settings.
  12. penkert

    penkert Network Guru Member

    Thibor15, that's exciting news.

    Thibor, were you able to get WPA2-PSK-AES to work on a WDS connection without the intermediate step of setting up WPA1 first? And how about WOL magic packets being sent over a WDS link? (This is not meant as a bugger----I'm just curious.)

    I'll probably get around to flashing my routers this weekend. And after that it's definitely time for a little donation from me as well. I've waited to see how stable the firmware is on a long term basis and, so far, it's been magnificient! (That's something I haven't experienced with any other 3rd party firmware I tried so far.)

    Thank you!!!
  13. Toxic

    Toxic Administrator Staff Member

    Thats nice to here. its about time some folk donated something to Thibors hard work, and he does work all hours. i should know he keeps me up most of the night bug finding and fixing:)
  14. mstombs

    mstombs Network Guru Member

    I'd like to see a comment from Thibor about this, I skipped the reset coz I didn't want to type in all my static DHCP entries etc again and all seems well. If he's only added NVRAM variables and not changed use shouldn't it be OK?
  15. reber

    reber Network Guru Member

    After upgrading to Thibor 15, I've experienced trouble in Client mode.

    Has anyone successfully operated a WRT w/Thibor 15 in Client mode?
  16. Thibor

    Thibor Super Moderator Staff Member Member

    i successfully operate client mode with Thibor15, and have also set up wds links using wpa2 without stepping through wpa1. haven't used WOL at all though. If you think you don't have to factory reset although it's been advised, fine. if i disagreed with Natehoy, i would've spoke up, but as i didn't, then obviously i agree with him.
  17. mstombs

    mstombs Network Guru Member

    Message received and understood, at the first sign of trouble I'll follow the advice - what a rebel - I don't think I bothered clearing from Thibor13 to 14 either! - but haven't tested wireless yet...
  18. Thibor

    Thibor Super Moderator Staff Member Member

    13-14 wasn't a leap, the entire qos system has changed now
  19. scorpy

    scorpy Network Guru Member

    Just upgraded and working a treat. Thanks Thibor, and Toxic for the testing.:clap:
    And to show my appreciation of the hard work that's gone in to it I just made a donation. :D
  20. pharma

    pharma Network Guru Member

  21. myersw

    myersw Network Guru Member

    Downloaded and installed Thibor 15. As usual with Thibor's code installed without any problems. I always do a factory reset, so did that and tested. Seems to be working fine.
    And as Toxic says, give Thibor some money, I have. He does this for free/fun but he still has expenses. If he had more money, he might be able to buy more routers and other things to make this an even better firmware. I have tried others, but Thibor has to be the most stable just works firmware out there.
  22. yosemite610

    yosemite610 Network Guru Member

    Interesting thing happened to me during installation; Firefox started behaving badly, gave me a 'Server Reset' error everytime I tried to 'Save Changes' after Thibor15 install and NVRAM clearing.

    Eventually I blew the dust off IE and used it (no errors), made most of my base configuration changes, and then tried Firefox again (quit and restart Firefox). Problem gone, Firefox behaves appropriately.

    I'm thinking Firefox/cache/burp issue, but posting my experience in case anyone else notices this...

    Thanks again Thibor ;')
  23. NateHoy

    NateHoy Network Guru Member

    mstombs -

    I hear you. I have about 8 static DHCP entries, but of course cut-and-paste is a beautiful thing - I copied all of the MAC addresses to a Text document and simply cut-and-pasted in each one, and keyed the IP address and network name. <5 minutes work for my entire configuration, including static DHCP and my wireless security and QoS.

    It won't brick your router to skip the step, but having Thibor 14 NVRAM values out there running in a completely different firmware like Thibor 15 may cause you some odd glitches. Look at all the underlying code that Thibor has replaced.

    Having said that, well, it's your router. If it works, it works. Can't argue with success. :rockon:

    Just be sure, if you run into any oddities, that you do the NVRAM reset and rekey your settings before you post that something is not working. I know that I found QoS to be somewhat buggy, and a few other oddities, before I reset.

    The same thing happened when I went from Tofu to Thibor, and Thibor recommended the reset to me when he sent me the beta versions. I intentionally ignored that advice the first time and tried it without the reset because I knew that's what a lot of people would want to do. It gave me some minor issues, but it might work for you. "Unpredictable Results May Occur".
  24. NateHoy

    NateHoy Network Guru Member

    After the firmware upgrade, it seems for some reason to be important to shut down and restart Firefox. I think Firefox is storing something in the session cache that messes things up.
  25. b00ze

    b00ze LI Guru Member


    Is there something special i should know about disabling the "Firewall Protection" with the newest Firmware Version "v4.71.1, Hyperwrt 2.1b1 + Thibor15" (on a WRT54GL)?

    I tried to disable the firewall (with+without a reboot and a reconnect to my isp), but portscans (sygate, grc, pcflank, aso.) still show all ports as "stealthed". Any ideas why?

    Thanks in advance,
  26. NateHoy

    NateHoy Network Guru Member

    "Stealthed" simply means that nothing is responding to connection requests in any way.

    That is a standard function of NAT - unless you have something monitoring a specific port from behind the router and responding to requests (which usually requires DMZ or port forwarding), you'll get stealth.

    The router itself will not respond to requests on the WAN except for specially-configured services like remote admin.

    If you need something to respond, and you understand the security implications of what you are about to do, add a PC in your network to the DMZ, then that PC will respond to ping requests and other connection requests based on your configuration of that PC.
  27. b00ze

    b00ze LI Guru Member

    Ahh ok, i got that. Thank you for the fast response. :rockon:
  28. jonhpick

    jonhpick Network Guru Member

    Thanks for this great work Thibor!

    One small glitch:

    Router name on Basic Setup page and on router's Login dialog box should be changed from WRT54GS to WRT54G(L) for the later models.

    It is possible in a next version to include total active/inactive connections under "Status/Statistics"?

    On QoS are ACK and ICMP prioritized? I think so, is this related to NVRAM variables qos_ack=1 and qos_icmp=1?

    Under Security / Firewall what's behind "Filter P2P Applications", is L7-filter or ipp2p? How can we configure the protocols/rules?

    Thanks in advance.
  29. Thibor

    Thibor Super Moderator Staff Member Member

    1. GL thing = don't think so, it's built using the GS codebase, it only has the GL codepattern
    2. no
    3. qos_ack and qos_icmp are remnants from 14 that i haven't re-integrated into the gui, although i plan to put them back in for Thibor 15a
    4. ipp2p, you can write the rules manually and put them in the firewall-script
  30. robsonn

    robsonn Network Guru Member

    Maybe somone can confirm too that QoS works unpredictably? Tested on v2.2 and v3.1 and when you start p2p or ftp upload/download router slows down a lot (web gui), www surfing also. With similar setings on v14 everything was working flawless.
    Maybe there are some new problems, bug with new linksys source code.
  31. Acid-drop

    Acid-drop Network Guru Member

    qos_ack and qos_icmp is a damn nice feature :)
  32. Mag1c1an

    Mag1c1an LI Guru Member

    Hi all, im afraid i am having massive problems getting this Kai script to work.

    I have cleared nvram, rebooted router, applied the script to the startup script, rebooted router again.

    I am still unable to connect to Kai via XBMC. I have disabled Kai in XBMC, rebooted, then reeanbled Kai. Still no luck.

    I have just telnet'ed into my router and typed ps, and ./gokaid -d is listed but like 27 times.

    Does anybody know what is going wrong at my end.

    Please help!

    Thanks in advance.
  33. silsila

    silsila Network Guru Member

    That's odd.
    Do you not even get the kai icon on the XBMC homepage?
    Have you filled in your Xlink details in Settings/Programs?

    I entered script, saved, rebooted router. Started XBMC, enabled Kai in settings and entered my user/pass. Rebooted xbox and Kai icon was there. Tested with Forza.
  34. Mag1c1an

    Mag1c1an LI Guru Member

    No, im having no luck, i have had to remove the script from my startup as i have just telneted into my modem and ran the ps thing again, and there were over 40 instances of the ./gokaid -d running.

    So i have cleared the nvram again, and am starting from fresh.

    This is really doing my head in as i have tried loads of different things and nothing seems to be working, but i know my login stuff is right as i can get it all running through my pc as usual.
  35. DallasFlier

    DallasFlier Network Guru Member

    Carl - thanks for all your hard work over the last few months. Sounds like from this thread that your PayPal account is hopefully showing some appreciation in a bit more tangible terms than just the kudos in this thread. I just sent you a donation also.

    Nate - as I've said here before, I've gone from stock firmware (I have no idea what version!) to HyperWRT 1.3, 1.4, 2.0, 2.1, all the rupan releases, followed by tofu's releases, and then Thibor 13 & 14 here, without breaking down and doing the nvram reset after updating. You convinced me it was finally time, so I just got Thibor 15 running after doing the reset and rekeying everything.

    One really strange oddity here immediately after the upgrade and nvram reset, but it went away on its own. I installed the new software and everything seemed fine - logged back in (using FireFox) and proceeded to to the nvram clear & reboot. Upon reboot, my hardwired PC couldn't get a DHCP address issued, although the two Vonage boxes got theirs with no problem. I rebooted the PC, and it still couldn't get an IP assigned. I opened up the network connection IP parameters, and everything looked fine - set to get IP and DNS addresses via DHCP. Was about ready to hardcode the IP and DNS to get it reconnected, but first I went to my wireless notebook, was able to connect to the now default "linksys" SSID just fine, and get an IP via DHCP. So, I went in and started looking at the router config from the wireless machine, and actually keying in some of my parameters. After about 10 minutes, I glanced back over at the other computer, and it was up and running fine again, had been given a DHCP address finally. Not sure why it had problems for a few minutes though, even after a complete reboot. Guess all's well that ends well in this case, but it was a bit strange.
  36. mstombs

    mstombs Network Guru Member

    Only oddity I observed was the wireless sitesurvey command would only find one new network per scan, so you scared me and I have now cleared and re-entered all settings. The notepad cut and paste was good tip plus Firefox remembered most items I had to type - I didn't have the Firefox issue others report! I did save "nvram show" before and after, they are quite different mainly coz the order changed but looks like things missing from both!

    Now compared the nvram dump, only thing I am surprised about is that the processor speed is no longer overclocked


    was 216 before I reset and rebooted the router - but I am still able to transfer big files between LAN and WLAN so should run cooler!
  37. GhaladReam

    GhaladReam Network Guru Member

    I just read in another thread that Thibor is going to release 15a for the G/GL/GS later today... I already cleared NVRAM and re-keyd all my settings for 15.. Does that mean I'll have to do it again for 15a?
  38. Thibor

    Thibor Super Moderator Staff Member Member

  39. Toxic

    Toxic Administrator Staff Member

    was it working before you upgraded the firmware? then go back to a firmware that works for you.
  40. Lumute

    Lumute Network Guru Member

    Thanks again! :thumb:

    Just installed and reconfigured my GS v2.0 and is working just fine! (in client mode by the way)

    Also sent a well deserved donation...
  41. _Jeff_

    _Jeff_ Network Guru Member

    I attempted to update to Thibor 15 but my router suffered from the Setup page issues that someone posted about in the hyperwrt forums.

    I have noticed that I don't experience the issue with:
    Thibor 14
    Linksys stock 4.70.6

    I do have the issue with:
    Thibor 15
    Linksys Stock 4.71.1

    Therefore, I do believe the Setup page problem is not from Thibor's code but the code upstream from Linksys.

    I even upgraded from stock 4.70.6 to stock 4.71.1 and experienced the problem.

    I am running a GSv3.

    I am now back on Thibor 14.

  42. Lumute

    Lumute Network Guru Member

    Is everithing in this Thibor 15 for G/GS release included in the 15a for SL? I mean, as it came later... was any change included later that was not part of 15a for SL?

    When 15a for G/GS comes (maybe later today as Thibor anounced) will both branches be identical? of course, apart from the obvious SL only features...
  43. Toxic

    Toxic Administrator Staff Member

    afaik they will be a close as possible however the SL still has the old QoS page and not the Progressive QoS like the WRT54G thibor15 has.

    both branches cannot be identical. they use different source codes

    they will have the same features once we get to about thibor16, but please guys stop guessing and requesting more and more features to be added before thibor is ready.

    he is working on the firmware as much as possibly however he needs space to get on with it as well.
  44. GuiPoM

    GuiPoM Network Guru Member

    I wanted to upgrade my wrt54g to thibor 15 but I read that 15a is available soon

    Is it important to wait for it or can I upgrade it right now ?

    Thanks ;) (and thank you for your work too)
  45. tonyp2020

    tonyp2020 Network Guru Member

    I also use Thibor 15 on my WRT54G v2.

    I have read through the HyperWRT forums and I wish I knew what the heck some of you are on about in these posts as my technical knowledge about code and programming is nil.
    A lot of the postings just go right over my head.

    I use very little of the extra bits Thibor has provided, I just know that the router is very stable with his firmware, unlike before I updated the router.

    I too have sent a small donation of GBP5.
    Not much I know, but surely it is better that 10 people donate GBP5 each than no people donate GBP50.

    So if you were wondering how much other people have donated so that you don't send him the lowest amount donated, now you know that I have sent the lowest amount, and therefore you can match it or beat it.

    The guy deserves a beer. :drinking:

  46. cglenn

    cglenn Network Guru Member

    File not Found

    Hmmm, then I try to download, all I get is "File not Found". What's up?

    >>>> Clay >>>>
  47. ofbarea

    ofbarea Network Guru Member

  48. Thibor

    Thibor Super Moderator Staff Member Member

    stop jumping the bloody gun :) , and yes it's there now
  49. cglenn

    cglenn Network Guru Member

    Got it!

    Cool! Thanks for all the great work. A couple of pints are in the e-mail for ya.


    >>>> Clay >>>>
  50. GuiPoM

    GuiPoM Network Guru Member

    wonderful !!! thanks !
  51. dareino

    dareino Network Guru Member

    Loaded 15 earlier today....amazing internet response....
    Saw an updated ver :D and installed it and used the restore function to load my previous settings....
    Great job Thibor!!!!!

  52. lwf-

    lwf- Network Guru Member

    Maybe this is a stupid question, I don’t know, but I thought that I might as well try the qos as it looked pretty lightweight (with is good, I prefer when function made to speed up things doesn’t make everything crawl instead). Anyway, I am wondering what priority the traffic is getting that isn’t defined in the qos settings. Medium perhaps?

    And another thing (to thibor :) ), it would be nice if you could show which ports that a option includes in a future version, wouldn’t be too much work to do it and it would be pretty neat.

    Thank you.
  53. Thibor

    Thibor Super Moderator Staff Member Member

    The default setting is the same as previous Hyperwrt's, that is in between medium and low
  54. MarkA

    MarkA Network Guru Member

    Just updated to 15a and everything seems to be alright except on the QOS page when I choose to add a new application, the lines are all out of whack: also there are 3 sets of From To. What is this for? I didn't notice this in the first 15 build. Everything looked fine in Firefox before: now it won't refresh the page correctly. It doesn't show the changes I saved, but in IE it does.

    Very fast firmware by the way. Thanks Carl!

  55. Thibor

    Thibor Super Moderator Staff Member Member

    yeah, you should update to thibor15b, it fixes that bug
  56. MarkA

    MarkA Network Guru Member

    Thanks Carl. I just upgraded and it fixed the problem in Firefox, but the lines in Add New Aplication are not even: they are not lined up. Is this by design or not. Also, why are there 3 From To Fields. I have 3 in adding pcAnywhere. What is the third one for, if you don't mind checking.

  57. Thibor

    Thibor Super Moderator Staff Member Member

    they aren't lined up because there a 5 characters visible for the box, i've set that to 2 and they now line up correctly. there are 3 fields for From/To because you now have the option of specifying 3 different port ranges per application(that's why numbers 2 and 3 say "Optional")
  58. MarkA

    MarkA Network Guru Member

    Thanks again Carl for looking at this. Do I have to re-download the firmware again after upgrading to 15b? That's ok if so. I'll look at your website now. :thumb:

  59. Thibor

    Thibor Super Moderator Staff Member Member

    you will, but don't bother yet as i've not uploaded
    i'm still working on something, and will be for another hour or so
  60. MarkA

    MarkA Network Guru Member

  61. Thibor

    Thibor Super Moderator Staff Member Member

    it's being uploaded now, give it a couple of minutes and then you can get them
  62. Toxic

    Toxic Administrator Staff Member

    we are now on 15b1


    * Added Zoneedit to DDNS.


    * Fixed cosmetic QoS page bug that caused Summary not to show.
  63. MarkA

    MarkA Network Guru Member

    Thanks Carl for the Great firmware - fast fixing . . . :thumbup: By the way: we're not fussing at you; just thought you'd like to know when something isn't quite right with this great work you're creating - enhancing.

  64. GuiPoM

    GuiPoM Network Guru Member

    same "bug" than with tofu 11-12-13 (not present in 9)

    First time I start my wrt54g v2 wifi led is on. Then I power up my main computer on eth1 port, and laptop on wifi. wifi diod is blinking. Then I shut down laptop (and even later other computer) and wifi diod is still blinking, as if something was connected ... of course SSID is disabled and no computer is connected on wifi

    Have you any idea why this behavior is present still tofu 9 ? (laptop is still present in dhcp table after shutdown)
  65. mstombs

    mstombs Network Guru Member

    Looks like you have a problem with your clock! (body not PC!)

    THANKS for all the hard work to give us the FREE software!
  66. phinn

    phinn Network Guru Member

    There are a couple problems in the QoS gui.

    1) Under Applications you find World of Warcraft, this should be under games.

    2) Disablo 2 should be spelled Diablo 2.

    Both minor, but I figured I should point them out.

    Thanks again for another great release!
  67. Lumute

    Lumute Network Guru Member

    This is one of the first projects I have seen in which bugs are fixed faster that what we take to find them... :thumb:

    Good job Thibor!
  68. Thibor

    Thibor Super Moderator Staff Member Member

    1. World of Warcraft has a layer7 filter available, games section is port range only, that's why it's in applications, bloody ingrate :)
    2. Disablo2, a linksys cockup, fixed.
  69. Toxic

    Toxic Administrator Staff Member

    do you have STP enabled? that usually makes the wifi led flash, are you really worried about it? :)
  70. GhaladReam

    GhaladReam Network Guru Member

    Dumb question... When you say "fixed" do you mean it will be in the next release or did you simply re-upload 15b1?
  71. Thibor

    Thibor Super Moderator Staff Member Member

    i'm not editing, recompiling and re-uploading just to correct a typo. it will be present in 15b2, which will contain other fixes too. this will be released soon.
  72. GhaladReam

    GhaladReam Network Guru Member

    Ok, I was pretty sure you wouldn't. Reason I asked is because the DD-WRT author does that... He seems to release a new (beta) build of that FW pretty much every day. Sometimes I wonder how that guy sleeps. Nevertheless, I stopped using that one a few months ago because it gave me problems. LONG LIVE THIBOR!
  73. Thibor

    Thibor Super Moderator Staff Member Member

    hopefully b2 will be out later today, but i have a couple of bugs to trace and squash first, i'll get it done soon as
  74. lwf-

    lwf- Network Guru Member

    Sure, brainslayer is truly fantastic but thibor works different. I never feel 100% safe when flashing dd-wrt, there have been problems before that involved all kinds of problems including bricked routers. However, I have never had any trouble with thibors hyperwrt, just minor problems that are fixed very fast. We all appreciate it I am sure.
  75. Thibor

    Thibor Super Moderator Staff Member Member

    well thank you very much indeed, i wish my flashing experiences were as trouble free as yours, i have bricked more times than i care to remember. last bug to kill now, logging isn't traversing lan2wan when access restrictions are enabled.
  76. JeFFJuH

    JeFFJuH Network Guru Member

    I have never flashed my WRT54G v2.2 with a 3rd party firmware before. I will do so when Thibor's HyperWRT 15b2 has been released, so that I will be sure most of the bugs have been smashed.

    I'm like scared to death that I will kill my router somehow. My dad would kill me for that, but he gets irritated because of the router slowdowns when he's using P2P software. Hopefully HyperWRT will fix that.
  77. sir_bas

    sir_bas Network Guru Member

    After going to 15b1 I still seem to suffer from the "QOS summary bug". After adding some priority entries, the summary doesn't show up anymore upon saving changes...
  78. JeFFJuH

    JeFFJuH Network Guru Member

    I see that 15b2 has been released. Anybody who's already using it?
  79. GhaladReam

    GhaladReam Network Guru Member

    I just flashed 15b2 on my WRT54GS v2.0. Seems to be working great! I have a question though... Would it benefit me in the least to set the clock frequency to 216 mhz? Or is that just something that fixes the WRT54G v2.2?
  80. JeFFJuH

    JeFFJuH Network Guru Member

    Do you know if it's important to plug off my Cable Modem before flashing it?

    I'm about to start flashing it for the 1st time.
  81. lwf-

    lwf- Network Guru Member

    Not needed but if you want you want extra security you should do it. Also reset the router by holding the reset button for 30 sec and reboot your computer. Do not flash over wireless and make sure that any cable isn’t loose. I think thats all. ;)

    None of those things isn’t really needed; I have haven’t done that every time, in fact I have only done it a few, but my router is still not a brick. :)
  82. GhaladReam

    GhaladReam Network Guru Member

    I don't think it matters. I never disconnect anything. Just be sure you have your router plugged into a reliable power source (i.e so the power doesn't go outm as this can and will brick your router if it happens during the upgrade). I always keep everything plugged in.
  83. JeFFJuH

    JeFFJuH Network Guru Member

    Thanks all! I just flashed my router, and it all went well! :D:D
  84. prowler1968

    prowler1968 Network Guru Member

    Just upgraded from 15b1 to 15b2 and running great! Tested the WOL and successfully powered on 3 computers remotely!! Thanks again Thibor for the great firmware. 15 was definitely worth the wait.

    Hopefully, an SL router will make it's way to me soon!
  85. Thibor

    Thibor Super Moderator Staff Member Member

    can somebody confirm that DDNS is working please
  86. prowler1968

    prowler1968 Network Guru Member

    I use Dyndns at home and I set my work router to update my dyndns record to my work IP. I logged into the account and can confirm that the record at did NOT update to my work IP.
  87. Thibor

    Thibor Super Moderator Staff Member Member

    i know, i fixed it tonight. b3 is up on my site.
    included you'll find a change in DMZ i've been working on.
    this bloody crappy ddns system is a pain in the bottom, i don't even use it, and it's complete rubbish.
  88. prowler1968

    prowler1968 Network Guru Member

    Flashed 15b3 and tested the DDNS update. Status on GUI showed update successful and verified on my account.

    Thanks Thibor!!!
  89. Thibor

    Thibor Super Moderator Staff Member Member

    welcome, what did you think of DMZ?
  90. prowler1968

    prowler1968 Network Guru Member

    Allowing a computer to be in the DMZ only for a specified public IP looks like an awesome idea. I'll have to test that out a little the next few days!! I could see a great deal of usefulness using that between my home office and work office!

  91. mstombs

    mstombs Network Guru Member

    I can't keep up with your posting of binaries Thibor - just upgraded from 15a to 15b3, and all seems well with DDNS. I can force a change of IP by cloning/ uncloning the router MAC address and then rebooting my cable modem - and the status was always correct and update worked fine. From reading the latest Linksys code I still don't think they have fixed the forced update after 25 days - but the code is so convoluted I'll just wait to see what happens!
  92. Thibor

    Thibor Super Moderator Staff Member Member

    you can't keep up? if you're complaining i could always stop releasing them :)
  93. mstombs

    mstombs Network Guru Member

    No No please keep up the good work!

    There was a time I'd hang back waiting for a few weeks of positive feedback from others before jumping in - now you've got me hooked I feel I must be missing out if I don't have the latest!

    Thank-you again Thibor
  94. JeFFJuH

    JeFFJuH Network Guru Member

    My conntrack settings are on max. 2048 connections with a 600 sec timeout. Is this already higher compared to the stock firmware?
  95. mstombs

    mstombs Network Guru Member

    Shouted success too soon:- Access restrictions not working for me in 15b3.

    I didn't reset the nvram, should I have?

    I had 2 policies in place to block all internet access on kids PCs (by MAC address) from 10pm- 11.55pm and 12:00am to 06:00 am [NB never got allow only during daytime hours to work in Linksys firmware so kept this system with unavoidable 5 minute gap at midnight!]. Had to delete both to get internet access working. Will try reinserting later...
  96. JeFFJuH

    JeFFJuH Network Guru Member

    i have set my conntrack from 2048 to 4096 connections, and rebooted my router.

    when i type dmesg in the command prompt, it still says it has 2048 connections.

    ip_conntrack version 2.1 (128 buckets, 2048 max) - 368 bytes per conntrack
    ip_conntrack_rtsp v0.01 loading
    ip_nat_rtsp v0.01 loading
    ip_conntrack_pptp version 1.9 loaded
  97. Mafste

    Mafste LI Guru Member

    Was looking at what JeFFJuH described and noticed something more alarming for myself.

    If I flash Thibor15b3 on my wrt54gv2.2 and do a clear nvram+defaults, everything runs well.

    If after that I enter clkfreq 216 however, this happens :

    CPU: BCM4712 rev 1 at 252 MHz
    Calibrating delay loop... 251.49 BogoMIPS

    Now this has been running for a couple of hours (figured 216 did it's job and left it alone , went to bed).
    Could this damage my unit ? (and if so , is there a way to find out?)

    And is dmesg reporting it correctly ?
    nvram get clkfreq shows 216

    Clearing nvram+defaults again changes it back to 200 :

    CPU: BCM4712 rev 1 at 200 MHz
    Calibrating delay loop... 199.47 BogoMIPS
  98. JeFFJuH

    JeFFJuH Network Guru Member

    @ Mafste:

    The command 'clkfreq 216' isn't the correct one.
    You should use the following commands, followed by a reboot:

    nvram set cpu_overdrive=1

    That should do it. I did the same thing yesterday, and my router reports the correct values.

    # nvram get clkfreq
    CPU: BCM4712 rev 1 at 216 MHz
    Calibrating delay loop... 215.44 BogoMIPS
    # cat /proc/cpuinfo
    system type		: Broadcom BCM947XX
    processor		: 0
    cpu model		: BCM3302 V0.7
    BogoMIPS		: 215.44
    wait instruction	: no
    microsecond timers	: yes
    tlb_entries		: 32
    extra interrupt vector	: no
    hardware watchpoint	: no
    VCED exceptions		: not available
    VCEI exceptions		: not available
    unaligned_instructions	: 2
    dcache hits		: 4278189950
    dcache misses		: 2261160
    icache hits		: 406949905
    icache misses		: 2301189445
    instructions		: 0
  99. Mafste

    Mafste LI Guru Member

    I'm using "nvram set clkfreq=216" (thought it was obvious so I didn't write it out).

    overdrive doesn't seem to be doing anything either.
    nvram set cpu_overdrive=1 + commit + reboot.
    And cpu still shows 200.
    I always do a clear nvram+factory defaults after a flash.
    something seems wrong with my firmware but everything else is working just fine ?
    Just found out my router only uses either 200 or 252 , nothing else.
    If I set a value beneath 200 it stays at 200.
    If I set a value above 200 it sticks to 252.
    It's not thibor though , Tofu has it as well.
    Can't remember if I ever looked up the cpu info on tofu , perhaps I've been running 252 for ages without knowing it ?
    If anyone could make a guess as to why my router only uses those 2 values, I'd appreciate it :)
    4.20.8 gives me 200Mhz
    dd-wrt at 216 gives me a reboot loop
    dd-wrt at 252 gives me 252Mhz (no reboot loop)
    and now back with Thibor again at 200 :)
  100. JeFFJuH

    JeFFJuH Network Guru Member

    If you've got MSN, please add me:
    Maybe I can help you out.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice