Thibor15c and PPPoE behind a stupid Sympatico router/modem.

Discussion in 'HyperWRT Firmware' started by Devileyezz, Jan 9, 2007.

  1. Devileyezz

    Devileyezz LI Guru Member


    I have a PPPoE DSL modem provided by Bell Sympatico. The stupid thing about this modem is it's a modem/router, Speedstream 6520.

    And having moved to this from a cable Internet connection, this is annoying. Because I configured thibor15c to work properly with my network, and I do not want to ditch the thibored-WRT54GL and use their stupid router/modem.

    The only problem is I have it setup just the way I would've if it was simply a modem (also checked out dslreports, and this is what most have done), and now I experience random disconnects of anywhere between 1-3 hrs.

    Does anyone know if this is the WRT54GL/thibor15c's handling of PPPoE connections, or do you think it's the stupid 6520?

    Please help.
  2. ka9yhd

    ka9yhd LI Guru Member

    Have you tried connecting a computer directly to your modem and see if you still get the random disconnects?
  3. FreshNTasty

    FreshNTasty Network Guru Member

    You could also ditch their modem and put in your own. That's what I'm doing. You'll save the monthly modem rental fee too.
  4. Devileyezz

    Devileyezz LI Guru Member

    I'm connecting an old 5200 to see if it works properly or not. It's been about 15 mins.

    I'll report back if I see an uptime of atleast 4 hrs, lol.

    FreshNTasty: Out of curiousity, where did you get a modem of your own?
  5. Devileyezz

    Devileyezz LI Guru Member

    Ok, it's safe to say that it's upto thibor15c now.
    I tried it with 5300, a non-router modem and it disconnected within 30 mins.

    So, what's the catch with thibor15c and staying connected to a PPPoE server?
  6. Thibor

    Thibor Super Moderator Staff Member Member

    there is NO catch that i am aware of, i connect using PPPoE and i stay connected for days on end, and also running bt apps 24/7 too, as well as streaming video's, using ftp and vpn connections too. you really ought to be doing what the first response suggested and connect your pc directly to the modem and see how it goes rather than just blaming the router/firmware without any direct evidence. there was an issue with pppoe on an earlier firmware due to the qos system but that is long sorted out. believe me, if there was an issue with pppoe, it really wouldn't have been 7 months before it was reported, that's just plainly naive. it's not the firmware, but that's not to say that it's not the router, or your configuration. you could try resetting to defaults, or lowering your mtu value, or even checking your microfilters and other equipment on the line.
  7. Devileyezz

    Devileyezz LI Guru Member

    Hi Thibor,

    I'm going to connect directly to 6520, and 5200 and see how it goes before I reset thibor15c to default.
  8. Devileyezz

    Devileyezz LI Guru Member

    Connected again with same setup, except NVRAM cleared and factory reset.
    So far, it's a 1hr 15mins uptime.
  9. ka9yhd

    ka9yhd LI Guru Member

    It is quite possible that something got corrupted in the router. Doing a reset should clear it out and reset to factory defaults.

    I had to do a reset, holding in the reset button for 30 sec, on a WRT54GL ver. 1.1 with the Linksys firmware. I had the router for 6 months then it started doing random disconnects. No matter what I tried the router would not reconnect. I connected a computer directly to the DSL modem and configured it for PPPoE and the computer had a connection.

    After doing a hard reset, holding in the reset button for 30 seconds, I have not had a problem with the router and it has been working fine for almost two months now.
  10. FreshNTasty

    FreshNTasty Network Guru Member

    I bought mine from a local supplier (Toronto) whom I've been doing business with for years. I think it's a D-Link but I don't have it in front of me.

    Back to the topic at hand. I actually had my first disconnect last night with the GS (Thibor 14) using PPPoE. It would not reconnect using the "Connect" button in the interface. The only message was something like "unable to obtain IP address" or some such. I thought it was my ISP but I tried connecting my PC directly, while waiting on hold, and was able to connect. I switched back to the router, power cycled it, and voila! It worked again. Fortunately, I did not have to reset to defaults.
  11. ka9yhd

    ka9yhd LI Guru Member

    Last night I decided to put Thibor 15c on my WRT54GL ver. 1.1 Everything went well upgrading from the stock Linksys firmware 4.30.2 to Thibor but for some reason it refused to connect to my ISP with PPPoE.
    The router would get the two DNS entries but no IP address, gateway, or subnet mask....... all zeros. Played with it for three hours and even went back to the Linksys firmware and same thing..... no connection.

    So I got disgusted, shut everything off and went to bed. Woke up this morning and powered up everything and the router connected up to my ISP and I have a connection with Thibor 15c on it.

    I guess the router was tired too :)
  12. Devileyezz

    Devileyezz LI Guru Member

    So, I connected with 6520 and 5200 directly, and I was fine. Had no problems.

    Reset to factory default, cleared NVRAM, and it was fine for a couple hours before it went off again.

    Reset again.
    I only did reset from the GUI of thibor15c and also the NVRAM clearing. Not a hard one. Does that make a difference?

    I might try the Tomato firmware and see how it goes.
    FreshNTasty, did you get the PPPoE modem from Canadacomputers? As I'm from Toronto too.
  13. FreshNTasty

    FreshNTasty Network Guru Member

    No. I only use Canada Computers to get quick prices from their web site. I don't buy from them as they lack customer service and a return policy (essential for the company I work for). My supplier is Kiken Computers over on the East end in the Woodbine/Steeles area. If you don't care about service, then just use Canada Computers or Logic Computer House. Both have good prices but lack service.
  14. Devileyezz

    Devileyezz LI Guru Member

    Yeah, I dunno man.. I just moved to Tomato to see if I can do this well. But it doesn't seem to be working out at all.

    Detailed new thread
  15. Thibor

    Thibor Super Moderator Staff Member Member

    i hope you get it working man, it can be quite frustrating with non-specific disconnections. dealt with it myself a while ago, turned out to be the friggin isp at the end of it. caused a LOT of messing about with configuration, erasing nvram, changing routers, etc, and all for nought as there was absolutely sweet fa i could do about it till they sorted it out eventually and then it got stable again.
  16. Devileyezz

    Devileyezz LI Guru Member

    *sigh* I'm doing everything I can. And my stupid ISP, it's hard to get anything done in the first place due to ****ty CS.

    Thanks dude.
  17. Thibor

    Thibor Super Moderator Staff Member Member

    you have my sympathies, i can't even use PPPoE anymore now, due to my isp being a dick. worked until xmas, now i have to double nat as you have to with Tomato(yes, i read your post).
  18. Devileyezz

    Devileyezz LI Guru Member

    haha, I could've done the same with thibor15c too, but for some reason I thought it's the firmware in the router. Now that I know it's not the firmware (which is pretty much the brain of the router) and I know it's not the modems either, I have no understanding as to what can be the problem.
  19. mstombs

    mstombs Network Guru Member

    In which case I wonder if I can interest you with my problem. I bought a cheap Linksys ADSL2MUE for my free ADSL connection, and have finally found a complete and working 3rd party firmware for it over at

    As you will see the only obvious faults I have with this are that the LEDs don't work correctly (Power LED always red, internet LED always off) - and that the Linksys supplied PSU is no good!

    Unfortunately the current web config software does not seem to support the half bridge PPPOA connection that I think we need - modem passes WAN IP across to the WRT54GS and just routes traffic across handling the PPPOA encapsulation and the DSL line. But with full command line access to Busybox and Iptables etc I'm sure it could be done (anything can be done with Linux right?).

    So any chance of Thibor ADSL modem?
  20. Thibor

    Thibor Super Moderator Staff Member Member

    since i don't have an adsl2mue, not much chance, although i can see a potential benefit..........maybe.
  21. ka9yhd

    ka9yhd LI Guru Member

    When I was batteling with trying to get the router to connect and when I spoke with my ISP, they suggested to connect a pc directly to the modem. When I did connect the computer to the modem and configured it for PPPoE it connected right up. So the tech at the ISP said the problem is with the router not their system........ Naturally.

    The strange part is that I powered off both the modem and the WRT54GL over night and the next morning I decided to try again, I powered up the modem and the router and when I opened the browser on my Linux computer, I was surfing the web.
  22. digitalgeek

    digitalgeek Network Guru Member

    When I ran Thibor on sympatico, I never had any problems. It was actually quite stable. I recently had a 24 hour outage, wich was reproduced when I plugged the modem directly to the XP-PC. They still didn't want to blame their service, I was check the computers config, and I was even asked to remove IE7, because it was incompatible with XP... what kind of tech support is that. "Magically" the problem went away several hours later and I was able to connect with the router with out any problems.
  23. ka9yhd

    ka9yhd LI Guru Member

    Today I decided to hook up a WRTSL54GS and guess what..... It did the same thing. No IP adress, all zeros. Same with the subnetmask and gateway, all zeros but I have the two DNS entries.

    So I hooked up the WRT54GL and it is doing the same thing..... No IP address.

    I guess this confirms, for me anyways, that it is a problem with the ISP... Covad. Also a tech from Covad on the phone told me that they only support one computer connected directly to the modem, NO third party products.

    I guess I am shopping for another ISP. Seeing that the cable companies in the area are offering 6m download speeds and DSL is only at 1.5meg...... I will be looking at cable.
  24. Rampage

    Rampage LI Guru Member

    Sorry if this has been covered, but have you tried cloning the PC's MAC address in your router?

    FWIW, I've never run across an ISP that officially "supports" routers they didn't provide. They may try to provide basic help, but when they're troubleshooting they want them out of the mix most often.
  25. ka9yhd

    ka9yhd LI Guru Member

    I have been using Covad's DSL since 2000 and I have not heard that they require a mac address to be logged. Also I have tried it with several PC's and an Apple iBook setup for PPPoE connected directly to the modem and they connect right up and I can surf the web.

    When I first started using Covad I had a Win 98 PC with their dialer application on it, then I switched to a home built router/ firewall from a spare PC with two eithernet cards in it and running a Linux router/ firewall distro.

    Any PC that I directly connect to the modem connects right up, but for some reason both Linksys routers, a WRT54GL ver. 1.1 and a WRTSL54GS ver. 1.1 do not connect. If I power off both the ADSL modem and the Linksys router for more then 2 hours then when I turn them both on again, the router will obtain an IP address and connect right up. But if I just power cycle the modem and router for anything less then 2 hours, the router will not connect.

    I am wondering if there is something on Covad's end hat needs to release and reset?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice