Thibor15c slow bandwidth from internet wrt54gl

Discussion in 'HyperWRT Firmware' started by king2000, Jan 4, 2008.

  1. king2000

    king2000 LI Guru Member

    I'm using a WRT54GL router for quite some time with hyperwrt+thibor15c on a cable connection, everything works perfectly. Recently I've upgraded the bandwidth to 100Mbps/1Mbps and when working through the router, the maximum bandwidth I achieve is 6Mbps/0.5Mbps. I've tried connecting the cable modem to the machine and it's not a problem with the cable or ISP, speeds are fine.
    I've disabled the firewall, QOS, everything I could think of still the connection is limited somehow.

    I hope someone can help me here...

    BTW, tried reverting to the original firmware from LinkSys and everything is working fast there, so it's not an issue with the WRT54GL hardware. The problem I need the hyperwrt features...

  2. Harlock

    Harlock LI Guru Member

    Same problem here, but with a WRT54G. I previously had 10MBit/1MBit but now got upgraded to 15/1.5. Upload speeds are fine but i get only between 5 and 8 downstream from my router. Speeds from the modem are fine though, so it must have something to do with the firmware of the router.
  3. RoadRanger

    RoadRanger LI Guru Member

    Ouch, sounds like the WAN port is in 10mbs mode and I don't see any obvious way to change it? Maybe an NVRAM setting? I'll check it out and get back to you.

    Take care,
  4. RoadRanger

    RoadRanger LI Guru Member

    I'm running 17RC3 on a WRTSL54GS and the WAN port is running at 100mbps as it should be according to my port tester.

    You could try this: Go to "Admisitration" and push on "Run Command" towards the bottom of the page and enter:
    nvram show | grep wan_speed

    I get back:

    If yours is different try:
    nvram set wan_speed=4

    The setting of this variable doesn't seem to do anything on my system?

    Good luck,
  5. Harlock

    Harlock LI Guru Member

    Thank you very much for your input RoadRanger. I did what you said and i get back:

    # nvram show | grep wan_speed

    size: 15419 bytes (17349 left)

    So it seems to be something different. I also thought about trying out another firmware like tomato. Not sure though. I mean. Router hardware should be ok, otherwise it wouldn't work at all, right?
  6. RoadRanger

    RoadRanger LI Guru Member

    Sounds like it is worth trying out tomato, let us know how it goes!
  7. Toxic

    Toxic Administrator Staff Member

    can you confirm you are using a CAT5 or better and the twisted pairs are working correct? it you think the port speed is low then perhaps cable is affecting the speed.

    you say you used the cablemodem to PC and it was fine, try testing the speed again with a differen cable to make sure the cables are all first of all.
  8. Harlock

    Harlock LI Guru Member

    Well, the Cables are ok and they are CAT5. Actually i have two devolo power adapters between the router and my PC, but they have over 50MBits of capacity all the time according to the monitoring software, so i doubt they are the source of the problem. It's also strange that when i had a 10MBit connection i had constantly over 10MBits of bandwidth, and now that they upgraded me to 15MBits i never get over 8MBits... But i will connect the PC directly to my router and with different cables to be able to exclude sources to the problem.
  9. Harlock

    Harlock LI Guru Member

    Ok, now i have made tests connecting my PC directly to the router. Unfortunately it seems as if the Devolo Power adapters are the problem. Although the monitoring software tells me i have 47MBit connection to the router no more than 8MBit come through to my PC. This is strange, as before the upgrade to 15MBit i alway had the full 10Mbit downstream to my PC through the Devolo power line adapters... :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice