Discussion in 'HyperWRT Firmware' started by Thibor, May 10, 2006.

  1. Linkyguy

    Linkyguy Network Guru Member


    thibber see my PM re mail last week - have you been watching too much soccer or something?
  2. Dirty04

    Dirty04 Network Guru Member

    Ok, before we put this guy "thibor" completely crazy, I suggest : One at a time...

    A schedule-option for WOL would be much appreciated. Put it on the wishlist "Thibor 15c".

    For the other guy, who flashed from 14 to 15 en WOL doesn't work, I don't know and cannot give recommendations which will solve your problem. What i did:

    - Use a third-party firmware en first gave router a factory-reset.
    - Accordingly and exactly to flash-instructions Thibor 15c, I've flashed the Thibor 15C succesfully...
    - third and last but not least, gave a factory (incl. clear NVRAM) reset again.

    then I took WOL into service.

    @Thibor: I would be pleased if you can give a reaction if "WOL-scheduling" is possible according to the date/time set, and not to much work to implement it. Thanx on forehand.
  3. 0Kool

    0Kool LI Guru Member

    Thibor 15c WOL Issue

    Thanks for the reply Dirty04.

    You're probably right, Thibor probably gets bombarded (spelling?) with requests. Hopefully, all in due time. I do like your idea with the schedule WOL only wish I would have thought of it. :grin:

    Anyways, I couldn't get the WOL to work with Thibor 15c and didn't know if this was a bug. Since it's working for you, it must be my PC.

    This is what I did

    - flashed from Thibor 14 to 15c (flash was successful)
    - shutdown PC
    - did a hard reset on the router
    - unplugged & plugged in router
    - waited for router to initialize
    - booted PC
    - cleared NVRAM
    - restored factory defaults
    - setup my own settings

    Everything else works OK. I can't figure out why the WOL doesn't work. I set my settings the same as they were with Thibor 14(where it worked). Also, I did not use the restore setting option either. I also tried flashing from stock to Thibor 15c and from Hyperwrt to Thibor 15c. The WOL just doesn't work. I guess if I can't figure it out, I'll try the previous version.

    Anyways thanks for the thoughts & sorry for the long reply. :rockon:
  4. VladTepes77

    VladTepes77 Network Guru Member

    maybe a double-post...
    MindFreak I do have the same problem, no WOL since >15 firmwares :(

    Thibor let me know if we could help you on finding the bug...

    thnx anyway for the great work!
  5. Dirty04

    Dirty04 Network Guru Member

    For All members -> WOL doesn't work

    1 - keep in mind that WOL only works on systems with a soft and quiet operation like (Standby or Hibernate). WOL won't work with a complete shutdown. the NIC has to have some power to keep listening for the raw bit, on the network / LAN.

    2 - WOL works only on systems in which network-cards (NIC) are WOL-capable.

    3 - Use static IP. In WOL those static-IP members come up. You can then "WOL" them.

    If those 2 requirements aren't met, WOL will never work with any WRT54G-firmware of course. If WOL does not work with Thibor 15C, it's more likely to have a hardware / NIC-driver or something else problem because I can only say of Thibor 15C WOL-capabilities: Nice work !

    Only the scheduling option... :)
  6. 0Kool

    0Kool LI Guru Member

    Thibor 15c WOL Issue


    What you could try for the scheduled WOL is to check your power management settings in the BIOS and enable the boot PC option, then tell the BIOS what time to have the PC boot (if your PC supports this). My buddy reminded me of this option. I think you'll also need the jumper set on the motherboard for the +5VSB (which you probably have enabled already). The only problem I see is that you'll have to be at the PC to set it up, and you'll have to be at the PC to change the scheduled time. Whereas, if it were in the firmware, you could remote to the router and set it all up. Also, you wouldn't be able to turn the PC off unless you have some other software/setup; but I guess this goes for any WOL request.


    Thanks for letting me know you have the same issue. I thought I was the only one. I wish I had more to say :(
  7. Dirty04

    Dirty04 Network Guru Member

    @Mindfreak: yes that is possible and thought of that already but the BIOS is from and A-vendor, not flashable and very little options.

    the Bios doesn't have a boot_the_PC option. If the router could be upgraded to have a schedule, than it can be booted at any scheduled given time, regardless what kind of hardware / Bios/ PC / Server etcetera....

    Without any altering etc.. only flash a thibor 15-D version with WOL-schedule :) and if that goes wrong, in worst case it'll cost me a new WRT in stead of expensive servers etc...
  8. VladTepes77

    VladTepes77 Network Guru Member

    By the the time when iamqwerty developed his WOL implementation, it was the same problem as now...for most of the people it worked perfectly, but not for me...
    after some time of testing (4-5 different versions) he managed it...
    Will have to wait, maybe it will be solved...

    For those where WOL worked just fine before v15 have nothing to do with a misconfiguration or incompatibility (except with etherwake:)
  9. Thibor

    Thibor Super Moderator Staff Member Member

    i haven't done anything with wol in 15+, except that i changed from iamqwerty's wol to busybox's etherwake in the new busybox. qwerty's wol wouldn't compile in the new busybox, and the fix he gave me didn't quite work; almost but not quite.
    For those that ask for WOL-sceduling, doing this on the command line would be very simple. adding this to the web interface; not so simple. if someone wants to add it themselves; feel free. if not, as is usually the case, i will get to it in due time, but please understand that i don't use the vast majority of the features being requested and as such, aren't the highest priority. right now i'm working on the 300N firmware and this will keep me busy for the next week or two at the least. bear with me, and i'll get to it.
  10. lwf-

    lwf- Network Guru Member

  11. dbergl

    dbergl Network Guru Member

    Scheduling WOL


    You could schedule WOL via startup script.

    Add this to your startup script and reboot the router:

    echo "00 7 * * 1-5 root /usr/bin/ether-wake xx:xx:xx:xx:xx:xx" > /tmp/cron.d/wakeserver

    This should schedule a WOL Monday thru Friday @ 07:00 for mac address xx:xx:xx:xx:xx:xx

    Just replace xx:xx:xx:xx:xx:xx with your servers mac address. You may also need to add -b between ether-wake and the mac address but when I was experimenting adding that for my particular computer was not needed.

  12. prowler1968

    prowler1968 Network Guru Member


    Correction to your post - WOL function WILL bring a machine from the power-off state IF it is a reasonably current machine that supports the Wake function. This typically has to be enabled in the BIOS for the machine to Wake from the powered-off state. From Hibernate/Standby, the operating system controls if the machine will Wake to full power-on mode.

    One situation that will be a problem is if you have an improper shutdown. If the power is removed, or the system powered-off by holding the power switch for 4 seconds, then it cannot be powered-on by the wake function.
  13. VladTepes77

    VladTepes77 Network Guru Member

    I'll have to contact iamqwerty and see what he can do for us (this small group where WOL v15> doesn't work).
    This will be next week, I'll inform you as soon as I get more input on this topic.
  14. VladTepes77

    VladTepes77 Network Guru Member

    There seems to be an error in the WOL-GUI...he will fix it as soon as possible, for those where the WOL failed in Thibor >14...
    ...just informing...
  15. MP3Stang

    MP3Stang Network Guru Member

    Re: Scheduling WOL

    Linux Newbie here could you define what the parameters "00 7 * * 1-5" are. I would like to have my script WOL my PC Mon-Fri at 8:00 AM or Mon & Tues Only. Or give my some hints and I can lookup it Google.

  16. iamqwerty

    iamqwerty Network Guru Member

    I'm currently working on a schedule wol addon to the wolgui. But meanwhile search the forum for cron script
  17. Thibor

    Thibor Super Moderator Staff Member Member

    echo "00 8 * * 1-5 root /usr/bin/ether-wake xx:xx:xx:xx:xx:xx"> /tmp/cron.d/wakeserver will execute monday-friday at 0800hrs
    echo "00 8 * * 1-2 root /usr/bin/ether-wake xx:xx:xx:xx:xx:xx" > /tmp/cron.d/wakeserver will execute monday and tuesday only at 0800hrs
    you could've just done a google search for the answers you know.
  18. MP3Stang

    MP3Stang Network Guru Member

  19. iamqwerty

    iamqwerty Network Guru Member

  20. 0Kool

    0Kool LI Guru Member

    Thibor 15c WOL Issue


    Thanks for the reply and for keeping the WOL working. It is much appreciated; I use it all the time. I'm sure I'll probably use the schedule when you get that done too (if you decide to do that).

    Also, I downloaded the .ZIP file. I'm getting getting weird error messages with WinRAR when I open it, you may want to take a look at it. It downloads OK, but errors out when I open it. I think the .ZIP file is corrupt.


    Please don't forget about iamqwerty's WOL. If you need help testing it, let me know. I'll do my best to help out.

    To All,

    Your hard work is greatly appreciated. :rockon:
  21. iamqwerty

    iamqwerty Network Guru Member

    I have uploaded it again - the MD5 checksum should be:
  22. 0Kool

    0Kool LI Guru Member

    Thibor 15c WOL Issue

    Sorry about that iamqwerty, I couldn't find this thread since the forum update. Ha ha. Anyways, I'm a big time novice on this programming and checksum stuff and try to learn on my own and from others. I tried to download this file to dabble with, and I get the same file is corrupt messages with WinRAR. Just thought I'd let you as well as others know.
  23. MP3Stang

    MP3Stang Network Guru Member

    Same here, file corrupt.
  24. VladTepes77

    VladTepes77 Network Guru Member

    the ones interested in iamqwerty's WOL fix, plz send me a PM with your e-mail to forward you the file...
  25. the_g_cat

    the_g_cat Network Guru Member

    Hi there,

    I have a weird problem with my new-installed thibor (was a tofu, cleared the nvram twice): some 'subtabs' are missing on the Setup tab, and some form entries have no title. Here a screenshot to make it a little clearer:


    Is this normal? Has something gone wrong during the upgrade?

    Anyway, found most of the usefull stuff with a little find / -name *.asp, hope I didn't miss anything. Thanks to everyone involved in this great firmware :) (although I might switch to openwrt in the future, because I may need 2 WANs, 1 DMZ, 1 LAN and the WLAN on a really seperate network with a no-cat splash...)
  26. Toxic

    Toxic Administrator Staff Member

    is your browser/antivirus blocking images/javascripts perhaps?
  27. Thibor

    Thibor Super Moderator Staff Member Member

    try setting "nvram set capfix=1; nvram commit" in a telnet window and see if it fixes your browser issue.
  28. the_g_cat

    the_g_cat Network Guru Member


    sorry for the delay before trying these hints, it's been a busy week :-/

    To make it short: the web interface doesn't like safari (standarnd mac browser). Long version: capfix was already set to one, had nothing to change, safari shouldn't be blocking anything except pop-ups, but displays this broken page I have shown you, Camino (gecko engine, same as firefox) dixplays everything correctly.

    I totally understand you can't test your web interface on every borwser/platform, so maybe a little note/advice for mac users on the download page would be nice :)

    Again, thanks for the help and this feature-rich distribution.
  29. 0Kool

    0Kool LI Guru Member

    VladTepes77 & iamqwerty,

    Sorry for taking so long. Thanks for the WOL fix. Worked like a charm. Not to be picky, but I did notice when you click on the Static DHCP & WOL options, they do not turn white like the rest. I can live with it; just thought you'd like to know. There may be more that do this, but these are the two I noticed.
  30. GhaladReam

    GhaladReam Network Guru Member

    Tiny UI Bug in Thibor15c

    I found a really tiny bug in Thibor15c. Not the kind of bug that will affect performance in any way, it's just a very cosmectic UI bug.

    On the "Basic Wireless Settings" page in the web interface, when you pull down the menu of selectable wireless channels, (1-14), channel 10's frequency days it's 2.572 GHz. If I'm not mistaken, this should be 2.457 GHz.

    Just thought I'd let you know Thibor!
  31. Morac

    Morac Network Guru Member

    I got a WRT54GL about a week ago and put Thibor 15C on it and it was working fine until today, when I had a strange issue occur.

    I usually hibernate my laptop and had done so a few hours ago. I turned it back on and noticed that it didn't automatically connect to the WRT54GL, I also noticed that my WET54G was flashing meaning it was not connected either.

    I manually connected (and my WET54G auto-connected) and I looked at the status page and all the values (uptime, stats, etc) had got reset back to 0. I looked in my computer's log to see when my laptop resumed compared to when the router reset itself. They were about the same time.

    I had an issue on my old WRT54G 1.0 starting with Thibor 9 where it would just decide to periodically drop all connections (LAN and WAN) for no reason and then re-establish them. It would usually do this a week or two after I flashed it. It was so annoying that I had reverted back to Thibor 6.2c (last one that worked without this problem). I figured this was just because I was using a WRT54G 1.0, but now I'm not so sure.

    Has anyone seen something like this?
  32. opex

    opex Guest

    Hello Thibor,
    do you have any idea about firmware upgrade for 300N date release?
  33. Thibor

    Thibor Super Moderator Staff Member Member

    try looking in this subforum
  34. in1400

    in1400 Network Guru Member

    Same as me!

    I notice the same "Bug" with my WRT54G (v3.1) with Thibor15c. This came up with Firmware Thibor15c. In formertimes I use DD-WRT which has no Problems ... in this Case.

    Are theire any planned Fixes??

    Sorry for my poor English!

  35. TLSL78

    TLSL78 Guest

    Hi, i'd the linksys WRT54GS V1 which firmware "Thibor" i could use on it ? I'm in French and i would like to optimize my WIFI between my Freebox V5 (MIMO) and my Router. Thanks for the response.
  36. Toxic

    Toxic Administrator Staff Member

    TLSL78, goto and select the WRT54GS v1-v3 download. either one will do as the links/file are the same.
  37. in1400

    in1400 Network Guru Member

    Thanks for your answers
  38. tiagoespinha

    tiagoespinha Network Guru Member

    Morac et al, could you try this and see if it fixes your problem?

    nvram set cpu_overdrive=1;nvram commit

    Run it either through "Run command" on the webserver or through SSH/Telnet.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice