Thibor16b for the WRTSL54GS Released.

Discussion in 'HyperWRT Firmware' started by Toxic, Dec 31, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    Changelog show the following fixes:

    Changes since Thibor 16a
    1. Changed behaviour in QoS.asp, the Summary table is not visible when QoS is disabled.
    2. Changed default storage popup window sizes.
    3. Fixed defaults bug in VPN page.
    4. Changed SES to Default:Disabled in Wireless_Advanced.asp.
    5. Fixed DDNS not functioning.
    6. Added DDNS update period box(1 Day,1 Week,2 Weeks,3 Weeks,4 Weeks and 30 days)
    7. Added DDNS force update control, use this wisely people as it can be considered abusive.

    Changes since Thibor 16
    1. Fixed User_Properties.asp
    2. Fixed Management.asp
    3. Fixed Small file issue in Samba removed "" tags from mtu in index.asp

    You can grab this upgrade on the Downloads Area Here: HyperWRT Thibor16b for the .WRTSL54GS
  2. Toxic

    Toxic Administrator Staff Member

    If you have any problems with the SL and 16b then reply to post.

    WRT54G/GS/GL posts in this topic will be deleted

    Please use the thread already opened. Thibor16 for the WRT54G/GS/GL will be done when Thibor is ready and not a second sooner. do not ask when though. Information on the new firmware, when ready, is posted here: Thibor 16 for the .WRT54G/GS/GL
  3. ka9yhd

    ka9yhd LI Guru Member

    I just picked up a WRTSL54GS and it is version 1.1 The serial number starts with CJK11

    It came with Firmware 2.00.5 and I put 2.06.0 on it from Linksys. Later on I'll put Thibor 16B on it.
  4. Toxic

    Toxic Administrator Staff Member

    or wait for 16c :)
  5. phinn

    phinn Network Guru Member

    Hey dunno if this is the right thread to ask but does anyone have a full feature list for this sweet firmware?

    I'm patiently waiting for 16 to come out for the 54G but now I'm starting to think about buying this router as it looks damn nice.

    Is this router capable of doing say, plugging in a 1GB flash drive and using the router as an FTP server so you can grab files from it anywhere without needing a box running? Or maybe even say SSHing into it and running IRC?

  6. frenchy2k1

    frenchy2k1 LI Guru Member

    yes, the sl can run as an ftp server. You can also ssh into it.
    Not sure if you can run IRC on it, but I guess you could.

    1GB flash drive would work fine although as I had a HDD lying around, mine has a 60GB USB drive on it.

    The SL is really sweet I must say.

    Toxic, you were talking about 16c. What bug are outstanding in 16b and what feature would be added? I'm quite lazy and I got stuck on 15b for that reason. I would prefer to flash directly to the greatest ;) If 16c is close with more fixes (DDNS is what I miss on 15b and why I was looking forward to 16b) or features, I could wait more.
  7. Thibor

    Thibor Super Moderator Staff Member Member

    16c(or 17rc1, haven't made my mind up yet) has only fixes in it. UPnP igd is fully working now, and i've changed ddns behaviour, and a few web page code changes, nothing major from 16b
  8. frenchy2k1

    frenchy2k1 LI Guru Member

    Thanks for the update Thibor.
    I guess I'll be waiting for the next one with the new, improved, DDNS ;)

    Thanks again for all your great work. Without you, those routers wouldn't be as useful.
  9. Thibor

    Thibor Super Moderator Staff Member Member

    who said anything about improved ddns? i simply said i'd changed it's behavioiur, and that is to run the update check when the wan_done() is called instead of just running ddns.
  10. K1nslayer

    K1nslayer LI Guru Member

    Slow HD access in Thibor16B ...

    Hello, I'm hoping that someone here can be of assistance.

    Here is my current setup ->
    (Gateway) Buffalo WHR-G54S running the latest Tomato and setup as a DHCP Access Point
    (Console_Bridge) Buffalo WHR-G54S running the latest Tomato and setup as a wireless bridge to the (Gateway).
    (Office_Bridge) Linksys WRTSL54GS running Thibor16B and setup as another wireless bridge to the (Gateway), this has a 500GB NAS drive formatted with NTFS.

    Previously the WRTSL54GS was setup as the gateway with the two buffalo routers acting as the bridges from the other parts of the house. However I was having the large file problem with the NAS drive. (Basically, it was not possible to copy files over 2MB to the NAS drive) I upgraded the WRTSL54GS to Thibor16B because it has some fixes for this (and is generally sweet all around). In the process I switched one of the Buffalo's to act as the gateway. (This way I can easily upgrade/poke at the WRTSL54GS with a direct connection)

    Now I can no longer stream files to my entertainment center, and reading writing to the drive is MUCH slower. So I wondering if the fixes for the large file problem involve slowing down the drive access? Or is it just that now the media files have to make two wireless jumps to get to the (Console_bridge)? The drive really seems like it’s using USB 1.0 instead of 2.0. This was not the case when I had Linksys firmware installed. Of course I could only read from the drive.

    Any suggestions? I have also considered converting the filesystem to something other than NTFS, but thats kind of a pain given that I only have windows boxes in the house.

    Thanks in advance.
  11. phinn

    phinn Network Guru Member

    How do i login to the telnet server? I just admin as my login name and my password but it's not working.
  12. K1nslayer

    K1nslayer LI Guru Member

    Thibor16B USB 1.0 or 2.0? - and ACK Problem, Help Please

    I found part of my problem with extreamly slow access to the HD on my WRTSL54GS. I have to turn off ACK on the Wireless QOS page or the throuput on the router tanks. This is from the external USB HD, or any PC hooked to the ethernet ports. Anyone got any ideas why that is?

    Also I am still only getting ~1.5MB/s from the drive not the ~60MB/s I should be getting.

    See my other post in this thread for my set up

  13. BanditRider

    BanditRider Network Guru Member

    phinn, telnet login is root.

    K1nslayer, Why do you think you should be getting 60MBytes/s over a 54Mbit/sec wireless connection?
  14. penkert

    penkert Network Guru Member

    Thibor, if you have the time, would it be possible to include a "force PPPoE reconnect at a given time once a day" feature into your firmware? This would be extremely helpful for people running VoIP services while using an ISP that resets their PPPoE connection every 24 hours. Right now, every time a DSL connection drops in the middle of the day (for whatever reason) every PPPoE reset thereafter happens pretty much exactly at that time a day as well, potentially terminating phonecalls. A forced reset at say 3 o'clock at night would solve that problem.
    Thanks for your great work, no matter if you do this or not!
  15. K1nslayer

    K1nslayer LI Guru Member

  16. Toxic

    Toxic Administrator Staff Member

    how are yout transfering the data for benchmark tests? The Media Server or using an ftp Client?
  17. mstombs

    mstombs Network Guru Member

    What Linksys source is Thibor 16b based on?

    Just noticed that 2.07.0 posted on 12 Jan 2007
  18. Thibor

    Thibor Super Moderator Staff Member Member

    goddammit, didn't notice. i'm downloading it now and i'll take a look at it for changes.
  19. ka9yhd

    ka9yhd LI Guru Member

    OK where do you see 2.07.0? I only see 2.06.0 on the US download site.
  20. K1nslayer

    K1nslayer LI Guru Member

    GPL Code Center

    2.07.0 is up in the "GPL Code Center"
    Home »Support » Technical Support » GPL Code Center

    Toxic - I was using Robocopy to move large files (>700MB) to/from the USB HD. My PC is directly connected to the router via 100Ethernet .

  21. ka9yhd

    ka9yhd LI Guru Member

    Thank you :)
  22. hansen

    hansen Guest

    Where is the source for Thibor16b for the WRTSL54GS Released posted ??
  23. mstombs

    mstombs Network Guru Member

    Thibor packages up and posts the software via his website when a release is stable. As we can see he is still working on 16c (or 17) I wouldn't expect to see this one.
  24. Turbe

    Turbe LI Guru Member

    I may be wrong, but version 16 (16, a or b) is not on his website. Current versions and info is here on
  25. ka9yhd

    ka9yhd LI Guru Member

    Thibor has a lot of things going on there. When he has some free time it will get updated.
  26. TheHUTMan

    TheHUTMan LI Guru Member

    DynDNS won't disable

    One minor bug I found. I enabled DynDNS for some testing purposes, and when done, tried to disable it from the web GUI (as I really don't need it on for now). However, once selected to DISABLE, I couldn't save the page, thus it never disabled. I tried this in Firefox and in IE7 on my PC. I ended up disabling it via nvram settings through ssh, so not a biggie.

    As a side note, I just got a new WRTSL54GS, and loaded this latest firmware up on it. Greatest thing since sliced bread :biggrin: Given that my previous router was a D-Link 624 with major reboot issues, I love this one. Very stable!

    One minor request -- any chance of getting OpenVPN in this? I find it much better and easier to use than PPTP or even Ipsec. Main reason is it's very NAT friendly.
  27. Thibor

    Thibor Super Moderator Staff Member Member

    there's a 50/50 chance of it. you write it, i'll put it in. i'll check ddns, but last time i tried to disable it, it worked just fine. what service was selected when you tried to disable it?
  28. setaylor

    setaylor Network Guru Member

    Also can't disable DDNS

    I also cannot disable DDNS (I use I made the changes you noted to get rid of the potential abuse, but if I try to save after switching from to Disable I get an "error on page" message in IE, and nothing saves.
  29. Thibor

    Thibor Super Moderator Staff Member Member

    i now use dyndns, due to having to test this stuff, and it's testing here fine in firefox, i'll check ie7 now.

    works fine here using firefox, ie7 and konqueror.don't really know what to suggest. if i can't see a bug, i can't fix it.
    you could always try 17rc1 from my website, it may help
  30. TheHUTMan

    TheHUTMan LI Guru Member

    I understand the debugging issue and needing it to be able to reproduce it. I'll give as much detail as I can. Just tried this again, selecting to enable ddns (using the DynDNS site, no mail exchange selected, all other settings entered). Saved OK. Then selected to "DISABLE", and SAVE -- nothing.

    I enabled FireBug (plugin for Firefox), and found an error occurs when I click the save button:

    apply.cgi (line 87) : F._ddns_force has no properties

    related to code block:

    function to_submit(F)
     if(ddns_check(F,"save") == true) {
       F.ddns_force.value = F._ddns_force.checked ? '1' : '0';   /// ERROR LINE
       F.submit_button.value = "DDNS";
       F.action.value = "Apply";
    One oddity I see in the HTML for DDNS.asp, line 435:

    <td width="296" height="25""><input type="checkbox" value="1" name="_ddns_force" >
    There appears to be an extra quote mark on the height parameter, maybe this is confusing the creation of the _ddns_force element.

    Hope this can help you track it down. I'll have to wait for v17 until the wife is done using the internet :wink:
  31. Thibor

    Thibor Super Moderator Staff Member Member

    sorry, i'm using a newer version that doesn't use a checkbox for forcing an update.
    new version uses a standard button.
  32. bkmo

    bkmo LI Guru Member

    I cannot disable it running 16b on my router either.
  33. drewser

    drewser LI Guru Member

    Wow, this firmware is great Thibor! Thanks.

    What UPnP client software would you recommend for use on the WRTSL54GS?
  34. Thibor

    Thibor Super Moderator Staff Member Member

    er, i just use windows for UPnP control
  35. drewser

    drewser LI Guru Member

    Ok, I'll just use the one I'm currently using.

    I'm having trouble getting the UPnP Media Server enabled. It's enabled under the Applications & Gaming -> UPnP tab, but in the Storage -> Media Server tab everytime I select "enable" and try to save, it gets to the "click continue" page, but it kills the connection between the computer and router and nothing is really saved.
  36. Thibor

    Thibor Super Moderator Staff Member Member

    let me check mine drew. i'll get back to you.
    drew: there is no problem with the Media Server. perhaps you are confusing UPnP with the functions of the Media Server. UPnP is the Internet Gateway Device that you see in Windows network places, and opens/closes ports controlled by applications.
    the media server serves photos, videos and music to upnp aware clients on the network.
  37. drewser

    drewser LI Guru Member

    Hmmmm, Ok. So then I am able to enable the UPnP for the internet gateway (I can see the hard drives in my workgroup shared correctly), but I can't enable the media server. Can I only run one service and not both?
  38. Thibor

    Thibor Super Moderator Staff Member Member

    you are able to run them both, i do. but the media server will not start if there is not a share available on the SL
  39. drewser

    drewser LI Guru Member

    I think perhaps it isn't displaying properly in 17rc2. When I roll back to 16b, the enable is selected. It must have gotten the settings from the seemingly failed attempts in 17rc2.
  40. Thibor

    Thibor Super Moderator Staff Member Member

    it is running whilst showing disabled within the web interface. i'm looking into it now
  41. Thibor

    Thibor Super Moderator Staff Member Member

    there was an extra "checked" within the MediaServer.asp page. it only affected the web interface and not the functionality. due to the trivial nature of this tiny bug, i'll release it with rc3, but not immediately unless there is some requirement.
  42. Kamilion

    Kamilion Network Guru Member

    Since this seems to be the most active thread on the SL, I've been wondering something -- has anyone upgraded from a WRT54G/GS to an SL and had a immense drop in range? I'm thinking this has a lot to do with the SL's pitiful antenna... If so, I'll have to pick up a GL to boost the wireless, because I'm not giving up my SL... it's been the most stable router I've ever had since I've thrown thibor's firmware on it, with the exception of the full linux box that was replaced by my original WRT54G. Linksys really should have stuck with the removable antenna design. Also, does anyone have any recommendations on an inexpensive antenna to purchase for my GL? I'm aware of a bunch of neat designs like cantennas and woktennas, but I'm looking for something inexpensive, off the shelf, and preferably omnidirectional. Inexpensive being under the price of a WRT ;)

    Thanks, all. And thanks to Thibor's continued work :D
  43. drewser

    drewser LI Guru Member

    Is there a way to remove the login requirement for shared usb drives connected to the WRTSL54GS? Right now the best I can do is when selecting the machine I must enter "guest" with no password. I'd like to be able skip that all together.
  44. Thibor

    Thibor Super Moderator Staff Member Member

    no, there is no way to do that
  45. mcaslan

    mcaslan Network Guru Member

    WRTSL54GS running HyperWRT and Thibor fails to aquire DHCP

    I have been running the lastest versions on WRTSL54GS for ages - almost a year. I have noticed that after a while the router reboots on it's own as if it crashes. It's not routing traffic and when I browse to it the router crashes and when it reboots it usually works, a few times it's set at defaults and I have to reconfigure it.

    This time the router boots and appears to be partially running. It has the default IP address, I can flash it using TFTP with the firmware or the current Linksys Firmware, but when it boots the Power Light flashes and the USB light remains solid.

    Reading all the notes I now have loads to try but what would you think have caused the router to partially boot, almost as some scripts are running but others are not?

    I can't browse or telnet to the device so is there a way to access it other than the Serial port?

    What's the sequesnce of ways to try and access it and in what order?

  46. Toxic

    Toxic Administrator Staff Member

    if its dead, then try this.

    set pc ip to gateway

    have readly TFTP with binary file ready to sent to router. power off router, then back on. as soon as the power is restored (or just before) send firmware binary using tftp. if Boot wait is ON then it should take the firmware. once it confirms it has sent leave it alone for about 5 minutes. try then pressing the reset button for 30 seconds. leave again to reset/reboot. and reset LAN ip for automatic to see if it now works. I have bricked my SL a number of times in the past but this always works with me. For all, firmware Thibor17 RC3 for the SL is the latest.
  47. Jmystikcfl

    Jmystikcfl LI Guru Member

    Having a problem with my SL54GS. About 2/3 of the time when I enable the media server it totally crashes the router. Doesn't seem to be any rhyme or reason, but the only way to correct the problem and restore connectivity is to power cycle the router. The USB hard drive shuts down and everything. And on those occasions when it shows that it's enabled and I can get a share into the list, it doesn't scan it. It'll say that it's successfully updated the database, but it does so pretty much instantly. I'm using 17rc3 BTW. Any help at all would be great appreciated.
  48. RoadRanger

    RoadRanger LI Guru Member

    Does it do this on a particular usb drive or does any attached drive have a problem? I'm running the Media Server with an NTFS formatted 40Gb drive and it seems rock solid. I did have some problems with it crashing when changing settings sometimes but once I got it set up it's been fine. I think I had the best results from disconnecting the drive, factory reset & NVRAM erase, setting everything, saving changes, then connecting the drive and "scanning" it.
  49. tstrike2000

    tstrike2000 Network Guru Member

    I was curious if anyone had a copy of Thibor16b for the SL54GS for testing purposes I could download? It's not available on here or any of the mirrors.
  50. RoadRanger

    RoadRanger LI Guru Member

    We seem to be missing all of the "16" builds for all platforms and have only the bin (but not the source) of 17RC3 for the SL here:
  51. Toxic

    Toxic Administrator Staff Member


    if you have read any of my comments within the HyperWRT Thread I have asked Thibor to supply me with the 17RC3 src. If you cannot be patient enough then what I propose to do is remove the firmware downloads altogether , since you are wanting the source code. and this violates GPL Licencing.

    I suggest if YOU want the code or firmwares then go ask for them from thibor. he does not have to give you anything however if he is done with the compilation of firmware builds for the 3rd party firmware for the WRT54G series..

    I had supplied a mirror for users as a curtious service but since the constant moaning by users of not getting "this or that" then I may remove it altogether since it looks like HyperWRT is no longer a ongoing build.

    Man..... you try to help people but it never works!
  52. RoadRanger

    RoadRanger LI Guru Member

    Jeez guy, don't have a cow!
    Most folks don't go reading through every message in the forum before asking a question. guess you didn't read his previous post? I too didn't realize that guy looking for a "16" build had a problem with 17RC3 - you can go list all his postings and he posted about it in his previous post back in September. Guess he assumed the same as we did about everyone reading and remembering every post here.
    Anyways an interesting bug he found, maybe in the newer Linksys "stock" firmware that "infected" 17RC3? Anyways I think I found Thibor's email addy - but if possible/ethical could you toss the one you have my way? I'll see if I can get'r'done...

    Take care,
  53. RoadRanger

    RoadRanger LI Guru Member

    Thibor lives!

    I just confirmed the existance of the previously mythical "Thibor". Unfortunately the source for 17RC3 is still missing after a couple weeks of him searching for it.
    But the changes between that and RC2 are fairly minor and the source for RC2 is rumored to be on its way. I also requested the source/bin for the "16" releases as somebody here wanted to try "16".
  54. RoadRanger

    RoadRanger LI Guru Member

    I now have the source for 17RC2 :) .

    Thibor is restoring a backup tape that might have all the other missing stuff, should know tomorrow.

    tstrike2000, I'll try to get that 16B for you.

    Take care,
  55. Toxic

    Toxic Administrator Staff Member

    I do have 16b for the SL but no source code.
  56. RoadRanger

    RoadRanger LI Guru Member

    16B still M.I.A. but Toxic found me 16C which I'm running right now. PM me if you want it. It is based on Linksys's latest release, 2.06 . Thibor 17RC3 is based on the unreleased 2.07 .

    Rumor has it that you can beg 2.07.2 out of Linksys if you can get to level 2 support and say you're running Vista. Please PM me if you have it!

  57. plugh

    plugh Network Guru Member

    I have


    (sorry no 16's)

    Even got a copy of Thibor's old home page.

    Also have some tofu and grcore stuff,
    various Linksys SL binaries and sources,
    and other odds and ends.

    What ya need?
  58. tstrike2000

    tstrike2000 Network Guru Member

    Thanks for the offering. I was able to get SL_16C from a link from Road Ranger and I believe Toxic was able to get. I was just curious of anyone still had a copy as I didn't realize it would cause a little bit of a stir. If it wasn't readily available from anyone I wasn't going to worry about it as it was just an idea I had. I've still had some problems with 17RC3 trying to copy large amounts of files over to my 160GB external IDE HD that's in a USB enclosure. It still crashes the drive either copying files larger than 1GB or more than a few Gig's of data. Wasn't sure if anyone's had success with it or just use the USB for music files or just a few other files with 17RC3 or a previous release.
  59. RoadRanger

    RoadRanger LI Guru Member

    I may have spoken too soon, I now can't get Media Server to work with a large number of files. I also had your problem where the scan happens way too fast and I took the drive over to my PC and found it had corruption that chkdsk was able to fix. That got the scanning working again but I now wonder if I ever saw the Media Server working correctly with my 15gb of music files. I have even seen enabling the Media Server resetting me to factory defaults. I have tried "stock" firmwares and Thibor 17RC3 and 16C and it seems to behave the same. I fired up a Media Server on my PC (TVersity) and am able to serve the 15gb of files off of the share OK. I suspect there is an error log buried in the box somewhere, I'll be looking for it next.
  60. plugh

    plugh Network Guru Member

    You don't mention what filesystem you are using...

    I don't use my SL for media serving any more, but I used FAT32 for quite a while with no problems (once the SL's FAT filesystem issues were fixed).

    The NTFS support is from a third party; don't know how well it works.
  61. tstrike2000

    tstrike2000 Network Guru Member

    I've tried formatting the USB drive as both FAT32 and NTFS. I'm copying to it from a Windows XP NTFS machine. It appears to have the same results either way. Did you have a different setup than this or copy a file that was larger than 700MB and get it working?
  62. microcao

    microcao Networkin' Nut Member

    i cant download it

    i cant download it
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice