Thibor's HyperWRT WRT54GS 4.70.6-191005 Released

Discussion in 'HyperWRT Firmware' started by Toxic, Oct 19, 2005.

  1. Toxic

    Toxic Administrator Staff Member

    Changes in 191005:
    - telnetd enable/disable in Management.asp
    - Added Active Client List to Lan Status page
    - Added More Encryption Detail to Wireless status page
    - Fixed selpwr bug present in IE
    - Fixed Wireless Indicator not showing in ActiveClientList.asp
    - Fixed Wireless Access Web killing httpd
    - Changed backup file name(MODEL_NAME, CYBERTAN_VERSION, MINOR_VERSION)

    Changes in 161005:
    - Added compile_date to Version in top right corner of gui
    - Added Rate,Tx Power and Wireless Mode to Status_Wireless.asp
    - Numerous web code changes and alignments.
    - Integrated Tofu's 6.2 changes:
    Changes in tofu 6.2
    - Fixed: cron jobs may run more that they should.
    - Fixed: When using Deny in Access Restriction, DNS port was always blocked.
    - Fixed: "iptables -vL" results in SIGSEGV.
    - Fixed: Transmit power wasn't saved if it wasn't set manually.
    - Other entries in the hosts file are now preserved.
    - The entire hostname field is now shown in the DHCP client list.
    - The Active DHCP Table button at the bottom of the Static
    - DHCP page has been replaced by a new Active Client List.
    - The content is a mixture of the ARP table, DHCP table, and wl assoclist.
  2. picopir8

    picopir8 Network Guru Member

    Does this version have Kai? I downloaded the 161005 version and it did not appear to have Kai so I reverted back to the previous release.
  3. Thibor

    Thibor Super Moderator Staff Member Member

    it does indeed have kai, you have to enable it in Management.asp first and then reboot
  4. Toxic

    Toxic Administrator Staff Member

    updated to 191005 now...
  5. lollol

    lollol Network Guru Member

    i've flashed an it look's very good :)

    Uptime 4h with many traffic over wlan/lan to wan.
    -> no performance problems

  6. picopir8

    picopir8 Network Guru Member

    Oops forgot about that, reloaded the newest version and its running great. Both normal router usage and kai are up and running.

    Not to hijack the thread but when I run the kai it works great but the kai control pad from does not recognize that kai is running. Has anyone tried this. Does this script only work with the teamxlink firmware or should it work with any firmware with kai?
  7. Thibor

    Thibor Super Moderator Staff Member Member

    i've not seen the script, but if it has a telnet password...comment that part out. Hyperwrt doesn't use a password for telnet
  8. itsmeohmy

    itsmeohmy Network Guru Member

    Were should i download 191005? Cant find it anywere :( ...
  9. Toxic

    Toxic Administrator Staff Member

  10. Kamui1407

    Kamui1407 Network Guru Member

    I have a pb with this firmware my XP VPN work in LAN but when I try to connect in exteriour I get error 721 , can someone help me ??

    Thx :thumb:
  11. lollol

    lollol Network Guru Member

    Connection Uptime : 0 days, 13:30:39

    i have this in my startup-script:

    /bin/sleep 30
    /bin/echo "15 3 * * * root /usr/bin/killall pppoecd" >/tmp/cron.d/dslreconnect
    But in the morning-hours i see this in the status page: Connection Uptime : 0 days, 13:30:39

    -> the Keep Alive : Redial Period is set to 60 Sec.

    The cron-entry is not processed at 03:15 am and also the pppoecd connection was not reconnected.

    I tested this startup-script entry with the same result:
    /bin/sleep 60
    /bin/echo "15 3 * * * root /usr/bin/killall pppoecd" >/etc/cron.d/dslreconnect
    I've checked the "/etc/cron.d/dslreconnect" and "/tmp/cron.d/dslreconnect" entrys - correctly. :jester:

  12. flammekueche

    flammekueche Guest

  13. evorice

    evorice Network Guru Member

    anyone having problem downloading bittorrent file with this latest firmware?

    When I download 4+ files at one time it would prevent IE and Firefox from browsing the net. If I stop all the bittorrent files IE and Firefox would work again.

    I did a Hard reset on the router after flashing the firmware.
  14. m33p

    m33p Network Guru Member

    what is kia?
  15. picopir8

    picopir8 Network Guru Member

    Kai is a tunneling app. It sets up a virtual network over the internet so you can play console games online. The consoles think they are on a local network and you can play most console games online without having to pay for services like xbox live. See for more information.
  16. Dwibbly

    Dwibbly Network Guru Member

    New firmware


    I've updated to the new firmware, when downloading using Bit Comet it slows down the web brousing more than before but the Bit Comet downloads are coming down strong.

    Emule is now getting a low ID, not sure why, it was high before.

    It's fine now, odd!!
  17. Dwibbly

    Dwibbly Network Guru Member


    Hi me again.

    Any help docs on kismet.

    How to transfer the files across and how to use.

    I managed to Telnet using putty, I type hel to get commands but lists nothing, telnetd option is enable in hyperwrt.

    Anyone??, just a good link or a step through to get the files across would be fantastic.

  18. g0gie

    g0gie Network Guru Member

    I've flashed and verified that I am using this version of Thibor's firmware and it wokrs great, but one problem- for the life of me i CANT find the static DHCP menu or options. PLEASE HELP ME !!!!
  19. Thibor

    Thibor Super Moderator Staff Member Member

    when you enter the ip address of the router and get the index.asp page, look at the far right tab that says "Static DHCP" and then click it
  20. gaster

    gaster Network Guru Member

    Would this work for a WRT54Gv4 that is supposed to be the same as a GS?
  21. gaster

    gaster Network Guru Member

    I am impatient and decided to go for it. It works, but there were some glitches at first. I was running DD-wrt but wanted to give this a shot. After the flash and changing the default password it got flaky. It would not accept my new password except maybe every once in a while and it asked for it every click I made. I know I was typing it correctly, but it just wouldn't take and wouldn't remember itself even though I checked that box.
    I had to reset by the button on the back twice and now it seems better. Of course now I'm locked to this firmware, it won't flash to anything else, even DD-wrt mini and I tried many versions. It won't flash to Tofu 6.2 either.
    Oh well, it seems like a good firmware and has many extra features I didn't have before like speedbooster, or I think it does. Not bad for a router that will be $39 after $30 in rebates, well that is if I get them.
    The GS ones on the shelf next to this were listed at $79.
  22. Dwibbly

    Dwibbly Network Guru Member

    Flashing problems


    Have you tried rebooting both your PC and the router?
    Both my brouser and my PC has given me problems before, a system reboot usually helped me. Or try a different brouser, worth a try maybe. If you are updating firmware, always hold in the reset button for 10/20 secs to clear settings to default, then flash to avoid problems. I hope some of this helps!!

    I had a problem with my ADSL2MUE modem, it wouldn't take the password, I reset it, still a no go, so I disconnected the telephone line then reset, worked.

    HyperWRT is a nice firmware, and the guys updating it care about making it work to it's best.

    Does any of the experts out there know anything about Kismet??
    I need a little help. Any info you have please post in here-

    Thanks guys.
  23. itsmeohmy

    itsmeohmy Network Guru Member

    Im sorry, but why in hell cant i flash another firmware?! Hyperwrt says the flash was all right but when restarted its STILL hyperwrt 191005 in my box! What should i do :cry: ?
  24. larciel

    larciel Network Guru Member

    how did u flash thibor's fw ? i tried to flash it but i got the 'upgrade are failed' error, so i tried the tftp.exe and it gives me wrong pattern error.

  25. ecolive

    ecolive Network Guru Member

    Good policy to flash a new firmware

    Try the hardware reset button BEFORE and AFTER a new flash.
    Just use a pin and hold the reset button located in the rear or the router for 30 seconds. Flash the firmware. Reset the router again.
    It should bring the router to the defaults to the firmware just flashed.

  26. Dwibbly

    Dwibbly Network Guru Member

    Flash failures


    As he said always hold in the reset button at the back of the router before and after updating then put your settings in. If you fail to do so your then it may fail and cause major problems, like turning your router in to a big piece of blue plastic with no use but to use as a door stop.

    I prefer my WRT to work, so I always reset before and after, plus never use the config back up util between different firmware versions as data can get damaged.

    Good luck guys.
  27. itsmeohmy

    itsmeohmy Network Guru Member

    Well i did that. And it works pretty good overall. But i can still not change firmware. Am i the only one with this problem or is it a bug in the firmware itself?
  28. Thibor

    Thibor Super Moderator Staff Member Member

    there is no upgrade bug in the firmware itself. if you flash v4.x firmware on your router you can NOT downgrade to ver 3 via the web interface. it has to be done via tftp. if you have a G router, you have to use the g version and the same applies to the gs, unless you have cross flashed it(ie, GS firmware on a G router)
  29. Maugus

    Maugus Network Guru Member

    Hey Thibor, could you please incluse L7Filter to hyperwrt ?
  30. Thibor

    Thibor Super Moderator Staff Member Member

    @maugus: no
  31. itsmeohmy

    itsmeohmy Network Guru Member

    thanks! i will check out that tftp later.
  32. taichi

    taichi Network Guru Member

    weird problem.. I just reset my router, flash with the new Thibor firmware and reset the router again..

    The problem i have is that im unable to download some bt files.. (I haven't tried other files from some website)
    such as (im unable to download any of those files but i asked a friend to test those links and they are up)

    does anyone know why im not able to download the files?

    i turned off windows xp firewall but i never changed any security setting on the router..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice