Think i've killed my WAG354G-UK

Discussion in 'Other Linksys Equipment' started by AdamR100, Jan 8, 2006.

  1. AdamR100

    AdamR100 Network Guru Member

    Hi all,

    Had my wag354g for a month or so, all ok. Recently been having issues with ftp, very poor performance, under 1KB/s.

    Thought I would see if there was a firmware for it, it was running .03

    Checked the linksys site, and .05 was there, so i downloaded and upgraded via web interface. It said it was succesful, but the light on the router went red and connectivity stopped.

    I waited a little while, and then powered it off and on.

    flashes green (boot process?) and then goes solid red, and cannot be pinged/http'd.

    I tried putting my nic in 10mbit half duplex, and holding reset for a 30 seconds (and more), from power on and also after booting. No ping response at all. I have set a static ip of

    I've emailed linksys support but no reply as yet (it;s sunday so...)

    I'm hoping someone here can tell me about some other way to reset to defaults (if possible).

    Sorry my first post is a question, I hope I can help others in the future :)

    Found the site via google btw.

    p.s. I noticed there seems to be different versions, I did not know this till just now. I am in the UK and using analog ADSL. The box has ADSL2+ all over it, printed not stickered.
  2. AdamR100

    AdamR100 Network Guru Member

    also, i checked this morning, and the firmware version has dissapeared from the site, so i'm thinking the worst :(
  3. FriedEggs

    FriedEggs Guest

    It should be not 1.10

    I expect it will have forgotten your adsl settings when you updated, so if you can get through (via a network cable, maybe) you'll need to put them all in again, set to PPoA and so on.

    Other people have upgraded to the new firmware OK, I believe.
  4. AdamR100

    AdamR100 Network Guru Member

    Hi, I tried using .1 aswell, no luck. Am not worried about adsl connectivity atm, more wireless on my network, have cables everywhere atm!

    Are linksys OK with regards to replacing routers gone wrong?
  5. Gandyman

    Gandyman Guest

    Normally yes.

    Only in the Netherlands the dutch RMA is very slow, and wen you get an englisch helpdesk they send you within a week a new Router. :eek:

    dont understand it but its experiance what I have with them,.....

  6. AdamR100

    AdamR100 Network Guru Member

    Surely if I use .1 then it would be the same as the router (I get an error message if i try to use it).
  7. AdamR100

    AdamR100 Network Guru Member

    hmm, seems i can tftp to it and flash with same firmware:


    I'm now guessing i need a UK one?

    Does anyone have the correct file? or perhaps and older version I can try?

  8. booly

    booly Network Guru Member

    I've flash a device with this version the weekend, no problem
  9. AdamR100

    AdamR100 Network Guru Member

    yes but you are EU, im UK :)
  10. JayDub

    JayDub Network Guru Member


    That's the correct version. I've upgraded my WAG354G with it and had no problems.

    I'd have a go at reinstalling it if I were you.
  11. AdamR100

    AdamR100 Network Guru Member

    I would if i could. I need to original firmware though.
  12. icest0rm

    icest0rm Network Guru Member

    now UK is anymore on EU? 8O
  13. AdamR100

    AdamR100 Network Guru Member

    I flashed my router with:


    but my router is


  14. JayDub

    JayDub Network Guru Member


    This is the right firmware for your router.

    Its the firmware you download from the UK site and I can assure you it works on the WAG354G-UK.
  15. AdamR100

    AdamR100 Network Guru Member

    well clearly not, as my router no longer works after installing it.
  16. AdamR100

    AdamR100 Network Guru Member

    Also why would linksys of removed it from the site altogether, and their ftp?
  17. itsmeohmy

    itsmeohmy Network Guru Member

    Well I flashed mine with that exact file and it still works fine. It hasn't dissappeared from the UK Linksys download site.

    Somehow you screwed up your firmware flash or you have have a faulty router.
  18. AdamR100

    AdamR100 Network Guru Member

    either way, if anyone has the original firmware, please can they let me know :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice