Think I've loaded wrong firmware

Discussion in 'Linksys Official Firmware' started by janjoker, Aug 12, 2006.

  1. janjoker

    janjoker LI Guru Member

    I have a WRT54G ver 2, and lately I have downloaded and installed new firmware. Now it is on firmware version 4.30.5 and the webpages are showing it is a WRT54GL.
    It is working properly and all settings are okay. But I am not feeling comfortable with it. Can I simply load the correct firmware without getting into troubles?

    I am planning to add a WAP54G as repeater in the network, so it might be wise to load the proper firmware.

    Any comments or hints are welcome.
  2. Toxic

    Toxic Administrator Staff Member

    its only the router name.

    if you dont want the WRT54GL name the change it. logon to the router and change the Router name

    however your WRT54G is a L version L stands for Linux. your Router runs on it.

    linksys amalgamated all the Linux router firmwares.

    WRT54G v1-4 and the GL use the same firmware.
  3. janjoker

    janjoker LI Guru Member


    I'll stop laying awake over it.
  4. Bruck

    Bruck LI Guru Member

    Same issue

    I did the same as you, but my router firmware doesn't seem perfect.

    I too was suprised when the display in the top right corner (not the name of the router) says WRT54GL, i think this is a mistake on linksys's fault, i realize you're saving time but it may make people worry when a firmware upgrade changes the model name of their router.

    I have 2 issues though. I did the firmware upgrade for a few reasons, of which it solved none of them, but it did manage to remove half of the management options.

    On the basic setup screen i have 1 not five options across the submenu on the top. I know other options should be there because i have a brand new version of the router in the other room, and its a much more robust firmware.

    I tried loading it twice, still hasn't fixed it.

    Anyone experience this?
  5. jchuit

    jchuit Network Guru Member

    To Bruck

    This is a bug in the 4.30.5 firmware, some internet browsers (not Internet Explorer) are not able to handle this faulty java script.

    The Tarifa firmware has solved this.

    And about the WRT54GL name in the right upper corner: this can be changed in the 4.30.5 firmware and above, by changing the Router Name at the first page.

  6. slepert

    slepert Guest

    I have a Linksys WRT54G Ver 2, I upgraded to firmware V4.30.5. I have 2 win xp computers and they both pick up an ip address, subnet mask, and default gateway However, only one of the computers at a time will reconize the dns servers and that is the computer that connects first. If I turn off the computers and unplug the router for a minute and plug it back in and start up the other computer, it connects and browses fine, but the other will not resolve domain names. Anyone have a guess as to why? When I do a nslookup at the dos prompt, it says: "Can't find server name for address Timed out
    DSN request timed out. Timeout was 2 seconds. It then repeats that for the other DNS server and then it says: Default server unknown.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice