Toastman Releases - up to 1.28.7492

Discussion in 'Tomato Firmware' started by jsmiddleton4, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Toastman

    Toastman Super Moderator Staff Member Member

    Hmmm. This is a Vlan-GUI build. Perhaps this is something to do with that mod - I'll bring it to Augusto's attention.

    It appears to be something to do with a default MAC from the router's cfe, searching on google it seems that this has happened in many versions of firmware, not only Tomato, and is probably something lurking in the cfe code that has managed to escape.
  2. Toastman

    Toastman Super Moderator Staff Member Member

    bagu - Only the interference mitigation default setting. Nothing else in the wireless area that I can think of, no :(

    For it to be weak 1 meter away, something has to be really wrong. I can't imagine what.
  3. Toastman

    Toastman Super Moderator Staff Member Member

    Now here's a nice feature from Augusto. Build 1.28.7481 uploading now.

    #### NEW ####

    Revised combined Static DHCP/ARP Binding and Client/Bandwidth monitor
    allows realtime monitoring of multiple clients.

    Now both incoming and outgoing details are shown on the same graph :cool:

    Thanks to Augusto Bott (Teaman).

    *** Unless you need VLAN-GUI, this is the preferred build ****


    Information Page

    Client Bandwidth Monitor

    QOS Pie Charts
  4. Hackerivs

    Hackerivs Networkin' Nut Member

    if i want to move from kernel 2.4 to kernel 2.6 with an appropriate build must i upgrade my cfe?
  5. USNetboy

    USNetboy Networkin' Nut Member


    First I would like to thank you for the great mod you provide. I have been using it for a few weeks and it is a really neat image. I have been working during the past two weeks on getting IPv6 and think I have found a problem with the initial firewall ruleset. The initial IPv6 INPUT chain is the following:

    Chain INPUT (policy DROP 0 packets, 0 bytes)
    num  pkts bytes target    prot opt in    out    source              destination
    1        0    0 DROP      all      *      *      ::/0                ::/0                rt type:0
    2        1    56 ACCEPT    all      *      *      ::/0                ::/0                state RELATED,ESTABLISHED
    3        0    0 ACCEPT    59      *      *      ::/0                ::/0                length 40
    4        3  248 ACCEPT    all      br0    *      ::/0                ::/0
    5        0    0 ACCEPT    all      lo    *      ::/0                ::/0
    6        0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 1
    7        0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 2
    8        0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 3
    9        0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 4
    10      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 128
    11      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 129
    12      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 130
    13      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 131
    14      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 132
    15      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 133
    16      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 134
    17      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 135
    18      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 136
    19      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 141
    20      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 142
    21      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 143
    22      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 148
    23      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 149
    24      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 151
    25      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 152
    26      0    0 ACCEPT    icmpv6    *      *      ::/0                ::/0                ipv6-icmp type 153
    As seen above, rule 4 is an all catch for the local interface. Rules 6-11 are the recommended "must have" types for IPv6 global access as per RFC-4890. The problem that I have is with rules 12-26. Those are the recommended rules for IPv6 local access. Apart from the fact that those are redundant (as we have the all catch rule 4 for local) they breach our external security by allowing remote icmpv6 types that are clearly only for local access to hit any of the router's interfaces. The 12-26 group was introduced to the code by commit 75691f85. Not sure why this was introduced as the all catch rule commit precedes it. In my opinion it should be reverted. Maybe the only case this might be needed is in router mode (not gateway mode) where the "wan" interface is actually local. Can anyone shed some light on this ruleset? Are others in agreement that it needs to be taken off?
  6. bogderpirat

    bogderpirat Network Guru Member

    from the official tomatousb build 9052, i went to Tomato Firmware v1.28.7481 MIPSR2-Toastman-RT K26 USB VPN-NOCAT the day before yesterday and already had two sporadic reboots of my wnr3500l.

    i've got a bit of an unusual setup that isolates one lan port in a separated vlan and has a few binaries (igmpproxy, custom dhcp-script, udp proxy) running off an attached usb device, but this was never a problem for the regular tomatousb.

    how do i go about debugging this?
  7. Toastman

    Toastman Super Moderator Staff Member Member

    USBnetboy - we'll wait to see what the main developers have to say about that. The ipvg devs hang out on - wes campaigne was the guy that did a lot of the work on it.

    bogderpirat - this doesn't sound good. I think you would have to start with a basic setup and see if that works, eliminate your special needs as a source first. I can't help much as that build is very stable here, with what I use it for - but that's nothing special, and I don't actually use the portal.

  8. BeHappy

    BeHappy Network Guru Member

    Does anyone know this build supports 3G wan modem as Dantes version?. Dantes version is quite old and newer builds is stopped for further development. Thanks for yr reply.
  9. Toastman

    Toastman Super Moderator Staff Member Member

    No, as far as I know, the only versions that did support it were Dantes' version, and maybe the Chinese Dual-WAN firmware.
  10. Hackerivs

    Hackerivs Networkin' Nut Member

  11. Toastman

    Toastman Super Moderator Staff Member Member

    You don't touch cfe ...

    You didn't say what your router is, or what you wanted to do? I guess it's a WRT series - just flash the appropriate K26 version as normal. Unless there's a good reason, such as wanting to play with ipv6, K26 runs slowly and uses much more resources than K24 on these older routers. You probably won't like it much.
  12. Hackerivs

    Hackerivs Networkin' Nut Member

    thanks for the answer :)
  13. eXDee

    eXDee Networkin' Nut Member

    Hey Toastman,
    I'm running an Asus RT-N16 and your latest build w/EXT.

    Just wondering whether this can be included:
    I see you appear to have posted on it before:

    This is particularly useful for those in countries with restrictive data caps.

    On top of this, if it was implemented, would it be possible to add either data capping to throttle users over a certain bandwidth or cut them off entirely?
  14. Toastman

    Toastman Super Moderator Staff Member Member

    I tried once to include this, but I did not succeed. I wrote to the author to see if he was interested in actually getting this into a build, but I think he's now moved on to other pastures.

    Anyway, Teaman is currently working on a similar scheme, but I am having trouble getting it into MIPSR2 builds. So stay tuned for further news!
  15. Toink

    Toink Network Guru Member

    I just tried tomato-E3000USB-NVRAM60K-1.28.7482MIPSR2-Toastman-RT-VPN-NOCAT on my E3000. As always I clear the NVRAM. Have set the router in the exact settings as previous builds.

    I noticed that it has considerably slowed down my connection.... Accessing websites came to a crawl. Reflashed to tomato-E3000USB-NVRAM60K-1.28.7480MIPSR2-Toastman-RT-VPN-NOCAT and got my actual speed back as well as instant/normal web browsing speed....

    Has anyone experienced the same issue? I'm not sure if it's QOS or something, but I don't see anything Toast has done with the QOS since 7480 in this new build. Seems like the inbound and outbound speeds are inverted or something. Not so sure though.....
  16. eXDee

    eXDee Networkin' Nut Member

    Thanks! Awesome work, I know lots of people in Australia/NZ would love this feature due to the small caps, especially those with shared internet connections :)
  17. Toastman

    Toastman Super Moderator Staff Member Member

    Toink, no, nothing was changed with QOS, but you may well need to erase NVRAM with this version and reconfigure - but you did that already ? So dunno. I'm using it here and it's OK as router (I'm not using wireless though).

    One of the nvram variables has been altered to avoid unnecessary duplication of clients, so I guess it might be something to do with that [extra field in dhcpd_static).
  18. Toink

    Toink Network Guru Member

    Hi, Toastman!

    Yes, I already cleared NVRAM via the webgui, before flashing, and twice after flashing... Will try to replicate with my other E3000 router later and observe... I will also try the reset button on this E3000 :) Will keep you posted. Thanks!
  19. Dr Strangelove

    Dr Strangelove LI Guru Member

    I have a Linksys E4200 with original 1.0.02 firmware build.
    It's a solid firmware and hasn't given me any problems in my environment.

    Now... I 'need' to install a VPN server on something.
    Was going to install it on my QNAP NAS but decided not to.
    Now considering using my E4200.

    So to maintain as much of the original Linksys E4200 functionality, but with the inclusion of a VPN server, what would be the most stable Tomato Toastman firmware/feature package to use?

    Without any informed(and valued) opinions, guess I just go with the following:

    tomato-E4200USB-NVRAM60K-1.28.7482MIPSR2-Toastman- RT-VPN.bin

    Thank you in advance for any info.
  20. Kilack

    Kilack Networkin' Nut Member

    I've been using tomatousb on a n16. Development seems to have stalled? and lots of people recommending toastman builds so going to give it a go.
    I do have one question. Will we ever see quotas like in gargoyle in tomato? It is such a good feature.. just a shame that tomato doesn't have it because everything else in tomato rocks...
  21. EOC_Jason

    EOC_Jason LI Guru Member

    Toastman -

    I posted a thread on the openrouter forum too, but figured I would post here in case you check this forum more frequently.

    I believe there is a bug in build 7482 in relation to static hostname entries.

    The problem is as follows: Basic -> DHCP/ARP/BW

    Entries look okay on this page, no problem. HOWEVER...

    The hostnames (i.e. /etc/dnsmasq/hosts) themselves end up looking like: 3115CN<0 AP411W<0 DVR<0 FONERA<0

    Took me a while to figure this one out when I couldn't access one machine from another via the hostname!

    Just flashed back to 7481.1 and it's okay... So it must of been one of the "optimizations" you did for 7482... ;)
  22. teaman

    teaman LI Guru Member

    Apparently... that's most likely my fault - these static ARP binding 'optimizations' come from branch Teaman-BWM :confused:
    This issue has been identified a couple of days ago, patched, fixed and pushed to the git repo a few hours ago ;)
    In any case, I'm still reviewing things around that and should be pushing a couple of minor patches/updates on top of that fix in a few...

  23. EOC_Jason

    EOC_Jason LI Guru Member

    Ah, glad to hear that it's been caught and fixed, I knew I wasn't the only person out there that used static bindings!
  24. Dr Strangelove

    Dr Strangelove LI Guru Member

    Firstly, thank you to all those involved in building and maintaining the Tomato firmware.
    This is VERY much appreciated.

    I have installed tomato-E4200USB-NVRAM60K-1.28.7482MIPSR2-Toastman- RT-VPN.bin on a E4200
    Looking at the 2.4Ghz WiFi bandwidth rate and it only shows 144Mbps with a channel width of 20Mhz.
    I tried a few things to get the full 300Mbps on the 2.4Ghz channel, but can't find anything to set it.
    Even bullishly setting 40Mhz doesn't change anything.


    MAC Address cc:cc:cc:cc:cc:cc
    Wireless Mode Access Point
    Wireless Network Mode N Only
    Radio Enabled
    Security WPA2 Personal (PSK) + AES
    Channel 6 - 2.437 GHz
    Channel Width 20 MHz
    Interference Level Acceptable
    Rate 144

    My Notebook reflects the current router setting, showing a Bandwidth of 130Mbps.
    The Notebook is capable of using both 2.4Ghz or 5Ghz at 300Mbps.
    Using the original E4200 firmware 300Mbps on 2.4Ghz was not a problem.

    I'm aware 5Ghz is not supported at the moment. But 300Mbps on 2.4Ghz?????

    Am I missing something, or is 144Mbps on 2.4Ghz WiFi the maximum available on the Linksys E4200 using Tomato firmware.

    Thank you for any pointers.
  25. jinjorge

    jinjorge Addicted to LI Member

    updated my RT-N16 from Build 54 to Toast's 7482 build - All I can say is WOW!!! I was impressed with the stock QoS features, but Toast's builds just took it to the next level.

    Thanks Toast and all that are involved in making this firmware what it is today and tomorrow....

  26. Hackerivs

    Hackerivs Networkin' Nut Member

    toastman are you planning to add 3G usb modem support in your builds?
  27. EOC_Jason

    EOC_Jason LI Guru Member

    20 MHz = Normal channel width, meaning you will only get 144Mb from N and 54Mb from G devices.
    40 MHz = Two adjacent channels = 300Mb for N....

    Set the channel to "auto" and the width to 40MHz and give it another try... Do you have any wireless G devices on your network?
  28. Toastman

    Toastman Super Moderator Staff Member Member

    Hackerivs - maybe will add it later when we have some feedback.

    In the meantime, a new build 1.28.7483 coming shortly.

    This is a trial fix for the nf-conntrack rtsp helper module. Anyone able to test and post the results?

    Thanks to Olivier Castan !
  29. Toastman

    Toastman Super Moderator Staff Member Member

    Regarding the 300MHz and the selection of channels. You will find it much easier to understand what is going on if you install inSSIDer (a free wifi monitoring utility for Windows) and look at the channel graph - you will find this really helps.

    In fact, using AUTO gives no end of trouble as far as I am concerned, I would personally never use it, because you have no control whatsoever over what is going to happen as it jumps around randomly selecting new channels every time the wind changes. It's bad enough having an unreliable delivery medium in the first place without making it even worse :)
  30. EOC_Jason

    EOC_Jason LI Guru Member

    Well, I suggested auto because I know some firmwares you have to choose certain channels or the channel bonding will not work so it was just a debugging step. I agree with toast in that you should do a wifi scan and find a channel with the least interference.

    Unless you are out in the boondocks by yourself, odds are there will be so many wifi networks around you that it's not even worth trying to run 300Mb (two channels)... If you can find one channel with minimal interference consider yourself lucky... ;) I remember one time do a netstumbler scan I could pick up maybe two networks driving down my street, now my notebook can pick up over a dozen just sitting in the living room!

    I'm kind of tempted to start digging through code and see if it's possible to enable 'G' for channel 14...

    23 Wireless Networks... woohoo...

    Attached Files:

  31. nutellajunkie

    nutellajunkie Networkin' Nut Member

    tomato-K26USB-128.7821MIPSR1-Toastman-ND-Ext is what I am using on an Asus, with USB & 8ROM/32RAM.

    Please forgive me if this has been asked before. I have tried to figure it out myself, only advice I have been given is that its not a "typical" build. Again my apologies if this was on any notes that I may have missed.

    The issue I am having is, I have no way of connecting to the web interface? I can access router via my computer here, which lets me connect to internet and also directly telnet the router. I read above that some build has DHCP off, perhaps this is the issue?

    I have looked for this in NMRAM, which outputs..

    Then I had a look at the HTTP list, which outputs.. Which I believe to be the defaults anyway.

    and also since wireless is off, I had a look at that also..

    The issue is, if the case is there is no web interface or it is a duff version. There must be a way that I can switch the web interface and wireless back on via telnet, even just for now so I can at-least update the firmware to a usable version. Id prefer to do it this way instead of just a TFTP, because Id never learn otherwise. I hope you understand my predicament!

    Thank you for your time and much much appreciation for your firmwares, which has satisfied me since your early versions!

    update: I now have wireless (radio) to work, though it is VERY unstable for some reason. I had my android change to a static address a few hours ago.
  32. Hackerivs

    Hackerivs Networkin' Nut Member

    all toastman releases have DHCP turned off. you must set your gateway to
  33. nutellajunkie

    nutellajunkie Networkin' Nut Member

    hummmm.... You may have read that I have used versions since early releases my friend, which means I obviously have this set by now!!

    Besides, you cannot continue "edit connections" on Linux without setting that anyway!
  34. gutsman7

    gutsman7 Networkin' Nut Member

    Set your computer or device with a static ip like Thts the one i always use then you will be able to connect to the routers gui.
  35. gutsman7

    gutsman7 Networkin' Nut Member

    Thnks Toastman for the new build 1.28.7483 its working real goooooooooooood.
  36. nutellajunkie

    nutellajunkie Networkin' Nut Member

    yeah I was reading that.. I hope to update soon as I get this one sorted. I really do not wanna have to TFTP though.

    And perhaps I never made it fully understandble.. Ill say it here, I always use static with internal stuff. If DHCP is indeed off, Its the only way I would be connecting at the moment anyway.. My Voip hardware uses DHCP and it is unavailable at the moment. Like my main desktop, my android also uses a static address. it is just this build I am using that has got this "issue" which I am aware of, I just wish to try fixing it manually. You know, to learn more :)
  37. nutellajunkie

    nutellajunkie Networkin' Nut Member

    I also realise there is an overwhelming number of settings within nvram that can be screwed up.. which shows us the power of this thing.. For reference, does anyone know of a document listing and explaining each of these variables?
  38. Dr Strangelove

    Dr Strangelove LI Guru Member

    Thankyou for your reply. I've been using inSSIDer for years and find it very useful.
    Pity it only shows the AP and not the clients connected [tongue in cheek] ;)

    This is where the Tomato firmware can also help (in conjunction with inSSIDer)
    One can check the list of connected devices in the Device List menu to identify any devices connected via WiFi which need attention.

    Found a mobile phone 802.11G (54Mbps) which auto connects when in range, was left on and thus pulling the network bandwidth down.
    So focused on old kit like routers/Desktop/Notebook/Range extenders etc, one forgets about smart phones.

    So sorry, It's off to the naughty stool in the corner for me. Doh!!!!

    The Linksys E4200 using Tomato Firmware can provide 300Mbps bandwidth on the 2.4Ghz frequency when compatible devices ONLY are connected. This has been tested and verified.

    If I remember correctly you had to use auto with the original Linksys firmware due to it's limitations when configuring 2.4Ghz 300Mbps.
    I would NOT recommend using auto for Channel selection where configuration settings can provide the required support.

    With the Router's Wireless Network Mode set to 'auto' to support both G and N devices, the mobile phone is able to join the WiFi network.
    However in doing so it reduces the E4200 router WiFi bandwidth rate down to 54Mbps.
    When the mobile phone leaves the network, the bandwidth returns to 300Mbps.
    The channel width remains at 40Mhz during these network changes.

    So in short I have found using Wireless Network Mode: auto and Channel Width: 40Mhz, one can provide a dynamic bandwidth rate with both 802.11g and 802.11n devices.
    Just don't have any devices less than 802.11n 300Mbps active when the router WiFi is configured as the results may be that the WiFi channel width and bandwith rate are never configured above the lowest spec'd connected client WiFi device, thus 40Mhz will just keep resetting to 20Mhz.

    Thank you to all and sorry for being a muppet.
  39. bagu

    bagu Network Guru Member

    Finally! Toasman thank you for making operational the RTSP.
    v1.28.7483 work really well on my RT-N16.
  40. Toastman

    Toastman Super Moderator Staff Member Member

    Bagu, hey, that's good news!! Thank you for posting that confirmation, I know it's bugged you for a long time :cool:

    EOC_Jason - setting country to Japan will enable CH14. But the power is limited on all channels, this may be a problem. BTW - the list you published of 23 routers shows that almost all of them are far too weak to cause you much trouble.

    BTW - the above saga of the mobile phone dragging down the network: it doesn't have to be your mobile phone. It can be any passing mobile phone, or one next door that you don't know about. Worse - it doesn't even have to make a successful connection, which means you won't see any record of it anywhere on the router or even know it's happening!
  41. EOC_Jason

    EOC_Jason LI Guru Member

    Yeah, I have setup two Fonera's with DD-WRT configured for channel 14 for a wireless link ~270ft away. I don't remember on which end that signal test was from... Needless to say on each end they pick up different networks @ different signal strengths. You should have seen how many networks I picked up when I stuck an antenna 20ft in the air... lol. Even channel 14 @ B speeds is plenty sufficient, I'm just linking a remote security camera to my main network and it only uses like 2Mb tops.

    Signal strength really varies since that is at an office/warehouse complex (and one of the points the building backs up to a neighborhood). With warehouse doors closed the metal buildings contain the signals pretty good. But when someone opens a warehouse door then power level jumps... At home it's much worse ever since AT&T Uverse has rolled out. Some genius decided it was a good idea to have the routers full power @ 400mW!!!

    I spent the other day playing with an Airlink AP411W that someone gave me. Usually for a decent signal I had to put this in the window. I got bored and was trying to flash it with an DWL-2100AP EU firmware (for extra channels and adjustable power level). No success on that, but I started going through all the US DWL-2100AP firmwares and noticed at one point the "full" power was 20dB (100mw)!!! It even had an power override command in the console, but testing showed that it didn't actually do anything. Later firmwares dropped the max power level down to like 17 or 18 dB (confirmed by signal strength from other points), and removed the power override command... The only advantage to the newer firmwares was the addition of WPA2... So it's a toss-up of more power or better security...

    Sorry to go off topic... ;)

    Planning on flashing to 7483 on my WNR3500L, thankfully it doesn't take too long to reconfigure everything.

    One quick Q... What version of OpenVPN is compiled in? I'll probably look this evening in the source, but figured I would mention it in case you knew off the top of your head.
  42. EOC_Jason

    EOC_Jason LI Guru Member

    Okay, I found the answer to my own question... OpenVPN 2.1.1. Just for kicks I think I might try and upgrade it to 2.2.1 and see if it will compile.

    Another feature that I'm not sure is missing or I just don't see it, is the ability to issue shell commands via the web GUI? I'm going to look over each menu item once more but if I don't see it I'm going to either code in a page or add it to one of the others.

    In the mean time, I took your 7483 build and removed more images / css and shaved down the size a little more. If anyone wants to download, the file can be found at:

    It's the same features as Toastman-RT-VPN, sans excess images. I'm able to create a 640k JFFS partition with my 7483 build... :) Maybe one of these days I'll be able to figure out git more and can upload my own tags.
  43. mraneri

    mraneri Network Guru Member

    It's in Tools->System. It's called "Execute System Commands"
    EOC_Jason likes this.
  44. EOC_Jason

    EOC_Jason LI Guru Member

    Man, I'm so glad you replied! I *never* go in the Tools menu. I did once when I originally installed Tomato and remembered it had ping and trace and nothing that I really use so it's just been mentally blocked ever since... lol!

    It's okay, someone can give me a facepalm and utter, "I can't believe this guy...."
  45. nutellajunkie

    nutellajunkie Networkin' Nut Member

    I was hoping this was gonna be a learning experience for me.. Remember, we all need to learn!

    Could even Toastman himself look over my recent postings and reply.. Either here or in PM.. But there are a few questions there that lots of people would find the answers interesting im sure when they crave to learn it as much as I do.

    Thank you.
  46. EOC_Jason

    EOC_Jason LI Guru Member

    The web interface should be enabled by default. Did you do a hard reset to your router? Did you try doing a 'ps' when you telnet'ed in to see if the httpd process was running?

    Which ASUS router do you have? Are you sure you downloaded the correct build?
  47. Toastman

    Toastman Super Moderator Staff Member Member

    That is a kernel 2.6 build which, I always point out, are rather "experimental" in nature and which do take more resources than K2.4.

    Having said that I'd have thought you should be OK, although you don't say what model router that is. I've just flashed that build on an ASUS WL500GPv2 with no problems, and I have had plenty of mail from people who are using it also. So there's seemingly nothing inherently wrong with the build itself.

    A few tips:

    First, if you have telnet access, erase nvram from the command line. That may restore the GUI. If you have a new install with nvram erased, and it still has problems, there is the possibility of a bad flash. You need to reflash. To do that, if you can't access the GUI, you need to use a different method. There are many posts on that already. The easiest way with ASUS routers is to use the ASUS firmware recovery tool. Or you could use a different tftp method. Or you could flash from the command line - there's some help to be found here:

    Common Tomato Topics ------- (Help & Information)

    If that build still doesn't work for you, remember the warnings and caveats in the README file. Try something else :cool:
  48. kthaddock

    kthaddock Network Guru Member

    I have strange behave with latest build, 7483-nocat and some builds before. (same in shibbys AIO-070)
    Bandwith=>Lastest 24h Lim. IN(imq2) Lim.OUT(imq1) have shown up in grafscreen.
    And as you can see between 14-23 and 10-11 there is some Wan IN (Rx) but there is no ongoing transfer or anything.
    Real time and client monitor working as I can see. Tun 21 graf doesn't show anything, yes I have openvpn running.
    I don't know if this is a bug or it's lack of my knowlege regarding this !?
    Pleas let me know if I can supply more info from this stange behave.

  49. Toastman

    Toastman Super Moderator Staff Member Member

    Sorry, I can't cast any light on that. I would presume that if the graph shows it, then something, somewhere, was responsible for generating the stats that created the graph. And the transfer both started and stopped, so it isn't an aberration in the stats program, it does look like something really started and stopped transferring data at that time. Curious.
  50. kthaddock

    kthaddock Network Guru Member

    That is from WAN-side (RX) to router. I don't have any downloading kids or GF. Maby it's some port scanning.
    I have to ask my ISP if they can see this.
    What about LimIN and LimOUT showing up, they don't bee there when I config router and Tun21 graf not showing anything.
  51. EOC_Jason

    EOC_Jason LI Guru Member

    Lim = Limit? Some sort of port / bandwidth limited setting?

    As for traffic, yes it could be something from the net hitting your router, either port scanning, log in attempts, etc, etc... Or maybe Windows Update running in the background?
  52. Hackerivs

    Hackerivs Networkin' Nut Member

    yesterday i realized that the web-monitor on my wrt54gl does NOT work
    i'm on fw 1.28.7625 -Toastman-ND ND Mini.
    can anyone test it?
  53. Beast

    Beast Network Guru Member


    Tomato Firmware v1.28.7483 MIPSR2-Toastman-RT K26 USB VPN on Asus RT-N16

    I noticed that after the router has run for a few hours or myabe 1 day when I go to the Client Mointor all I get is this::

    RX Avg Peak Total
    TX Avg Peak Total

    and nothing else. And yes I do have a couple of devices setup for monitoring. After a reboot of the router all works great again.
    I think maybe this may be related to my modem disconnects, then when some of the services restart something is just out of order.

    Toastman any idea's???

  54. Toastman

    Toastman Super Moderator Staff Member Member

    Sorry, I haven't. I never saw that problem. And if I deliberately stop WAN and restart mine starts OK, as it does after the usual ISP reset every 24 hours.
  55. bagu

    bagu Network Guru Member

    I just see something on my rt-n16 :
    CPU Freq should be 480 Mhz ... no ?
  56. Toink

    Toink Network Guru Member

    Yes. It's 480MHz and you should change it in the Advanced> Miscellaneous> CPU Frequency and then reboot your router to save the setting.
  57. bagu

    bagu Network Guru Member

    It's already set to 480,240 ^^

    Edit :
    I have done an erase Nvram and it work now...Maybe an upgrade issue ?
  58. Toink

    Toink Network Guru Member

    Perhaps, but I never had any trouble saving the CPU frequency in this build (and the previous ones)... all it takes is a simple reboot for the frequency to set :)
  59. EOC_Jason

    EOC_Jason LI Guru Member

    Yeah, my Netgear WNR3500L does the same exact thing. If the CPU speed is not set and the router is unplugged (not just a warm reboot) then it will only run @ 133MHz.

    You can change the speed as someone said above, however the new speed won't take effect until you reboot the router.

    When you clear the NVRAM settings it leaves the cpuclk (or whatever the setting is) blank. I noticed DD-WRT will fill in the proper CPU speed, even if you don't mess with the CPU frequency settings in that firmware. I can only assume it's some random chance for some routers that will end up running at a slower clock speed unless it is specifically entered in the nvram.
  60. Toastman

    Toastman Super Moderator Staff Member Member

    All of my RT-N16's seem to set themselves to 480. I haven't found out why some set to 133. The Netgear 3500L sometimes does it also. Yet it's apparently only a few out of the many thousands of downloads. Odd.
  61. jinjorge

    jinjorge Addicted to LI Member

    I see the same thing with Tomato Firmware v1.28.7482 MIPSR2-Toastman-RT K26 USB Ext on my RT-N16

    MAC address is bound to IP Address and Bandwidth monitoring is enabled

  62. mage

    mage Guest

    I saw mine at 133 after I restored the old bandwidth logs after the firmware upgrade. Probably not a good idea in highsight. Had to go into Misc and set it back to 480 and a reboot and all is fine again.
  63. Toastman

    Toastman Super Moderator Staff Member Member

    Beast, Jinjorge - I just looked at a remote site which I remembered using to look at a particular client about a week or so ago, and which left running. It's still running.

    So I don't know what is happening with you guys. It may be that the rstats program isn't running.

    Maybe Teaman might have some thoughts.
  64. Beast

    Beast Network Guru Member

    Im glad im not the only one, but if rstats wasnt running i would think the other monintor screens wouldnt work either. But they do even when the client one didnt. BTW this happened to both of the RT-N16 i loaded up this week. One for me and the other for my bro. And cleared nvram after installing tomato over the dd-wrt mini. What is the command for seening which programs are running, next time the client monitor dont work, Ill check to see what is running or has died if any.

    Which program actually draws the grid work and stuff?

  65. Toastman

    Toastman Super Moderator Staff Member Member

    There's two that you might try if you don't know them already. top and ps
  66. Toastman

    Toastman Super Moderator Staff Member Member

    I'm just posting two new builds for K2.4 MIPSR1.

    September 11 2011 - 1.28.7626 BETA
    This is UNTESTED

    It just brings things up to date by merging with the RT release.
    Contains the recent multi-client Bandwidth Monitor from Teaman (bwclimon).
    Several themes have been removed and color reduction has been done on
    theme images to try to conserve space.

    **** Unless you need VLAN-GUI, this is the preferred build *****


  67. Sunspark

    Sunspark LI Guru Member

    Hi Toastman:

    I tried your 7627 beta build briefly. I was/am running 7625-std on an asus wl-520gu.

    I think there's something glitching in it, because if you ping the router, you will see it spiking ping to 10 ms fairly often, yet reverting to 7625 does not display this behavior.. it stays at the expected 1.3 ms ping mark. So there is a process somewhere that is tying up the router.

    I also observed that 7627 has about 500 kb less ram available, despite having removed themes.

    On themes, I think the asustek red theme should be left in place, because it was/is a very easy theme to view due to shaded background, etc. Asus blue, seems very plain and I wouldn't bother with it.

    In the kernel 2.4 build directory, a 1.28.8025.2 from March 2011 exists.. should that one be deleted? I can see how it could confuse people as you are building today 7627 in september 2011.. having it in that directory could lead to mistaken downloads

    A question for you, I only ever bother erasing nvram when one is changing from a custom firmware to another.. i never bothered doing it for builds produced by the same person.. (e.g. jon) likewise for all builds produced by you in the 2.4 tree, there shouldn't be a need to erase nvram like some people do.. do you agree with that statement?

    A minor final comment, you might want to add to your signature line or posting a link to the website for downloads as it's not obviously visible.. so I'll post it in this comment.

    Thanks for all your work!
  68. Toastman

    Toastman Super Moderator Staff Member Member

    8025.2 could be moved into an "older builds" directory.

    500K RAM may be used by the new features, at this moment I don't know.

    Normally between builds from the same modder, you can get away with not erasing NVRAM - but it's always safer to do it. Some changes made occasionally by the same modder that involve nvram variables will sometimes catch you out. Especially big changes like the update to a new client monitoring system etc.

    Re the links - perhaps you have display of signatures turned off and don't see them.


    Does the build 7627 BETA actually work - as in:

    (a) can you connect to the web?​
    (b) do the new IPTraffic graph pages work?​
    (c) Do any stats build up?​

    I have no MIPSR1 router online to test it.
  69. EOC_Jason

    EOC_Jason LI Guru Member

    Maybe I'm loosing my mind, but the MIPSR2 builds seemed to have gotten a new date (09/10 vs 09/07), despite the latest version still being 7483? File size changed too, for the VPN build it went from 7,106,560 to 7,020,544 ??? We lost 80KB somewhere?
  70. Sunspark

    Sunspark LI Guru Member

    I was testing some nvram variables in 7625 and I noticed that for whatever reason when you change a setting in the web interface, it changes wl_ but not also wl0_ so one can end up with wl_ on and wl_ off for various items such as afterburner, or different transmit powers for wl_txpwr and wl0_txpwr shouldn't all settings mirror on both wl and wl0?
  71. EOC_Jason

    EOC_Jason LI Guru Member

    Did you ever clear all you nvram settings? I think wl_ used to be the old style, but at one point they changed to wl0_ ? Take that with a grain of salt...

    It wouldn't make sense to have so many duplicate settings in nvram as that would be a colossal waste of precious space.
  72. Sunspark

    Sunspark LI Guru Member

    Yeah I did when I installed 7625 but didn't when I took a look at 7627.. perhaps when I reverted back, it left residue behind. It's possible.
  73. Hackerivs

    Hackerivs Networkin' Nut Member

    The 7627 build bricked my wrt54gl.
    The unit reboots every 5 seconds.
    What should i do?

    recovered with tftp.
  74. Toastman

    Toastman Super Moderator Staff Member Member

    Dunno, it doesn't brick mine.
  75. Viccher

    Viccher Networkin' Nut Member

    The 7627(tomato-ND-1.28.7627-Toastman--ND-BETA-Std) build bricked my wrt54gl rev.1.1
    The unit reboots every 5 seconds.
    Recovered with tftp.
  76. Toink

    Toink Network Guru Member

    I can confirm that Build v1.28.7627 BETA have issues partially bricking my WRT54GS v1.1. After flashing my router was unresponsive and locked me out even though I have set a static IP on my pc. I was able to telnet, set boot_wait=on, then use tftp.exe to flash to its original firmware and reflash with build 7625...

    So for everyone else who would like to try the said build, caveat emptor.....
  77. Toastman

    Toastman Super Moderator Staff Member Member

    Confirmed, we've been able to reproduce it now., there are certain conditions which need to be met but then it gets stuck in a reboot loop. You can recover with tftp or the Linksys recovery tool etc.

    I have pulled that build until we fix it.

    7626 works OK.
  78. Toink

    Toink Network Guru Member

    Thanks, Toast... If anyone is interested, I can confirm that Build 7626 works ok.... Toast, you know me. Everytime I see a new build in your repository I can't help but to try it HAHA! It's the least I can do to help with everything you and the rest have been doing for the community. Cheers!
  79. Hackerivs

    Hackerivs Networkin' Nut Member

    where was the problem? :)
  80. EOC_Jason

    EOC_Jason LI Guru Member

    No answer to my post a page or two back about the 7483 build getting re-built and the file size difference?
  81. lancethepants

    lancethepants Network Guru Member

    Just confirming that on the build I'm currently using, v1.28.7482, and on previous builds, it shows it running @ 133 mhz on my rt-n16, until I manually change it from 'auto' to '480'.
  82. EOC_Jason

    EOC_Jason LI Guru Member

    It's more of a bug with the hardware than the firmware. But yes, on numerous RT-N16's and WNR3500L's and others they will cold-boot at 133MHz unless you specify a CPU speed in the GUI.

    You might want to step up to build 7483 as it fixes a gitch with static hostnames.
  83. Toastman

    Toastman Super Moderator Staff Member Member

    The build change was actually because I had 2 files on 4shared that were corrupt. I recompiled and re-uploaded because I had obviously deleted the old build directory. The change in size is, I think, because I had reduced the size of an image, I forget which one.
  84. Dr Strangelove

    Dr Strangelove LI Guru Member

    Upgraded my Linksys E4200 to the 'current' Toastman Tomato firmware.
    All good thus far, but I had few moments (Stupid Desktop PC) that gave my heart a bit of a workout.

    Model: Linksys E4200 v1
    Chipset: Broadcom BCM4716 chip rev 1 pkg 10
    CPU Freq: 480MHz
    Flash RAM Size: 16MB
    Current Version: 1.28.7483 MIPSR2-Toastman-RT K26 USB VPN
    Free Memory: 50.46 MB (aprox. size that can be buffered completely in RAM)
  85. EOC_Jason

    EOC_Jason LI Guru Member

    kthaddock - I have a WNR3500L and my realtime graph shows traffic on tun21 just fine... The brand of router really shouldn't matter though since tun21 is the same interface on all machines.

    Are you sure traffic is actually going over the tunnel? Are you sure it's just not the graph scale? (in the lower right corner of the graph, choose Max: Per IF)
  86. kthaddock

    kthaddock Network Guru Member

    Thanks I have seen a tiny little graf today I hit realtime then scale show minimum speed and graf shows !
  87. Tom Parkison

    Tom Parkison Addicted to LI Member

    Under "Basic -> Network -> Wireless (2.4 GHz / eth1)" shouldn't there be a "G/N Mixed" option for the "Wireless Network Mode" configuration line?

    I'm using a Linksys E3000 by the way.
  88. Toink

    Toink Network Guru Member

    ^^ There is on my E3000.
  89. Toastman

    Toastman Super Moderator Staff Member Member

    I've rebuilt the broken K2.4 release from the ground up. Tested for 1 day.

    Have fun!


    September 14 2011 - 1.28.7628

    This has been rebuilt from scratch, it's not quite finished yet but
    seems to work well.

    This contains VLAN-GUI support and new IPT-Monitor. If this is stable it will
    be the new preferred client monitor.

    Real-Time and Logged client graphs and statistics.

    Several themes have been removed and color reduction has been done on
    theme images to try to conserve space.

    Please ERASE NVRAM when you upgrade!


  90. altdel

    altdel Networkin' Nut Member

    Running the latest 7483 build for E4200, I noticed that when using Channel 6 and 40MHz channel width and Control Sideband: Low, inSSIDer showed that the signal spans both Channels 6 and 11, as opposed to the expected Channels 1 & 6 (which is what I got when using Victek's 9006 build with the same setting). Not a big deal, but just need to use the "correct" Control Sideband as shown by inSSIDer instead of the High/Low designation.

    The firmware is running great, by the way. Thanks for your great work!
  91. Toink

    Toink Network Guru Member

    Running the latest K2.4 1.28.7628 EXT build BETA in my WRT54GS v1.1 and Asus WL-520GU so far so good.

    A couple of things I notice in this build:
    1. DHCP IS enabled by default.
    2. UPnP is disabled by default.

    I will try to test drive and report for any problems - if I found one...

    Thank you Toastman! :)
  92. Tom Parkison

    Tom Parkison Addicted to LI Member

    I don't see it.

    Attached Files:

  93. Sunspark

    Sunspark LI Guru Member

    Toink: Could you please ping your router and see if it's demonstrating 5-10 ms ping spikes?
  94. Toink

    Toink Network Guru Member

    Tried it for 5 minutes, my ping was consistent to <1ms. No ping spikes at all
  95. Toink

    Toink Network Guru Member

    I mistook the "B/G Mixed" to your post.... As far as I know "G/N Mixed" was never there.... I've always used Auto for the 2.4GHz though....
  96. Toastman

    Toastman Super Moderator Staff Member Member

    Sunspark, 7627 was apparently buggy for some people because it would enter a reboot loop for some reason (so far unexplained). However, it did work for me. I flashed it only on an AP. Ping replies were always below 0.5mS and it otherwise seemed to behave normally. I have rebuilt K2.4 MIPSR2 in a different way - but it isn't quite the same, as yet it has no BW Limiter and no Portal. Still working on it. 7628 had a brief test online for about a day and worked well, seemed very responsive - I rather like it.

    Meanwhile I am looking again at the old 7627 build because I know I must have screwed something up, and I would rather like to find out what it is. If I can get it to work without the reboot loop, I will repost it.
  97. mvsgeek

    mvsgeek LI Guru Member

    After upgrading to tomato-ND-1.28.7628-Toastman-VPN (from 7625) I noticed that a change to the Wireless MAC address isn't saved across reboots. I even tried changing it from an ssh session and issuing an explicit nvram commit, but it still reverts back to the original WAN MAC. I went back to 7625 and all is now well.

    Just like to say a huge "Thank You" to Toastman et al for all their work! I'm so happy I found this site:) In terms of knowledge, response to questions, ease of firmware configuration etc., the difference between Toastman and the previous firmware I was using is like night and day.

    BTW I clicked on the "make a donation" button on the "about" page, and my donation apparently went to Jonathan Zarate - is this correct?
  98. EOC_Jason

    EOC_Jason LI Guru Member

    Jonathan Zarate is/was the creator of the main TomatoUSB software... Toastman is someone else... I think he deserves a PayPal link for his hard work!
  99. kthaddock

    kthaddock Network Guru Member

    Hmm in build 7483-nocat it's seems "Web Usage" - "Recent Web Searches" and "Recently Visited Web Sites"
    doesen't work, is it only in my place ?
    Does your's working as is should ?
  100. Toastman

    Toastman Super Moderator Staff Member Member

    I just flashed it to test, seems fine here.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice