Toastman Releases - up to 1.28.7492

Discussion in 'Tomato Firmware' started by jsmiddleton4, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Solace

    Solace Networkin' Nut Member

    also occurs on the 0468 as well not just 0406.2

    even with a single rule in bwlimiter seems to set it off, i also had enabled at the time for the single mac addy to be static to a set ip. along with the bw limiter to enable limited values to unknown ips

    and yes nvram was cleared after flashing.

    to make it a tad more clear these are the following steps on the e4200

    30/30/30 reset if unable to get that glimsp into the router when its rebooting constantly "was watching a ping to see if ttl 64 hits allowing me temporarily to get into the router before it crashes and disable it. if unable to i would perform the reset, load into basic networking and apply dns/dhcp/ssid/wpa2 personal, proceed to devices, add static, enable bw/ip limiter, bind ip, proceed to bw limiter and enable a single rule for that ip and have all unknown ips to obey something else enabled.
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Nick Birke

    I'll fix the makefile for the next build so it has USB support. I thought it did already, I expect it got changed during all of the recent merges. :)

    Why not use the USB 60K VPN build?? I think that has both

  3. nutellajunkie

    nutellajunkie Networkin' Nut Member

    Tomato Firmware v1.28.7481 MIPSR2Sandwich K26 USB VPN-NOCAT
    Netgear WNR3500L/U/v2

    Freshly flashed today when I got the router (sexy little thing)​

    Ive had a little search, but either its the headache making me as a n00b question, or I just cant find it...

    JFFS, doesnt seem to (want to?) mount after apparently I mount and format.. It goes through what it does, then tells me something went wrong.

    I know I read the documents, and I did activate DHCP! :rolleyes: though dont want to mess around TOO much until I get JFFS to work. Why? Well i had/needed it in previous version and I just want to break in easily and not jump tooo deep into the unknown.. I came from a girlie wee 4mb router.
  4. eXDee

    eXDee Networkin' Nut Member

    Switched to the VLAN build as it has the IPT Traffic Monitor from Teaman on my RT-N16.
    This excellent, it appears to be working perfectly. However its disappeared from 4Shared as far as i can see? is there any difference between these and the 7XXX builds from the usual branch? Confused with the numbering schemes.
  5. Toastman

    Toastman Super Moderator Staff Member Member

    What version to use?

    When you get to 4shared:
    • First - decide what branch you want. This depends on your router.
    • If it's for the older MIPSR1 routers like WRT54 series, choose "ND"
    • If it's for newer MIPSR2 routers like RT-N16, WNR3500L, Linksys "E" series, then choose"RT"
    • If it's for a very recent dual-band MIPSR2 router (E4200 etc) you may need "RT-N" to get support for the 5GHz radio. You can still use the RT version if you don't need the 5GHz radio to work and it may be a better choice for some.
    Once inside the correct folder, you will have another choice to make:
    • If your needs are simple, and you don't intend to set up a VLAN, then select "RT"
    • If you need the easy setup VLAN GUI, then choose the folder marked "VLAN-RT"
    Now you'll see a list of builds:
    • Mini - no USB, no CIFS, no Zebra
    • MiniIPV6 - no USB, no CIFS, no Zebra + IPv6
    • Std - normal build
    • Ext - normal + Extra utilities + NTFS
    • VPN - normal + Extras + NTFS + VPN
    • VPN-NOCAT - normal + Extras + NTFS + VPN + NOCAT portal
    If your router needs USB support, chose a version with "USB" in the title.
    There are "tailed" versions for named routers that have special needs.
    There's also a "generic" version for routers with 60K nvram.
    airdrummingfool likes this.
  6. Mercjoe

    Mercjoe Network Guru Member


    It is much easier to understand now.

    Thank you
  7. Solace

    Solace Networkin' Nut Member

    toastman have you identified/have a hunch on why it boot loops when enabling the bw limiter? if not since i can reproduce this issue and clearing nvram seems to do no aid on flashes nor either current builds how would i go about providing some sort of dumps/logs. i would assume a dump of the syslog/nvram?
  8. Toastman

    Toastman Super Moderator Staff Member Member

    No, I can't reproduce it here, BW limiter always worked fine. Wait until the current batch of development is finished and let's see if it clears up.
  9. Solace

    Solace Networkin' Nut Member

    I lied its actually related to the specific part of the BWlimiter "Default Class rate/ceiling for unlisted IP's" with that disable i am able to use the BW limiter perfectly fine.
    gonna give it one more test in a second, makes sense as well cause i recall setting everything up last time and the last thing i did after making rules for everyone was enable that incase a new ip came on board. not the biggest drawback since i can just add the device/ip later i suppose if any issues arise. the default class rate was set to 1000kb down/100up rate=ceil max tcp=50 udp=5s
  10. dadaniel

    dadaniel Network Guru Member

    Where have all the bin-files gone? I can only see trx files in the MIPSR1 folders...
  11. Solace

    Solace Networkin' Nut Member

    minor update: being without the default class for unlisted IPs it does work but still crashes every 5 minutes or so instead of a constant boot loop.
  12. Toastman

    Toastman Super Moderator Staff Member Member

    Toastman-VLAN-RT-1.28.4407 MIPSR2 K2.6 for RT-N16 etc.
    Toastman-VLAN-RT-N-1.28.0407 MIPSR2 K2.6 for E4200 etc.

    With IPTraffic Monitor, Static ARP Binding, and new cstats V2 from "Teaman".

    Allows real time and 24 hour graphic monitoring per client. Per-IP traffic stats and history.

    Improvements to IPT-Monitor:

    Major highlights/improvements on cstats V2:
    - internals/stats moved away from static arrays to an AVL
    binary tree (there used to be a hard-coded max of 64
    IPs cstats would be able to track)

    - load/save stats is a whole more resilient to temporary
    failures (mostly, at startup, when external/remote
    filesystems are being mounted, etc...)

    - added 'auto-discover IPs' to IPTraffic monitor (previously,
    you had to explicitly enable tracking for each IP address
    you wanted to keep/track BW/IP traffic history)

    - preliminary testing indicates keeping track/stats for one
    IP address 'costs' 7920 bytes (memory is now allocated
    and/or freed dynamically as required)

      • MiniDLNA 1.0.22: cvs 2011-08-25
      • Miniupnpd ver. 1.6 (20110725)
      • Dnsmasq: 2.58 update
      • Busybox 1.18.5 update
      • radvd: 1.8.1 update
      • ebtables: update to 2.0.10-2 (August 11th, 2011)
      • Samba 3: security updates CVE-2011-2522 & CVE-2011-2694
      • ntfs-3g release 2011.4.12
      • IPV6 improvements
      • BCM SDK: wireless driver
      • BCM SDK: wireless driver in RT-N builds
      • PPP: single line MLPPP support
      • Support for Belkin F7D3301/F7D3302/F7D4301/F7D4302/F5D8235v3 routers.
      • Added support for USB led on E3000, WRT610Nv2, DIR-320, H-618B routers.
      • Various optimizations backports and fixes from upstream 2.6 kernel.
    NB - The RT-N versions have a newer (and bigger) wireless driver optimized for use with the E4200 and other dual-band routers. It will probably work well enough on earlier routers too, but there may be compatibility problems. It works fine on RT-N16 and E3000 here. Your mileage may vary :cool:

    Includes the above new updates from Tomato-USB/RT by Fedor Kozhevnikov.

    Source code is at

    Based on Tomato firmware by Jonathon Zarate.


  13. Toastman

    Toastman Super Moderator Staff Member Member

    Change the extension to "bin" if you need it.
  14. Toink

    Toink Network Guru Member

    Wow, Toastman! You're in roll, mate!! That's an average of 1 build per day since the dual-wifi driver was out and working :)

    And I like your new folders' naming scheme. Much clearer to understand which build/flavor to download/taste :D

    My hat's off to you (and for everyone involved) for your great contribution :) Kudos!
  15. Toastman

    Toastman Super Moderator Staff Member Member

    My hat off to Teddy Bear, Ray123, Keith Moyer, Victek, Teaman, Shibby, Wes, Deon, Phykris, plus many, many others - and let's not forget Jon Zarate who started it all !
    eahm likes this.
  16. gamer2win

    gamer2win Networkin' Nut Member

    is there a site or anyone here have a best setting for the 2.4GHZ wireless?? using Toastman-VLAN-RT-N-1.28.0407 MIPSR2 K2.6 for E4200 .. thank you Toastman
    some how the wireless file transfer is slower compared to the WRT54GS :(
  17. Toastman

    Toastman Super Moderator Staff Member Member

    Solace - I have been able to reproduce your problem. It just started to happen all by itself - as I hadn't actually changed anything on that router. I don't see the cause yet, strange because both limits work, it's just this weird rebooting. I may not be able to fix this easily.

    EDIT: occurs on 0486 also? aha. It may be one of Teddy Bear's newer commits that has caused it. Switching to "Sherlock" mode ... ;)

    Nope, 7486 works fine, 0486 reboots. Can't see any other reason than the wireless driver.
  18. Solace

    Solace Networkin' Nut Member

    people are on the net now so i cant retry 7486 til later tonight. did you just test 0487? if so i can skip on that build for now. im fairly certain i tested the old wireless driver and the problem still persisted as well. ill give it another shot to make sure though. good news is the problem is at least addressed and will be solved eventually.
  19. Toastman

    Toastman Super Moderator Staff Member Member

    It's beginning to look like the newer drivers cause it. Looking at the zillion files that were changed, I almost fainted.


    I just reflashed 4407 and checked "new file" on both rstats and cstats setup to start with a fresh system. Now the BW Limiter is working with normal and default speeds with no rebooting.
  20. Daky

    Daky Network Guru Member

  21. eline

    eline Network Guru Member

    Hi everybody!
    Thank you Toastman for the new release.
    I would like to try it but when i look at
    then I see only 'beta'-builds. Is this correct?
    I have 2 routers; a E3000 and a WRT320N. Which one to use for my WRT320N?
    (I used Victec's release for months...)

    Thanks for any help ;)
  22. djroby19

    djroby19 Networkin' Nut Member

    I went back to Tomato Firmware v1.28.0486 version MIPSR2 Toastman-K26-RT-N USBExt for my E-4200 and much more stable and functional than the others, remains only the problem of the wifi crashes in Access Restriction rules giving him Overview off but notback on the next day .....
    @ Toastman instead use a script to see how I could set scheduler? You could do ....
    Last thing you potrbbe disable QoS on the night in scheduler? because the NAS has no limitations when downloading .... well
    Thanks for all the positive feadback Staff ......
  23. Solace

    Solace Networkin' Nut Member

    Did you test the Default Class rate/ceiling for unlisted IP's? for me i followed your steps and it seems to have cleared the BW limiter reboots "for now" but the Default Class rate/ceiling for unlisted IP's still causes a boot loop. configured nothing else other then one value for the lan client i used to flash the router and applied the default class and manually rebooted the router to ensure stability. upon rebooting with default class enabled it cycled into a boot loop barely allowing enough time when booted to alter the setting back.


    ill give 4407 a shot in a minute.

    EDIT:Seems like the older driver is running normally for now. will update if it begins to occur.

    toastman if you could test the 0407 and repeat the steps to confirm that the default class is the culprit causing the boot loop there that would be great but based off your previous assumption i would assume its accurate. The bwlimiter part was solved by renewing the 2 log files and changing to the older driver solved the Default class for unlisted IPs rebooting.
  24. pharma

    pharma Network Guru Member


    Just to let you know I flashed to "tomato-E4200USB-NVRAM60K-1.28.0407MIPSR2-Toastman-VLAN-RT-N-BETA-VPN" and have no problems. Everything is stable and all features I use are functional.

  25. Solace

    Solace Networkin' Nut Member

    phrama if you could be nice enough to repeat my steps in the previous post that would be great since your on the same model/firmware. simple enable bw limiter and enable default class for unlisted ips and just specify your own ip i suppose for the bwlimiter part then reboot. if its a continious loop you have a small window when pinging the router "TTl 64" to hit "save" after unchecking default class if it does cause a issue.

    EDIT:yea well i checked it twice, 0407 suffers from it. ticked off bw limiter + default class rebooted router manually and ended up in boot loop. 4407 does not suffer from it, no big loss since no one in the place acutally has a 5ghz device nor will benefit from it anyhow due to the speeds are already limited due to isp and no local networking is really being done streaming etc.. will give it a test when a supposed fix pops along, until then ill stick to the old driver without the second radio/updated driver.

    once again thats for the e4200, idk about any other models with the newer driver. i believe toastman has the e3000 but i have no idea if he tested what i did on the newer driver or not.
  26. Toastman

    Toastman Super Moderator Staff Member Member

    The default bwlimit settings seemed worse, but I wouldn't say the router was "stable" when just running a normal limit either. I have had several slowdowns and a couple of reboots.

    Is 4407 faulty? I don't think it is.

    No, I'm pretty sure now. Been up several hours with both normal and default limits turned on after new files created in rsats and csats (on USB drive). Using 4407 on both E3000 and RT-N16 OK.

    Let's see if it continues. I don't need the 5GHz either because I don't have a 4200. And let's see if people have any other funny things happen when using that driver on E4200 etc.
  27. pharma

    pharma Network Guru Member


    Sorry I can test since others are on -- when I get chance I will flash the EXT version. Anyway I don't believe the bandwidth limiter is in the VPN version.
  28. Solace

    Solace Networkin' Nut Member

    yea the 4407 is running perfectly fine afaik, the 0407 is the one that hits unstable for the e4200 if the limiter for unknown ips is enabled then the device is rebooted. pharma said he/she would try it later since the vpn build is a tad different. im 99% sure it can be reproduced on any e4200 if i can manage to do it at will unless the hardware is of a different version/model
  29. pharma

    pharma Network Guru Member

    Was able to flash 0407 - EXT version and goes in boot loop when "Default Class rate/ceiling for unlisted IP's" is checked. If enable "Limiter" and leave "Default Class rate/ceiling for unlisted IP's" unchecked it seems to function ok.

    I also tested on 0407 -VPN and same behavior occurred -- only goes into boot loop when "Default Class rate/ceiling for unlisted IP's" is checked.
    I normally do not use bandwidth limiter feature, and since other features I use work will continue to use 0407 version.

  30. Solace

    Solace Networkin' Nut Member

    thanks for the confirmation. does the vpn build lack any features of the ext build or is it the same +vpn?
  31. csm746

    csm746 Network Guru Member

    I have the advantage of having two E4200's to compare builds on. I also am back on .0486 and I find it a better build because of wireless speeds. I have a 375 meg file on my NAS that I transfer for testing and this build does that faster and at steady speeds. The .0407 build fluctuated and took longer, but I also noticed that in routine use the wireless speeds would fluctuate in Windows wireless networks from 81 mbs to 162 mbs, and settled at 120 or 135 most of the time. With identical settings, the .0486 build is always indicating 270 mbs or 300 mbs. Both units were flashed the same, I always restore to factory defaults thorough, 30-30-30, nvram erase, and flash with the erase all NVRAM data checked.
  32. Solace

    Solace Networkin' Nut Member

    @toastman do i need to create a script to frequently clear those 2 log files? or is it just a one time thing from crack flashing different builds?
  33. Toastman

    Toastman Super Moderator Staff Member Member

    I don't know for sure but I suspect it is stuff accidentally left between builds. I've been trying to remember to clear NVRAM every time but perhaps I didn't do it last time. But seems all right now. Quite probably the files may be handled differently between cstats V1 and cstats V2, this is most likely the cause.
  34. Toastman

    Toastman Super Moderator Staff Member Member

    pharma - Never mind, it's early days yet, and I'm sure Teddy Bear will be tweaking it up a little soon.

  35. Daky

    Daky Network Guru Member

    I have E4200, and i just noticed at back of my router there is no activity light on, its off, its not blinking when i am doing something, downloading, browsing, etc.

    Is this normal?

    Thank you
  36. pharma

    pharma Network Guru Member

    Currently it's normal for lights on the back not to blink.
  37. _NemO_

    _NemO_ Networkin' Nut Member

  38. pharma

    pharma Network Guru Member

    An interesting note: one of the ddwrt forum users posted the following about the E4200:

  39. Toastman

    Toastman Super Moderator Staff Member Member

    pharma - I read that also, but I don't find any evidence to back that up. I think this originated with a reviewer who obviously didn't understand what he read in the data sheets. The only added power amplifier is the normal SiGe 2528L added to the 2.4GHz section SOC, which is nothing unusual, and has been standard in most common routers for many years.

    Here are photos of the 5GHz section:

    I believe I see the 2594L's connected to the antennas - there is no extra power amplifier.

    The 2.4GHz section:

    Again, I see two SiGe 2528L power amplifier chips connected via S236 diversity switches to the antennas. These are the same chips as the WRT54

    There are no extra preamplifiers visible anywhere.

    So the output power on 2.4GHz is the same as the old WRT54 series. The 5GHz section actually has only half the power per channel as the 2.4GHz section. Datasheet Rev 1p3.pdf

    The second (5Ghz) radio actually has an unused 2.4GHz section, but some people have apparently enabled this and found it does do something - at least, it seems to be receivable on the first wireless. But be warned - even if it does "work", it's not connected to a 2.4GHz antenna. And it will also cause interference to the "real" 2.4GHz radio.

    I do see claims that the E3200 has extra amplifiers (Microsemi LX5535 2.4GHz PA
    at 5v can give +32dbM (1.6W) and Microsemi LX5530 5GHz PA
    at 5v can give +25dBm (316mW). But I haven't seen one of these routers, nor found any pictures of it's insides. If true, and the amplifier chips are being run off a 5v rail, then this router would be very nice for large sites or long-distance links! However, I also read that it is actually USB based wireless and therefore not currently supported by Tomato.


    Just found this a few posts down in the same DD-WRT forum:


    Which agrees with the above.
  40. Solace

    Solace Networkin' Nut Member

    would lie kto confirm the wireless speeds are crippled on the 4407 as well compared to 4406.2 i also experianced the 133mhz on the vlan/ext/N builds. will update if it occurs on the older driver as well.
  41. kthaddock

    kthaddock Network Guru Member

    I have loaded 1.28.0407-Toastman-VLAN-RT-N-BETA-VPN-NOCAT and testing and after 2h and 30min all seems working.
    Only find cosmetics issues no importent. Lets time show what happends.

    Big thanks to Toastman and others................. :D
  42. Toastman

    Toastman Super Moderator Staff Member Member

    Solace, did that happen again AFTER you set 480,240 in the Advanced menu? If so, I cannot reproduce it here.
  43. Solace

    Solace Networkin' Nut Member

    on the N version i had downclocked and never forcefully set it back as i experienced any negative performance of any kind. with 4406.2 i have not yet to encounter this and been running for a . i recall it was extremly random both times it occured as well, once after i finished configuring all my settings and the other was about a day later between the 2 builds. i would install the newer driver/builds and test for you what scenarios can reproduce it except this specific bug takes time and is pretty sporadic when it occurs and the newer build/newer driver does not suffice for the daily use here until those other issues are fixed.

    short answer is i never forced 480/240 since i was changing builds too frequently. once a more stable N build is available i will be more then happy to switch over and try.
  44. Toastman

    Toastman Super Moderator Staff Member Member

    OK, thanks!

    If no cpu clock frequency is set in nvram, then some routers revert to 133. Most of them don't. So any time nvram is cleared the router "might" set to 133, and then it needs to be manually set back to 480 and rebooted. This is the same on any recent Toastman build with the clock speed changer. Actually, many people never notice any change in the router's performance until they try some file transfers :cool:

    I am collecting data on different router models, and I'll try to fix the CPU speed bug sometime soon.
  45. Solace

    Solace Networkin' Nut Member

    I have came across a minor issue on 4406.2. when opening multiple tabs or loading multiple pages in FF 7.0.1 it seems that a few of the pages do not load of which one of the pages are of the routers Cpanel as well.

    gonna make this alot shorter and simply say more testing needs to be done on my end, tmr night ill test stock firmware for the e4200 along with 4406.2 with nvram cleared to see if its a configuration issue. its windows 7 so theres no tcp/halfopen limit enforced, along with it occurs in both chrome/ff7

    edit:its not browser related for certain given if i get to the choke point and open a single tab/browser of chrome which is usually instant it hangs.

    edit2: default settings "didnt clear nvram" make it fully functional. "certain of this since i opened 100+ tabs that all sucessfully loaded + chrome managed to open router cpanel just fine.

    will start testing to see what module is causing this slowdown later. given factory settings on 4406.2 solved the issue means its something i changed/enabled.

    edit3: its to do with the BW limiter "had a hunch", upon disabling the bw limiter everything functioned fine and every single page loaded without timeouts. weird thing is the IP i use is set to highest priority with no udp/tcp limits... the ISP line is also idle "i was the only user at the time"

    final edit: removing myself from BW limiter and unchecking default class for unlisted IPs "since my ip would be unlisted" solved the issue while leaving BW limiter enabled. i suppose either i lack the knowledge of how the bw limiter works? or does it need to be tweaked slightly?
  46. Solace

    Solace Networkin' Nut Member

    final question

    that was not answered by anyone before was is there any features lacking in the VPN build from EXT? or is it just EXT with adding the VPN. if theres a page for build comparison i failed to find it via google. i would check it myself but quite tired atm.
  47. Mercjoe

    Mercjoe Network Guru Member

    Comparison Chart:

    To save you the time. VPN is EXT plus VPN.

    One thing that is not covered is VPN+NOCAT. That is VPN with the addition of a Capture Portal. Looking in the makefile, it does not look like anything was removed to add the NOCAT.

    Thus, if you want it ALL, and your router supports 2.6 and has 8meg of flash get: VLAN +VPN+NOCAT.
  48. Solace

    Solace Networkin' Nut Member

    thanks for the link, normally i would take your word for it but the 2 builds for the e4200 differ in size greatly between VPN/EXT

    tomato-E4200-NVRAM60K-1.28.4406.2MIPSR2-Toastman-V LAN-RT-BETA-VPN.bin

    4,261 KB
    tomato-E4200USB-NVRAM60K-1.28.4406.2MIPSR2-Toastma n-VLAN-RT-BETA-Ext.bin

    6,777 KB

    however there is at the bottomthe k26/.trx files are similar in size.

    tomato-K26USB-NVRAM60K-1.28.4406.2MIPSR2-Toastman- VLAN-RT-BETA-VPN-NOCAT.trx

    7,076 KB File

    its not specifying "e4200" but isnt the k26 just meaning kernal 2.6? and its a k60 "e4200"

    or am i mistaken and k26 is another router model? the differences are in size/extension.
  49. Toastman

    Toastman Super Moderator Staff Member Member

    There isn't any reason I can think of why the BW Limiter should cause this behavior just because of a different set of drivers, which aren't supposed to be directly related. However, do bear in mind that the change doesn't involve only wireless drivers, look at the git code, and see just how many other files are involved in the update to the N driver.

    Remembering this is an experimental build, and it's purpose was really to test the new wireless driver for the E4200, I think enough has been said. The driver works, it appears to have less throughput at the present time than the older driver, and there may be some bugs caused by it's inclusion. Those with an E4200 have to weigh up the benefits against the problems and decide whether to run it or not.

    Re. some of the other points people have been raising. I don't have an E4200 so maybe I cannot properly reproduce faults on that model. However, Wireless on/off by access restrictions, or as scheduler scripts, works as normal on the routers I have (RT-N16 and E3000) and we have verified that they also work on 3500L. We don't get any change after the router has been online for a while, no resets, just keeps on working. That may not be the case for everybody. Again, enough has been said. enough posting the same thing over and over again - we can't reproduce the problem. Let's wait until we have a debugged and production tested N driver - and see what happens then.

    BTW - the differences between those builds:


  50. kthaddock

    kthaddock Network Guru Member

    Okey 8 hour up time now and some issues:

    In ip-tabeles there is double rules, maby it should be there ?
    :FORWARD DROP [0:0]
    -A FORWARD -i br0 -o br0 -j ACCEPT
    -A FORWARD -m state --state INVALID -j DROP
    -A FORWARD -m state --state INVALID -j DROP
    -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
    This new gadget have some issues that causing audio to hack so no problem with FW!
    When I have gadget running with "stream portal" and do some download or messuring speed audio is "hacking".
    EDIT: When using other way to stream no hacking. I keep testing this !
    I don't know if it's my stuff but I haven't before, you can test !

    There is double settings of this:
    Advanced - DHCP/DNS - Ignore DHCP requests from unknown devices
    Basic - DHCP/ARP/BW - Ignore DHCP requests from unknown devices
  51. Mercjoe

    Mercjoe Network Guru Member

    Please notice,

    One says tomato-E4200

    The other says tomato-E4200USB

    One is missing the USB support and all its entailing coding. That is the reason for the size difference.

    The K26 indicates that is is 1 2.6 kernel. If you are using a E4200 you want to use the specific version for your hardware. The more generic is for other hardware. It may or may not work on your hardware.
  52. Daky

    Daky Network Guru Member

    [Exception... "prompt aborted by user" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource:///components/nsPrompter.js :: openTabPrompt :: line 462" data: no]

    I just got this error, with popup.

    What is this?:)
  53. Toastman

    Toastman Super Moderator Staff Member Member

    Something from your browser, I imagine. What page were you trying to open?

    KTH, seems to be a problem with Stream Portal.
  54. Daky

    Daky Network Guru Member

    IP traffic monitor, i only had that message once, after that it was fine.

    I am running firefox, latest stable version.
  55. frandel

    frandel Networkin' Nut Member

    I am having an issue with this latest release (tomato-K26-1.28.7486MIPSR2-Toastman-RT-Mini) with my PPPOE reconnect scheduler on my WRT320N

    My ISP disconnects my session each 36hrs, to anticipate I have a scheduled reconnect running each 24 hours (Administration/Scheduler/Reconnect)
    but after my reconnect, the router takes it's ip ( as WAN ip instead of the ip provided by my ISP

    routing table before the scheduled disconnect:

    routing table after the scheduled disconnect


    and the WAN overview tab where you can see it takes the router IP as the WAN IP


    after I manually disconnect and reconnect it is fine again
    Any idea what is causing this ?
  56. kannanni

    kannanni Networkin' Nut Member

    Hi All,

    just bought a linksys e4200 today, and looking to flash it with tostman's latest tomato build.

    can someone please confirm if CTF is supported on these builds ?
    and also can someone please advice or link me to a stable build so i can download and flash my router ? i am after good wireless or wired connections only.

  57. MPS

    MPS Networkin' Nut Member

    I too have found that I am having an issue with BW Limiter on my e4200. Unit started to reboot once or twice a day, but today, it restarted 6 times, and once while I was trying to figure out what was wrong. Found in this thread about others having issue, turned off BW Limiter, and all is good again. Using Tomato Firmware v1.28.0485 MIPSR2-Toastman-RT-N-BETA K26 USB Ext.

    EDIT: Was still doing the reboot, even after disabling. Changed to firmware Tomato Firmware v1.28.0407 MIPSR2-Toastman-VLAN-RT K26 USB Ext. Will have to see how this one works for us.

    EDIT: Alright, that version was doing the same thing. Reverted back to *shudder* the Linksys firmware until I can find out why. Just saves me the hassle of hearing the kids whine "My Internet is not working, boo hoo..." The reason I went the Tomato was so I could have more control over their usage and speed so they arent causing me to go over the cap again... brats.
  58. Toastman

    Toastman Super Moderator Staff Member Member

    Do you use the 5GHz band ? If not, the other builds are OK, it's only the new wireless driver that seems to provoke this bug.
  59. pharma

    pharma Network Guru Member

    You might want to try version Tomato Firmware v1.28.0486 MIPSR2-Toastman-RT-N K26 USB Ext. According to some others the B/W limiter seems to be working but does not incorporate the VLAN feature or dual band.

    EDIT: Testing tomato-E4200USB-NVRAM60K-1.28.0407.1MIPSR2-Toastman-VLAN-RT-VPN right now. While the B/W limiter still suffers issues when "Default Class rate/ceiling for unlisted IP's" is checked, the wireless speed (2.4 / 5 ghz) seems to be better with 0407.1 than with 0407. I use the same SSID and let clients connect to whatever band they think is best. Since I don't use B/W limiter I'm going to continue using this version and report any issues.

  60. MPS

    MPS Networkin' Nut Member

    The Tomato Firmware v1.28.0486 MIPSR2-Toastman-RT-N K26 USB Ext seems to be working for now. I would like to have the DualBand working as well, but for now, I can settle for this. I will just have to be patient for a fix to be ready.

  61. pupie

    pupie Networkin' Nut Member

    i just complied build 7486 for my BCM5354 router (make nc V1=7486) and flashed firmware to my mod router (flash 16m ram 64m) but the router does not work with this firmware. i can not logon to web and it got no response to ping
    but it works with build 7483.
  62. kannanni

    kannanni Networkin' Nut Member

    im trying to find a download link for this firmware, can you please point me in the right direction ?

  63. Pioneer

    Pioneer LI Guru Member

    kannanni likes this.
  64. gamer2win

    gamer2win Networkin' Nut Member

    why not try
    I see both 2.4GHZ and 5GHZ options (but I don't have 5GHZ , N card to test it)
  65. kannanni

    kannanni Networkin' Nut Member

  66. _NemO_

    _NemO_ Networkin' Nut Member

    Setting wl_wmf_bss_enable=1 we enable Wireless Multicast Forwarding, that allows watch IPTV through Wi-Fi without UDPXY!
    nvram set wl_wmf_bss_enable=1
    nvram commit
    Perhaps, we should add the appropriate setting in the WEB GUI?
  67. pokerman123

    pokerman123 Networkin' Nut Member

    I'm currently using the e3000 as my server router and an e2000 as my vpn client router, and installed the latest tomato firmware for each. Overall it works excellent, my only issue is that when I restart the e2000 client router, occasionally it doesn't start the VPN, and I have to restart it again to get it to work (or go to the tomato config page and hit Start Now). Has anyone had this issue, or know how it can be resolved? There doesn't seem to be any pattern to when this happens, I'd say right now it happens about 20% of the time I reset the router. Is there a way to configure it so if the VPN doesn't start on the client side, the router won't work? I already have it configured so if the vpn server goes down, the client router does not connect via other internet options, so I'm not really sure why this is happening. Thanks for any help you can give me!
  68. _NemO_

    _NemO_ Networkin' Nut Member

  69. Tom Parkison

    Tom Parkison Addicted to LI Member

    My ISP is supposedly giving out IPv6 addresses. How do I configure TomatoUSB to get IPv6 addresses via DHCP (DHCPv6)?
  70. kaabob

    kaabob Addicted to LI Member

    I've searched around but haven't seen any mention for support for the e3200. I see builds for the e3000 and e4200, but mention of the e3200 has been minimal on these forums.

    Also, I know this is super noob, but are there any specific instructions on flashing the new e-series linksys routers?
    Just flash, wait 5 minutes, and reboot?
    Not sure if "Flashing Tomato on a WRT610N" is a necessary overkill flashing procedure.
  71. htpcdude

    htpcdude Networkin' Nut Member

    I've tried tomato-E4200USB-NVRAM60K-1.28.0407MIPSR2-Toastman-VLAN-RT-N-BETA-VPN.bin for my E4200. Why does this maintain Linksys's limit of a /24 network on the LAN as the largest subnet? The original versions of tomato do not have this restriction. Or am I doing something wrong?
  72. Toastman

    Toastman Super Moderator Staff Member Member

    djroby, these new releases are mostly BETA test builds to evaluate the new N wireless driver and inter-operability between it, the VLAN-GUI, and the IPT monitor, etc. - they aren't guaranteed to be bugfree. While your bug reports are welcome and are added to the list of things to look at, this isn't a paid-for support line. Posting about a problem once is enough, and don't expect replies within 5 minutes. That should help to cut down the spam, otherwise I will have to start deleting posts. If the firmware works for you, that's great, by all means use it. If it doesn't do what you want, then just wait and it will most probably be fixed in due course - if it is reproducible.

    In case you haven't considered this, people have lives to live, families to take care of, and other pressing issues. Most of us have to work. Some have jobs that means they have to travel and have no access to the internet. Many of us are suffering from natural disasters such as flooding and lack of essential supplies. While sometimes that means we have spare time on our hands to mess about with Tomato, sometimes it means we have none at all. Patience!
  73. Toastman

    Toastman Super Moderator Staff Member Member

    htpcdude, this is most probably something that Augusto can answer. He's probably busy right now, but I'm sure he will reply when he has time.

    _NemO_ - I will add this to my builds, as there seems to be no reason not to, and it seems to be something that isn't otherwise obvious to people.

    EDIT - added 15th October
  74. Tom Parkison

    Tom Parkison Addicted to LI Member

    Does anyone know how to configure this firmware to get an IPv6 address via DHCP from their ISP?

    I have the latest MIPSR2 kernel 2.6 build for the E3000 (7486.1). It doesn't seem to want to grab an IPv6 address via DHCP which my ISP is supposedly giving out now.
  75. djroby19

    djroby19 Networkin' Nut Member

    I did not want to open any controversy, I just pointed out that the firmware problems ..When I wrote Toastman where you was just a satirical take .....
    I also have a family and a sea of ​​problems to be solved ... like all my might, perhapseven more serious .... I just wanted to share in the same ... Thanks Toastman ooffesoI apologize if you think you so much .. maybe I've heard from ..
    A big welcome ....
  76. Toastman

    Toastman Super Moderator Staff Member Member

    Just remember these are experimental BETA builds and please treat them as such. Complaining over and over again they are not stable, and in other threads, is rather insulting to all of the developers.
  77. magnus33

    magnus33 Network Guru Member

    I can asnwer this one.
    There ins't support for it because the 5ghz in the e3200 is a usb device and there is no driver for it.
    Support could likely be easily added for the rest of it and the 2.4ghz since that differs little then the 4200.
    Ddwrt has support for it (no 5ghz) thanks to the modders in the ddwrt forum rather then brain and the boys since they gone nearly totally comercal.

    Unless someone finds the driver (broadcom isn't giving it out) or adapts one there ins't going to be 5ghz support.
  78. free2share

    free2share Addicted to LI Member

    Has anyone had problems with site to site vpn? Possible bug seems to be causing routing issues. Server side can't ping any client side, but client can ping server side. If "push" is enabled, then client router can ping server side, but losses all connection to its local LAN.

    Local LAN =
    Server LAN =

    push "disabled" can ping local LAN can ping server LAN

    push "enabled" can not ping local LAN can ping server LAN

    Routing on Client with push "enabled" 0 tun11 * 0 br0 (LAN) 0 tun11 0 tun11 0 tun21
    x.x.x.0 * 0 vlan2 (WAN) * 0 lo
    default x.x.x.1 0 vlan2 (WAN)

    It looks like the push is adding the local subnet route and causing it not let the client be able to access the local LAN.

    - Flash with clear nvram, manual setup again
    - Client config stayed the same, only upgraded the server

    Worked on:

    Not working:
  79. kthaddock

    kthaddock Network Guru Member

    I have this up and running for 3days now with no problem. Only small issues, web gui and some name.
    v1.28.0407 MIPSR2-Toastman-VLAN-RT K26 USB VPN+NOCAT
  80. Dr Strangelove

    Dr Strangelove LI Guru Member

    I have the following Linksys E4200 router firmware installed and using OpenVPN.
    It all seems to be working and I can access my NAS folders without any problems.

    Tomato Firmware v1.28.0486 MIPSR2-Toastman-RT K26 USB VPN
  81. whatsinaname

    whatsinaname Addicted to LI Member

    Ok All I can say is WOW thanks Toastman and every one who works on tomato. For a long time I had a wrt54g running dd-wrt.
    Just purchased the Linksys E4200 and started running toastmans build for it. Nice, very nice.

    I am working on ironing out QOS for my network, but that is a story for another time, my question is about wireless.

    I have some laptops, phones etc that have wireless N adapters, but only my sony dvd player sees my n network.
    Currently I have the wireless networks in tomato having different ssids, and the 2.4 radio eth1 is b/g only, at 20 MHz, the 5GHz eth2 is running N only at 40 MHz.

    I guess if my computers don't have 5GHz radios, what would be the best settings to have? I guess I want my wireless N devices running fast, and not dropping down to b/g speeds.
    sorry if I don't make sense, but I am trying to figure this all out and optimize this nice new router :)
  82. teaman

    teaman LI Guru Member

    Hi there!

    Interesting thing you mentioned... I assume you're (probably) talking about the LAN section under Basic -> Network, right? Here's the thing: while working on the VLAN web UI, I realized there's a /lot/ of code within Tomato that simply /assumes/ it's dealing with a /24 subnet for LAN at all times. In fact, user KyleS reported some problems back in July when he tried to configure a /27 LAN network... So I did some patching/fixing on the code and... at the time, it made sense to add some code on the web UI to enforce limit/restrict LAN subnets to a minimum of 24 bits set:

    I don't think that statement would be completely /accurate/: as mentioned above, there's a lot of code in Tomato that 'assumes' it's dealing with a /24 LAN (such limit is just not 'enforced' on the web UI, so I actually suspect people out there might get unpredictable results, etc...).

    While I do believe there's a good chance using larger/wider subnets/mask might work just fine with the existing code, such thing has never actually been tested :) So... if you wanna experiment... you could always try setting some NVRAM variables manually (and of course, please let us know the outcome!).

  83. kthaddock

    kthaddock Network Guru Member

    In build 0407.1-nocat is RTSP fix included ?
    I have tested a couple of day and when streaming music it is "hacking" when i turn it off all working as is should.
  84. though

    though Network Guru Member

    thanks toastman for all your hard work. it's really appreciated by a lot of folks.

    i have a quick question though. i know you have a very large network requiring many routers, AP's, etc. do you have a way to get 'wireless repeater' mode to work in your builds? i have a special situation where i need this in a couple places and am forced to use dd-wrt on those.

    thanks in advance!
  85. Toastman

    Toastman Super Moderator Staff Member Member

    whatsinaname -

    If you have no G or B devices set mode to N. If you do have them, then you have to set a mixed mode, but speed will sometimes be dragged down while the B or G clients are being addressed. But it will go back up so don't worry too much about it, get it going first and then experiment to see what happens with your clients.

    If you have clients that can do MIMO successfully they may be able to support 300Mbps mode with 40MHz bandwidth. On 2.4GHz you will need to experiment to find the best channel. Set 1,6, or 11, then swap Control Sideband between lower and upper until you find the one that works on that channel. Use InSSIDer on your PC to monitor what is happening on the wireless band, it will help you. Sometimes people find that getting a good speed on 20MHz mode is actually easier and faster than they get with the 40MHz bandwidth.

    though -

    No, I never use any kind of wireless connections between routers or AP's for any "mission critical" application, I only use CAT5. I have used WDS outdoors on a few special occasions, always had to be on standby to reboot it when it went pear-shaped though. On this forum, jsmiddleton4 has used WDS successfully, you might PM him to see if that offers an alternative. Beware - in recent esp. VLAN-GUI BETA builds, WDS is apparently broken - we're working on that but it appears to be just an iptables problem, and will be fixed soon.

    kthaddock -

    yes, the "fix" for RTSP helper from Teddy Bear is in the RT-N builds, I checked.
  86. Beast

    Beast Network Guru Member

    Just wondering is the 4407.1 build for the RT-N16 now stable.????

    Or are there still some unresolved issues?
  87. though

    though Network Guru Member

    it says 'BETA' on it.

  88. Toastman

    Toastman Super Moderator Staff Member Member

    There are quite probably some unresolved issues, I believe the wireless driver has issues, but many people seem to be finding that for them, it works fine. It's hard to be sure about some of the issues, because of that. Until Teddy Bear is able to work on them, any such possible issues will probably remain unresolved. Be patient, things will happen in due course, as and when people have time or inclination to fix them.
  89. though

    though Network Guru Member

    just out of curiosity what does the average user gain by using the latest toastman release compared to the latest teddy release (54) besides extra features?
  90. boomcha

    boomcha Networkin' Nut Member

    Hi everyone, have been lurking for a while but decided to join. I have been running Tomato (regular flavour) on my WRT54GL for a few years and it works rock solid.

    I purchased a Linksys E4200 yesterday and put Toastman's "tomato-E4200USB-NVRAM60K-1.28.0486MIPSR2-Toastman-RT-N-Ext" on it. Looked nice and promising but...
    It seemed like the N network (5ghz) was weak, are there any issues with N on this build still or is that taken care of?

    I originally put the new E4200 in the same spot (basement furnace room) as the WRT54GL, and I could get G signal all over the place but the N signal was weak.
    It then remedied my situation by having the WRT54GL go back to its regular spot and putting the E4200 (flashed back to stock linksys firmware) hardwired upstairs where its free to distribute G+N wireless signals. So my thinking is.. WRT54GL handles all the DHCP and monitoring stuff, and the E4200 just does the wireless signal in a prime spot. What are your thoughts on this? Wrong way to go about it? I would rather just have the E4200 do everything but need clarification if the Toastman firmware I mention above is the best to use? I feel dirty using the stock Linksys. :)
  91. Toastman

    Toastman Super Moderator Staff Member Member

    5GHz is always going to be weaker as these higher frequencies have less range and less penetrating power to get through walls, etc. And also, the 5GHz radio runs less power than the 2.4GHz (I'm reasonably sure). While there may well be some quirks to be sorted out in the wireless, I don't think anything will make it stronger.

    Why not leave your E4200 upstairs handling the internet connection and doing the wireless stuff too. Are you using ADSL? Just connect modem out to the LAN cable and run it upstairs to the WAN socket of the 4200. If you need the 2.4GHz AP in the basement just add it to the LAN cable and tune it as an AP.
  92. Dr Strangelove

    Dr Strangelove LI Guru Member

    I have the same revision level of Tomato firmware on a Linksys E4200, just the VPN version.

    The 5Ghz signal on the Linksys E4200 was never that brilliant to start with and as the distance increases the 2.4Ghz SSID becomes more favorable.
    I have not noticed any degrading of the 2.4/5Ghz signal using the Tomato firmware over the original Linksys firmware.
    I have bumped the transmit speed of my WiFi up to 70mW. Not sure if it does anything, but it makes me feel better.
    Also check the CPU frequency is set to 480Mhz, I saw it at 133Mhz on one upgrade, but it's been stable at 480Mhz since then, which has included nvram clean upgrades.

    Just a very rough indicator, I managed a 71Mbits/sec binary ftp at 15 metres (through a few walls) with a connect speed of 108Mbits using a 2.4Ghz SSID from my QNAP TS-112 NAS
    At the same location using 5Ghz I got 39Mbits/s ftp transfer rate at 15 metres from the E4200 at 54Mbps connect speed.
    This was using a DELL 2.4/5Ghz 300Mbits WiFi mini card in a notebook. Expect better results with a better card.
  93. boomcha

    boomcha Networkin' Nut Member

    Interesting, I thought 5GHz was supposed to have longer range than G. Or does N run on 2.4GHz as well?

    I also have a D-link Gigabit switch (this guy here ) and I wonder if I take the cable from the modem and plug it into the switch (which then splits into my wire basement machines) and take the cable that is running between the WRT54GL to the E4200 and put it into the WAN socket of the E4200. I wonder if that would get the e4200 to be the main router and take the WRT54GL out of the picture.

  94. Toastman

    Toastman Super Moderator Staff Member Member

    yes. I often unplug my modem and plug it into the LAN switch, then bring the router upstairs to my apartment to work on. Plug LAN into the WAN port, and the router will discover the ADSL modem and I can then use it to test. You don't need a separate cable, everything can be put on the LAN.
  95. Jacques

    Jacques LI Guru Member

    Hi Toastman.
    The tomato-E3000USB-NVRAM60K-1.28.7486.2MIPSR2-Toastman-RT-VPN.bin is unstable especially 5GHz wifi.
    RSSI varies continuously in device list from -55 to -110 and are even moments of the RSSI
    value is +120 and the moments of the internet by the 5GHz is not available. And i must reboot E3000.
    I went back to the tomato-E3000USB-NVRAM60K-1.28.7483MIPSR2-Toastman-RT-VPN.bin then everything is ok
  96. mraneri

    mraneri Network Guru Member

    "N" by itself doesn't say anything about whether it's on 2.4GHz or 5GHz. Many times you see "N", it's on a single band router, so, means 2.4GHz... But "N" is valid for 5GHz too.

    5GHz is generally less congested than 2.4GHz so some people have better luck, but as others have stated here, 5GHz signals don't pass through walls as well, and as a result, generally, the signal isn't as strong over a substantial distance (all other things being equal). Everyone's residence/setup is different (size, wall material, router location, etc.), and where 5GHz works better for some, it will not work better for all.
  97. Toastman

    Toastman Super Moderator Staff Member Member

    Jacques, I'll check that out...

    OK, same version of 7486.2 loaded and working. Stable on internet acccess and 2.4GHz wireless, monitored at -52dBm +/- a few dB as usual. QOS and all other functions appear normal.


    There is one guy here who has a 5GHz laptop. He just came home from work, and I've just got him to connect at 5GHz and to load InSSider. Seems stable here, his received signal is -63dB +/- a dB or two variance. He can access net normally. The media server and USB is also working normally. I will leave the thing running and see what he says tomorrow. All settings default.
  98. kthaddock

    kthaddock Network Guru Member

    I reconize that problem it's same issue that dd-wrt have, wifi signal decrease over time.
    That only with new drivers 5.100.?.? older still okey!
  99. boomcha

    boomcha Networkin' Nut Member

    This is great to know. Thanks for the explanation.
  100. boomcha

    boomcha Networkin' Nut Member

    Did just this and everything works perfectly. I can now pass on that WRT54GL to my parents.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice