Toastman Releases - up to 1.28.7492

Discussion in 'Tomato Firmware' started by jsmiddleton4, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Jacques

    Jacques LI Guru Member

    Hi Toastman
    I'm back to the tomato-E3000USB-NVRAM60K-1.28.7486.2MIPSR2-Toastman-RT-VPN.bin and i check again WiFi 5GHz
  2. electricblender

    electricblender Networkin' Nut Member

    Toastman, I've been trying different builds for the routers at our camp. I decided to use yours because of the QOS, the Traffic monitor from Teaman and the extended number of clients supported, which we need here. It's working really great. I see you have several beta versions for the new wireless drivers and I am using one on our E4200. But I'd like to ask if there is there a version without the vlan GUI that has the updated monitor with auto-detection of clients?

    Thanks for making this firmware available.
  3. Morac

    Morac Network Guru Member

    I have a few questions which from the quick scan I did of posts since I last checked here, doesn't look like it was asked.

    I have a E3000 currently running the 7483.1 firmware since I only tend to upgrade when I notice problems. After upgrading to iOS 5 on my iPad 2, sometimes it just drops off my 5 GHz network even though the signal strength looks good (though I am near the range limit). I then have to manually reconnect. As such I figured maybe a newer firmware would help.

    Is there any benefit of switching to the 0486.1 firmware? If I understand correctly, the only difference between the 0xxx and 7xxx firmwares is the wireless driver version, which was updated to get dual working on the E4200, correct? Would the E3000 benefit from the newer wireless driver?

    On a related note, I know the recommendation is to wipe the NVRAM on every upgrade, but I've found upgrading along the 0xxx didn't really "require" it to get things working. Would going from the 0xxxx branch to 7xxxx branch require a NVRAM reset?
  4. eXDee

    eXDee Networkin' Nut Member

    New builds looking good!

    Any chance we could see QOS + IP Traffic to be used in tandem in the future? For example being able to set caps per PC, being able to cut off or slow once they go beyond the limit.
  5. Toastman

    Toastman Super Moderator Staff Member Member

    electricblender, yes, I want this too, and I'm going to add it to the RT build, but at the moment am having difficulty getting it to work. Augusto's helping me. Be patient, and it'll come soon I hope.

    Morac, I don't really know if the new wireless driver would help you, but I suspect not. Apple devices are very troublesome unless you use them with Apple routers :) However, it's worth a try of course.

    I have to tell everybody yet again that you should ALWAYS erase NVRAM after an upgrade. As you probably know by now, you can sometimes "get away" with it, but if you look at many of the posts above and in the other threads, you can see dozens of examples of what happens when people don't do what is recommended and then start complaining when things don't work properly! And please, PLEASE, will other people stop telling members that it isn't necessary. Just because it seemed to be OK for you, is irrelevant. Stop being smart. There's a REASON why you should do it. And ALL modders are really getting fed up with answering this damned question every day.

    eXDee - there might be some further development I would imagine, but no idea what at the moment.
  6. Morac

    Morac Network Guru Member

    I upgraded to tomato-E3000USB-NVRAM60K-1.28.7486.2MIPSR2-Toastman-RT-Ext.bin and see the following in the log upon boot up.

    Oct 21 17:43:26 e3000 daemon.err miniupnpd[1677]: setsockopt(udp, IPV6_ADD_MEMBERSHIP): No such device​

    I'm not using IPV6 so is that something worry about?
  7. onryo

    onryo Networkin' Nut Member

    My question is how does the development cycle work with your project. Yesterday I bought a RT-n16. I don't need Vlan or NOCAT stuff. What I need is the most stable, fastest Tomato with VPN+USB support. This is going to be used in an office with 9 wifi machines behind the router using dhcp static IPs that will be using the router as a OpenVPN client. There will also be some servres behind the router piped though the VPN. After reading a bit on the net I was hearing conflicting (whats new) stories that BETA is the most stable releases, atm this would be for my Asus RT-N16.


    Is this true that BETA is the most stable and tested?

    It takes a special kind of person to donate 100s/1000s of hours on a project for free. People tend to take open source coders for granted. Hats off to a fellow open source coder.

  8. Toastman

    Toastman Super Moderator Staff Member Member

    Greetings Onryo, and welcome to the forum.

    Perhaps you are new to firmweare terminology - so FYI BETA means it is really a "Test" build and are quite likely to have bugs. (But even "normal" versions may have bugs, of course, just that most have been corrected to make a "stable" release).).

    The most "stable" branch is probably the RT branch. 7486.2 and earlier. This is the branch I use mostly. These are the latest versions which have many updates incorporated from Teddy Bear's development branch.

    October 6 2011 Toastman-RT-1.28.7486-RT MIPSR2 K2.6 for RT-N16 etc.

    With Teaman Client Monitor (BWclimon).
    (Not the IPTraffic monitor, which you can find in the Toastman-VLAN builds).

    MiniDLNA 1.0.22: cvs 2011-08-25
    Miniupnpd ver. 1.6 (20110725)
    Dnsmasq: 2.58 update
    Busybox 1.18.5 update
    radvd: 1.8.1 update
    ebtables: update to 2.0.10-2 (August 11th, 2011)
    Samba 3: security updates CVE-2011-2522 & CVE-2011-2694
    ntfs-3g release 2011.4.12
    IPV6 improvements
    BCM SDK: wireless driver
    PPP: single line MLPPP support
    Support for Belkin F7D3301/F7D3302/F7D4301/F7D4302/F5D8235v3 routers.
    Added support for USB led on E3000, WRT610Nv2, DIR-320, H-618B routers.
    Various optimizations backports and fixes from upstream 2.6 kernel.
    October 10 2011 Toastman-RT-1.28.7486.1-RT MIPSR2 K2.6 for RT-N16 etc.

    Fixes HFS file system support for USB storage (broken by 7481)
    More builds available.
    October 14 2011 Toastman-RT-1.28.7486.2-RT MIPSR2 K2.6 for RT-N16 etc.

    Added Wireless Multicast Forwarding checkbox to GUI
    Cosmetics - added some notes to several pages to
    assist in setting up QOS etc.

    The previous issue that does NOT have these recent updates would be 1.28.7483.1 if you do find anything that doesn't play ball. The readme file on the download site explains what the changes are since the last version, and anything else important to know.

    7485-7485.4 were actually early VLAN-GUI BETA test builds and while nothing terrible with them, they aren't current, and are deprecated.

    There is of course with any of these tomato projects, (nor any OEM firmware either) no such thing as a "stable" build. Changing the label on the firmware doesn't alter that but apparently does make people feel better :) It's also true to say that the biggest cause of instability /problems /bugs /complaints /finger troubles /whatever is due to use of the wireless. If you don't use wireless, you are free from all that uncertainty. By and large, it's very stable indeed compared with the OEM firmware for most of us.

    Good luck!
  9. teaman

    teaman LI Guru Member

    We've been working on a non-VLAN-GUI IPTraffic/cstatsV2 brew over the last few days - at the moment, some testing/patching/fixing is being done. Anyways: there's a good chance such (new?) version will/should be ready soon... and released over the next few days (a.k.a. not exactly as soon as possible, but when/if both Toastman and Teaman are satisfied with the code and/or consider it somewhat ready to be released) :)

  10. Toastman

    Toastman Super Moderator Staff Member Member

    Do you have a 3TB GPT drive that you can't mount? (EFI GUID)

    Toastman-RT-1.28.7486.3-RT MIPSR2 K2.6 for RT-N16 etc. - initial build.

    Acknowledgement and feedback for this code mod to Yaniv Hamo on

    Thank you Yaniv!
  11. Jacques

    Jacques LI Guru Member

    The tomato-E3000USB-NVRAM60K-1.28.7486.3MIPSR2-Toastman-RT-VPN.bin have a probleme with rssi on wifi 2.4 GHz too.
    See here
  12. Toastman

    Toastman Super Moderator Staff Member Member

    Jacques - yikes! Still happening?

    The wireless driver was changed by Teddy Bear in the latest git commits, so this could be the cause. But so far this is the only report of it. I'm checking it here, I have the E3000 set up refreshing every 5 seconds, and this location has 28 AP's. But all of the AP's are showing sensible, normal readings for almost an hour now. I don't have the problem.

    Is it just that one device?
  13. Jacques

    Jacques LI Guru Member

    Hi Toastman.
    I noticed the problem is in the first 15 minutes when the user starts his computer.
    bad results of RSSI underway for several minutes and then everything returns to normal.
    >The wireless driver was changed by Teddy Bear
    Let's go back to previous drivers.
    >Is it just that one device?
    probably both, to make sure you must have a lot of time to observe.
  14. Solace

    Solace Networkin' Nut Member

    Recently had the cpu downclock to 133 on my e4200 "set to 480/240" will see if it ever downclocks again

    also noticed something about the webmonitor that its logging same data under alternate users/ips... and this just isnt me making up stuff because i know for a fact that the second IP is idle/been idle for the last some hours and the information is related to a personal account "login details" which cannot be the same. yes someone could log in from the other computer but not at 4 am where no one else is away no remote connection and within the same minute...

    basically the information is being represented under recent web searches.

    Mon Oct 24 2011, 1:05:21 AM 81XXX
    Mon Oct 24 2011, 1:05:14 AM 81XXX
    Mon Oct 24 2011, 1:04:19 AM 409XXX
    Mon Oct 24 2011, 1:04:13 AM 409XXX

    the last 3 digits are identical from each LAN ip... the thing is 103 is IDLE at the the time of the event. the only thing i could thing of is both PCs have some simular software thats auto updating to a server with the same login thats being picked up on by webmonitor? the only traffic between those 2 minutes is to do with youtube and

    heres the traffic from both pcs during those 2 minutes

    Mon Oct 24 2011, 1:05:42 AM
    Mon Oct 24 2011, 1:05:21 AM
    Mon Oct 24 2011, 1:05:21 AM
    Mon Oct 24 2011, 1:05:14 AM
    Mon Oct 24 2011, 1:05:14 AM
    Mon Oct 24 2011, 1:04:41 AM
    Mon Oct 24 2011, 1:04:40 AM
    Mon Oct 24 2011, 1:04:40 AM
    Mon Oct 24 2011, 1:04:26 AM
    Mon Oct 24 2011, 1:04:25 AM
    Mon Oct 24 2011, 1:04:23 AM
    Mon Oct 24 2011, 1:04:23 AM
    Mon Oct 24 2011, 1:04:22 AM
    Mon Oct 24 2011, 1:04:21 AM
    Mon Oct 24 2011, 1:04:20 AM
    Mon Oct 24 2011, 1:04:19 AM
    Mon Oct 24 2011, 1:04:19 AM
    Mon Oct 24 2011, 1:04:18 AM
    Mon Oct 24 2011, 1:04:16 AM
    Mon Oct 24 2011, 1:04:16 AM
    Mon Oct 24 2011, 1:04:16 AM
    Mon Oct 24 2011, 1:04:15 AM
    Mon Oct 24 2011, 1:04:14 AM
    Mon Oct 24 2011, 1:04:14 AM
    Mon Oct 24 2011, 1:04:11 AM
    Mon Oct 24 2011, 1:04:11 AM
    Mon Oct 24 2011, 1:04:10 AM
    Mon Oct 24 2011, 1:04:06 AM
    Mon Oct 24 2011, 1:04:06 AM
    Mon Oct 24 2011, 1:04:00 AM
    might help reproduce what or why that the webmonitor is picking up on these random logs...

    just a hunch but seems like something to do with yahoo updates.
  15. gamer2win

    gamer2win Networkin' Nut Member

    hi, Toastman
    if there a firmware like the above for E4200? (supporting 3TB drive)
  16. Jacques

    Jacques LI Guru Member

    Hi Toastman.
    wonder what i saw in the log
    Oct 24 12:44:38 unknown dnsmasq-dhcp[11109]: DHCPREQUEST(br0) 74:ff:ff:ff:ff:d2
    Oct 24 12:44:38 unknown dnsmasq-dhcp[11109]: DHCPNAK(br0) 74:ff:ff:ff:ff:d2 wrong address
    Oct 24 12:44:39 unknown dnsmasq-dhcp[11109]: DHCPDISCOVER(br0) 74:ff:ff:ff:ff:d2
    Oct 24 12:44:39 unknown dnsmasq-dhcp[11109]: DHCPOFFER(br0) 74:ff:ff:ff:ff:d2
    Oct 24 12:44:39 unknown dnsmasq-dhcp[11109]: DHCPREQUEST(br0) 74:ff:ff:ff:ff:d2
    Oct 24 12:44:39 unknown dnsmasq-dhcp[11109]: DHCPACK(br0) 74:ff:ff:ff:ff:d2 Nicolas-Laptop
    tomato begins to assign wrong IP address, and then assigns the correct,
    should immediately allocate the correct IP address...
  17. Toastman

    Toastman Super Moderator Staff Member Member

    gamer2win -Not yet, the next issues will have it.

    Jacques - that's normal. One of your machines requested an IP of and your router declined the request (NAK) . The offending machine then asked for an IP and was offered the correct one, which it accepted.
  18. Jacques

    Jacques LI Guru Member

    OK thanks Toastman.
  19. kthaddock

    kthaddock Network Guru Member

    I found strange behave in: Qos => view details. When you use "Auto resolve addresses" then all source change from
    ex to hostname and and when you turn it off all is normal again.
    I have "Enable Auto-Discovery" on. Same in shibbys build 079V-AIO
  20. CistiC

    CistiC Networkin' Nut Member

    First of all sorry for my English.

    I have problem with miniDLNA, SAMSUNG TV and FullHD .mkv which stutter every 15 - 20 seconds.

    TV is connected by wire and .mkv has bitrate 9674kbps.
    When I copy from USB disk connected to ASUS RT-N16 (tomato-K26USB-1.28.7486.3MIPSR2-Toastman-RT-Ext.trx) over samba to my notebook, speed is cca 10000 kBps (wire), cca 7000 kBps (wireless) and cpu load of asus is 100%. So I thing the troughput of USB is sufficient.

    When I am playing .mkv on tv, cpu load of asus is still 0% and movie stuttering.
    When I am playing .mkv on tv from allshare application on my notebook (wireless) everything is ok.

    Is it normal? Is rt-n16 weak for hd movies? Is something wrong?

    Thank you.
  21. Toastman

    Toastman Super Moderator Staff Member Member

    I'm not a big user of miniDLNA, some of my customers do use it for playing MP3 and 720p/1080p movie files, but not at anything like that bitrate. I suspect the router is not up to this task. I'm sure you'll get more knowledgeable replies, anyone?
  22. Toastman

    Toastman Super Moderator Staff Member Member

    kthaddock, yes, you're right. It isn't happening in the normal builds (<7486.3). Teaman, do you have any ideas about the cause?


    Apologies, I believe I am seeing something different to you. I am now doubtful that I am seeing any real problem. Everything is OK now.
  23. though

    though Network Guru Member

    i stream movies on my network using the RT-N16 as my router all the time without any problems. i am on Tomato Firmware v1.28.7486 MIPSR2-Toastman-RT K26 Std

    attached is the details of a movie i am currently watching error-free. not sure if this helps or not. toastman.PNG

  24. Toastman

    Toastman Super Moderator Staff Member Member

    If it's really streaming at 15529 kbps, then yes, it proves that it is possible, Thanks for the screenshot!

    I would have suspected Tomato's HDD performance to be a limiting factor at those bitrates.
  25. teaman

    teaman LI Guru Member

    Hi kthaddock!

    It seems you have just found/run into a (new/unknown) problem... (thanks for bringing that up!). But still - I'm not sure if I understood what you mean or... what seems to be the problem :-(

    Would you be able to post a few more details and/or maybe some screenshots so we can have a better idea of what exactly you've been experiencing/seeing (what's actually happening)?


    EDIT: @Toastman - do we know at which 'point-in-time' (which commit/merge/change) those kinds of things started to happen? or... that thing/issue has been around for a while but hasn't noticed until recently - keep in mind that I'm still not sure what exactly we're talking about - a.k.a. what seems to be the problem ;-) Cheers!
  26. CistiC

    CistiC Networkin' Nut Member

    For me "is possible" is kind of the worse option :) Now I must determine where is problem.

    I tried to replace WD MyBook (640GB) for USB flash disk and same behaviour.

    I will try reformat from ext3 to ext2 if is lighter for rt-n16 (i don´t belive help)

    Strange is that the CPU when playing the movie shows 0% and when I downclock rt-n16 (200Mhz) there isn´t significant difference. Load 0% a movie stuttering same way.
    Otherwise minidlna works great with my TV. With the original firmware from asus television shows only unsupported format.
    I do not want to buy another box (NAS) :( ... RT-N16 is so great in conjunction with the tomato firmware from you.
  27. kthaddock

    kthaddock Network Guru Member

    I'm not home at the moment, comming back later today.
  28. Hexxer

    Hexxer Networkin' Nut Member

    Im sorry that i cant found a info. But im confused about that many files. Im on a WRt160N (300Mhz, 4MB Flash - running RAF1.28.9006 MIPSR2_RAF K26 Std-NOCAT).
    What file do i have to try? Am i right with tomato-K26-1.28.7486.3MIPSR2-Toastman-RT-Std.trx? or tomato-K26USB-1.28.7486.3MIPSR2-Toastman-RT-Std.trx

    Thanks a lot
  29. Toastman

    Toastman Super Moderator Staff Member Member

    Teaman, sure...

    I sent you a PM... but today, everything is actually normal here after all.

    kthaddock, waiting for your post when you get home, because today I'm not seeing what I thought I saw yesterday :confused:
  30. Toastman

    Toastman Super Moderator Staff Member Member

    Hexxer, yes, those seem to be OK.
  31. kthaddock

    kthaddock Network Guru Member

    Pictures without using "Auto resolve addresses": qos-view.jpg

    Pictures using "Auto resolve addresses": qos-view-Auto resolve addresses.jpg

    As you can se in "Source" raw, info is changing when use "Auto resolve addresses".
    Let me know is I can add more info to this.
  32. Toastman

    Toastman Super Moderator Staff Member Member

    Hmm. Yesterday I *thought* that I saw all clients display my own IP and hostname instead of their own. But today it isn't doing that and I had thought I was quite mistaken. Now I think I am under the influence of some mushrooms :confused: Presumably is your router's IP, so it's not quite what I saw, but similar.
  33. kthaddock

    kthaddock Network Guru Member

    Yes, Presumably is your router's IP.
    Maby it have something to do with auto discovery........:confused:
  34. teaman

    teaman LI Guru Member

    Auto-discovery for IPTraffic/cstats is about including new IPs in monitoring automatically - begin/start monitoring traffic from/to an address as soon as any traffic is detected (or flows) through the router...
    Therefore... no: nothing to do with auto-discovery :-/
  35. CistiC

    CistiC Networkin' Nut Member

    I try connect back my old WL500Gp with tomato-K26USB-1.28.7821MIPSR1-Toastman-ND-Ext.trx
    Same USB disk and .mkv... without stuttering

    I thing, something is wrong with rt-n16 or newer tomato or newer minidlna...

    I tried 1.28.7475 where is same version of minidlna like for wl500gp and there is stuttering.
    I tried Tomato Firmware v1.28.9054 MIPSR2-beta K26 USB Ext and there is stuttering
  36. tenskwatawa

    tenskwatawa Networkin' Nut Member

    I use Asus ns-rt16 with Tomato Firmware v1.28.0407 MIPSR2-Toastman-VLAN-RT K26 USB VPN
    It happens two times after few days.
    Processor usage 2-3% and in the log 150 same errors in one second
    miniupnpd[9297]: send(res_buf): Broken pipe
  37. Toastman

    Toastman Super Moderator Staff Member Member

    Anything that might have triggered it? Did you see this happening with RT branch? The VLAN branch is BETA and experimental. I haven't seen that error here in any version, though.
  38. onryo

    onryo Networkin' Nut Member

    Thank you Toastman for your advice.
    I am using (tomato-K26USB-1.28.7486.3-MIPSR2-Toastman-RT-VPN) on a new RT-N16. Behind the router we have 8 wireless connections. A LAN printer, our VoIP phones and LAMP server. Every device has a static DHCP including the server ( Everything is piped to out to our VPN provider on tun11. The idea that out phone calls are piped though AES256 to our VPN host is quite neat indeed :). Although the web server works fine though our client VPN (tun11) our host provider was not impressed (understandably) due to bandwidth usage. For this reason I need pass the WAN to port4 on the routers LAN so it is not sent through the VPN with the rest of the traffic. I would prefer not to loose any of the QOS, monitoring or ability to use the internal IP of this web server if possible. My question is what would be the most appropriate way of doing this? I know Teaman has done a lot of work in this area lately. Should I be using the VLAN-RT branch? If so what needs to be done? Any advice/help would be much appreciated.

    On a side note I use to work on a lot of wifi projects for BackTrack (Remote-Exploit). One of them was designing a Yagi antenna that has a forward gain of 20.88 dbi in free space. Some of the freak lobes hit 26.1 dBi. In practice we were getting decent speeds at over 5km with standard wifi gear. Now I am using this antenna on my router so some friends who live about 1.5km away can use my AP. If you are interested my design can be found here: or just google something like - onryo ultra long range antennas.

    All the best!
  39. buckle

    buckle Networkin' Nut Member

    Hi Toastman,

    I found the problem that is causing the graphs not to show! It turns out that some of the hostnames that I put had spaces and 's in them.. once removed all the graphs come up normally now. I noticed some others have had this issue as well; maybe this will help.

    Keep up the great work,
  40. Toastman

    Toastman Super Moderator Staff Member Member

    A space is used as a separator for multiple names, so that's quite useful to know. Thanks!
  41. airdrummingfool

    airdrummingfool Networkin' Nut Member

    Hey Toastman, thanks for the great builds! I'm using a Linksys E4200 and just wanted to share my experience with a few of your releases as it relates to 5ghz performance.
    • tomato-E4200-NVRAM60K-1.28.0407.1MIPSR2-Toastman-VLAN-RT-Std: performance on the 5ghz band seemed spotty and poor
    • tomato-E4200USB-NVRAM60K-1.28.0486.2MIPSR2-Toastman-RT-N-BETA-VPN: 5ghz performance seemed fine
    Do you anticipate any VLAN builds that incorporate the wireless driver used in 1.28.0486.2? (I'm not really sure what the difference is - both list the Broadcom driver in the About section). I really love the IP Traffic tool (Thanks Teaman!), and it would be great to have it and a stable 5ghz driver together on my router :)
  42. dadaniel

    dadaniel Network Guru Member

    PPTP is broken in 1.28.7628.1 @ Linksys WRT54GL. Connection works for 15sec, after that time there is no internet connectivity anymore but tomato still displays it is connected. I tried with original Tomato 1.28 and that works without any problems.
  43. pharma

    pharma Network Guru Member

    People's experience with different mods is what developers love and need! I'm also running Toastman's mod on my E4200, and also see a decrease in performance on both bands on the tomato-E4200-NVRAM60K-1.28.0407.1MIPSR2-Toastman. In my setup the Tomato Firmware v1.28.0406 MIPSR2-Toastman-VLAN-RT-N-BETA K26 USB Ext mod with Linux kernel and Broadcom Wireless Driver updates is much better performance wise when using both bands.

    Special thanks to the Tomato developers for your hard work and commitment.:)

    airdrummingfool likes this.
  44. spoz

    spoz Networkin' Nut Member

    Hi Toastman,

    I just updated from "Victek Tomato RAF 1.28.8525 ND + VPN" to "tomato-ND-1.28.7628.1-Toastman-VPN" on WRT54GL. Works great, thank you for all the developer of this great tomato firmware.

    I noticed one feature of Victek build that I would really want to see integrated on you firmware release. Since my internet connection is shared, I have used the "Per IP bandwidth limiter" on Victek firmware. Maybe in future firmware release you could put in that feature.

    Thanks again.
  45. Toastman

    Toastman Super Moderator Staff Member Member

    It was still there last time I looked! Try a different build.
  46. Cyanix

    Cyanix Networkin' Nut Member

    Greetings Toastman.

    New user of your firmware here, testing a Linksys E4200.


    I cannot manage to get the QOS working right, although i've read your guide.

    I currently have a 100 mb down/ 5mb up connection.
    The simple fact of switching QoS ON in the respective control panel cuts my download bandwith in half, regardless of the values i enter for up/ down.

    Can you help me please.

    Thank you.
  47. airdrummingfool

    airdrummingfool Networkin' Nut Member

    Thanks for this, Pharma! 1.28.0406.2 seems to be what I was looking for on my E4200. The 5ghz band is working fine, and it has the IPTraffic tool.

    Thanks again to Toastman, Teaman, and everyone else involved in these builds!
    pharma likes this.
  48. Toastman

    Toastman Super Moderator Staff Member Member

    Pharama, can you expand on what was wrong with 0407? The IPT Monitor was improved, but other changes were insignificant. (I'm trying to establish why 0406 should be any different in wireless performance ot throughput?).


    Cyanix, if switching on QOS cuts your downloads in half, that is because something in the QOS setup is telling it to do that, or QOS is failing because of incorrect settings. You have to find out what it is, and adjust accordingly.
  49. Cyanix

    Cyanix Networkin' Nut Member

    Well, it was my BF Killer Nic 2100 which was causing the bandwith issues, but only with specific firmwares... go figure...

    So, assuming i dont want to use wireless, and considering my setup (Cable 100/5, Gigabit Ethernet + Cisco E4200), which one of your multiple releases should i install ?

    My only interests are browsing and gaming (especially TCP/ MMO games), so i suppose it would be a very basic firmawre version.

    I've read about the famous "TCP Vegas" setting. Is it really effective ?

    Thank you.
  50. Torbjörn Hagel

    Torbjörn Hagel Networkin' Nut Member

    I'm running v1.28.7486 MIPSR2-Toastman-RT K26 Std on a Linksys E4200 but whenever I generate lots of torrent trafic, like 60mbps down and up at the same time my router starts to choke, cpu load has gone as above 4 at some point and that's just impossible to work with.

    It did get a little better after deactivating Inbound layer 7 but still chokes up from time to time, I've set up QoS with Toastmans guide, caping both up and down at 80% of my bandwidth (which uncaped is 100/100mbps fiber). Is it perhaps the amount of connections that are choking my router? it mostly happens when downloading a couple of torrents simultaneously.

    Any more suggestions on what I could/should do to get a better flow in my router? I bought the E4200 two months ago thinking it would be able to handle my speed successfully with the use of a good firmware but I'm not so sure right now, but I'm still guessing there are some issues with setting it up correctly for my connection.
  51. pharma

    pharma Network Guru Member

    Try setting it to 100% or 120%, adjust your torrent client's upload rate and play with your QOS category rate settings ... I don't have any problems downloading multiple torrents, web browsing, online gaming, streaming music simutaneously with different computers. Toastman's guide is a starting point but you need to make the necessary adjustments since everyone's computer setup and bandwidth priorities are different.

  52. MGP

    MGP Networkin' Nut Member

    Static DHCP/ARP conflict:

    - I rotate 2 WNR3500Ls (wireless: off) with 3 WAPs to serve 20-30 tenants.
    - All IPs Static/ARP bound.
    - I've used 10 Toastman-RT-Std builds:
    K26-1.28.7486.1MIPSR2-Toastman-RT-Std (current)

    #1 Problem arose when I deleted some 25 unidentified tenant MACs in StaticDHCP/ARP
    and entered Dummy MACs in their place. After saving the settings, I clicked over to "Device List". There, I found all the deleted MAC/IPs alongside their duplicated IPs (bound to Dummy MACs), leases in force. Rebooting the Router eventually broke their leases.
    I thought then, I could simply allow a scheduled Nightly Reboot to finish a job whenever I rearranged clients in ARP during the day. However, after a couple weeks of doing this, random tenants began to suffer permanent disconnections.
    So, I configured the disconnected tenants' clients to Static IPs.
    They then reconnected fine.
    I continued to move clients in "Static DHCP/ARP", not rebooting immediately.
    Again, after about a week, even the static configured clients were now disconnecting permanently.

    I did an "NVRAM Erase (Thorough)".
    Reconfigured settings manually.
    Configured clients back to default DHCP.
    But, I now reboot immediately after moving clients in ARP.
    No more disconnections.
    Perhaps a command can be entered to address this issue?
    I don't know how to.

    #2 Now, I happened to bind a new IP (xxx.15) to a certain client. But, I was unaware the
    Building Manager had manually configured this client to it's old IP (xxx.11). At first, the client did appear in "Device List" correctly matched to xxx.15. Afterward, I remembered seeing xxx.11 (disabled) logged in "Web Usage". Eventually it got disconnected, and the tenant complained.

    I swapped in the Twin WNR3500L (Different build firmware. Don't remember which).
    Entered at xxx.15, he was quickly awarded a lease to xxx.11, with Internet!
    I erased NVRAM on the first Router.
    Upgraded to new build firmware.
    Erased NVRAM once more.
    Entered him at xxx.15.
    Again, he was leasing xxx.11!

    Eventually, the Manager remembered to tell me what he'd done.
    I configured the client to default DHCP, and it was good at xxx.15.
    The client: HP laptop, Vista.

    I was not able to duplicate this with my own client devices.
    Maybe length of time configured with Static IP factors in.
    Don't know what to make of this one, just curious.

    Another Subject: B/W limiter
    It took me a few days to get the B/W limiter to work properly ...
    I don't remember my exact sequence of thought, nor what I saw. But, I'd come to a conclusion:
    Our 3 WAPs' (non-Tomato) IPs conflicted with the attached Wireless Client IPs in the Limiter table.
    B/W limiter settings that do work for us:
    - All Tenant IPs............... Limited + High Priority
    - All WAPs.................... No Limits + Low Priority
    - Enabled Default Class......... No Limits
    (No Unlisted IPs)
  53. Hackerivs

    Hackerivs Networkin' Nut Member

    Toastman, do you have plans to intergrate apcupsd into any of your future builds?
  54. Magyosha

    Magyosha Networkin' Nut Member

    I'm using Tomato Firmware v1.28.7821 MIPSR1-Toastman-ND K26 Mini
    on a wrt54gl in as multi user setup , small village with shared internet, between 30 & 50 clients.
    there are 3 users who seem to be very heavy torrent users so i have been trying to setup QOS to throttle them and limit there torrent connections. not had much success so far. i'm fairly confident i have the classifcations setup right but my problem now is the number of connections the torrent users are making . when i try and use the prerouting in the firewall section to limit them the wifi side of the router keep crashing after about 30 minutes whihc is a problem as i do not have physical access to the router only wifi myself so then everyone is offline until i can get into the office which is only open a few hours per day . my only workround has been to setup schedulign to reboot every 2 hours in case it crashes out thenonce it comes back up get on quick and disable all the rules while i scratch my head about why it crashed again.
    we have what is supposed to be a 7mb adsl line , 512k up.. i've set it to 4000/300 in the qos as the line is a bit flakey and we never seem to get full speed anyway nad am using the default ruleset that is there with an nvram wipe slightly changed to lower the p2p part even more, but as i said i don't think this is where i'm having problems it the connection limits in the firewall script going wrong and crashing it out.
    i'm using these 2 lines below.
    iptables -t nat -I PREROUTING -p tcp --syn -m iprange --src-range -m connlimit --connlimit-above 50 -j DROP
    iptables -t nat -I PREROUTING -p ! tcp -m iprange --src-range -m connlimit --connlimit-above 15 -j DROP
  55. DanielCoffey

    DanielCoffey Networkin' Nut Member

    Toastman, I am using your 7486.4 firmware on my Cisco E3000 and I am having a problem setting up the Dynamic DNS to point to I have registered with OpenDNS and can sign into their site but the router will not allow me to set up a DDNS entry for them.

    Firmware : Tomato Firmware v1.28.7486 MIPSR2-Toastman-RT K26 USB Ext
    Router : Cisco E3000
    ISP : Virgin Media (Edinburgh)
    Hardware : Mac Pro 2010 6x3.33GHz, 12Gb ECC RAM, ATI5870 1Gb, ACD 27", OSX 10.7.2 Lion

    In Basic - Network - LAN - Static DNS I have and and

    In Basic - DDNS - Dynamic DNS 1 I have selected OpenDNS (url, username is my email, password is my OpenDNS password. Network is blank, Use as DNS is ticked, Force next update is ticked and then I click Save.

    After some thought the router displays a short message in the Dynamic DNS 1 block saying "Invalid Hostname (1/3 : Automatically retrying in 16 minutes)".

    Any ideas if I am doing something wrong or have omitted a setting? I am a bit of a numpty when it comes to this stuff.


  56. Toastman

    Toastman Super Moderator Staff Member Member

    My web access is poor at the moment, but I'll try to get some quick answers across.

    hackerivs - no. I think very few people have use for it, but that may change in the future if I get enough requests.


    the limit rules work OK here, so not easy to tell you what the problem might be. However, to begin with, turn those rules OFF and then go to Advanced/Conntrack Netfilter page and check the timeout values are low - set most of them to the minimum (10) except for established TCP. That should keep the number of connections down. If they still get high enough to kill the router, I'd suspect a connection storm from one of those machines (perhaps caused by a virus). I assume you did clear NVRAM and set up from scratch when you flashed Tomato?​


    I've never used OpenDNS - but someone else did post something a few days ago, I seem to recall. Take a look on the forum and see if you can find it, also perhaps the poster will reply to you.​
  57. DanielCoffey

    DanielCoffey Networkin' Nut Member

    Thanks for the pointer to that previous post about OpenDNS. I didn't find the solution on that page but I did find it eventually... the error message returned by OpenDNS is incorrect and does not shed any light on the problem. There is a setting in your OpenDNS account you have to change first.

    To enable Dynamic DNS updates in OpenDNS...

    1. Sign into your OpenDNS account.
    2. Click the "Dashboard" tab if you are not already there.
    3. Click the "Settings" tab.
    4. Select your current network in the "Settings For...Select a Network" drop down.
    5. Click "Advanced Settings"
    6. Tick "Enable Dynamic IP Update" since it will be unticked by default.
    7. Click "Apply"

    Then, in your Toastman or Tomato Router settings, make sure you have entered your OpenDNS username and password (and optional Network name that you used in OpenDNS), click "Use as DNS" and "Force Next Update" and Save. You should see the date and time and the message "Update successful".

    I must say, by the way, that all the effort you have put into polishing up this firmware really shows! While there are many, many more options to bewilder the unwary than in the original manufacturer's firmware, the defaults you have chosen are sensible and the basic home router for a small household is a breeze to set up. It also seems to me that the web browsing response I am getting on my E3000 is much snappier than I experienced with the original Cisco firmware. I am not sure how much of that is ditching my ISP's DNS service but even so, it feels great!

    Many thanks,

  58. _wb_

    _wb_ Networkin' Nut Member

    Hello Mr. Toastman,

    I have a WRN3500L that I flashed with dd-wrt then tomato 1.28.4407 MIPSR2-Toastman-VLAN-RT K26 USB VPN+NOCAT. I erased and did a 30/30/30 but I am UNABLE to get an IP from my cable modem. I tried connecting another router to the cable modem and the IP is shown almost automatically.

    Any ideas? COnnection Type for WAN is shown as DHCP.
  59. Toastman

    Toastman Super Moderator Staff Member Member

    _wb_ - I'm strictly ADSL PPPOE here, so no experience with cable modems, but I believe this has been raised before several times. There are several people on here who probably know the answer to your question, I'm sure they'll be able to help.

    daniel - thanks for the compliment! The tip about openDNS will help several people I think. Thanks.
  60. _wb_

    _wb_ Networkin' Nut Member

    I appreciate your help Toastman. Your build is awesome. I just have to figure out the WAN issue I am experiencing. I posted a thread maybe I can get it resolved today. Thanks again.
  61. jsmiddleton4

    jsmiddleton4 Network Guru Member


    Did you turn off cable modem, turn off router. Turn on modem let it synch and then turn on router? You are sure you are plugged in WAN port on router?
  62. _wb_

    _wb_ Networkin' Nut Member

    @jsmiddleton4: I did cycle both devices as you mentioned before but did not work. Also, I am definitely sure the internet labeled port on the net gear router is the WAN on the router unless you tell me otherwise.
  63. Magyosha

    Magyosha Networkin' Nut Member

    toastman .. yes i had wiped nvram on setup ..
    lowered the timeout setting as you suggested and removed the iptables rules.
    then within 5 minutes of reenabling qos wifi went down again :( this tiem it came back up after about 20 minutes which was odd as status showed it had not rebooted so no idea why it took so long
    should i perhaps go back to k24, is that more compatible with the wrt54gl ?
    does not help i'm sure havign unreliable thai (pattaya) internet as it makes the max settigns hard to guage.. but that does nto explian the lockups
  64. Toastman

    Toastman Super Moderator Staff Member Member

    Sure, K2.4 builds are smaller, faster, and in my experience, generally more reliable for the GL. Worth trying. I have a few sites that I can still access which use GL's and they have around 50 clients, been up for 3 years. Also, worth trying older build too, 7515.2 was nice and stable, and had a different wireless driver. If that cures the problem, then work back upwards.
  65. JLongshanks

    JLongshanks Networkin' Nut Member


    Sounds like you need to change the MAC address of the WAN port. Cable ISPs identify their customers via their MAC address. So the MAC address of the WAN port on any router you use has to be the one you were originally setup with. (This is the case for me at least, with Virgin Media.)

    So get the MAC address of the WAN port from the router which works then change the MAC address of the WAN port on the other router to match, via the Advanced -> MAC Address page.
  66. Monk E. Boy

    Monk E. Boy Network Guru Member

    Normally you just need to power cycle (disconnect from power, connect to power) the modem after changing the system that's plugged into the modem. Sometimes the modems have a simple reset button on the back that you can momentarily press to reboot the router, on others you can visit and use it to perform a soft reboot on the modem. Obviously the latter only works if you perform the reboot moments before disconnecting the system/device from the modem.

    With VOIP cable modems, having battery backups built into the device, you typically need to reset the modem through hard/soft means, unless you crack it open and disconnect the battery after having disconnected it from power.
  67. jsmiddleton4

    jsmiddleton4 Network Guru Member


    When I had a 54GL the 2.4 kernel worked much better then that 2.6 kernel.


    I've never had to do more than make sure connections are correct, cables are good and as suggested turn everything off, modem on first then router.
  68. PJON

    PJON Addicted to LI Member

    Tomato on Toast review here.

    Any chance of adding a whatsnew.txt file with each update?
  69. Toastman

    Toastman Super Moderator Staff Member Member

    There already is - the readme file in each directory shows what is new, changed, reverted, reasons why, etc.
  70. PJON

    PJON Addicted to LI Member

    I was thinking of a small text file bundled with each release, but no big deal. Thanks.
  71. Toastman

    Toastman Super Moderator Staff Member Member

    There have been quite a few strange reports of all manner of things not working correctly in recent weeks.

    The fact is, there have been thousands of downloads and very few complaints. In most instances the reports have been by just one individual, mostly newcomers, and very few have been reproducible. Most people are finding both the RT and RT-N builds are stable. There are a few things, as always, that needed to be addressed.

    This is a dilemma. This has prompted me to revert the mainstream Toastman-RT (MIPSR2 K2.6) code to build on that of 7483.2 - leaving out the recent commits from Teddy Bear, before most of these claims began. I have added the latest IPTraffic Monitor from Teaman, which uses "cstats v2". This ought to be a stable build. I've tried to keep the IPV6 functionality as it was, but if it appears broken, I'll try to fix it. When I am happy with this build, that it has no weird bugs reported, I will build on it.

  72. kthaddock

    kthaddock Network Guru Member

    I have alot of this in my logg since upnpd get some error. using 0407-nocat, rt-n16
    I get alof of this message: Name daemon.err miniupnpd[13913]: send(res_buf): Broken pipe
    I restart Upnpd and all function is ok.
  73. altdel

    altdel Networkin' Nut Member

    I also get this message once in a while (seems to correlate with playing online games on the Wii).
    How do you manually restart Upnpd?
  74. kthaddock

    kthaddock Network Guru Member

    Turn "Enable UPnP" off-save and on-save then it should restart. (port forwarding => Upnp/nat-pmp)
  75. Toastman

    Toastman Super Moderator Staff Member Member

    kthaddock - try the build 7487 above - the upnp error messages seem to only have happened since the recent upgrades.

    I will fix it if/when I update to the latest code again.
  76. Toastman

    Toastman Super Moderator Staff Member Member

  77. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Tried 7487. Messed my routers up. One took over 7 minutes to flash 7487. Twice as long as normal. Had to telnet the old fashion way to reflash back to xx83.2. My opinion is something amiss with 7487.....
  78. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks for that, let's see what else we get. I've flashed it on most of my "active" routers, they are RT-N16's. The test E3000 took 3 minutes to flash (but it was a VPN-NOCAT build which is big). But I always found the E3000 took a long time to flash, so I'm not sure if it's normal or not. But it's working just fine afterwards. BTW - I believe the WDS is now fixed, but I haven't tried it myself. Needs checking ....
  79. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Average flash time is just over 3 minutes for me. Also once flashed with xx87 WDS broken and 2 laptops could not connect. Only way back on one of them was to telnet as noted. Back to xx83.2 and all is well in the wireless world for my network.
  80. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Also WPA seemed to be problematic. To get any connection at all had to disable security.
  81. gutsman7

    gutsman7 Networkin' Nut Member

    7487 Flash time just took 1 minute and 30 seconds and its running fine so far.
  82. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Could have been a bad flash but on two routers? Something wasn't right. Not technically literate enough to say what. The build 87 is built on works great for me. Tested both WDS and Ethernet bridge modes with WPA Personal AES. With 87 something was goofed. Don't know details but know goofed when I see it.

    Glad its working for others.
  83. Toink

    Toink Network Guru Member

    Hi, Toast!

    Thanks for the new build. I flashed my new E3000 from stock E3000 firmware to tomato-E3000USB-NVRAM60K-1.28.7487MIPSR2-Toastman-RT-Ext.bin. So far so good.

    Been trying to dowload the tomato-E3000USB-NVRAM60K-1.28.7487MIPSR2-Toastman-RT-VPN-NOCAT.bin version but 4shared somehow effed-up the link, I can't download it each time I attempt to do so. I think the particular file needs to be re-uploaded? Thanks
  84. javilin

    javilin Addicted to LI Member

    is the same,
  85. kthaddock

    kthaddock Network Guru Member

    I'm satisfied with my 0407-nocat build as that are the best performance build I have used latley.
    But I have to ask, do you plan to do a "0408"- build with every latest fixes included? I appreciate to have it !
    I have 32 days and 11 hour uptime right now !
    cost21 likes this.
  86. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, soon they'll all be the same as far as the latest updates are concerned.

    Toink, Javilin- I uploaded it again. It took 17 secs to download here so it definitely works now.
  87. pharma

    pharma Network Guru Member

    Just loaded "tomato-E4200USB-NVRAM60K-1.28.0487MIPSR2-Toastman-RT-N-VPN" on my E4200. Load time was normal ... no issues, performance good -- will post updates.

  88. robinhood1701

    robinhood1701 Networkin' Nut Member

    Thanks Pharma,
    Recently got a E4200 myself, am thinking about upgrading to Tomato to improve speed, please post updates !
  89. Jacques

    Jacques LI Guru Member

    Hi Toastman,
    In 1.28.7487 IP Traffic, Real-Time and Last 24 Houts
    will by very nice to have possibility to sort also by address IP,
    and be easier to read with bold character.
  90. Jacques

    Jacques LI Guru Member

    always my WRT610Nv2 and E3000
    took a long time to flash almost 4 minuts with soft 7Mo
  91. javilin

    javilin Addicted to LI Member

    It works, thanks.
  92. Toastman

    Toastman Super Moderator Staff Member Member

    November 14 2011

    Toastman-RT-1.28.7488 MIPSR2 K2.6 for RT-N16 etc.
    Toastman-RT-N-1.28.0488 MIPSR2 K2.6 for E4200 etc.

    Now 7487 seems reasonably stable, it has been merged with Fedor's latest udates from git. Now we're back to where we were, but with the improved IPTraffic Monitor (cstats v2) in the basic RT build. Like it or not, this wireless driver is in the git code, so we should try to get used to it. Your feedback will help Teddy Bear to make a decision on whether to keep it.

    MiniUPnP bugfix: (lly)

    • Fixed infinite loop in SendResp_upnphttp() (Syslog spammed with messages: miniupnpd[379]: send(res_buf): Broken pipe)
    • Consolidated CloseSocket_upnphttp() calls.
    Due to many changes in the firewall code to incorporate the IPTraffic Monitor into the basic
    RT builds, it is possible that the IPV6 operation has been affected. This needs checking.
  93. Catalin

    Catalin Addicted to LI Member

    In build 7488 the SAVE button does not work in Basic Network TAB, therefore settings cannot be modified.
  94. kthaddock

    kthaddock Network Guru Member

    Did you do a "Erase all data in NVRAM memmory (thorough)" after installing software ?
  95. Catalin

    Catalin Addicted to LI Member

    Like always. The SAVE button works for you in that specific tab?
  96. kthaddock

    kthaddock Network Guru Member

    I haven't tested yet I'm on 0487.1 and that's working, shall update soon to 0488.
  97. jsmiddleton4

    jsmiddleton4 Network Guru Member

    As noted "Save" is not working in Basic Network tab. I just tried it.

    Also don't remember all the setup stuff for things like WEP, Radius server, WDS, etc., showing up on Basic Network screen. As I remember only the stuff that was relevant would display. So IF you selected Radius Server, the setup for radius server would display. If you select WPA, only WPA stuff would show. WDS only show if you select WDS, etc.
  98. Catalin

    Catalin Addicted to LI Member


    It was working on 7487.
  99. kthaddock

    kthaddock Network Guru Member

    Okey I wait some time before I upgrade. That save me some headache :oops:
  100. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm going back to xx83.2
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice