Toastman Releases - up to 1.28.7492

Discussion in 'Tomato Firmware' started by jsmiddleton4, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, 7488 has a problem. Will update later. The first time I compiled it, it worked. But now it doesn't. (sob)...
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Jim, the "radius" stuff showing is not supposed to be there, it's only because of the same bug that stopped the page saving, which was due to the single-line MLPP code not merged correctly. I've fixed it now, just recompiling it and will upload soon.
  3. javilin

    javilin Addicted to LI Member

    I installed and it works great.
    Tomato Firmware v1.28.7488 MIPSR2-Toastman-RT K26 USB VPN-NOCAT
  4. Jason404

    Jason404 Addicted to LI Member

    Where are these builds?

    I spoke to Toastman, who said the build I am using was old, and there are much newer builds than I was using (tomato-K26USB-1.28.2405MIPSR2-Toastman-VLAN-MultiSSID-BETA-VPN-NOCAT) which had the VLAN GUI, but I cannot find them anywhere.

    Apparently his 1.28.7626.1 and 1.28.7628.1 builds have VLAN GUI support, but I cannot find them in amongst the downloads.

    (I've got a Netgear WNR3500L)
  5. jsmiddleton4

    jsmiddleton4 Network Guru Member

    the same bug

    Figured that was the case. Just letting you know what else was off a bit.
  6. Low-WRT

    Low-WRT LI Guru Member

    Hey Toastman,
    .7483.2 is the latest VPN build I can load on my RT-N12...In the newer builds, the "File is too big to fit in MTD."
    Is there a way around this? If not, is there an earlier build that is "rock solid"? Thank you.

  7. Toastman

    Toastman Super Moderator Staff Member Member

    Jason404 - you must look in the ND (MIPSR1 - Older WRT series etc.) if you need those builds 1.28.7626.1 and 1.28.7628.1 that you asked for. Because of that, I had perhaps misunderstood from your mail you were using an older router.

    If you really are using a 3500L then you need MIPSR2 K2.6 builds, there are a great many of those including the ones mentioned below. VLAN builds will follow shortly. Download and look through the readme files in each download directory to find out what is in the builds.

    Low-WRT - I'll take a look, should be possible.

    "Save" bug fixed
  8. Catalin

    Catalin Addicted to LI Member

    7488 working fine so far. Thanks!
  9. Looking forward to installing the newest 1.28.7488 (now running latest official TomatoUSB, which is quite old nowadays), but there is no Non-USB version for the E2000. Will this one be available sometima later?
  10. As far as I know, the E2000 doesn't have an USB port. At least, I couldn't find one and it isn't in the specs either.
    Up to 7488 there always was a FW with and without USB support, so I don't know what happened with the makefile in this version. (Maybe because you added a NoCat version)
  11. Lior

    Lior Networkin' Nut Member


    I installed 2 versions 0488, 7488 and the same also with the former
    The problem for me once I install these versions can not connect Lrator handset, I checked on 2iPhones and laptop both he connects to 5 seconds and disconnects right, as soon as I put theversion of the LINKSYS everything works correctly, you can help me here?

    Router I have is E3000
  12. Toastman

    Toastman Super Moderator Staff Member Member

    nobugme - Thanks for pointing it out.

    Lior - without having one of those devices to try, I wouldn't have a clue how to fix that. Sorry. Maybe someone else has some advice? Could be something to do with the APSD power saving mode...
  13. slyderz

    slyderz Networkin' Nut Member

    IPv6 using 6to4 anycast relay doesn't appear to be working in 7488
  14. kthaddock

    kthaddock Network Guru Member

    I have tested 0488-nocat and problem with save-button is still there, basic =>network=>save. I'm back to 0407-nocat.
    MD5: 6F845337024D6553FC7CD36066784485
  15. jsmiddleton4

    jsmiddleton4 Network Guru Member

    WDS working. Save working. Display for Basic Network is correct regarding radius, wds, etc., setting display. I can't test IPV6.

    Using the simple USB EXT version.

    2 E3000's.
  16. Lior

    Lior Networkin' Nut Member

    Hey TOASTMAN ,

    I checked the version


    On my E3000 and it seems that the wireless network works fine,but I encountered another small problem I not have remote access to ROUTER(not inside the network out side the home), do you know this problem? Other equipment l so can not access the router remote lythrough the NAS, for example my but into router i not have access
  17. kthaddock

    kthaddock Network Guru Member

    You can turn remote access in Web Admin =>Remote Access=>HTTP/HTTPS or a better way is to enable SSH.
    Do a port forwarding to yor NAS and connect, nas port or set up Dyndns account
    then you can connect with: http// port
  18. Lior

    Lior Networkin' Nut Member

    i have

    i try https/http
    But that still does not work, if I write port 80 so I get to my NAS to ROUTER correctly but I can notget to like having something blocking precisely the ROUTER
  19. kthaddock

    kthaddock Network Guru Member

    Port forwarding=>Basic=>ext port 6117=>int port 6117=>int adress 192.168.1.???
    then you should connect with this from wan-side:
  20. Lior

    Lior Networkin' Nut Member

    it's not work , any idea?
  21. kthaddock

    kthaddock Network Guru Member

    Hmm if that doesn't work I should do a "NVRAM memmory thorough" reset and configure again by hand.
  22. Lior

    Lior Networkin' Nut Member

    try it too and it doesn't work...

    whit version from (beta) all working ok but other version (old and new)
    doesn't work (problem whit wireless i have too
  23. kthaddock

    kthaddock Network Guru Member

    Okey, Then you have to post screen shots. It's easier to see whats going on then.
  24. kthaddock

    kthaddock Network Guru Member

    Just loaded 0488.v3-nocat and its seem to work.
    Under USB storage support => Automount=> Automatically mount all partitions to sub-directories in /mnt.
    If I unset that option I'ts still automount to /mnt (sda1, sdc1) thats working in 0487.1-nocat

    This in smb.conf:
  25. jhigh2000

    jhigh2000 Network Guru Member

    I recently upgraded from my old WRT54g V2 running Tomato to the E4200 and am looking for the best Toastman edition for my new router. Could someone explain or point me to a link/sticky that explains the differences between these editions (I'm sorry if this is explained elsewhere)?

    Edit: I understand what USB/VPN/VLAN is for, I just want to make sure I understand the naming conventions.

    tomato-E4200-NVRAM60K-1.28.0407.1MIPSR2-Toastman-V LAN-RT-Std.bin
    tomato-E4200-NVRAM60K-1.28.0407.1MIPSR2-Toastman-V LAN-RT-VPN.bin
    tomato-E4200USB-NVRAM60K-1.28.0407.1MIPSR2-Toastma n-VLAN-RT-Ext.bin
    tomato-E4200USB-NVRAM60K-1.28.0407.1MIPSR2-Toastma n-VLAN-RT-VPN+NOCAT.bin
    tomato-E4200USB-NVRAM60K-1.28.0407.1MIPSR2-Toastma n-VLAN-RT-VPN.bin

    I'm also curious about the wireless performance difference people have seen with Tomato on the E4200 over the stock firmware.

    Thank you.
  26. Toastman

    Toastman Super Moderator Staff Member Member

    7488.1 posted - the IPV6 6in4 is fixed.
  27. Toastman

    Toastman Super Moderator Staff Member Member

    Std is the base build
    Ext is Extras - contains almost all variations and extra utils
    VPN has the OpenVPN built on top
    VPN-NOCAT also has splashd web portal (aka NoCatSplash)
    The last VPN version is a cut down VPN version for routers that can't take the EXT build.
  28. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Had to reboot to resynch WDS. Some times I do, some times I don't. Have yet to figure out why or when I have to or don't.

    Synched right up. I see no issues with any of the screens.

    I have a network printer connected via wired lan to my home network system that can do IPV6. I have no idea what to set the router up to do for a LAN attached IPV6 device. My ISP does not do IPV6.
  29. Toastman

    Toastman Super Moderator Staff Member Member


    I tried to set up a Hurricane Electric IPV6 tunnel, but for some reason nothing seems to work. I'm going to try again using advice from "gs44" .. who has it working. It's possible we have a block on it (gov..) I suppose.
  30. magnus33

    magnus33 Network Guru Member

    Sniff sniff i can only watch i bought a E3200....the pain the pain.
  31. Lior

    Lior Networkin' Nut Member

    I played with The Router and after many installations of versions I decided to do a master resetbecause I had filled with problems, I found web servers that reset 30/30/30 30 with electricity 30without electricity and over 30 with electricity, after I did this, your router is not getting addressaccording to, but there is no access to router, ping test to router all is well, also haveaccess to in TELNET but still do not have access to the router itself and there is not much you can do via TELNET, can be router now in how I brick out of this situation ?
    Even if you have responsibility for the router but still, always fun to solve yourself:)
  32. Toastman

    Toastman Super Moderator Staff Member Member

    Did you set a fixed IP on your PC and gateway to the router? I guess you did, because you have ping replies.... hmmm.
  33. Toastman

    Toastman Super Moderator Staff Member Member

  34. pharma

    pharma Network Guru Member


    Quick question .... The "tomato-E4200USB-NVRAM60K-1.28.7489MIPSR2-Toastman-RT-VPN" only has 2.4 ghz capability (Single radio)? Correct?

  35. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, it's the RT version - so it has the limitation of the old wireless driver - but some people still prefer it. I will be uploading the RT-N versions of these builds later. Followed by the VLAN versions. Just have a lot of work to finish first (real work).

    The RT-N builds are needed to get 5GHz working on the E4200.
    cost21 likes this.
  36. Just a last check before I install 1.28.7488.2 + VPN for the E2000: has the 'save'-button bug been fixed in this version?
  37. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, everything is fixed. Unless there's something else? (There's always something else ....:p)

    I will upload RT-N and VLAN-GUI versions when I've compiled and done brief tests. That may take a day or two.
  38. jsmiddleton4

    jsmiddleton4 Network Guru Member

    .2 version?
  39. jsmiddleton4

    jsmiddleton4 Network Guru Member


    If you can get pings you should be able to send firmware to it via telnet. Look for routertools. Download stable firmware like the xx83.2 version and use routertools to send the firmware via telnet.

    Not router tools. Let me do some looking. Its router something or other.
  40. jsmiddleton4

    jsmiddleton4 Network Guru Member

  41. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Tried to test IPV6 but don't know enough about it to make it work with my wired printer. Printer just turns off IPV4 and on IPV6. Turn on IPV6 and it has the longer IPV6 IP but looks to router for everything else.
  42. Jacques

    Jacques LI Guru Member

  43. Lior

    Lior Networkin' Nut Member

    thank's for help ', but i have error when i load frimware i have error message ( i upload image)
    i tried 2 frimwares from here and the orginal from linksys but i still get the same message

    Attached Files:

    • op.jpg
      File size:
      102.4 KB
  44. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I have used version xx83.2 and uploaded with the router tool utility. Make sure file is completely down loaded and it is named x.bin.
  45. jsmiddleton4

    jsmiddleton4 Network Guru Member

  46. Tom Parkison

    Tom Parkison Addicted to LI Member

    This this mean that WAN-side IPv6 has been fixed?
  47. DanielCoffey

    DanielCoffey Networkin' Nut Member

    Toastman - did you do anything amazing to the WiFi performance between 1.28.7486.4 and 1.28.7488.2 RT-Ext builds?

    The reason that I ask is that when running SpeedTest on my iPad2 across my E3000 under 7486.4 I saw a highly variable 3-7Mbps with quite a few "sawtooth" shapes visible in the SpeedTest graph but today under 7488.2 I am getting a very consistent 14-16Mbps with a fairly level SpeedTest graph even at peak times. This is across a 30Mb Virgin Media Cable connection.

    Hardware used :

    Mac Pro 2010 6x3.33GHz, 12Mb ECC, ATI5870, ACD 27"
    E3000 router
    Virgin Media SuperHub in CableModem mode

    The results were consistent regardless of whether I used the 2.4GHz or 5GHz bands and showed none of the sawtooth shapes I had observed under 7486.4. I suppose it is possible that a major source of interference has gone but even so, the speeds I saw under 7486.4 had been relatively consistent and never higher than 7Mbs at any time, even off-peak. Now I am getting a lovely 14-16Mbs to the same server at a decent cross-section of times of the day.

    If you *did* do something to affect the WiFi - thanks!

  48. Lior

    Lior Networkin' Nut Member

  49. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Dont know why but I'm getting stalls on wireless clients. Going back to xx83.2.
  50. jsmiddleton4

    jsmiddleton4 Network Guru Member

    No stalls with xx83.2 firmware.
  51. tomatofan2011

    tomatofan2011 Networkin' Nut Member

  52. Toastman

    Toastman Super Moderator Staff Member Member

    Tomatofan - That's good news! So it seems there's nothing wrong with the refurb. E3000 then. Great!

    Danielcoffey - No, nothing special.
  53. kthaddock

    kthaddock Network Guru Member

    This is cosmetic, Under "bandwidht" is daily, weekly, mothly but under "ip-traffic" is daily, monthly missing weekly.
  54. Toastman

    Toastman Super Moderator Staff Member Member

    That's true. Maybe when Teaman has time he may take a look, and perhaps add it ? I seem to recall looking at this once before, there was a lot of maths involved.
  55. Toastman

    Toastman Super Moderator Staff Member Member

    I'm uploading the RT-N builds and VLAN equivalents of 7488.2 shortly. This is done automatically by an uploader and may take a while to synchronize as my upload speed is rather low. Keep checking :p

    All builds now contain (most of) Fedor's latest udates from git.

    To recap:
    • Single-Line MLPPP fixed
    • Fixed infinite loop in SendResp_upnphttp() (Syslog spammed with messages: miniupnpd[379]: send(res_buf): Broken pipe).
    • Consolidated CloseSocket_upnphttp() calls.
    • Fixed missing IPv6 address in Overview/LAN
    • IPV6 6in4 firewall config fixed
    • Fixed missing IPv6 address in Overview/LAN
    This also marks a change to how I build these versions.

    VLAN versions are now built from the RT and RT-N branches, but with
    VLAN=y flag set at compile time. This makes it an ideal time to tidy up the
    numbering scheme to make it easier to relate to the different builds.

    Some builds will therefore change their numbering.

    The first digit will identify the different builds but the number following will allow an instant
    comparison between builds, as it remains the same.


    7 488.2=Normal RT build
    0 488.2=RT-N build for E4200
    4 488.2=VLAN-RT build
    2 488.2=VLAN-RT-N build for E4200

    Consult the readme files in the build directories for information on the build contents.

    Don't forget to erase NVRAM after flashing these builds, reconfigure
    from scratch OR by cut and paste following this guide:
    cost21 likes this.
  56. Toastman

    Toastman Super Moderator Staff Member Member

    DJRoby, let me tell you once more. When people wish to respond to your mail they will do so. This is NOT a social networking site. You are not banned from making sensible comments or questions but this endless spamming has to stop.

    When the build is ready it will be announced.

  57. Toastman

    Toastman Super Moderator Staff Member Member

    Just for the record, while the members of this forum will do their best to help other members out with their problems or questions, this is not a social networking site and it isn't here to keep people entertained. Before posting your questions please use the search facilities and google. The chances are that your questions have been answered before. Keep questions to the point and supply as much information as possible.

  58. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Hitting N build now with a couple of different laptop clients. No stalls so far. Still can't figure out how to setup my IPV6 option printer and LAN side to test IPV6.
  59. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I'm not an IPV6 expert by any means, not even an IPV4 expert. But it seems to me, and this isn't a complaint, the IPV6 stuff is not a IPV6 DHCP server kinda of code yet for the LAN side?
  60. pharma

    pharma Network Guru Member

    Best bet would be to try a Google search regarding IPV6 uses in home networks and setting up printers ... it might involve hardware setup issues in your computer setup. Developers rarely have the time to "hand hold" with each user when they come out with new features, and since the primary developer of that "new" feature rarely posts in this forum other options seem best.

    A better solution would be to start a new forum thread in case others in the general Tomato population are either trying to do the same or have a working knowledge of what to do.

    Good luck!

  61. jsmiddleton4

    jsmiddleton4 Network Guru Member

    That's fine but Toastman wants to know if IPV6 is working. I've got the printer setup for IPV6. Its the router setup that is the variable. Printer is IPV6 Off or On. The printer is connected via LAN to the router. Not connected to my computer in any way.
  62. Toastman

    Toastman Super Moderator Staff Member Member

    Just woke up. GM!

    Yes. It would be nice to know if the IPV6 support is complete. The fact is that the primary IPV6 developers aren't around at the moment and the rest of us don't have any way to test this stuff. Due to complete lack of familiarity with the whole IPV6 thing we're all mostly groping in the dark here. Most of my experiences with IPv6 here have been fruitless, and help from a coupla guys here and on TomatoUSB has been invaluable.

    Whether the OS is trying to use IPV6 or IPV4 for the printer is another variable.
  63. jsmiddleton4

    jsmiddleton4 Network Guru Member

    For my setup I'm thinking the OS is irrelevant. Printer connected directly to router. I can get the printer to see a gateway address with IPV6 but seems like the router doesn't see the printer. It never shows up in Device screen.

    I also am quite in the dark with IPV6. I'm guessing but it looks like what the IPV6 stuff does is work with an ISP what is doing IPV6 and the router connecting to it. So the router can connect to an IPV6 ISP.

    I think it is a different matter for an internal IPV6 DHCP server in the firmware code for attached LAN devices that can do IPV6 to get connected to the router.

    Also for one of them, can't remember which IPV6 mode now as I messed with all of them, when turned on I had to reboot the router to reconnect WDS. Only for one of them. Must change something internally, write something to a different place in memory, something.

    But again GUESSING.

    Edit: The router will connect to a modem of some type and the modem does IPV6 right? It hands off IPV6 IP's to the router.... So the router is doing NAT with IPV6 IP address on the WAN side. What's it doing on the LAN side? I'm so confused.
  64. metroplex009

    metroplex009 Addicted to LI Member

    Hi Toastman,

    Mad props for all the handwork. I am running a RT-N16. Upgraded to v1.28.7488.2 (tomato-K26USB-1.28.7488.2MIPSR2-Toastman-RT-VPN.trx). For some reason when I unplug my Macbook pro's wired connection and plug it back in I loose my IP under 10secs and can't communicate with the router. This seems to be the case with any device that was once plugged and then unplugged. NVRAM was flashed after upgrade. I tried wiping all configs router is running on defaults for now.

    Any help will be appreciated.

  65. metroplex009

    metroplex009 Addicted to LI Member

    Update to my testing. I have tried booting the router and then plugging in my devices and getting the same result. I have tried different ports on the router as well. I have also notice that the processor is running at 133MHz and if I save any configs I find my that my ip lease has ended and not renewed
  66. kthaddock

    kthaddock Network Guru Member

    I have loaded 2488.2-nocat and it's working JUST fine. I have discovered one new nice feture,
    Staus => Device list => interface => when a "interface" have disconnect it's dissipear from list, br0, eth1.
    Thank you nice work, Toastman. :D

    Attached Files:

  67. Toastman

    Toastman Super Moderator Staff Member Member

    November 19 2011

    Uploading shortly:


    New - from Jean-Yves Avenard (in VPN Builds):
      • OpenVPN enhancements & username/password only authentication
      • PPTP VPN client integration and GUI
    Setup Screen:

    PPTP Client.png

    Thanks, Jean-Yves!
  68. Toastman

    Toastman Super Moderator Staff Member Member

    Metroplex009 - no ideas on that one. Sounds like you've lost IP and need to renew the lease.

  69. jsmiddleton4

    jsmiddleton4 Network Guru Member

    The problem right now with trying to analyze or note any stalls is the DNS server problems going on with my ISP and on some networks here in the US.

    One article on it:
  70. jsmiddleton4

    jsmiddleton4 Network Guru Member

    What are we banging on with xx89 to test? Is it just the VPN stuff that is added to xx88.2 version?
  71. pharma

    pharma Network Guru Member


    It's good to know I'm not alone. ..:) Since I'm in the mood now think I'll join you and try .0489.
  72. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I prefer the 00xx versions. Newest wireless driver.
  73. metroplex009

    metroplex009 Addicted to LI Member

    Well seems like the new build seems to have fixed my issues :) Thanks for all the help and awesome work
  74. Toastman

    Toastman Super Moderator Staff Member Member

    Metroplex009 - I'm glad about that, though I can't claim credit for doing anything :D
  75. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Thanks but its router to router on the WDS channel not client to router. I already have that stuff turned off in advanced wireless settings.

    And "Auto" works fine to keep WDS channel on the higher speed protocol with 0488 as well as 7488.2 etc.

    Staying at 0489 with "N" selected manually, at least for the day. :)

    Also I'm leaving IPV6 stuff alone for now until we hear from someone who actually knows IPV6 stuff for LAN attached devices.
  76. emporer

    emporer Networkin' Nut Member

    Just joined and am going to grab a toastman f/w for my e3000, been using the old 1.28 tomato from over a year back but its just not good for me, dropouts and plays havoc with my satellite boxes.

    One thing though, ive noticed there are 3 different versions for the e3000 usb, ext/vpn-nocat/vpn - can someone explain the differences for me as i'd like the correct one before flashing, ive looked around a bit and cant see anything obvious explaining the difference.
  77. jsmiddleton4

    jsmiddleton4 Network Guru Member

    The versions are based on your need. Do you have external hard drive or printer attached to the router? Do you use VPN? Do you have wireless access point for clients to log in to? Have VLAN's setup?

    If no to any of those things you just need the std version.
  78. pharma

    pharma Network Guru Member

    Toastman's explanation:
    Std is the base build
    Ext is Extras - contains almost all variations and extra utils
    VPN has the OpenVPN built on top
    VPN-NOCAT also has splashd web portal (aka NoCatSplash)
    There is also more on the Wiki page ...
  79. emporer

    emporer Networkin' Nut Member

    got it flashed ok, big probs though, wifi is just not playing ball and my usenet speed is non existant, more playing needed
  80. Mercjoe

    Mercjoe Network Guru Member

    On a WNR 3500L, 4489 is defintely buggered as far as wireless speeds go. WDS went from a constant 54 to a 18-36 flucturations with lag time galare.

    NVRAM reset each time on the main router, the remote router was untouched. I have both routers wireless set to G only in all configurations..

    When I rolled back to 4488.2 all is well again.
  81. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I thought I had WDS speeds taken care of with manual selection of 'N' protocol instead of 'Auto' but I just checked and I'm back to 54 speed instead of 300. Going back to 0488.2.

    Does seem to be if I have 0489 on both routers, master and slave. If I put 0488.2 on one, both routers report the higher speeds.
  82. Toastman

    Toastman Super Moderator Staff Member Member

    Mercjoe - that's very interesting. Same wireless driver. I will look again to see if anything changed to impact this between the 2 versions. But basically, the only changes were VPN - nothing that should affect wireless.
  83. Mercjoe

    Mercjoe Network Guru Member

    Yeah.. I know it is weird. From what I can follow in the GIT, you hit nothing that is wireless related.

    I typically spend an hour or 2 doing testing before I report a bug. I like to make sure that it is not an operator induced error. I can replicate the lower wireless speeds with ease. I have found that the WDS link speed to be a quick indicator of overall wireless performance.

    The android phone and the Wii both show lag when using them, but my laptop browses just fine. Buffering may be the main difference.

    Want to know something equally weird?? My wife and I feel that 4489 is FASTER in the loading of web pages. It definitely has a lower lag time in the MMO we play together. In the game we can monitor ping time to the server and it dropped by about 15ms using 4489. Again, this decrease in ping time is repeatable.

    Our machines are wired into the main router. The wireless may work better in 4488.2, but the internet to the wired computers on the main router we have found to be subjectively faster with 4489.
  84. paladin252

    paladin252 Networkin' Nut Member

    i installed 7489 vpn nocat on my WNR3500L that i use as an access point attached to an RT-N16 both running toastman and when i did it wiped all my settings, changed the MAC addresses to strange different numbers and the cpu no longer defuaults to 480 but 450 instead and i can't change it even when i try and force it to change.
  85. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "I will look again to see if anything changed to impact this between the 2 versions."

    I may have tested too quickly to see similar behaviors in both 0488.2 and 0489 versions. Now that I've gone 24 hours with 0488.2 it in WDS mode demonstrates similar behaviors with the tx/rx speeds between the two routers. I have no lags, or stalls as another user calls them, but with 0488.2 by tx/rx speeds drop back to displaying 54G speeds for router to router connection. If I set it to "N" protocol manually not "Auto" the display stays at "N" protocol speeds unless there is no traffic for some time. I do not know the time period it takes but clearly after a certain time period and no traffic between the routers I am seeing the 54G rx/tx speeds. Its as if when it wakes up it only wakes up to 54G speed OR it is a cosmetic thing and the display only gets 54G information. Which it might be. The connection might actually be "N" 5 ghz connection and the tx/rx information is incorrect.
  86. Toastman

    Toastman Super Moderator Staff Member Member

    That's good observation. One poster who did some similar tests with file transfers yesterday reports the same, but not noticed the displayed speed changes, I'll ask him if he's seeing it. I wonder if it's anything to do with power saving, APSD mode. With this new information, what would be your preferred choice for the E3000?

    Just posted this in response to wireless related queries:
  87. Toastman

    Toastman Super Moderator Staff Member Member

    November 20 2011 - Toastman-RT-1.28.7489.1

    Fixed PPTP when used over WAN setup using PPPoE

    (VPN Builds)
  88. hawkmat

    hawkmat LI Guru Member

    Hi Toastman! I discovered something very interesting. I run a fleet of E4200 and RT-N16 running 0489 and 7489 respectfully. I have always found that adjusting the Transmit Power had no effect on any of the routers. It did not matter if I set it to 0, 1, 17, 60 or 200 because inSSIDer always showed the same out put level. I have always used the standard Tomato Color Scheme. Today I tried the Cisco theme and behold I can now change the the Transmit Power level! inSSIDer clearly shows the changes now. There must be a problem with the Tomato scheme and making changes. Thanks for the great effort you put into these firmwares.
  89. Lior

    Lior Networkin' Nut Member

    Hey Toastman,

    I checked the versions of your new and old, I found something strange, that once I start a remote access router, the wireless stops working (computers connect and disconnect a few seconds straight)

    If I disconnect eliminates the Lrator remote access, wireless network is working correctly

    Is this a bug? Or is it the problem of stress and how to solve it?

    my router e3000

    What could be different for others it works and it makes my problems?
  90. ledek

    ledek Networkin' Nut Member

    This has probably already been answered all over this forum, but I cant find the info...

    Short version:
    Can I flash my F7D4301 with "tomato-K26USB-1.28.0489MIPSR2-Toastman-RT-N-Std.trx" from 4shared? Anything I need to consider to make my first tomato install less-than-painful?

    Long version:
    According to this post:, support for the Belkin F7D4301 Play Max wireless router has been added. Yesterday I went and bought one and checked out 4shared to find the correct firmware version.

    But I'm slightly confused, since based on the names of the bulds none supports the F7D4301...
    0486 (referenced in the linked post), has versions named: E2000, E3000, E4200, F7D8235v3, F7D3301, F7D3302, F7D4302. But not F7D4301. Neither do any of the later versions.
    My guess is that a generic RT-N build like "tomato-K26USB-1.28.0489MIPSR2-Toastman-RT-N-Std.trx" should work just fine. But since my second question would be "what happens if I try to flash the wrong version?", I dont want to chance it. Also I've seen mentioned that the file should be renamed .bin before flash. True?
  91. Toastman

    Toastman Super Moderator Staff Member Member

    Ledek - These routers all got supported around the same time by Teddy Bear's code commits. The F7D4301 is mentioned in several places as being supported. The other models you list are also mentioned and have special builds for them, as presumably this was found necessary. One can therefore probably assume that since the FD4301 is mentioned as being supported and yet doesn't have a special build, that it doesn't need one. My guess is therefore the same as yours.

    I have no idea whether the FD4301 needs a .trx or a .bin file, but you can usually rename to whatever is necessary. I'm sure if you try to flash the wrong one it will tell you. As for flashing the wrong build, unless Teddy Bear makes a post to confirm the above, then someone will have to chance it, I suppose. Maybe someone already has, if so, would you care to post ?
  92. ledek

    ledek Networkin' Nut Member

    I'll try it then.

    Just rather ask and look like a fool than not ask and be a fool. :p

    Will post, just have to fix a few other things first.
  93. Toastman

    Toastman Super Moderator Staff Member Member

    Good luck, I have my fingers crossed for you !
  94. MaX PL

    MaX PL Networkin' Nut Member

    hey toastman, or anyone that can help me...

    after upgrading to your latest 89.1 build which had a significant improvement in signal quality over the latest raf build, the only device that could connect to the E3000 was my laptop.

    my brothers laptop and his xbox could not connect at all after a few reboots of the router.
    i reset his tcp/ip using a script microsoft suggested, one that has worked for me in the past, but no success either.

    anyway, after all those attempts, i tried to clear the nvram under admin and thats where ive run into trouble.
    i waited the 60 seconds plus extra for it to reboot and now cant get access to router. wireless network is up but i cant get to and it seems like ive bricked it

    any suggestions?
  95. kthaddock

    kthaddock Network Guru Member

    No I don't think so, DHCP is disabled by deffault. Set static IP and login
  96. MaX PL

    MaX PL Networkin' Nut Member

    you dont think what? that its bricked?

    and yeh the odd thing was that dhcp was enabled by default. in the basic tab right above mtu, dhcp was listed as active. lan dhcp is disabled though.


    okay got in after i set a static ip. whats the best course of action to reset everything back to defaults and get all the devices connected?

    should i attempt another nvram erase or what?

    thanks and keep in mind i know very little about networking. love the stability of tomato and ddwrt so thats why i come here.
  97. kthaddock

    kthaddock Network Guru Member

    DHCP abowe MTU is DHCP on WAN-side, ex to your Modem or LAN. I'm not sure where it's in your build as a use VLAN-build but it should be in LAN-section. Then best reset is todo it in Admin => Configuration=>Restore Default Configuration and then config all again by hand.
  98. MaX PL

    MaX PL Networkin' Nut Member

    lan dhcp is in the same section under basic. sorry about that.

    gonna try to set everything back up now. hopefully all devices connect.
  99. MaX PL

    MaX PL Networkin' Nut Member

    uh man still cant get anything to work.

    i think all these ip conflicts are screwing something up. cant get online with the other router now either and am forced to directly connect.
    ive never been so stumped.

    got a bunch of dns server errors so i reset my modem and now my old router is online.

    the e3000 is still basically a brick. it connects wirelessly sometimes and other times it doesnt. i think i'm gonna try flashing another build because clearing the nvram doesnt seem to work.

    the cpu frequency is listed as 133MHZ as well for some reason.
  100. MaX PL

    MaX PL Networkin' Nut Member

    this is what was happening to me on the latest RAF build so i tried Toastmans latest build and it introduced the problems i described in my posts above.
    drops down to 54 in the config page yet windows showed 200-300. Toastmans build maintained 300 yet introduced new problems.

    i'll be trying 88.2
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice