Toastman RT-N Tomato Firmware on Asus RT-N66U 'Dark Knight' Dual Band Wireless-N900 Gigabit Router

Discussion in 'Tomato Firmware' started by though, Feb 24, 2012.

  1. Kaos

    Kaos Serious Server Member

    Does any one know what the maximal WAN2LAN speed is when running Tomato firmware on the RT-N66U?

    I'm currently running a WNR3500Lv2 with Tomato firmware (tomato-K26-1.28.7498.1MIPSR2-Toastman-RT-VPN) and my maximal WAN2LAN speed is 130 Mbit downstream (80 Mbit downstream when broadcast relay mode is turned on in the PPTP server).

    A router upgrade is necessary for me to match my 1000 Mbit fiber connection.
  2. shibby20

    shibby20 Network Guru Member

    no. there is no existst (IMO) to handle 1Gbit WAN connection. The best routers can handle 200-250Mbps. IMO you need a soft-router (powerful PC with linux).
  3. Kaos

    Kaos Serious Server Member

    Ok. Thanks for your reply Shibby.

    I don't think I'm ready to upgrade to a soft-router yet and having a powerful PC running all the time, so what is my best option then?

    The RT-N66U looks like a great upgrade from the WNR3500Lv2 but does any one know the maximal WAN2LAN speed running Tomato firmware on the RT-N66U?

    Standard firmware for the RT-N66U is rated around 730 Mbit/s WAN2LAN but running Tomato firmware will for sure not be as fast as the standard firmware.

    But I need the Tomato firmware for OpenVPN and PPTP access so standard firmware is not an option for me.

    So, does any one know the WAN2LAN speed for RT-N66U with Tomato firmware?
  4. Gitsum

    Gitsum LI Guru Member

    Does the CTF actually work now with this new release?
  5. SteveE

    SteveE Serious Server Member

    In this new release and also the previous one, I have noticed that the QoS seems to stop working. I just notice that in the graphs screen, the top graph of connections/category shows, but the second graph does not appear.
    If I turn QoS off and on again, then it starts working again for a while. (Using RT-N66U)
  6. ArCan

    ArCan Networkin' Nut Member

    Looking for and watting for new TOASTMAN firmware
    with new drivers/SDK, samba etc. like in Shibby's firmware.

    Somebody know when it will released?
    Thanks a lot to Toastman and Shibby!
  7. jyavenard

    jyavenard Network Guru Member

    The bug on tomato (and most likely will occur on any dd-wrt base one) with a RT-N66 isn't limited to just running scripts.

    The core issue is an incorrect initialisation of the paging kernel sub-system and would lead to certain memory corruptions...

    I've submitted a patch to linux-mips and pushed a fix on the tomato git tree.
    shibby20 likes this.
  8. jyavenard

    jyavenard Network Guru Member

    Why would that be ? why do you think it will be any slower? All the routing features are hardware based, which firmware you run will have little relevance.

    Having said that, I've extracted all the latest drivers from the Asus image, and will be putting them on tomato... so if there's any difference left, it will be very very small
  9. Gitsum

    Gitsum LI Guru Member

    Shibby himself did a comparison test at the polish linksys-info site and wan-lan throughput was considerably slower with Tomato firmware. I think the CTF not working correctly in Tomato is the culprit.
  10. jyavenard

    jyavenard Network Guru Member

    There is an updated ctf with asus source code and I have updated it.
    Having said that, I wouldn't have trust anything running with 3rd party firmware earlier on... May be worth redoing some benchmarks now...
    3 metres away, on 5GHz, I was maxing out the wireless link with 30MB/s transfer which is nothing but amazing. This was with asus 112 firmware. Will redo the tests today with tomato and updated Broadcom drivers
    Gitsum likes this.
  11. jyavenard

    jyavenard Network Guru Member

    Well... I should have actually tested things before stating that speed would be the same....
    Asus 112:
    2.4GHz: 11.23MB/s peak at 13.5MB/s (varies heaps, those are the best 3 results)
    5GHz: 15.3MB/s, peaks at 19.4MB/s

    Tomato (Toastman RT-N, with ug fix)
    Wired: 20.1MB/s (peak at 21.3MB/s)... That's abysmal !
    2.4GHz: 6.5MB/s peak at 9.2MB/s
    5GHz: 14.3MB/s peak at 15.5MB/s

    At least 2.4GHz and 5GHz speed are consistent and reliable all the time, which isn't the case with the asus firmware. it takes quite a bit longer for download to start.

    How I tested:
    rsync of a 268468320 bytes file, over either gigabit ethernet to a linux PC with an intel 520 SSD, or over wireless, about 2m away from my desk.

    I bricked my RTN66 with my updated drivers, so I 'm going to redo it all ... it's not that easy, because the drivers in tomato have received mods so it works across a wide range of broadcom based routers.
  12. kthaddock

    kthaddock Network Guru Member


    Can you test with Shibbys RT-N build he have one step newer wifi drive,
    wl0: Feb 10 2012 09:31:54 version

  13. Jacques

    Jacques LI Guru Member

    When I was using tomato-K26USB-1.28.0498.1MIPSR2-Toastman-RT-N-VPN.trx I had no problems but now appeared with tomato-K26USB-1.28.9100MIPSR2-rtn66fix-vpn4.0.trx when I clicked on the device status list is displayed after 5 seconds. That is very slow.
    The same problems with IPTrafic, Last 24 Houres, Real time, Transfer rates, Daily, Monthly.
    Merci Jean Yves....
  14. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Where download this version?
  15. Jacques

    Jacques LI Guru Member

  16. hawkmat

    hawkmat LI Guru Member

    Toastman had the same problem with tomato-K26USB-1.28.0498.2MIPSR2-Toastman-RT-N-VPN.trx so he pulled it and returned to tomato-K26USB-1.28.0498.1MIPSR2-Toastman-RT-N-VPN.trx. Your version tomato-K26USB-1.28.9100MIPSR2-rtn66fix-vpn4.0.trx felt the same way as tomato-K26USB-1.28.0498.2MIPSR2-Toastman-RT-N-VPN.trx did. I installed tomato-K26USB-1.28.9100MIPSR2-rtn66fix-vpn4.0.trx on a spare RT-N66U and after 1 hour I lost wireless signal. The display lights were still lit but insidder showed no signal was being broadcast. A reboot did not fix the situation. I installed the factory firmware and all was fine. I will try it again this weekend.
  17. Jacques

    Jacques LI Guru Member

    it's strange because I did not lose wireless signal.
    but now in Device List has no data about Lease time.
  18. hawkmat

    hawkmat LI Guru Member

    Toastman's tomato-K26USB-1.28.0498.2 versions also did not display lease time info. Display list was painfully slow.
    When it was released:
    Toastman for new 1.28.0498.2 version.
    (- IP Traffic: Fix JS error causing initial load delay when default nvram 'tomato' skin
    - ash: fix execution of shell scripts without shebang
    - PPPoE Status Progress - overview page
    - add PPTPD to ext builds
    - Dropbear: 2012.55 update
    - Dnsmasq: 2.60 update)

    Toastman later replayed: OK, don't worry about the slow page, there is a bug with that, I pulled that build. But it made no difference to the ash problem as everyone already suspected.
  19. Jacques

    Jacques LI Guru Member

    Everything is clear now.
    Thanks for any info
  20. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Where i find the version of driver in the firmware?
  21. hawkmat

    hawkmat LI Guru Member

    Hi Mirko!
    In Tomato the verion number is display in the About section.
    It is usually on the third line: Example: Linux kernel and Broadcom Wireless Driver updates
    It is also displayed in the Status/Logs/View All
    Read down the list and it will show the wireless driver version.
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.warn kernel: eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.warn kernel: wl_module_init: passivemode set to 0x0
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.debug kernel: PCI: Setting latency timer of device 0000:00:01.0 to 64
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.warn kernel: eth1: Broadcom BCM4329 802.11 Wireless Controller
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.warn kernel: PCI: Enabling device 0000:01:01.0 (0000 -> 0002)
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.debug kernel: PCI: Setting latency timer of device 0000:01:01.0 to 64
    Dec 31 18:00:06 Linksys-E4200v1-AP1 user.warn kernel: eth2: Broadcom BCM4331 802.11 Wireless Controller
  22. Mirko Baila

    Mirko Baila Networkin' Nut Member

  23. Planiwa

    Planiwa Network Guru Member

    wl ver
  24. shibby20

    shibby20 Network Guru Member

  25. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Tnk's shibby!Waht'is the "ug" bug?Is this?I do not know if it's a security risk for my router...
    Thank'you for your work!
  26. The Doctor

    The Doctor LI Guru Member

    I wonder if Tomato doesn't use the hardware routing in this router, and just operates as a software router? That would account for the slow throughput.

    BTW, v1.28.7493 MIPSR2-Toastman-RT K26 USB VPN-NOCAT working very well on my RT-N16 :) Thanks Toastman!

  27. ArCan

    ArCan Networkin' Nut Member

  28. tony550

    tony550 Networkin' Nut Member

    With Asus .112 on the RT-N66U, I'm measuring near wire-speed gigabit WAN->LAN transfers when using curl to repeatedly download a 1GB random-data file from an iMac web server on my local "WAN".

    File prep on server
    imac$ dd if=/dev/random of=random1GB bs=1k count=1m
    1048576+0 records in
    1048576+0 records out
    1073741824 bytes transferred in 104.663148 secs (10259025 bytes/sec)
    First client run (slow HD drive)
    macbook$ curl -o /dev/null http://imac/random1GB
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 1024M  100 1024M    0     0  47.7M      0  0:00:21  0:00:21 --:--:-- 46.2M
    Subsequent client runs (from server disk cache)
    macbook$ curl -o /dev/null http://imac/random1GB
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 1024M  100 1024M    0     0   109M      0  0:00:09  0:00:09 --:--:--  109M
    I'll also measure shibby this way to see how it compares.
  29. tony550

    tony550 Networkin' Nut Member

    As promised, I installed tomato-K26USB-1.28.RT-N5x-MIPSR2-094.1-AIO and it can pull about 25 MB/s to wired LAN from WAN.

    I installed tomato-K26USB-1.28.0499MIPSR2Toastman-VLAN-RT-N-VPN and it can pull about 16 MB/s to wired LAN from WAN.

    All three tests were done using default settings, "gateway mode" (NAT), home LAN and imac connected to WAN port and macbook connected to LAN port.

    edit: clarified that last sentence.
  30. Gitsum

    Gitsum LI Guru Member

    Was QOS on or off?
  31. tony550

    tony550 Networkin' Nut Member

    QOS was off, the default setting.
  32. zbeyuz

    zbeyuz Serious Server Member

    Hi, I tried Toastman's build and I have some problems with Advanced - Wireless and Virtual Wireless Settings.

    First, When I tried to increase Transmit Power to 300mW ( Country: US/Singapore ) on both bands and used inSSIDer to check RSSI.

    I saw it was around -45 on 2.4GHz and -59 on 5GHz, so I didn't feel the power increase at all as compared to when I set it at 100mW and the stock firmware.

    When I was using a stock firmware with 250mW on both bands. The RSSI was about -37 ,-44 on 2.4GHz and 5GHz respectively.

    Thus, I want to know is tomato firmware not compatible with Asus in that area ?

    Second, I couldn't see 5Ghz wireless settings in Basic - Network anymore. It happened when I set 2 guests/virtual accesspoints on 2.4Ghz ( wl0.1 ) and 5Ghz ( wl1.1 ) band.

    The setting on wl1.1 in Advanced - Virtual Wireless also dissapeared after rebooting the router, but inSSIDer still can see and connect to it without any problem.

    Thus, I think this maybe display bugs or what ???

    1. I got clear all Nvram before and after I flash tomato firmware.
    2. I also tried Shibby's beta build but no luck.
    3. I use IE 9, Chrome 20, Firefox 13 and Maxthon 3 for second issue.
    4. I noticed that the router take more time ( 2 minutes ) to boot when virtual wireless is set.
  33. Gitsum

    Gitsum LI Guru Member

    Maybe some of the dev's can explain why the throughput is so much slower than with ASUS' firmware. Also, can someone explain to me what the "cpu load" numbers mean? Does 1.00 mean 100% and .50 mean 50%? Thanks.
  34. NeutralGold

    NeutralGold Serious Server Member

    Think of the load as lanes of traffic. Having a 1.00 means the processor is exactly at capacity. Anything over a 1 for a single cpu is backed up/overloaded. Not necessarily a bad thing for a few minutes, but that's also where the 5 and 15 minute loads come in. Those let you know if there is a problem most of the time. If your 5 and 15 minute load is over a 1 for a single cpu. That usually means you've got to much information trying to be processed. My old wrt54g router would usually peak out at .66 under wireless use. But if someone were to start a torrent and also use wireless, It would overload my router to something like 1.45 or so. Sometimes causing a crash if it stayed that way for to long.

    CPU load isn't the same as the CPU Usage stat in some of the tomato/dd-wrt firmwares. So if you had 2 cpu's, anything under a 2.00 would be okay. That's about what I understand of it. I'm basically just remembering what I read.

    Some people have brought up the wireless throughput several times on other forums and there doesn't seem to be a definitive solution/explanation as of yet, that I know of. It was argued at one point that there shouldn't be any difference, so maybe that will get worked out soon. I really appreciate all the hard work these guys put into making us custom firmware!
  35. Frankie

    Frankie Addicted to LI Member

  36. Gitsum

    Gitsum LI Guru Member

  37. Makaijin

    Makaijin LI Guru Member

    Just checked the asus support website, and it seems they just updated the official firmware to
    Doesn't mention anything about 64k nvram on the patch notes though.
  38. godraab

    godraab Networkin' Nut Member

    They finally fixed the Sonos bug.
  39. NeutralGold

    NeutralGold Serious Server Member

    As you can see, nvram is still not upgraded.
    ASUSWRT RT-N66U_3.0.0.3 Fri Jun 15 14:09:13 UTC 2012
    admin@RT-N66U:/tmp/home/root# nvram show >/dev/null
    size: 32569 bytes (199 left)
    I didn't even realize mine was that full.. I think last time I checked I had at least 2000 bytes left..
  40. dbonin

    dbonin Serious Server Member

    If we are to believe Asus,which I am inclined to, the NVRAM issue will be adressed in a future firmware update (see below).
    I'm running .144 now (posted june 18, 2012) and NVRAM is still @ 32k. :(
    Personally, I don't care how much nvram I have AS LONG AS THE ROUTER IS STABLE and features work as advertised. So far, with stock this has NOT been the case. What looked like a homerun by Asus may soon be caught near the outfield fence... or will it? Since I dropped the $200 on this router I want to see Asus hit this one out of the park. There is still time!

    -----------------copied from another thread -------
    Adam Kwong
    Thank you for that information and thank you for your patience. The size of the NVRAM will be fixed and adjusted to 64KB in an upcoming firmware update. The tentative time frame will be by June.

    Let me know if you have further concerns.

    Best Regards,

    Adam K.
    Customer Care Specialist J
    ASUS Computers International
    May 3 2012
  41. NeutralGold

    NeutralGold Serious Server Member

    Yeah I remember reading someones else reply from Asus regarding the 64k nvram fix coming in June. I was overly excited when I seen them post new firmware as I quickly downloaded and installed only to be disappointed. It caused some issues with my static ip assignments and my nvram has no room at all left. I've also had some problems with my share from usb device not showing up over my network. Not really a big deal since I don't really use it, but the download manager was there after the upgrade and disappeared from the ui a few hours later.

    How ever, since they pulled the firmware just hours after they posted it. I'm hoping that maybe they'll still get to it soon. Their firmware really isn't that big a deal for me, all I really care about is the nvram issue and hoping that it can be easily added to tomato's firmware. I'm dying to use shibby's latest build but keep putting it off in case I need to update Asus's firmware in order to get the 64k nvram update in tomato. I don't really want to reapply my settings more than needed as I have a lot.

    Regardless of the stuff not working since I updated, It's nothing essential at the moment and my ip's are still being assigned, I just can't edit/delete any atm. I can use ftp to access the usb devise for now which is okay by me.

    Here's hoping for some good news soon.
  42. jyavenard

    jyavenard Network Guru Member

    From what I've analysed..

    the Asus firmware comes with a hardware nat driver. It is enabled by default. With this, you get over 60MB/s WAN to LAN routed.
    You can disable hardware NAT in the Asus firmware, and this will drop the speed to about 45MB/s.
    Also, this driver isn't compatible with QoS, as soon as you enable QoS speed drop to less than 20MB/s.. Which is what you are seeing with the tomato firmware.
    Gitsum likes this.
  43. Gitsum

    Gitsum LI Guru Member

    So, if your using QOS, they is no performance difference between ASUS firmware and Tomato?
  44. jyavenard

    jyavenard Network Guru Member

    I actually got worse performance using the Asus firmware than when using tomato with QoS enabled...
    I need to check it further, because performance were actually worse than my RT-N16...
  45. dbonin

    dbonin Serious Server Member

    Tried v1.28.9100 MIPSR2-rtn66fix K26 USB Std and USB drive (the drive I've used with many tomato versions) will not mount.
    Yes, cleared nvram and rebooted - it's listed but won't mount. Is there something I'm missing? This is my first try with a toastman FW.
    Also, not sure what might be causing this - sometimes nat UPnP opens ports but then nothing else can access the web - like my kids xbox will connect and ports will open but then right after no one else can get to the web. Weird. Could be my main Time Warner router doing weird things, but who knows. Just wanted to post this in case anyone else see this behavior.
  46. lilstone87

    lilstone87 Serious Server Member

    Well I am running the latest firmware v1.28.0499 MIPSR2Toastman-RT-N K26 USB Std. Things seem to be running pretty good, but I have notice wireless signal is a little weaker on tomato compared to the asus firmware. Messing with transmit power seems to do nothing, so to me there seems to be some bugs to be worked out regarding wireless signal on this tomato firmware.
  47. jyavenard

    jyavenard Network Guru Member

    while the drivers have been updated recently
    wlconf hasn't ; seems to have been an overlook.

    that and I doubt the various tomato utilities have been updated for making use of all the new functionalities either...

    Also, toastman build is using an older drivers than what found in Asus firmware... Have you tried the shibby build? it has a newer drivers, see if that makes a difference
  48. Toastman

    Toastman Super Moderator Staff Member Member

    I've tried Shibby's driver build specifically to check the signal strength, and found it no different to the previous drivers. I didn't check throughput.
  49. jyavenard

    jyavenard Network Guru Member

    I'll test the reports that changing the output power doesn't change when you tweak the value.

    I'm only about 5m away from my RT-N66, and I can't see the 5GHz network... so it is indeed pretty crappy.

    With the Asus stock firmware, I can go on the other side of my house and still see the 5GHz network.

    The RT-N16 located much further away than the RT-N66 give me a stronger and faster signal.... very puzzling
  50. shibby20

    shibby20 Network Guru Member

    RT-N66u with and Netbook Asus EEE1215N with Intel 5100.
    Result: 5GHz performance is awful. My intelnet DL speed is ~30Mbps. On 5GHz i had only 18Mbps. On 2.4GHz i had full 30MBps. On both radios result of speed when i downloading file via samba from router was poor 3MB/s

    RT-N66u with and Netbook Asus EEE1215N with Intel 5100. i have full internet speed on both radios and finally i can use 5GHz. When i copy file via samba from router (5GHz) i have ~8-9MB/s!!

    My friend has internet 100MBps. On has only about 25MBps on both radios well he had to go back to OFW. After upgrade to new driver he has now ~52MBpps on 2,4GHz and 85Mbps on 5GHz well improvement is huge.

    Update driver was improvement performance, not signal strength.
  51. Toastman

    Toastman Super Moderator Staff Member Member

    That sounds good! Thanks for posting your test!
  52. hk2k2

    hk2k2 Networkin' Nut Member

    @ shibby, i just tried your AIO 95 build on my RTN66U, and works great.

    but i figured out something strange in muliple ssid:

    you have wrote in your changelog: - MultiSSID: some minor fixes

    the GUI settings are fixed now, menus are not damaged anymore :)

    i can create new ssid, all ok! BUT they have NO TX POWER!

    i use my other notebook with high density wlan card, it found the networks but no power :)
    RSSI is -100

    same problem on 2,4 and 5ghz network,

    i use: WPA / WPA2 Personal + TKIP / AES and ACESSPOINT mode only.

    any ideas to get this to work? i know its highly experimental... :) but maybe.. :)

    thanks :)
  53. lilstone87

    lilstone87 Serious Server Member

    Well I should of explained my self a little more, and that's my fault. But yeah I am using the 5ghz wireless on a couple things, and when I switched from the asus firmware to Toastman's tomato firmware, connection speed, and such dropped for me. I know I said signal before, was really meaning connection speed had dropped over the 5ghz wireless with just switching the firmware. As of right now, I am back to the asus firmware, but I would love to go back to tomato with its options. I just think there is a issue to be fixed regarding the 5ghz wireless band.
  54. shibby20

    shibby20 Network Guru Member

    Well try my tomato with newer wireless driver ported from asus stock firmware sources. You should be happy. I am :)
  55. lilstone87

    lilstone87 Serious Server Member

    I am gonna load tomato-K26USB-1.28.RT-N5x-MIPSR2-095-AIO.trx on it a bit later, and I will let you know how it goes :). So after reading a couple of the latest post in here, it seems Toastman's firmware isn't using the latest drivers. Which seems the latest drivers seem to perform better over the 5ghz band. Thanks again guys, and hopefully Asus release's a new firmware soon to increase the nvram, so you guys can add it to your builds :).
  56. lilstone87

    lilstone87 Serious Server Member

    Well I flashed your firmware shibby, I have notice one thing regarding wireless settings though, and I seem to remember this also on Toastman's firmware. I setup wireless settings for the 2.4ghz band, for some reason leaving everything on auto, and using 40mhz channel width. After saving setting, and looking at the overview of wireless settings. I notice the 2.4ghz band only using 20mhz channel width, and looking at the saved settings shows I saved it to 40mhz channel width. So I then went back changed control sideband from lower to upper, and changed channel from auto to channel 11. Now it shows it using 40mhz channel width, but has me wondering why its defaulting to 20mhz channel width when I was using auto channel, with 40mhz, and control sideband set to lower.

    Edit: Seems to be an issue when not selecting a channel, and leaving it on auto. Because I have since set to use channel 1, and 11. Both times it has kept the 40mhz channel width, and not defaulted back to 20mhz like it did when i used auto channel select on the 2.4ghz band.
  57. lilstone87

    lilstone87 Serious Server Member


    Have you messed with the transmit power settings on the n66u? Just wondering if anyone has, to know if adjusting them does anything. Also seen you have both set to 42, I know asus has both defaulted to 80 on there firmware.
  58. shibby20

    shibby20 Network Guru Member

    i changed Transmit power to 0 (auto) for both radios.
  59. The Doctor

    The Doctor LI Guru Member

    Please explain auto power setting, shibby. I thought 0 was hardware default, which was just some preset level. Does it actually adjust power level based on some sort of report from clients or something?

  60. hk2k2

    hk2k2 Networkin' Nut Member

    what version you mean? helps this also against no muliple ssid wlan power ?! :)
  61. hk2k2

    hk2k2 Networkin' Nut Member

    i tested now something:

    if i disable and enable WL0 and/or WL1, their virtual interfaces wl0,1 or wl1.1 work! with same tx power al wl0 or wl1 itself, BUT, as soon as i play something with wlan settings from wl0 or 1, tx power is lost :( also a router reboot causes this. i have to manually disable and re-enable wl interface, then tx power is back.

    can you fix this :)

    same issue is in 20 and 40mhz bandwith on both radios.

    thanks br hk2k2
  62. jyavenard

    jyavenard Network Guru Member

    I posted this on smallnetbuilder:
    There's been lots of talk about how much better the Asus RT-N66 stock firmware performed over Tomato.

    Being an irregular developer on the tomato project, and having recently acquired a RT-N66U, I wanted to identify the issue considering that:

    - Tomato now uses the exact same broadcom drivers as Asus latest firmware
    - The Tomato kernel is slightly more recent (note: the newer Asus 144 firmware has caught most of those changes up)
    - Tomato is leaner, with far less junk running...

    So, with the same hardware and drivers, how could tomato be slower?

    So I wanted to quantify the difference in a particular use case: my typical usage.

    Speed over a 5Ghz link between a macbook air (dual channel so 300Mbit/s max) located in another room than the RT-N66, about 12m away.

    The test consisted of varying the transmit power, then transfer a 512MB file of random data using rsync over a ssh connection.

    Peak transfer speed was looked at the hardware interface level
    Average transfer speed is the average speed reported by rsync at the end of the transfer.
    Repeat three times.

    When I first started my test, the Asus was crushing tomato big time. It was significantly faster. But very irregular too.

    Trying to investigate the differences between tomato and the Asus stock firmware, I noticed that Asus by default uses the hardware accelerated NAT driver (ctl kernel module, it's not just for NAT but that's what Asus calls it).
    Tomato doesn't use this module.
    This module is incompatible with netfilter and qos ; the second you enable QoS with the asus firmware, the ctl module is unloaded.

    Here are the results:

    Conclusion: Asus stock firmware is only faster when no QoS is in use...
    also tomato provides more consistent throughput.

    If you want to use QoS, you're better off using Tomato.

    There's some other differences in regards to signal level, the Asus stock firmware provides a more linear power output... I need to sort this out on Tomato which shouldn't be too complicated

    I also tested router transfer speed over gigabit ethernet.
    The results were also very interesting.
    Asus with ctl: 66.4MB/s (this is in line with SNB's own test)
    Asus without ctl: 45MB/s
    Asus with QoS on: 20MB/s
    Tomato: 24.1MB/s

    So once again, tomato is faster with QoS active.

    Summary: don't use QoS and want best performance: use Asus firmware
    Use QoS? use tomato :)

    Edit: I was looking at adding ctf support in tomato.. The asus firmware disable ctf when:
    -QoS is enabled
    -Port forwarding is enabled
    -DMZ is enabled
    -URL protection is enabled.

    So pretty much, very often if not always... make the whole purpose of hardware acceleration only useful for benchmark and not any serious usage of a wireless router.
  63. Gitsum

    Gitsum LI Guru Member

    Thanks for those tests. So do you think CTF reduces latency for gaming when it's on, or just allow more throughput?
  64. jyavenard

    jyavenard Network Guru Member

    CTF creates some strange behaviours. Yes you get much greater peak speed, but throughput varies greatly, it goes like a yoyo...
    I won't be adding CTF support, I have a build running, but provided it will have to be disabled under most common usage I don't see the point in spending time in sorting this out.
    I guess it's great for commercial reviews such as the one done by SmallNetBuilder, they do quick routing with all features disabled...
    Gitsum likes this.
  65. tvlz

    tvlz LI Guru Member

    Was looking at the e2500 CTF code and notice that the code in \include\hndctf.h differs on just one line, only a typo or something important?
    from Linksys:
    #define ctf_ipc_count_get(ci) \
        (CTF_ENAB(ci) ? (ci)->fn.ipc_count_get(ci) : BCME_OK)
    from asus/tomato:
    #define ctf_ipc_count_get(ci, i) \
        (CTF_ENAB(ci) ? (ci)->fn.ipc_count_get(ci, i) : BCME_OK)
  66. shibby20

    shibby20 Network Guru Member

  67. lilstone87

    lilstone87 Serious Server Member

  68. Engineer

    Engineer Network Guru Member

    Is this driver included in all of your new 95 build version of Tomato or only certain ones?

    Edit: I think I found it - only in RT-N versions. I assume this will not work on the RT-N16 Asus router?

  69. Riddlah

    Riddlah LI Guru Member

    The RT-N builds work fine on RT-N16. Been using it for a few months now. Just make sure to choose the builds labelled 'with usb'
  70. Engineer

    Engineer Network Guru Member

    Have you used it since the version (93 I think) that has the updated Asus driver?
  71. Riddlah

    Riddlah LI Guru Member

    I've used that version and currently have version 095 loaded
    Engineer likes this.
  72. The Doctor

    The Doctor LI Guru Member

    Shibby, just read at smallnetbuilder discussion on RT-N66U "Starting with 152 h/w accel will not be disabled if pf is enabled." Is there any chance you will include the ability to use hardware acceleration when QOS is not used?

    My ISP offers 150/65 & 300/65 speed packages. Tomato on this router is (currantly) barely adequate on the 1st, and not capable on the 2nd. I am a big fan of Tomato for many years now, mainly for the stability, bandwidth monitoring, and clean UI. I'm hoping to continue running it for many years to come, but may be forced out by speed requirements. Probably others in same position as speeds rise. Seems like this acceleration may help.

  73. hk2k2

    hk2k2 Networkin' Nut Member

    i just recognized a nrew problem with my RTN66U.

    from time to time it dropps WLAN connections for about 3 minutes. lan connection is still ok during this time, but no wlan! (i only checked 2,4ghz..)

    it dont broadcast anything in theese ~3 minutes, after this, wlan turned on automatically again and everything is fine.

    dmesg shows nothing during this time...

    i used shibby AIO 95.

    any ideas?


    EDIT, just googled about this,

    could this be the problem?

    Changelog in 95 Shibby:
    - wl_mitigation disabled by default

    what was the value before ?? i can´t remember that i got this issues BEFORE version 95...
  74. bx10

    bx10 Serious Server Member

    I can confirm the same issue as hk2k2 in 095 AIO on the RT-N66U: The Virtual Wireless GUI works well, and I have a simple multi-SSID configuration working, but if a setting is changed the Virtual SSIDs become unuseable (though they still appear in Windows). Radios off, reboot and radios on sometimes restores function to the Virtual SSIDs, but not always, so I'm forced back to factory firmware for now. Even changing small items like SSID or channel causes this behaivor.

    I have a backed up config from before making the change, restoring it restores functionality, changing any setting breaks it again. The main SSID always works.

    Shibby, thanks for the great work. I can post any logs or data you need to help troubleshoot this.
  75. shibby20

    shibby20 Network Guru Member

    before was 3 (WLAN Auto). Now is 0 (None).
  76. jyavenard

    jyavenard Network Guru Member

    I've spent the full day working on this last week, trying to sort out the problem...

    This is occurring with the RT-N branch, with any of the new drivers (including last year "new" drivers.
    I haven't been able to identify what the problem is and where it fails. I gave up for now

    But yes, it pretty much works once: as soon as you modify the settings or your reboot, the virtual WLAN stop working and require a reset
  77. hk2k2

    hk2k2 Networkin' Nut Member

    @ shibby, thx! i´ve set it back up wlan auto, till now no wlan interrupt .. :)

    can you say something to the mulitple ssid issue ?

  78. tvlz

    tvlz LI Guru Member

  79. zbeyuz

    zbeyuz Serious Server Member

    I quite don't get what you meant. In my case, I let wl0.3 be 2.4Ghz SSID and wl1.3 be 5Ghz SSID.

    What should be the code to put in tools > system commands ? Please advice... Thanks in advance.

    Btw, Does it code also fix the issues with the wireless signal disappearing or unable to connect after 2-3 days of running ??
  80. tvlz

    tvlz LI Guru Member

  81. Quint

    Quint Serious Server Member

  82. Quint

    Quint Serious Server Member

    Has anyone answered this?
    I am using rt-n66u with Tomato Firmware 1.28.0000 MIPSR2-099 K26 USB AIO-64K (Thank you Shibby :)
    I have Fiber Internet with 250Mbps Down, but can only get appx 160Mbps Down.
    When connecting ethernet direct to Fiber Modem, can get almost all of the 250Mbps.
    No idea what the Asus firmware will provide (and will never find out, as there are way too many features in Tomato to consider Asus stock)
    Test ran multiple times with same approx results:
    1) Firmware loaded
    2) NVRAM cleared after reload
    3) PPOE configured

    I was hoping it was something i was doing, or something maybe the ISP was doing (MLPP) that i could prevent, but still no luck :-(
    Any others tested with different results?

  83. gingernut

    gingernut LI Guru Member

    At the dev theMIROn has made loads of bug fixes/updates to the fastnat module which could probably be used, there's also loads of updated/patched code that TB used to cherry-pick from their source and viceversa.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice