Toastman VLC multicast

Discussion in 'Tomato Firmware' started by Javo1, Dec 10, 2011.

  1. Javo1

    Javo1 Networkin' Nut Member


    I am running vlc (vlc_0.9.9a-2) on my E3000 with Toastman (tomato-E3000USB-NVRAM60K-1.28.7483MIPSR2-Toastman-RT-Ext.bin). It works fine, I use it for streaming video files from Iomega HDD connected to my E3000 USB - through UDP stream. When I stream to e.g. it works, but I cannot get it to stream to any multicast address (e.g.

    Can anybody help me, please?
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Never used it so I have no real help to offer.

    But to bring this to the attention of everybody streaming multicast, there are a few things that you should look at.

    1) The Allow Multicast box. (Advanced/Firewall)
    2) Wireless Multicast Forwarding (Advanced/Wireless)
    3) New - updxy-Chipmunk in latest Toastman versions (Advanced/Firewall)

    The last is a new addition by Teaman :D
  3. teaman

    teaman LI Guru Member

  4. were55

    were55 Addicted to LI Member

    Hi Javo1,

    I'm also interesting to stream video files from my asus-rtn16, could you give me some directions how to do it?

    thanks for you help
  5. masster

    masster Addicted to LI Member

    Hi Javo1,
    I'd like to know too. How do you run vlc as a root? Did you create a new user? Which command do you use to call vlc? A "vlc" or "vlc-wrapper or "cvlc" or how?

  6. Javo1

    Javo1 Networkin' Nut Member

    Hi were55 and masster,

    I have installed Optware and VLC player on my E3000. My IPTV Set-top box can receive UDP stream on its port 1234. To run VLC as root I followed monemihir's instructons on page - I replaced all instances of "geteuid" with "getppid". I run VLC player with http interface : cvlc -I http (I start it in autorun file after mounting Optware partition). Then I can connect to VLC from my notebook through web interface on <address of my router>:8080 (e.g. Here I select desired video or audio file, set streaming parameters (UDP address and port - <address of my Set-top box>:1234, MPEG-TS encapsulation).

    Hope I helped you.
  7. masster

    masster Addicted to LI Member

    Thanks again,
    finally it's working for http. Now I'm trying to figure out how to make vlc access rtp stream. Always getting same error: open of `rtp://@ip address' failed: no access module matched "rtp".
  8. were55

    were55 Addicted to LI Member

    Hi Javo1,

    I just installed vlc (ipkg intall vlc), but I'm not sure which vlc file needs to be modified, I found several of them in different directories, all of them needs to be modified?

  9. masster

    masster Addicted to LI Member

    Hi were55,
    I edited only one file "vlc" located at /opt/bin with hex editor (XVI32, freeware). I replaced "geteuid" on address 1531 with "getppid". That works for me.
  10. were55

    were55 Addicted to LI Member

    Hi Master,

    I'm still having problems to run vlc :-( , now I'm receiving the next error:
    I have dbus Version: "1.2.16-1 "....seems like something is need it :-( any clue?

  11. masster

    masster Addicted to LI Member

    I've got same error after "cvlc -I http" command but vlc web interface working well on
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice